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[bookmark: Definition]
1 Definition

This is part I of some Flash
tutorials.


Learning goals:


	Learn about various components of the Flash Desktop

	Learn how to configure and how to save configurations



Prerequisites:


	none



Next steps:


	Flash drawing tutorial

	Flash layers tutorial





Notice: As of November 2008 you should acquire CS4. It offers
various new features, such as 3D support or better motion tweening
support. However, if you don't find a good CS4 desktop tutorial,
you still may profit from this. The overall logic of the interface
remains the same.

[bookmark: Opening_the_desktop_from_the_Flash_welcome_screen]
2 Opening the desktop from the Flash
welcome screen

When you launch Flash you will see a welcome screen. This
screen offers a few shortcuts. It looks like this:


[image: Flash CS3 Welcome Screen]
Flash CS3 Welcome Screen





To start working with a Flash file, you now can use either the
File Menu or you can click on an item in the welcome screen.
E.g.


	Use File->Open to open a *.fla file you are working
on

	Open a "recent" item either through the File Menu or the
button

	Create a new Flash file

	...



If you tick Don't show again you won't see the welcome
screen anymore, but the same options are available through the
File Menu. If you want it back:
Edit->Preferences.

To start learning the Flash desktop, we suggest to click on
Flash File (ActionScript 3.0) since this the most recent
Flash standard.

ActionScript 2 would let you use some built-in behaviors (i.e.
do some action script without programming). Action Script 3.0 does
not support this, but then it's probably a bad idea to work with
something that is outdated ...

Now you really entered the Flash Desktop working environment.
Read on...

[bookmark: Layout_and_configuration_of_the_Flash_Desktop]
3 Layout and configuration of the
Flash Desktop

Definition: By Flash Desktop (Desktop in short) we
mean the whole authoring environment that you can see when you work
on some Flash animation.

[bookmark: The_default_desktop]
3.1 The default desktop

When you first open a the Flash Desktop you will not see all the
tools you later will use. Your initial desktop configuration should
look a bit like the screenshot below (I am not so sure about the
right-hand side panel area). This annotated screenshot already
conveys an idea of the kinds of tools you get, but we will
introduce them later.


[image: The Default Flash CS3 Desktop]
The Default Flash CS3 Desktop





You can arrange the Flash Desktop in various ways (see below),
but for the rest of this tutorial we will try to stay with a
somewhat stable environment, i.e. leave the main tool panel to the
left and the timeline on top.

[bookmark: Configuring_the_desktop_layout]
3.2 Configuring the desktop
layout

Before we explain some tools components I suggest that you learn
how to arrange your Desktop.

Firstly, we'd like to show how to display some more panels
(tools and libraries). Having tools at your fingertip is IMHO
always a good idea if your screen is big enough. BTW, if you can
afford to buy CS3 it maybe is also a good idea to invest in monitor
that can display 1900x1200 pixels....


	Always display the tools panel (if hidden by mistake)



You most of the time will need the main drawing tool panel
(leave it to the left). You then can add two other tools panels
that include some of the most commonly used menu commands.

To display all the toolbars


	Window->Toolbar

	Check/tick all three, i.e. Main, Controller,
Edit Bar.




	Adding and moving panels



Panels are tools and libraries that contain special editing
functionalities. Some of these you can't find in any menu,
therefore at some point you have to learn what kind of panels
exist. Btw, if at some point panels you put on the desktop
disappeared, hit F4 or Window->Show Panels). So F4
toggles between more space for drawing and more tools

Now let's see how you can organize the workspace. CS3 lets you
arrange panels in various ways:


	They can be floating (undocked, usually you would move
them outside the Flash Desktop)

	They can be docked to the panel area to the right, to
the bottom or even to the left.

	They can be docked in groups of panels (each one will
show as a tab)



To dock a panel, simply grab it with the mouse (press the
left-mouse button on a empty area in its top bar) and then drag it
to a "place" that will "light up" in some light blue color.


	If you see a blue line (vertical or horizontal) and then
release the mouse the panel will dock below or to the right of the
line as a "lone" panel

	If the top bar of another panel turns blue, you can dock your
panel next to the other panel, i.e. it will appear in a tab.



The two screenshots below should illustrate the principle.


	Docking against a line example



The Swatches panel (shown in transparent color) is being dragged
to the empty and therefore reduced right hand panel area. There is
a faint blue vertical line. Note, that you also may encounter
horizontal blue lines against which you can dock ...



[image: Undocked color and library panels and swatches panel to be docked.]



Undocked color and library panels and swatches panel to be
docked.






	Docking together with an other panel example



The (transparent) Color panel is in the process of being docked
together with the library panel. The top bar of the library panel
is light blue, i.e. ready for docking (see also the next picture)
...


[image: Docking the color panel as a tab]
Docking the color panel as a tab





Now the color panel is firmly docked as a "tab" grouped together
with the library panel


[image: Docking the color panel as a tab]
Docking the color panel as a tab






	To undock a panel



Drag it to some place that doesn't light blue.

[bookmark: Saving_an_environment]
3.3 Saving an environment

To make sure that you can find a configuration again you may
save it under a given name. If you do different kind of work with
Flash you can save several working environments.


	Window->Workspace->Save Current ...



If you are happy with what you did, save your configuration now
...

[bookmark: An_example_configuration]
3.4 An example
configuration

Here is an example configuration Daniel K. Schneider is using. I like
to have most tools at my fingertips and I have a big enough monitor
to allow for this. My real workspace is bigger than the one shown
in the screen capture, which I made smaller
in order to fit into this text.


[image: Example configuration of a CS3 Flash desktop]



Example configuration of a CS3 Flash desktop





Of course, you also may choose to work with less visible panels
and only open them when you need them, like in the following
example that you can enlarge if you wish. Finally, you may save
different configurations for different kinds of work you do...


[image: A simple desktop configuration]



A simple desktop configuration





[bookmark: Built-in_and_online_Help]
4 Built-in and online
Help

There are two sorts of support:


	Built-in help

	Help from Adobe's website



Built-in Help is quite good, although contextual help could be
better (like being a systematic option on the right-click
menu).

For some stuff you can get context-dependent help, i.e.
learn something about certain objects, an item, etc. It will open a
more or less appropriate section in the help tree. Select an item
first (e.g. in the Workspace or in a panel), then either get Help
from the Menu / hit F1 / or click on the little help icon in the
properties panel.

In addition, in the built-in help menu you can find links to
external sites. It doesn't work for me, maybe because my default
browser is Firefox.

Within the built-in help texts there are also links to Adobe's
on-line resources, but they do not necessarily work as they should
(e.g. the link www.adobe.com/go/learn_fl_tutorials doesn't lead to
a text tutorial as advertised. Quite typical of Adobe on-line
support I should say.

However there is good stuff on Adobe's website, e.g.


	the video tutorials are truly useful to beginners:

	Video tutorials at Adobe





	The overall Flash Help page

	Flash resources

	In particular, you can find HTML and PDF versions of the
built-in help. You may find HTML more practical than the internal
help window since the built-in window can not be detached from the
Flash workspace and will hide your workspace area while your are
reading. An good trick to help quickly open/close the built-in help
is to dock it against the Main tool panel (as shown in the screen
capture above). Finally, PDF versions of the on-line site can
printed, consider printing in some cases.

	Consult Flash and AS3 links -
documentation







[bookmark: Moving_on]
5 Moving on

In this section we will summarize functionalities of some Flash
components. We will introduce more functionalities in other
tutorials. This is just a short overview.

[bookmark: The_Work_area_and_the_stage]
5.1 The Work area and the
stage

The stage in the middle (white by default) is the area
where you work on your Flash contents. It is part of the work
area. The gray part of the work area (also called
backstage) can contain graphic elements on which you are
working and that you plan to integrate into the stage sometimes,
i.e. make them visible to the user. In deployed Flash "movies" this
area will hold motion animation objects that later will "walk" into
the scene.


	Setting up the size of the stage and other parameters



With Modify->Document menu you can make several
modifications:


	You can redefine the size of the stage. Stage size is the size
you final Flash application will have. Therefore you may think
about the size before you start composing...

	You may change the background color (per default it is white
and it will display as white in your animation).

	You also should give your work a title and a short
description



[bookmark: The_Menu_Bar]
5.2 The Menu Bar

On top of the desktop is the menubar (on the Mac it will be on
top of the screen of course). Flash lets do you things in three
different ways:


	Interact through the menu

	Use shortcuts

	Interact through panels



Available operations in menus and panels are context dependent,
i.e. they differ in function of what you are working on in the
workspace and also in function of the Flash "Publish Setting" (e.g.
ActionScript 2 vs. ActionScript 3).

Here is a short and incomplete summary of the menu
groups' functionalities:


	File

	Opening and creating new files

	Definition of Publication Settings (you may change settings you
initially defined)




	Edit

	Editing the scene

	Editing elements that are active




	View

	Define zoom level, grids, snapping (i.e. how the workspace
displays)

	Note: Other important "view" items are in the Windows menu




	Insert

	Add new layers, frames, symbols etc. into the timeline

	Add a new scene




	Modify

	Modify elements on the workspace, e.g. convert a graphic to a
symbol (make it a reusable object) or change the shape of a
drawing

	Modify timeline elements




	Text

	Change text properties

	Spell checking




	Commands

	Run macros

	XML export / import




	Control

	Test animation in various ways (including just
sub-elements)




	Debug

	Tools to find errors in your scripts




	Window

	Configure the workspace (add/remove panels)




	Help

	Built-in help and links to useful on-line resources



[bookmark: Toolbars_and_Panels]
5.3 Toolbars and Panels

We will introduce panels as we need them in other tutorials.
Here we only would like to introduce the library: It
contains all the objects you use in a Flash document.

For example, in the flash drawing tutorial we used five
different reusable objects, i.e so-called graphic symbols.
Once you defined something as symbol (either a graphic, a button or
a movie clip) you can reuse these as many times as you like in a
flash document.


[image: The library panel with a few reusable graphics]
The library panel with a few reusable
graphics





Now you should be ready to start learning how to create drawings
with Flash. Move on to the Flash drawing tutorial.

Flash drawing tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !
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This entry is part of the Flash tutorials.

[bookmark: Introduction]
1 Introduction



	Learning goals

	Learn about some features of the Flash CS3 drawing
environment

	Learn painting and drawing simple (!) objects

	Prerequisites

	Flash CS3 desktop tutorial

	Flash layers tutorial (first
part)

	Related pages

	texture and clipart (import media elements)

	Materials (*.fla files you can play with)

	http://tecfa.unige.ch/guides/flash/ex/drawing-intro/

	Quality and level

	This text should technical people get going. It's probably not
good enough for beginners, but may be used as handout in "hands-on"
class. That is what Daniel K. Schneider made it
for.

	Next steps




	More about drawing: Flash object transform
tutorial and Flash arranging objects
tutorial

	Any other introductory tutorial indexed in the Flash
article.





[bookmark: Setting_up_the_stage]
2 Setting up the stage

Besides choosing the right settings for publication (Flash
version) with which we shall not deal here, you should select the
right size for your your stage, i.e. the size of your future flash
document. You can do this either when you create a new file or
later.

[bookmark: Defining_document_size]
2.1 Defining document
size


	Creating a new document



Flash lets you create a new document from various templates:
File->New. Then choose from General or
Templates.

These templates may predefine several things:


	Size of the stage

	Version of Flash (based on Actionscript 1,2 or 3)

	Sometimes other things, e.g. the Photoslideshow contains photos
and tools to make slideshow.



In any case, to learn Flash's drawing feature, you don't have to
worry much about what template to choose from. Just make sure that
you have enough space to draw. If an initial size turns out to be
too small or too big, you simply can modify the document's size
(see next)


	Modification of a document



With Modify->Document (or by clicking on an empty spot
in the stage and then changing the properties) you can:


	Redefine the size of the stage.

	Change the background color

	Give it a title and a short description



[bookmark: What_size_for_a_Flash_document_.3F]
2.2 What size for a Flash
document ?

Size of your Flash document depends on its purpose. Since Flash
documents (unlike well made HTML pages) have a fixed size, you must
find a good compromise between readability (user should be able to
read and distinguish all elements) and horizontal/vertical space
you take up).


	Larger flash documents



The default documents takes up 550x400px. This makes the
document viewable without scrolling on a computer with a bad screen
resolution of 800x600px. Do not forget that a screen also contains
a tools bar (in most Operating systems) and that Flash is usually
viewed within a web browser that also contains menu bars, a bottom
bar and some pixels to the left and right.

Anyhow, most people today have bigger screen resolutions so you
certainly can go bigger than 550x400.


	Banners and other embedded items



Just don't make menu bars too large ....

[bookmark: Configuration_of_the_drawing_environment]
3 Configuration of the drawing
environment

Firstly you should know that there are two kinds of drawing
tools:


	Tools in the main tools panel (that appears by default
to the left of the desktop)

	Tools available through various panels



Here is screen-dump that I made while drawing a red "ray" with
the Pencil tool (the mouse pointer is missing from the
drawing).


	You can see that the properties panel (lower left) will
display properties of the object being drawn. E.g. when you use the
pencil, it will display color of the stroke, size of the stroke,
type of the line, fill color, etc.

	The same is true for the color panel that we display in
the upper right.




[image: The Flash CS3 drawing environment]
The Flash CS3 drawing environment





Since these panels give you shortcut access to features of
objects you are drawing, it's a good idea to keep them open while
you draw.

[bookmark: Some_definitions]
4 Some definitions

[bookmark: Strokes_vs._fills]
4.1 Strokes vs. fills


	When you draw something with a pencil or another drawing tool
like the pencil or the line tool (see below), then the lines you
draw are called strokes.

	The outlines of shapes you create with the rectangle, oval,
etc. tools are also called strokes. The insides of these
shapes can have fills (various forms of color). All
geometric shapes therefore have both strokes (the outline) and
fills.

	When you use the paint tool (brush), then you usually
just create fills (no strokes).



[bookmark: Colors]
4.2 Colors

There are several types of colors:


	None: You may choose to draw without fill or stroke

	Solid: Standard colors

	Linear: Gradient color changes that go from one side to
another

	Radial: Gradient color changes that goes from inside
out

	Bitmap: You can paint with an imported bitmap. This is
particular useful with textures. E.g. to draw floors, walls or
outdoors scenes with repetitive tiles.



To select a color type, there is a pull-down menu in the color
panel.

To work with gradients is not very easy and the interface
doesn't help that much. To change a gradient you need 2 tools:


	The color panel (select type=linear or type=radial), then play
with the sliders. You can remove slider buttons by dragging them
outside the area or if you leave the mouse down for a while, you
can change color of gradient controller. You also may try to start
from the swatches pane.

	To change orientation (e.g. from linear horizontal to linear
vertical), use the Gradient Transform Tool (usually hidden
below the Free Transform Tool). Catch the little circle and turn
around the object. Only the gradient will turn.



Read the [[Flash colors tutorial] if you want to know more
colors and gradients ...

[bookmark: The_main_tools_panel]
5 The main tools panel


[image: Items of the Flash CS3 tools panel]



Items of the Flash CS3 tools panel





The main tools panel contains the major drawing tools. We
suggest to leave this panel docked to the left side (since it's
frequently used). But depending on your screen size, you can
display it either in a single column or as a double column, click
the ">>" on its top bar to change this.

The main tools panel organizes tools by different
categories:


	On top, selection and transformation tools

	Below Drawing tools

	Next, Painting, color picking and erasing
tools

	After that, various configuration, view and
options tools that are context dependent.



Options change according to tool that is selected. E.g. in the
screen capture to the left you can see how the tools panels shows
with the selection tool (left) and the brush tool (right).

Tools may have variants (in this case you can see a little down
arrow in the icon). To see variants you must press the left mouse
for a while or Shift-click. E.g. instead of the Rectangle
tool you can display/access the Polystar tool.

[bookmark: Merge_.28shape.29_vs._object_drawing]
5.1 Merge (shape) vs. object
drawing

Flash has two drawing models:


	The merge model will erase shapes below something you
draw (but not graphic objects as defined next)

	The object drawing model draws shapes as separate
objects (that you later can manipulate like in a typical vector
graphics program).



Usually, you rather should work with the object model
since the shape of each object can be easily modified later on.
However the merge model can be used to draw complex shapes, e.g.
you can draw a circle and then carve off things by drawing over it.
The merge mode is also useful when you "paint" things (as opposed
to drawing). You later can convert "paintings" to objects of
course.

By default, the object model may be turned off, so turn it on by
clicking on the Object drawing button. You can find in the
options section of the tools panel after clicking on some drawing
tool (e.g. the Pencil). You can see if it's on when there is a
rectangle drawn around the button, like this: [image: object button pressed]

You can see the difference between the 2 kinds of objects
created in the Properties Panel:


	Objects are called Drawing Objects

	Simple drawings (from the merge model) are called
Shapes.



The behavior of tools changes according to mode used and it's
not so obvious to remember what Flash does.


	In merge mode




	In merge mode, when you draw a shape over another shape, it
erases the shape underneath by default. You can change this with
the control options (see later)




	When you draw another object (line, pencil, etc.) it will draw
over the painting, but not erase it.




	In object mode




	Shapes drawn in object mode with the brush tool are
drawn either within, on top or behind objects depending on how to
set the controls of the brush tool.




	Shapes drawn in object mode with the pencil, the pen tool
etc. are drawn on top of other objects. But in the object mode
they can be moved behind with the right-click->Arrange
context menu.



If you already tried to draw more complex shapes, you noticed
that it is difficult to work with a single layer (e.g. to select
objects), so you now have to learn how to work with layers.


	If you are not familiar with layers, please read the Flash layers tutorial now.




	Conversions




	To convert an object (instance) into its original
components : Right click->Break apart

	To convert some shapes into a drawing object: Select them first
(e.g. with the Lasso), then select Menubar Modify->Combine
Objects->Union

	To convert some shapes into a symbol, Right-click; Convert
to Symbol



[bookmark: List_of_standard_tools]
5.2 List of standard
tools

Also see the figure "Items of the Flash CS3 tools panel" above
in order to identify the corresponding icons in the tools panel.
Some tools are stacked on top of each other. Hold down the mouse
button for while to see the hidden ones.

[bookmark: Selection_tool]
5.2.1 Selection tool

This tool lets you select elements (shapes, strokes, fills,
symbols, bitmaps) in the workarea by clicking on it (simple click).
If you wish to select several objects together hold down the SHIFT
key or use a selection box or the lasso (see next).

You also can drag the mouse pointer to select an area with one
or several objects. You certainly have to do this for a drawing
made in merge mode, i.e. a collection of simple shapes). If you
want to select a non-rectangular area, use the Lasso tool.

Double-clicking would put you into object editing mode for
various parts (depending on where you click). To return from this
mode (which we will not explain here), double-click in some empty
area in the workspace.

Warning: This tool also can act as a distortion tool ! See
the Flash object transform
tutorial. Always make sure that you see a big "cross-hair"
cursor before you start moving around anything.

[bookmark: Subselection_tool]
5.2.2 Subselection tool

The subselection tool allows you to select paths of an object so
that you can make more sophisticated modifications. Click on the
outlines of objects. You then can drag around the little squares
and dots that will appear, i.e. modify portions of shapes. See the
Flash object transform
tutorial for details.

If you want to modify a symbol (in the properties panel you can
see something like "Instance-of") you have to break it apart:
Right-click->Break Apart.

[bookmark: Free_Transform_and_Gradient_Transform_tools]
5.2.3 Free Transform and Gradient
Transform tools

The Free Transform tool will allow you to make several kinds of
transformations. When you select an object with this tool and then
move the mouse over different spots, you will that the mouse cursor
changes shapes. Each one will allow you do different
transformations:


	Scale an object: double-ended arrow

	Rotate an object: circle arrow

	Skew (distort an object): double ended double arrow



To do a proportional scale, hold down the SHIFT key and then
drag a corner.

There are more options to the free transform tool, e.g.
so-called envelope transform, see the Flash object transform
tutorial if your are curious about this.

The Gradiant Transform tool is hidden below the free
transform tool (by default) and allows you to change the ways in
which color gradients flow. Hold down the mouse for a while and
then change the tool. See the Flash colors tutorial.

[bookmark: Lasso_tool]
5.2.4 Lasso tool

Select several objects or parts of a shape. Remember: to
transform an object into a shape, break it apart. This tool
also includes a "magic wand" mode (see the controls)

[bookmark: Pen_tool]
5.2.5 Pen tool

This is the tool that allows you to make the most complex
drawings, i.e. pathes with Bezier curves.

(not explained here ....)

[bookmark: Text_tool]
5.2.6 Text tool

Add text.

In the properties panel you may define various text properties
such as fonts, color and positioning, alignment, etc. If you click
on the paragraph symbol, you can define indent, line spacing and
margins.

[bookmark: Line_tool]
5.2.7 Line tool

Draws simple lines.

[bookmark: Rectangle_and_other_tools]
5.2.8 Rectangle and other
tools

On the same spot of the tools panel you got several tools. By
default you will see the rectangle tool. To select another tool:
hold the left mouse button down for while and then select the one
you want.


	Rectangle tool (by default): Draw simple rectangles. In the
parameter's panel you can define strokes and filling
properties.

	Rectangle primitive tool: Lets you define additional properties
like rounded corners

	Oval tool: Draw ovals

	Oval primitive tool: Define in addition other features, such as
start/end angle, inner radius etc.

	Polystar tool: Define polygons and stars (there is a small
pull-down menu in the properties panel that you should not
overlook !)



Below you can see a few drawings. The screen capture has been
taken with the Polystar tool activated.


[image: Various drawings with the rectangle, oval, polystar tools]
Various drawings with the rectangle,
oval, polystar tools





[bookmark: Pencil_tool]
5.2.9 Pencil tool


[image: ]






With the Pencil tool you make drawings like with a Pen. However,
there is optional support to draw straight or smooth lines since
drawing with a mouse isn't very obvious. You can define various
options.



	"Line" drawing Options



In the options section you can select different ways of drawing
support. I.e. the the straight icon looks like this: [image: straight]. Below is a screen-dump
that demonstrates the difference between straight,
freehand and smooth drawing.


[image: The three pencil drawing modes]
The three pencil drawing modes






	Stroke, color and line properties.



In the properties panel you can define various options like
stroke (pen) color, fill color, various dashes or not, and how the
end of lines should look.

[bookmark: Brush_tool]
5.2.10 Brush tool

The brush tool lets you paint. There are several special effects
and several modes.


	Object or merge mode




	In merge mode you only can paint fills

	In object mode you can add a stroke to your painting (by
default it is off). Look at the properties panel.




	The Brush Mode



With the "Brush Mode" in the options section (not the properties
panel) you can select the paint mode. Make sure to understand these
and to verify that the wanted mode is on, else you likely run into
frustrations ...


	Paint Normal: paints over lines and fills on the same layer.
Like painting with a "heavy" paint.




	Paint Fills: Fills empty areas leaving lines unaffected.




	Paint Behind: Paints in blank areas of the Stage on the same
layer, leaving lines and fills unaffected (this may be be default,
I am not sure).




	Paint Selection: Applies a new fill to a selection. Therefore,
before you start painting select a fill color first, then select
the object with the selection tool, then paint. This is the
quickest way to color drawings.




	Paint Inside: Fills the area within a "fill" (i.e. where you
start paining) and does not overpaint lines. If you start painting
in an empty area outside a fill, painting will not affect existing
filled areas.




	Selection of brushes and size



Choose from the options in the options section ....

[bookmark: Ink_Bottle_tool]
5.2.11 Ink Bottle tool

This tool allows you to apply color changes to the strokes of
drawings.


	Select the ink bottle

	Then select either a Stroke color (and/or a Fill
Color if the object is a graphic) from controls in the main
tools panel. If want to make more sophisticated changes (e.g. apply
a gradient) do this through the color panel.

	The click on objects you want to change.



You also can change the color of a fill or stroke through the
properties panel or the color panels, but make sure to select the
object(s) you want to change first.

[bookmark: Paint_bucket_tool]
5.3 Paint bucket tool

The paint bucket tool works like the ink bottle tool but it is
used to change colors of paintings. You also can fill in empty
areas (insides of drawings made with the pencil for example)


	First, click on the paint bucket tool

	Select fill color (and style)

	If you want to fill an area that is not entirely closed, you
can do so by modifying the gap size by changing the "Gap size"
control in the tool panel options. E.g. choose "Close medium
gaps".

	Then click on the shape or the area you want to fill



Again, you also can change paint of shapes and object, by first
selecting the thing in the stage, and then by making changes in the
properties or the colors panels.

[bookmark: Eyedropper_tool]
5.3.1 Eyedropper tool

You can select a color from some spot on the workarea. The tool
will then automatically change to the paint bucket tool (see
above).

[bookmark: Erasor_tool]
5.3.2 Erasor tool

Erase stuff. See the Flash object transform
tutorial for details.

[bookmark: Option_controls_and_tools_configuration]
6 Option controls and tools
configuration

Some option tools are always displayed, some only for certain
tools.

[bookmark: Hand_tool]
6.1 Hand tool


	Move the stage around (useful for big drawings/small screens or
with a strong zoom)



[bookmark: Zoom_tool]
6.2 Zoom tool


	Zoom in/out



[bookmark: Pen_color]
6.3 Pen color


	Select the pen (stroke) color



[bookmark: Fill_color]
6.4 Fill color


	Select the fill color



[bookmark: Swap_color]
6.5 Swap color


	Change fill color to stroke color



[bookmark: Configuration_of_the_Tools_panel]
6.6 Configuration of the Tools
panel

The Tools panel can be configured via Edit->Customize
Tools Panel (but for now I suggest not to change anything
there).

[bookmark: Configuration_of_drawing_settings]
6.7 Configuration of drawing
settings

Select Edit->Preferences and then change parameters in
the section Drawing. (no need to do this now). Basically you
can modify how Flash helps you drawing objects (e.g. connected
lines, vertical/horizontal) and how it identifies objects when you
click on them.




[bookmark: Painting_simple_objects]
7 Painting simple objects

In this chapter we will show how to make a complete (but
simple!) drawing. Disclaimer: Daniel K. Schneider doesn't even
remotely feel to be graphics designer. If you are not familiar with
layers, you now really should have a look at the Flash layers tutorial

Firstly, you can find lots of free clipart (drawings) on the Internet. As a principle it
is a better idea to search for vector graphics as opposed to
bitmaps and for three reasons:


	Vector graphics are smaller

	They can be re-edited

	They adjust nicely to size. A smaller or bigger version still
looks as good as the original.



To find vector objects you can for instance type in Google "free
clipart download" or see the links in the clipart article (finding good and free clipart on the
web is not easy).

Most often, clipart is distributed in *.wmf format (Windows Meta
File format). Flash can handle this format. It also can handle
Illustrator *.ai format, Enhanced Windows Metafile *.emf, Freehand,
Flash *.swf, and Autocad *.dxf. It can not handle SVG (but
you can open SVG files with Illustrater and then copy/paste).

You also can import a series of bitmap formats like the
"standard" *.png, *.jpg, *.gif, but also Photoshop *.psd and a
variety of Quicktime formats if it is installed on your
computer.

[bookmark: Drawing_fuzzy_objects]
7.1 Drawing fuzzy objects


[image: An apple tree drawn in merge mode]



An apple tree drawn in merge mode





The basic principles for paint-challenged people like me is the
following:


	Create a new layer. It is usually a good policy to create a new
layer for each drawing. Do not worry about size and position at
this stage, since you can later move the drawing around and resize
it.

	Zoom in (like 200%), e.g. with
View->Magnification

	Select merge mode from the Object Drawing tool and set
the brush tool to overpaint.

	Keep the painting as simple as possible

	Use large Pencils or brushes for starters, then small ones to
work on borders if needed.

	Use the eraser to trim off strokes that went too far

	Draw stuff that will go to the background first and then
overpaint



E.g. To the right is a simple apple tree with a green snake (I
later erased).

[bookmark: Drawing_animals_and_such]
7.2 Drawing animals and
such


[image: A really ugly cat drawn mostly in object mode]



A really ugly cat drawn mostly in object mode






	Find a recipe to draw these, e.g. on Google type: "how to draw
a cat"

	Then reproduce if you can ;)

	Rather use object mode and disable stroke since these models
often ask you to overlay ovals. Without stroke you may overlay
various geometric shapes of the same color.



E.g. here is a cat made as explained in Creature Features.

Alternatively you also can first draw the object with the pencil
tool (or the pen tool) and then use the Paint Selection or Paint
inside mode of the brush tool to apply colors.

Of course in the same drawings you can mix pencil, pre-built
objects like rectangles and paint. E.g. draw the outline of house
with the pencil and then draw the roof with the paint tool.

[bookmark: Save_each_object_as_symbol]
7.3 Save each object as
symbol

Once you are happy with a drawing, you should convert it to a
(reusable graphic symbol): Right-click->Convert to Symbol;
Graphic. E.g. call it "cat". You then can remove the layer you
used to draw this object, since the raw drawing is no longer
needed.


[image: convert a select object to a symbol]



convert a select object to a symbol





Once you have it in the library you can use several times, in
various sizes and distortions. You also can copy the object and
e.g. make a new one with different colors ... If you are unhappy
with the results (as I ought to be), you can just break a graphic
apart and restart again...

When you insert a library object into stage you can make it
smaller. Drag it from your library into the stage (but onto another
layer) and then select the Free Transform tool; Press Shift
(proportional reduction) and make it as small (or big) as you
like.

[bookmark: Importing_clipart]
7.4 Importing clipart

Flash can handle various vector formats and even better: you can
modify these within Flash.

To import:


	File->Import->Import to Stage or alternatively Import to
Library

	If you import it to the stage and like it, then save it to the
library with Right-click->Convert to Symbol; Graphic as
explained above.





[image: A cat from www.free-clip-art.com. Copyright: Personal and educational use]



A cat from www.free-clip-art.com. Copyright: Personal and
educational use





E.g. here is a cat I imported from Free Clip Art. This site has free clipart images
for personal use. You can use them for school, fun, non-profit Web
sites, and other personal needs.

[bookmark: Adding_background_and_Sky]
7.5 Adding background and
Sky

I suggest to draw background stuff with a new layer You can do
this beforehand or after. In order to see either background or
objects you can put all other layers in "outline mode". Click on
rectangles near each layer or on the rectangle on top.


[image: Making use of the "Layer Outline Mode"]
Making use of the "Layer Outline
Mode"






	First of all you can change the background of the stage:
Modify->Document; then change the background color.

	If the layer with your background drawings (e.g. sky) is drawn
over the objects instead of the other way round, just move this
layer (either to the top or to the bottom depending on your
settings).



[bookmark: A_result_.28sort_of.29]
7.6 A result (sort of)

Here is the result of a three times two trees, two of my cats,
an imported cat and a little house.


[image: A flash document with trees and cats]
A flash document with trees and
cats





[bookmark: Using_textures]
7.7 Using textures

Of course, you may find the grass to be too ugly. A good
solution might be to replace a background color with textures.
Search on the web for "free textures grass" and save the file
(usually a *.jpg).

You should be aware that there are textures and textures meant
to be tiled. Simple pictures (if smaller than the stage) will
produce tiles that you can see (not exactly what you want). So
instead you can search for something "free tileable grass
textures". If you can't find good tiles, you may learn how to do
this with this Photoshop from DadyyCool.


	You then can resize the image if it is too big and/or crop
it.

	After that, deselect all objects (click in the gray area) or
select the object you want to paint.

	Then open the color panel and select type: Bitmap from
the pulldown menu. Import the bitmap and select it (you also will
find a copy of the bitmap in your library).

	Then paint the outline of your textured area with the brush
tool (in the "Paint behind mode" (see brush tool above)

	Then fill the rest with the paint bucket.

	You can change the way textures are applied with the free
transform tool (see Flash colors tutorial).




[image: A flash document with trees and cats]
A flash document with trees and
cats





This result is not exactly better, but it's different and you
can see that you can draw with bitmaps :). Of course one now
also should repaint the house and the trees. I also rotated the
gradient for the sky by the way.

Of course, one can do better graphics and colors. See more
advanced Flash tutorials on drawing, e.g. the
Flash object transform
tutorial, the Flash arranging objects
tutorial or the Flash colors tutorial

[bookmark: Files_to_download]
7.8 Files to download

You can download the *.fla files here:


	http://tecfa.unige.ch/guides/flash/ex/drawing-intro/

	flash-cs3-drawing-trees.fla is the one with a simple
background

	flash-cs3-drawing-trees3.fla uses gradients and drawings
outside the stage are clipped away (so it's a clean version of the
above and I will use this one in the Flash motion tweening
tutorial).

	flash-cs3-drawing-trees2.fla is the one with the textures.







Flash object transform tutorial
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This entry is part of the Flash tutorials.

[bookmark: Overview]
1 Overview



	Learning goals

	Learn about basic Flash 9 (CS3) object transformations with
various tools.

	Prerequisites

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Moving on

	Select one from the Flash tutorials.

	Probably you'd like to animate shapes (Flash shape tweening
tutorial)

	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It aims at beginners. More advanced features and tricks are not
explained here.

	Materials

	None, just play with your own objects :)





Flash has quite powerful object transformation tools. You should
learn about these in order to create more sophisticated drawings
and/or morphing (shape tweening)
animations animations.


	Executive summary - Various drawing strategies for complex
objects




	Draw/paint in merge mode (overpaint shapes), then transform to
graphic object.

	Draw in object mode, then group or convert to symbol.

	Carve shapes with the eraser.

	Transform a simple shape with select tool, envelope transforms
and sub-selection tool.

	Assemble objects (see Flash arranging objects
tutorial), then any of the above.




	Executive summary - transform tools in the tools panel




[image: Tools for transformations in the tools panel]
Tools for transformations in the tools
panel






	The Select tool allows to quickly distort an unselected
object by moving the cursor close to it until it changes to
curve or edge shape. The you simply drag the mouse.
(BTW this is a very dangerous tool, by mistake you can dammage your
drawings if you don't lock the other layers ...)

	Use the Free Transform tool and its variants to make
complex transforms of the envelope of a shape, e.g. learn how to
use the envelope transform.

	The Subselection tool allows you drag squares
(distortion points) and turn/drag circles (curve control handlers).
I view it more as a "repair" and "fine tuning" tool.

	With the Eraser you can "carve" out objects (like a
woodcutter or a chainsaw artist).




	Executive summary - transform tools in other places




	The menu Modify->Transform can get you directly into
the modes of one of these tools.

	The Transform panel (Window->Transform) lets
do you the default free transforms by entering property values for
size, rotate and skew.

	Hit CTRL-ALT-S to resize or rotate a selected object by
entering a number.

	The menu Modify->Shape has a few tools to
automatically adjust shape.

	Finally, there are also transformation icons on the main
toolbar (which is not shown by default, use
Window->Toolbars->Main).



... a rather confusing amount of tools. Probably I forgot
something ;)

[bookmark: The_select_tool]
2 The select tool

The select tool (arrow on top) strangely enough has two
functions. These are entirely different and may lead to
confusion.


	Select objects

	Distort objects



To distort objects the easy way, read on ...

[bookmark: Default_behavior_of_the_select_tool]
2.1 Default behavior of the select
tool

If you click on an object or if you select it with a selection
box you see this:


	A hooked cross icon

	A white circle in the middle of the selected object (or
selected objects)



You then can move it around, but that's not what we are
interested in right now. The only important thing you may remember
is the following:


	when you see a cross, it means that you successfully selected
the object.

	The white dot represents the center, e.g the point where an
object will snap to a motion guide line.




[image: A simple oval]
A simple oval





... this is not what you want.

[bookmark: Let.27s_now_make_a_banana]
2.2 Let's now make a
banana

Ok, now let's distort an object. Let's start with an oval drawn
in object mode. See the picture above or below.


	Make a rounded banana with the selection tool




	First, deselect everything (including the banana), e.g.
click on the gray workspace area.

	Select the select tool.

	Then move it close to the stroke (outline).

	When the cursor turns into a curve, then hold down the mouse
and drag




[image: Select tool - curve icon]
Select tool - curve icon





Here is a result, a nice banana:


[image: A simple oval turned into a banana]
A simple oval turned into a banana






	Make sharper ends




	Copy/paste the banana, if you like the old one. (select,
ctrl-c, ctrl-v)

	Again, deselect everything

	Then hold down the ALT key and slowly search around the ends of
the banana.

	If you see the angle icon, then drag. The angle icon won't show
up everywhere, it's basically meant to drag corners.




[image: Select tool - curve icon]
Select tool - curve icon





Result: two bananas of different shape:


[image: A sharp and a round banana]



A sharp and a round banana





You then can fine tune things with the subselection tool (see
below).

[bookmark: Turning_lines]
2.3 Turning lines


	To turn a line use the select tool and move to one end. When
the edge icon shows up, you can turn/stretch a line.




[image: Edge/angle icon - turning/stretching a line]
Edge/angle icon - turning/stretching a
line





Hint: To rotate around a random rotation point, see the free
transform tool below

[bookmark: The_Free_transform_tool]
3 The Free transform tool

Make sure that you understand drawing basics, i.e. have an idea
what kinds of tools you got in the tools panel. If you don't,
please go read the Flash drawing tutorial.

[bookmark: Features_of_the_free_transform_tool]
3.1 Features of the free transform
tool

The free transform tool allows you to do several
things


	By default: Scale, rotate, skew and distort

	Envelope transforms

	Distorts (but see the selection tool)



So again, you face a multipurpose tool. You can define its
different variants by selecting different mode in the options part
of the tools panel (lower end). Read on ...


	The Transform panel



Instead of dragging around handles as explained below, you also
may type in transformation values in the Transform panel. That's
useful for technical drawings.

Get it with the Window->Transform menu. I usually have
this docked next to the color panels (top right) as in the
following screen capture. (If you don't know how to dock, please
read the Flash CS3 desktop tutorial).


	A screenshot of tools related to the Free Transform tool




[image: Lots of transform tools ...]



Lots of transform tools ...





[bookmark: Simple_transformations]
3.2 Simple
transformations

By default the free transform tool let's you scale, rotate,
skew.


	To select an object for transforms




	Select the Free Transform tool

	Click on an object (or the other way round)




	The transformation controls




	You object will be in a rectangular box with a distortion
control in each corner and one in the middle of each line.




	To scale in both directions (x and y)




	Grab a corner and drag as in the screen dump below:




[image: X and Y size transform]
X and Y size transform






	If you want to scale a graphic and keep the proportions, hold
down the SHIFT key.




	To scale into one direction (x or y)




	Drag one of the points in the center of a line (of the
surrounding box).




	To rotate an object




	Move your mouse outside near a corner. You will see a rotation
icon.

	You then can turn around the object.




[image: Rotate with the transform tool]
Rotate with the transform tool





You also will see the changes in the transformation panel. Btw.
you can move the rotation point (see next section).


	To skew an object




	Move your mouse over a stroke (line), but not over a distortion
box

	You will see some vertical or horizontal double arrow (skew
icon)

	Then drag ...




[image: Skew with the transform tool]
Skew with the transform tool





[bookmark: Rotations]
3.3 Rotations


	By default an object will rotate around the white circle in the
middle. But you can move this rotation point. Grab it with the
mouse and move it where ever you want. Flash also gives some help.
E.g. if the drawing is a line it will display the center of the
line and you then can move the point to one of its ends for
example.



In the following screendump we have a picture of a stick man and
we'd like turn his right arm. To do so:


	Click on the Free Transform tool (standard options as
above)

	Then move the little dot in the right arm towards the "inner
end" of the stick man. The cursor should have a little circle next
to it in this mode. See the screen shot below.




[image: Change rotation point with the Free Transform Tool]



Change rotation point with the Free Transform Tool





After that you can rotate the arm around its new rotation point
(as described in the previous section).


	Again, use the Free Transform tool (standard options)





[image: Rotate around the new rotation point with the Free Transform Tool]
Rotate around the new rotation point with
the Free Transform Tool





The standard options of the transform tool allows to rotate,
resize and distort an object. You have to work with options for
more complex transforms.

[bookmark: Envelope_transforms]
3.4 Envelope transforms

Envelope transforms allow to change the shape of an
object in a more controlled way. It works on both shapes and
objects. Let's now make a designer chair.


	Step 1 - Draw a rectangle




	Do it with the rectangle tool.




	Step 2 - Go into envelope transform




	Select the object first, i.e. the rectangle.

	Click on the Free Transform Tool.

	Select the Envelope option (see the screen capture
below). So this tool is an option of the "free transform tool"




[image: Envelope Transform with the Free transform tool]



Envelope Transform with the Free transform tool






	Step 3 - Transform




	Drag any little square. These are called distortion
points.

	Once you start transforming you also get curve control
handles (the little circles). You can turn these in order to
smoothen out curves. See the screendump just below. Or you can drag
them to add new distortion (or combine both movements of
course)




[image: Envelope transforming to make a designer chair]
Envelope transforming to make a designer
chair





[bookmark: The_transform_menu]
4 The transform menu


	The Transform Tools



The Menu Modify->Transform gives you the choice of
several kinds of transformations


	Select the object(s) to be transformed first

	Then select from several options




[image: The transform menu]



The transform menu





Basically it let's you all you can do with


	The Free Transform tool and its options

	The Subselection tool




	The Shape Tools



You can smoothen out shapes, make them blurry or straigthen,
etc.


	Menu (Modify->Shape) has a few tools



You can for example:


	Smooth, i.e. take away some edges

	Reduce the amount of edges (optimize)

	Add soft edges, i.e. make the borders "blurry"

	Straigthen



Here is an example of soft edges and straighten:


[image: Modify->Shape Tools]
Modify->Shape Tools





You can not do everything with composite objects. E.g. to add
soft edges, ungroup / break groups apart first, then union...

[bookmark: The_Subselection_tool]
5 The Subselection tool

This tool allows envelope transformations or rather fixing
envelope transforms made with the selection tool or with the
transform tool in envelope or distortion mode. Handles work like in
the Envelope transform tool.


	Distortion points



The little squares are distortion points


	You can drag these anywhere to change the shape of the
object

	You also can drag them along the stroke before you drag them
out

	You can delete these. Move the cursor over one of these and
when the cursor changes shape, click first, then hit delete. This
will simplify a stroke.




	Curve control handlers



The little dots are curve control handles with which you can
adjust the curves in two ways:


	You can turn them to change the curve: smooth or sharpen.

	But you also can drag them to some place to distort the shape
....

	To get curve control handles click on a distortion point or
move it.




[image: Dragging out a shape with a curve control]
Dragging out a shape with a curve
control





If you can't see well what your are doing (I can't in 100%
mode), zoom in like 200 or 400% ...

[bookmark: The_Eraser_tool]
6 The Eraser tool

The eraser tool allows you to carve objects. In the options /
controls in the tool panel, you can change the way the eraser
works.

Erasing shapes (drawn in merge mode) and graphics objects (drawn
in object mode) doesn't lead exactly to the same results. When you
carve an object it remains an object. When you carve a (single)
shape, it will divide into other shapes.

We shall not explain much here, better try it out ...


	Draw three nice fat ovals with a fat stroke. Two of them
overlapping

	Then, select the eraser mode. This works like the paint
tool

	Use Ctrl-Z to undo what you have done .... so you can try other
options.




	Eraser modes



Here are the modes:


	Erase normal: Will erase as you paint

	Erase fill: Will only erase fills (paint)

	Erase lines: Will only erase strokes (lines, contours of
objects)

	Erase selected fills: Will only erase fills that you
have selected (hold down the SHIFT key to select several)

	Erase inside: Will erase fills inside an object if you
start erasing inside the object.



In the following screen dump we used the 'erase fill
option to take out fills from the oval and the rectangle.


[image: Eraser options]



Eraser options






	The faucet




	Will kill any shape on which you click. It makes a distinction
though between the stroke and the fill of an object.




	Eraser shape




	You can select different sizes of circles and rectangles

	Use rectangles to carve off rectangles and circles to carve of
round stuff.



[bookmark: The_Lasso_tool]
7 The Lasso tool

Includes a magic wand (see the controls at the bottom of the
tools panel)

(to be continued some day)

[bookmark: Moving_on]
8 Moving on

If you already didn't do it, try the Flash shape tweening
tutorial, i.e. learn how to do morphing animations.

Flash arranging objects tutorial
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This is part of the Flash tutorials.

[bookmark: Overview]
1 Overview



	Learning goals

	Learn to align, stack, combine, break objects in Flash CS3

	Flash level

	CS3

	Prerequisites

	Flash CS3 desktop tutorial

	Flash layers tutorial (first
part)

	Flash drawing tutorial (at least
some of it)

	Quality and level

	This text should technical people get going. It's probably not
good enough for beginners, but may be used as handout in "hands-on"
class. That is what Daniel K. Schneider made it
for...

	It aims at beginners. More advanced features and tricks are not
explained here.





[bookmark: Snapping]
2 Snapping

Snapping refers to a kind of assistance you may get for
technical drawings. It helps to position an object with respect to
the others and without using the Align Panel.

You can tune the desktop to various snapping modes


	Menu View->Snapping or right-click on the
workspace

	Then turn on/off snapping modes or better click on Edit
snapping



I usually just have these ones. (But more often I turn snapping
off and then rather align objects with the align panel).


	Snap align

	Snap to objects

	Horizontal and Vertical Center alignment (will also allow to
snap against centers of objects, otherwise you only can snap
against sides)




[image: Edit Snapping]



Edit Snapping






	Snap to Objects




	Will snap an object you move against parts of an object. Move
slowly...




	Snap Align (when snap objects is also on)




	Will snap to dotted lines that will appear




	Snap to Grid




	Works when you turn on the Grid with menu
View->Grid

	Useful when you do technical drawings for instance.




	Snap to Guides




	Same principle as snap to grid. (View->Guides).




	Snap to Pixels




	For high precision work. Magnify the stage to at least
400%.



Object spacing does what its name says:


	If horizontal or vertical spacing defines the snapping distance
in relation to the edges of other objects

	Note: This means snapping to the center of a line ! E.g.
if distance is 0px and your lines are 5px, your objects will
overlap.



Disclaimer: I am not sure what certain combinations do. Here is
for example what happens if you drag the red rectangle close to the
yellow one in snap align / snap objects mode with zero object
spacing:


[image: Align object snapping]



Align object snapping





[bookmark: Aligning_objects]
3 Aligning objects

To align objects on the stage, there exist three solutions:


	Use the align panel (Open it with Window->Align or
CTRL-K and dock it next to the Colors panel

	Use menu Modify->Align

	Use the shortcuts (see Flash CS3 keyboard
shortcuts)




[image: Various align interfaces of Flash CS3]



Various align interfaces of Flash CS3





With the align panel, you can align, distribute or resize a
series of selected objects.

There are two fundamental modes:


	Align/distribute referring to the stage. I.e. you may want to
align a picture in the center of the stage.

	Align one or several objects with the first selected, or
distribute among the first two selected objects.



The align panel (with "to stage" option unticked):


[image: Various align interfaces of Flash CS3]
Various align interfaces of Flash
CS3





To see what each icon does, move your mouse cursor over it. The
align panel icons convey the following kind of message:


	The line represents the border against which alignment or
distribution will be made (left, right, middle, top, bottom,
etc.)

	The dark and the white rectangle represent the selected
objects



Match size will change the size (either width, height or both)
of smaller objects with a larger object. Space works a bit like
distribute.

[bookmark: Aligning_objects_in_several_frames]
4 Aligning objects in several
frames

You also may align objects in several frames. For example, to
align letters in all frames: Click on the Edit multiple
frames button in the bar below the timeline.


[image: Select all frames]



Select all frames






	Then, you can select the frames you want to edit together by
moving the "[" "]" sliders on top of the timeline

	Then select groups of objects you want to align (e.g. different
letter groups in our case), then use the align pane
(Window->Align), but untick To stage (!)



This tool is quite dangerous, since it is hard to control what
happens in each frame. Make sure to save your file before you
engage in this ! Also, when you are done, untick the Edit
multiple frames button.

[bookmark: Stacking]
5 Stacking

When you draw a new object it is drawn on top of the others.

You can move forward or backwards any selected object(s)


	Use the right-click->Arrange menu or:




	CTRL+Up Arrow - Move Ahead

	CTRL+Down Arrow - Move Behind



[bookmark: Grouping]
6 Grouping

[bookmark: Turning_shapes_into_objects]
6.1 Turning shapes into
objects

To combine several shapes into an object:


	Menu Modify->Combine Objects->Union



To break apart an object:


	Menu Modify->Break Apart or Right-click->Break
Apart or CTRL-B



Tip: This operation is not innocent, i.e. it creates a new
single editable object. If you just want to group vector graphics
into a composite object use "grouping" (see below).

[bookmark: Creating_a_new_object_from_others]
6.2 Creating a new object from
others

Menu Modify->Combine Objects lets you combine objects
in several ways:


	Union as above: It will create a new object and respect
the stacking (i.e. as you see it on the stage)

	Intersect will only the take the common area

	etc ...



To break apart an object:


	Menu Modify->Break Apart or Right-click->Break
Apart or CTRL-B

	The result will be shapes, not the original objects.



[bookmark: Grouping_Objects]
6.3 Grouping Objects

Use this feature, if you plan to re-edit hierarchies of grouped
objects as you may have in complex drawings. To group several
objects:


	Select the objects you want to group.

	Hit CTRL-g or menu Modify->Group



To ungroup an object


	Select it

	Hit CTRL-SHIFT-g or menu Modify->UnGroup



Note: Flash will allow you to animate grouped objects in a
motion tween, but it will create tweening objects in the library
(like it does for simple, editable objects). You can't ungroup
these anymore, except by breaking them apart. I suggest
alwaysusing movie clip symbols for motion animation! Tween
objects are bad (at this stage).

[bookmark: Grouping_Objects_into_a_symbol]
6.4 Grouping Objects into a
symbol


	Select several objects

	Right-click->Convert to Symbol or hit F8



Then you have to select the type:


	"Graphic" means a graphic (i.e. an named group of objects)

	"Button" will create a button symbol (you then can fine tune
the button frames)

	"Movie Clip" will allow you to use the object for motion
animation



All these symbols can later be edited (double click in the
library or the stage to land in symbol editing mode).

Tips:


	Use movie clips, unless you have a reason to do otherwise. A
movie clip is really not the same kind of object as button for
example.

	Always give your symbols a meaningful name !



[bookmark: Conclusion_.2F_more]
7 Conclusion / more


	If you draw a lot, you may want to print the list of Flash CS3 keyboard
shortcuts

	At some point you also should learn about the various kinds of
objects you can have in a *.fla file. They all have different
purposes, e.g. various kinds of tweens only work on certain kinds
of objects. See the Flash formats and
objects overview.



There is more stuff in the Modify Menu, but that's its enough
for now ... :)

Flash colors tutorial
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information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !



[bookmark: Introduction]
1 Introduction

This is part of the Flash
tutorials.



	Learning goals

	Learn about the color types (normal, gradient and bitmaps)

	Learn about color models (RGB and HSB)

	Prerequisites

	Flash CS3 desktop tutorial

	Flash layers tutorial

	Flash drawing tutorial (at least
some of it)

	Quality and level

	This text should technical people get going. It's probably not
good enough for beginners, but may be used as handout in "hands-on"
class. That is what Daniel K. Schneider made it
for...

	It aims at beginners. More advanced features and tricks are not
explained here.

	Materials (*.fla files you can play with)




	http://tecfa.unige.ch/guides/flash/ex/colors-intro/

	The Colors SWF includes a short demo of bitmap
colors, the alpha channel, gradients and filters.






	Color types overview



In Flash there are three kinds of colors


	Normal colors (solid)

	Gradients (linear and radial)

	Bitmaps



Both RGB and HSB model is supported for colors

[bookmark: Tools_overview]
2 Tools overview

[bookmark: Color_related_tools]
2.1 Color related tools

Flash CS3 has several color tools and controls


	In the tools panel




	Paint bucket and ink buckets

	Stroke color and fill color (for most tools). Select colors
before you choose a tool to draw




	In the properties panel




	Stroke color and fill color




	Color panel




	Color selection




	Swatches




	Preset colors



[bookmark: How_to_use_the_color_selection_popups]
2.2 How to use the color selection
popups

When you select (or change) fill or stroke color, a color popup
swatches pane will pop up. You then can select a color with the
eye-dropper tool or alternatively from any color in the Flash
workspace.

You also can change alpha channel or type a 6 digit hexadecimal
RGB Code (see color panel explanation below)

[bookmark: How_to_use_the_color_and_the_swatches_panel]
2.3 How to use the color and the
swatches panel


[image: Color panel - Gradients]



Color panel - Gradients





To work with the color or the swatches panel, select an object
on the stage (or decide to modify the one that you are working
on)

We recommend to have the color panel docked on top right, else
get it with menu Window-Color (or SHIFT-F9).


[image: The Flash CS3 Color panel]



The Flash CS3 Color panel





In the color panel you then can:


	Select the color type

	Select various colors (depending on color type)

	Change the alpha channel (i.e. transparency)

	With the little pulldown menu on top right, you also can change
the color model from RGB to HSB



The swatches panel (not shown here) includes a series of
standard colors. These are same ones you get with the Fill controls
in the Tools and Parameters panel

[bookmark: Solid_colors]
3 Solid colors

Solid colors can be defined in various ways (and there is a
whole science behind it). Let's just recall a few principles. For
more information, please see the Wikipedia links in the color
article.

Let's define a few terms first:


	Hue




	means "color"




	Saturation




	means amount of a color you apply, i.e. the intensity.




	Brightness




	How much light you apply. A lot of light makes a the color
washed out and very little light makes it very dark.




	Transparency




	How much you can see trough

	See alpha channel below



[bookmark: RGB_colors]
3.1 RGB colors

RGB colors are the most popular ones used in computing
applications. A color is defined by the amount of Red
- Green - Blue. By default, the CS3 color panel is in
RGB mode.

RGB is the way computer monitors work. E.g. to get a nice yellow
you need 100% Red + 100% Green + 0% Blue. RGB is a so-called
additive color mixing model. “Projection of
primary color lights on a screen shows secondary
colors where two overlap; the combination of all three of red,
green, and blue in appropriate intensities makes
white.” (Wikipedia). Now if you project each of these primary
colors with different intensity, overlapping colors will
change.

[image: A representation of additive color mixing (Wikipedia)]

This model is not how colors work when you mix real paint. Then
you'd rather work with a red-yellow-blue model. Color printers yet
work with another model, i.e. magenta, cyan and yellow (or more).
RGB colors can be encoded in various ways. For Internet formats
such as HTML, CSS or Flash, most often a hex triplet is
used, i.e. a hexadecimal 6 digit number. With 2 hexadecimal digits
you can represent numbers in the range of 0 to 255.

With ordinary numbers you would represent a full red like
this:


	(255,0,0) - meaning full red, no green, no blue



The corresponding hex triplet is FF 00 00:


	#FF0000



In terms of percentage of colors you get:


	(100%, 0% , 0%)



Let's now have a look at a few colors in a diagram we copied
from Wikipedia on sept 8 2007: It represents "Truecolor",
i.e. RGB values in 24 bits per pixel (bpp). In Truecolor, colors
can be defined using three integers between 0 and 255, each
representing red, green and blue intensities. For example, the
following image shows the three "fully saturated" faces of the RGB
cube, unfolded into a plane:



	

	(0, 0, 0) is black

	(255, 255, 255) is white

	(255, 0, 0) is red

	(0, 255, 0) is green

	(0, 0, 255) is blue

	(255, 255, 0) is yellow

	(0, 255, 255) is cyan

	(255, 0, 255) is magenta




	yellow

(255,255,0)
	green

(0,255,0)
	cyan

(0,255,255)



	red

(255,0,0)
	[image: ]
	blue

(0,0,255)



	
	red

(255,0,0)
	magenta

(255,0,255)




For more information about colors see links in the color
article. Have a look at Wikipedia's great list of colors if you need to find a number for your
favorite color name. (If you speak french, get this one. You also may read the Wikipedia Web
colors article. It also includes a list of colors and explains
what a hex triplet is.


	Using the Flash color panel with solid RGB colors




	It's probably a good idea to pick a standard color (click on
the little pain bucket or choose from the swatches panel)

	You then can adjust brightness/saturation with the slider or
select another more non-standard color from clicking into the
Color Picker.



Below is a standard blue (the brightness/saturation slider
remains in the middle)


[image: The Flash - Standard RBG Blue]
The Flash - Standard RBG Blue





Below is a blue with augmented brightness (using the slider to
the right of the color picker).


[image: The Flash - Washed out Blue]
The Flash - Washed out Blue





[bookmark: The_HSB.2FHSV_model]
3.2 The HSB/HSV model

The HSV (Hue, Saturation, Value) model also known as HSB (Hue,
Saturation, Brightness) defines a color in terms of three
components:


	Hue, the color: Represented as a position in the 360
degrees of a color circle.

	Saturation, the intensity or "purity" of the color:
Ranges from 0-100%. 0 means no color, i.e., a shade of grey between
black and white. 100 means intense color.

	Value or Brightness of the color: Ranges from
0-100%. 0 is always black. Depending on the saturation, 100 may be
white or a more or less saturated color.



The Hue scale from 0 to 360 degrees is the following:


[image: The hue scale (Wikipedia)]



The hue scale (Wikipedia)





In many graphics tools (not in Flash) you get a HSV color wheel
that looks like this:


[image: The hue scale (Wikipedia)]



The hue scale (Wikipedia)





On the outside you can select a color (H), then on the
inside you can select V and S.

For more information about HSV, read Wikipedia's HSV
color space article.

In Flash, when you change RGB model to HSB (with the little pull
down menu on the top right of the color panel) you will see
this:


[image: Color panel in HSV/HSB mode]



Color panel in HSV/HSB mode





The slider to the right will adjust both Saturation and
Brightness.

[bookmark: Tint_and_Shade]
3.3 Tint and Shade

According to Wikipedia, “In color theory, a tint is the mixture of a
color with white, and a shade is the mixture of a color with black.
Mixing with white increases value or lightness, while mixing with
black reduces chroma. Mixing with any neutral color, including
black and white, reduces chroma or colorfulness. The intensity does
not change.”

In Flash, tint is a color that you can add to a symbol in
motion tweening. Alternatively (but not at the same time) you can
modify its brightness. In addition you can change its alpha value
(make it more or less transparent)

See the Flash special effects
tutorial tutorial.

[bookmark: Flash_Color_Gradients]
4 Flash Color Gradients

Flash supports there are 2 kinds of color gradients (see the
picture below)


	Linear: color changing in one direction

	Radial: color changing from a center to outside




[image: Linear and radial gradients and Gradient Transform]
Linear and radial gradients and Gradient
Transform





Color gradients work with color bands. You can define 2
or more colors and Flash will fill in intermediate colors between
them. The result then depends:


	on the choice of colors

	on the width of the color band (from one color to the next
one)



You can change these be defining and dragging color pointers in
the Color panel. Read on ...

[bookmark: Using_color_points]
4.1 Using color points

There are some built-in gradients (linear and radial) that you
may use as is, however you most likely want to change things. To do
so, you need the color panel and then manipulate the controls in
the preview window.

If you select either "linear" or "radial" Type you will
see the gradient preview window at the bottom of the color
panel:


[image: Color panel - Gradients - Color points]
Color panel - Gradients - Color
points





The little "arrow squares" you now can move from left-to-right
are called color pointers and they delimit color
bands.

Here is a list of common operations:


	(a) Adjust color bands




	To make a color band smaller or larger, move various color
pointers left or right




	(b) Add new color bands




	Click into the area of the color pointers. This will add new
color pointer.




	(b) Change the color of a color pointer




	Click on a color pointer, then select a color in the panel
above or double-click on the color pointer to select from the
swatches panel.




	(c) Remove a color pointer




	Drag it down and off (below the gradient preview window)



[bookmark: Transforming_gradients]
4.2 Transforming
gradients

With the gradient transform tool (hidden underneath the Free
Transform tool) you can do five things:


	rotate gradients (both linear and radial).

	stretch out the gradient

	stretch the radial gradient in only one direction (make an
oval)

	Move the center of gradient

	Make the "rings" asymmetric




	Procedure




	Select the tool (hold down the mouse over the Free Transform
tool in the tools panel) and select the Gradient Transform
Tool.

	After selecting an object you will see five handles with which
you can: stretch in one direction, resize, turn, make rings
ellipsoid or move the center. See the screen capture below, which
shows the handles for a radial gradient transform:




[image: Radial Gradient Transform - resizing]
Radial Gradient Transform -
resizing





(note: I forgot to annotate the triangle which you also can
move).

Stretching or rotating a linear gradient works in a similar
way:


[image: Linear gradient transform - turning]
Linear gradient transform - turning





[bookmark: The_alpha_channel]
5 The alpha channel

In computer graphics, alpha compositing is the process of
combining an image with a background to create the appearance of
partial transparency (Wikipedia)

In more simple terms, you can set the alpha to some
percentage:


	100% can't see through

	80% bad see trough

	50% in between

	30% good see through

	10% good see through, but very little color

	0% no color left




[image: Alpha color channel]



Alpha color channel





Hint: With the alpha channel you can create other effects than
see-through "windows". E.g. you can overlay textures with color or
the other way round.

[bookmark: Drawing_with_bitmaps]
6 Drawing with bitmaps


[image: Color panel - bitmap colors]



Color panel - bitmap colors






	Importing a bitmap



There are two solutions:


	You can just paste a bitmap graphic into the library from the
clipboard. For example, if you see a nice (and copyright free)
texture on the Internet with the Firefox navigator, do the
following: (1) View image, (2) Copy Image, (3) CTRL-V into
Flash

	Save the image on your computer then click on the Import
button in the colors panel.




	Finding textures




	See the texture article




	Using a bitmap




	You can use a bitmap graphics either as stroke or as fill
color.




	Adjusting "grain size"



With the free transform tool you can adjust how a bitmap will be
applied. You can change:


	Size, i.e. whether the bitmap is applied as is, or reduced or
magnified in x, y direction or both

	Rotation

	Skew (a kind of distortion)



Select the Free Transform tool, then


	Click on the fill or stroke

	Play with the handles (if the bitmap is big, you may have to
search for these handle way out of the stage !)




[image: Gradient Transform tool on bitmaps]



Gradient Transform tool on bitmaps





Note: I have the impression that there may be some bugs (i.e.
the tool acts strangely when I use it twice with several instances
of the same bitmap).

[bookmark: Filters_for_symbol_instances]
7 Filters for symbol
instances

You can apply various color changes to all symbol instances
(movie clips, buttons and graphics). To do so, play with the
Color and Blend controls in the properties panel.

You can add filters (e.g. a gradient glow a bevel or a drop
shadow) to movie clip and button symbol instances. Use the Filters
panel to do so, (click on the tab in the properties panel), else
use menu Windows->Properties->Filters)

To add filters, simply click on the + sign and then play with
the parameters. Using different sorts of "Quality" also has an
important effect on the rendering, high quality may slow down
certain computers.


	Blur X and Blur Y define the size of the affected area

	Strength the force of the filter (more or less)

	Shadow and Highlight, the dark/light colors of the filter
effect

	Angle and Distance, direction of the filter effect

	Knockout and Type, whether it applies to the inside and whether
the orginal drawing is knocked away.



This is a nice feature that beginners often overlook. So if you
need cool looking 3D effects on graphics explore these filters. You
also can apply several filters to the same object. In the screen
capture below we show an attempt to create a floating 3D button
from a simple red circle.



[image: Flash CS3 filters you can apply to movie clip and button instances]
Flash CS3 filters you can apply to movie
clip and button instances





Tip: Since filters are applied to instances of movie
clips, you may use them in motion tweens. E.g. in the first key
frame you could use no filter and in the second keyframe a filter,
or change parameters or apply different filters ....

[bookmark: Colors_in_3D_graphics]
8 Colors in 3D graphics

Just for your information: 3D graphics languages and tools
usually offer a much richer palette of color types and much more
sophisticated textures. CS4 may have these too, at the time of
writing I didn't upgrade yet.

E.g. in VRML/X3D (a Web standard) you get color types like this:


	Diffuse color is a color that reflects light depending on the
angle of the surface. The object appears brighter (more lit) when
its surface is directly exposed to light as you would expect.
That's your "normal color".




	Emissive color defines "glowing objects". E.g. you would use
this to build a visible lamp.




	Specular color defines extra reflection has when the angle from
the light is close to the angle you are looking at. It is used
together with shininess. You can experiment this effect in real
life by holding a (new apple) or a photograph between you and a
window (or a lamp).



In Flash, you actually can get these effects (but I don't know
how to do it in a simple way, the easiest way may be to play with
filters as described just above).

[bookmark: Links]
9 Links


	General color




	See the color article. It includes links to good Wikipedia
articles




	Other kinds of assets




	Texture

	Clipart

	Sound Assets



Flash bitmap tracing tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !
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This entry is part of the Flash tutorials.

[bookmark: Overview]
1 Overview

Bitmap tracing means transforming a bitmap graphic (e.g.
a photograph) into a vectorized object.



	Learning goals

	Learn about basic Flash 9 (CS3), Illustrator and Inkscape
bitmap tracing.

	Prerequisites

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash layers tutorial

	Flash shape tweening
tutorial

	Moving on

	The Flash article has a list of other tutorials.

	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It aims at beginners. More advanced features and tricks are not
explained here.

	Materials (*.fla file you can play with)

	http://tecfa.unige.ch/guides/flash/ex/tracing-intro/

	http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/





Bitmap tracing will turn a bitmap (e.g. a photograph or a
non-vectorized graphic) into vector graphics. This allows you for
example to


	Shape tween portraits (see also the Flash shape tweening
tutorial)

	To take bitmap graphics found on the Internet and turn them
into somewhat usable vector graphics for animation (useful if you
can find any appropriate vectorized clipart).



[bookmark: Extracting_a_drawing_from_a_picture]
2 Extracting a drawing from a
picture


[image: Vienna Lion picture]



Vienna Lion picture





That's a tough problem, since a picture got many colors and
sometimes objects overlap (i.e. you have to remove these and then
repair with painting).

To the right you see the picture of some lion that can be found
in Vienna (plus the head of a research assistant). We show how we
extracted just the lion (about 30 minutes of work).


	Step 1 - Trace the picture




	Menu: Modify->Bitmap->Trace Bitmap

	Parameters used were: Color threshold=80, minimum area=5, Curve
Fit= tight, Corner threshold = normal



This will lead to a set of shapes that are neither too big nor
to small


	Step 2 - Kill unwanted shapes and erase overlapping ones



There are several kinds of tools and tactics you may use:


	Use the Lasso in the tools panel to get rid of most the
unwanted background, but don't use it too close to the shape you
want to keep.




	Magnify after this to something like 400 percent




	Use the eraser tool




	Use the lasso again or Shift-Click on unwanted objects. Then
hit the DEL key.




	Use the eraser to draw fine lines (elect a very small rubber)
if you have to cut wanted/unwanted area in the same shape. Then
kill the unwanted one




	Use the eyedropper to select a color and then the paint brush
to repair some stuff.

	Do not use object drawing mode for this.

	You should set the paint controls to "paint behind", i.e. to
repair outlines rather paint behind something when you touch it
with the brush.








	...




[image: Vienna vectorized lions scene]



Vienna vectorized lions scene






	Step 3 - Smooth it and make it a drawing object



Select all the shapes (hit CTRL-A). Then


	Menu->Modify->Shape->Optimize. Set this to
maximum.

	Menu->Modify->Union




	Step 4 - Convert to symbol and use it



The result is really dreadful as you can see in the thumbnail to
the right:)


	Source



See the "lion*" files in http://tecfa.unige.ch/guides/flash/ex/tracing-intro/

[bookmark: Tracing_parameters_in_Flash_CS3]
3 Tracing parameters in Flash
CS3

There exist four parameters in the tracing panel:


	(1) Color threshold




	When two pixels are compared, if the difference in the RGB
color values is less than the color threshold, the two pixels are
considered the same color. As you increase the threshold value, you
decrease the number of colors. If you want a minimum of colors, try
something like 255 (or even more)




	(2) Minimum area




	The number of surrounding pixels to consider when assigning a
color to a pixel. I.e. if you want few resulting vector shapes, set
this high




	(3) Curve fit




	This will determine how smoothly outlines are drawn. E.g. in a
portrait you can make disappear things like standing our hair.




	(4) Corner threshold




	Defines whether sharp edges are retained or smoothed out.



See this little gallery of my traced portrait.

Typical settings you could use are:


	(a) A trace that keeps most of the information (many many
graphic shapes in the result




	Color threshold=10, minimum area=1, Curve Fit= Pixels, Corner
threshold = many corners




	(b) A sort of "normal" picture that gets most of the important
outlines




	Color threshold = 30 and minimum area = 30, corner threshold
and curve fits = normal




	(c) A few colors picture result with sharp lines




	Color threshold = 200 and minimum area = 2



Source of the demo application (it uses a component for
navigation)


	Directory: http://tecfa.unige.ch/guides/flash/ex/tracing-intro/

	Fla: flash-cs3-tracing-parameters.fla




	Tuning



Of course, once you have your trace, you then can remove
unwanted elements (e.g. backgrounds in a portrait), change colors
or apply all other drawing techniques you know.

[bookmark: Bitmap_shape_tweening_in_Flash]
4 Bitmap shape tweening in
Flash

We will trace of portrait picture (jpg bitmap) and then add a
shape tween to it.


	Step 1 - Import a bitmap




	Import the picture to Flash, e.g. by dragging it to the Flash
desktop.

	You may resize the picture first with an external tool




	Step 2 - Trace it




	Menu: Modify->Bitmap->Trace Bitmap

	You can play around with a few settings



Here is an example that shows the original and the traced result
side by side


[image: Live tracing with IllustratorCS3]



Live tracing with IllustratorCS3






	Step 3 - Make a shape tween




	Hit F6 in some distant frame

	Make changes to the vector image in the new frame. E.g. distort
or change colors (use the Select or the Lasso tool to select areas
of the picture)

	Add the shape tween.



You can admire the result (files
flash-cs3-shape-picture-morphing3.*)


	Tuning




	Adjust the size of the picture to the scene with the

	You may extend the first frame to remain stable for a while so
that users can see the original

	Then you could add a "stop();" in the Last Frame. Hit F9 and
type




stop();



	This will stop the animation. (See the Flash button tutorial for more about
ActionScript.



Of course this is really ugly ...

[bookmark: Tracing_a_bitmap_with_Illustrator]
5 Tracing a bitmap with
Illustrator


	Step1 - Trace the bitmap



Illustrator CS3 has more sophisticated bitmaps tracing features.
Here is a very short example that includes a shape tween:


	Open the picture in Illustrator

	Select it

	Now you will have a "Live Trace button" on the control panel on
top

	Next to it is a little pulldown menu from which you can select
various options, for a portrait you may choose "Color 16"




[image: Live tracing with IllustratorCS3]



Live tracing with IllustratorCS3





Once you hit the trace button, the controls on top will change
and you can play with all sorts tracing methods and parameters


[image: Live tracing controls with IllustratorCS3]



Live tracing controls with IllustratorCS3






	Step2 - Import to Flash




	Copy/paste if from Illustrator with the options: Paste using
AI File Importer preferences and untick maintain
layers

	You may adjust the size of the stage to the size of the picture
somewhat, I chose to add some big margins for a reason you will see
later.

	Convert it to a symbol (so that you have a copy in the
library)




	Step 3 - Break it Apart




	Then right-click->Break Apart

	You have to do this several times, since illustrator produced
object groups within object groups (use ctrl-Z if you think you
went too far).




	Step 4 - Create a new keyframe




	Right-click on frame 20 and hit F6 to create a new keyframe
with the same picture.




	Step 5 - Distort the picture in keyframe 1



Try everything you can


	Select parts and change the color with the paint bucket. That's
actually the only thing I did

	You also can move parts, but probably you then should start
with a much simple ray trace.

	Distort parts with the Selection Tool, the Subselection tool
and the Free Transform tool




	Step 6 - Add a shape tween between the two frames



... enjoy


	Tune




	You also may at the very end (after the last keyframe) insert
the original jpg picture. Tracing bitmaps is a very
difficult issue, since there are many kinds of algorithms you can
select from.



Basically the machine must be told how to group similar pixels
together into a vector objects. For example, an algorithm can group
together pixels with similar brightness, similar color, or try to
find lines from similar pixels.


	Publish




	In the HTML setting you probably want to take off the "loop"
option



You can admire the result


	Files: flash-cs3-shape-picture-morphing.*)

	Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/



[bookmark: Tracing_a_picture_with_Inkscape]
6 Tracing a picture with
Inkscape

The free Inkscape editor can
also trace. If you don't own Illustrator and need more than CS3 can
offer, you may give it a try.


	File->New ; Select the bitmap file (e.g. a
*.jpg)

	Select it (!)

	Path -> Trace Bitmap item (or Shift-Alt B)

	You then will see a popup with various options, Click on
Update to make as many trials you like. Make sure your
picture is selected. Then play with:

	Brightness cutoff

	Edge detection

	Color quantisation





	Each of these does different sort of traces.

	Click on OK once you are happy

	The original picture will still be there. Remove it and save
the result with File->Save As








	Using two graphics from start



This time I used another strategy:


	I made two different traces with Inkscape

	I used one for keyframe 1 and the other for keyframe 2 and
saved them in SVG

	Since Flash cannot import SVG (why the hell ?) I open
these files in Illustrator and then pasted to Flash.

	I then used the erasor tool to isolate a few graphics shapes
(e.g. hair and eyes)

	I then put "hair" and "eyes" in a different layer

	I finally inserted some shape hints (see the flash shape tweening
tutorial




	Changing the background color




	I added a new layer and painted a rectangle over the stage in
Keyframe 1

	Same for a new keyframe

	Then I also added a shape animation between the two.



You can admire the result. It's also fairly ugly
(despite some extra work)


	Source

	Fla file: flash-cs3-shape-picture-morphing2.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/



Ok that would be the only picture of me in edutech wiki. In
addition I made these very quickly which is not what you should do
in a "real" production. The result is really ugly and useless
...

[bookmark: Links]
7 Links


	Convert bitmaps to vector graphics (Adobe Flash
C3 Help)

	Control shape changes with shape hints (Adobe
Flash C3 Help)



Flash pen tutorial


This article
or section is a stub.

A stub is an entry that did not yet receive substantial
attention from editors, and as such does not yet contain enough
information to be considered a real article. In other words, it is
a short or insufficient piece of information and requires
additions.
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This entry is part of the Flash tutorials.

[bookmark: Introduction]
1 Introduction



	Learning goals

	Learn about basic Flash 9 (CS3), Illustrator and Inkscape
bitmap tracing.

	Prerequisites

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash layers tutorial

	Moving on

	The Flash article has a list of other tutorials.

	Quality

	Not complete. This tool is fairly complex ...

	Level

	It aims at beginners. More advanced features and tricks are not
explained here.

	Materials (*.fla file you can play with)

	http://tecfa.unige.ch/guides/flash/ex/tracing-intro/

	http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/





The pen tool allows to create complex shapes with lots of
straight lines and perfect arcs.


	Basic use




	To insert a series of connect points with straight lines, just
click on several points in a row

	You may want to display a grid (Menu View->Grid->Edit
Grid or View->Grid->Show Grid

	Once you are done: double click on the last point to create a
closed shape or hit ESC or select another tool.




	To insert curves, select a new point where the curve should
start, but hold down the mouse for a while, then drag the
mouse either out (along the line) or turn right/left.




	To draw a line after a curve, click on the last curve control
(round circle you just created), the click elsewhere.




	Controls




	The tiny rectangles (magnify if you can't see them) are called
anchor points. You may later move them with the subselection
tool.




	The little dots are called curve controls. You can drag them in
all directions to create the arces you'd like.




	To close a curve, move it over an anchor point. A little circle
should appear next to the mouse pointer. Click.




	Other pen tools



When you hold down the mouse over the pen tool you can get three
other tools that you may use while your are working on a drawing
(before hitting ESC)


	The Add Anchor Point tool: To add an anchor point to a segment,
click on it.

	The Delete Anchor Point tool: To delete a point click on
it.



By default, the Pen tool changes to the Add Anchor Point tool as
you position it over a selected path, or to the Delete Anchor Point
tool as you position it over an anchor point.

Later, you also can use the subselection tool to repair.

[bookmark: Links]
2 Links


	Drawing with the Pen tool. These help pages are
fairly well done, e.g. look at:

	Draw curves with the Pen tool (Adobe Flash
Help)







Flash layers tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !
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[bookmark: Introduction]
1 Introduction



	Learning goals

	Learn how to use layers

	Flash/CS level

	Flash CS3

	Prerequisites

	Flash CS3 desktop tutorial. It's
probably a good idea to use a layout similar to the ones I suggest
there.

	You also may first look at the first part of the Flash drawing tutorial.

	Next steps




	One of the basic animation tutorials




	Quality and level

	This text should technical people get going. It's probably not
good enough for beginners, but may be used as handout in "hands-on"
class. That is what Daniel K. Schneider made it
for...

	It aims at beginners. More advanced features and tricks are not
explained here.





[bookmark: Introduction_2]
2 Introduction

Layers help you deal with more complex Flash projects. Working
with layers has several advantages:


	You can draw and edit objects in one layer without affecting
objects in another layer.

	You can lock layers (to protect their embedded objects from
unwanted editing)

	You can hide layers, make them visible (i.e. you can see their
objects in the workspace), or you can display just the outlines of
their objects.



The layers tool is part of the Timeline panel.

[bookmark: Overview_picture]
2.1 Overview picture

The layers tool is in the left part of the timeline. Annotations
in the following screen capture highlight a few functionalities we
will further explain below.


[image: The Flash CS3 Layers tool]
The Flash CS3 Layers tool





[bookmark: Drawing_in_a_layer]
2.2 Drawing in a layer

To draw, paint, or otherwise modify a layer simple click on the
the layer name in the Timeline to make it active. A pencil icon
next to it indicates that the layer is active.

[bookmark: Creating_new_layers_and_deleting_layers]
2.3 Creating new layers and deleting
layers

When you create a Flash document, it only contains a single
layer, i.e. less than you need.

To create a new layer, either:


	Insert->Timeline->Layer

	Click on layer icon (left most item in the Edit bar just below
the timeline)

	Right-click on an existing layer, then Insert
Layer




[image: Inserting a new layer]
Inserting a new layer





As soon as you create a new layer, you should give it meaningful
name. Right-click on its name (something like Layer 2) select
Properties and change the name. Alternatively, to display
this properties panel, just double-click on the layer
name.

To delete a layer and its contents: Right-click->Delete
Layer. You also can lock/hide other layers with this menu.
Before you delete a layer make sure that you save its objects if
you plan to keep them. You can insert them in the library as
symbols or copy them to another layer.

[bookmark: Show_only_outlines_of_a_layer]
2.4 Show only outlines of a
layer


	Click on the rectangle next to the layer name. If this
rectangle turns empty then you only should see outlines of its
objects.




	You also can change the outline color by double-clicking on the
rectangle. E.g. if your background is green (like the grassy hills
in our example), the outline should be of a different color.



[bookmark: Lock_and_hide_layers]
2.5 Lock and hide layers

Click on the dots below the appropriate hide/lock/display icons
in the panel to apply locking/hiding/displaying to a single layer,
or on the icons themselves to apply an operation to all layers
(e.g. lock them all).

TIP: Always lock all layers and then just unlock the
layer on which you are working. This way you can prevent yourself
from making mistakes.

[bookmark: Moving_layers]
2.6 Moving layers

To move a layer in the stack simply grab it with the mouse and
drag it up or down. Position of the layer has an influence on the
order objects are drawn. E.g. if a moving object should pass in
from of a tree and it doesn't, then drag the animation layer up or
down.

Drawing order depends on the load order defined in the
Publish Settings (File menu)

[bookmark: Example]
2.7 Example

The following screen capture shows hidden and locked layers:


	The painting layer is active (the pencil is shown)

	The objects layer only shows outlines and in addition it is
locked (the lock sign is on and the rectangle is empty. Its objects
are drawn in light green, i.e. the color of the rectangle)

	The Sky layer is hidden (The red "X" sign is on).





[image: The Flash CS3 Layers tool, shown with outlines of layer and a hidden layers]
The Flash CS3 Layers tool, shown with
outlines of layer and a hidden layers





[bookmark: Layer_folders]
3 Layer folders

Once your documents get really complex, you can organize layers
into folders, e.g. one folder per task: Static objects, animations,
background etc.

To create layer folders, either:


	click on the folder icon in the Edit bar (third item)

	or use Insert->Timeline->Layer Folder



You then can drag around layers. Hiding, locking etc. works more
or less like with folders (try it out ...)

However, at some point you also will have to decide whether you
really want to work with an "everything is in the main time line
model". Consider organizing and planning your project with embedded
movie clip objects (see the Flash embedded movie
clip tutorial). Putting everything in the main time line is
like programming with "goto's"...

[bookmark: Scenes]
4 Scenes

Once your animation gets bigger, you most certainly should break
it down to several scenes. There is no urgency to work with scenes
if you are new to Flash, but you should know about this now. Scenes
are played in the order you defined them.


	To insert a new scene

	Menu Insert->Scene




	To rename/reorder the scenes




	Menu Window->Other Panels->Scene (SHIFT-F2)

	Then drag up or down the scenes

	To rename, double-click on a scene name in this panel.




	To navigate between scenes




	Either via the scenes panel, or the Edit Bar (displayed below
the timeline). If you can't see it: Window->Toolbars->Edit
Bar.



One advantage of using scenes is that you can just test a single
scene (menu Control->Test->Scene).

Flash frame-by-frame animation tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
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[bookmark: Introduction]
1 Introduction

Frame-by-frame animation means to display one image after each
other and that creates the illusion of a movie.



	Learning goals

	Learn basic Flash 9 (CS3) frame-by-frame animation, one kind of
Flash animation.

	Save a frame-by-frame animation as reusable movie clip.

	Learn about symbol edit mode.

	Learn about some object transformation features




	Prerequisites

	Flash CS3 desktop tutorial

	Flash layers tutorial

	Flash drawing tutorial (for
starters some of it, at some point you'll have to dig into it a
bit)

	Moving on

	If you want to do serious frame-by-frame animation, you
probably better drawing skills. In particular, you should read the
Flash object transform
tutorial and the Flash arranging objects
tutorial since you'll have to change graphics from one frame to
the next one.

	The Flash article has a list of other tutorials. You
probably should continue with the Flash motion tweening
tutorial. It will teach how to make fly things. You also can
read the Flash shape tweening
tutorial which tells how to do morphing animation.

	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It aims at beginners. More advanced features and tricks are not
explained here.

	Materials (*.fla files you can play with)

	http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/






	The executive summary



Purpose: Frame-by-frame animation gives you very detailed
control over the movie (since it's the technology used to make
animation pictures until recently before different 2D and 3D
computer animation techniques came into the existence).
Disadvantage is that frame-by-frame drawing is very time consuming
work. Therefore, most often, designers use a combination of
frame-by-frame animation and interpolation techniques (called
tweening in Flash lingo). Often, frame-by-frame animation is
used to animate single objects that in turn can be used as part of
larger Flash animations. A typical example are buttons that
highlight when you move the mouse over them or when you click on
them.

Executive summary of the procedure:


	Insert drawings in various keyframes

	Modify these drawings a little bit over time



[bookmark: The_timeline_and_keyframes]
2 The timeline and
keyframes

The principle of frame-by-frame animations made with drawings is
that you draw various versions of the same objects in different
frames. These are then displayed one after each other in rapid
order (most often between 10-25 frames / second).

A frame is a drawing that is displayed at a given time.
In the timeline, each stop in each layer of the timeline is a frame
and they are numbered from 1 to whatever length your animation has.
Let's start by introducing the meaning of a few symbols in the
timeline. We later will come back to these.

If you feel that display of timeline elements is too tiny, you
can fix this with the time line options (little pull-down menu in
the upper right). This menu also allows displaying a preview of the
animation (but that takes up space of course).


[image: Time line options pulldown menu]



Time line options pulldown menu





When you start drawing with Flash, everything is drawn by
default into a first frame in layer 1.


[image: The default keyframe is frame # 1]



The default keyframe is frame # 1





E.g. if you insert a letter, for example, you will see something
like in the screen capture just above.


	The first frame in the timeline will have a dot inside.
So if you see a frame with ".", it means that there is some
content inside.

	The playhead showing the current frame (the red
rectangle) sits on top of frame one.



There are other symbols that can appear in the timeline and we
will introduce them later as we need these.

We now will introduce three frame-by-frame animation examples.
We will do this in the main time line of the *.fla file.
Alternatively, you also can first create so-called movie clip
symbols and then edit these objects as described in the end of this
article.

[bookmark: A_simple_letter_after_letter_animation]
3 A simple letter after letter
animation

Have a look at the this simple animation first.

The *.fla, *.swf and *.html files
flash-cs3-frame-by-frame-hello.* can be found at http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/

We will produce an animation that will display the word "HELLO",
one letter after each other. The principle is quite simple: We will
insert new letters in new keyframes. One could do this by inserting
"H" into keyframe 1, then add "E" to keyframe 2 etc. We will do
something slightly different here, i.e. we insert a keyframe every
5 frames.


	Step 1



We insert the letter "H" in frame 1 (alternatively you may start
in frame 5, i.e. the user won't see the "H" when the frame loads.
Anyhow, later you always can add extra empty frames.


	Steps 2 to 5



Now we repeat this procedure by adding new letters in new
frames. So first we will transform frame 5 into a new keyframe. It
is important to understand that there are two kinds of new
keyframes:


	Blank ones that will clear the stage, i.e. the objects will be
gone. That's not what we want here.

	Keyframes that carry "forward" contents of the keyframe before.
We will use this one.



The procedure is the following (see the picture below)


	Right-click in a frame, then select Insert
Keyframe (not insert blank keyframe). Alternatively hit
F6, i.e.use the [Flash CS3 keyboard shortcuts|shortcut]].




[image: Editing keyframe #5]



Editing keyframe #5





Repeat this, until you incrementally spelled out "HELLO".


	Step 6



Test if it works:


	Firstly you simply can move back and forth the playhead
(red rectangle that sits on the top of the timeline)

	Then you can test the movie though the menu Control->Test
Movie or hit CTRL-Return. This will open a up a new window
where you can see more or less what an end-user would see.




	Step 7



Now we want to tune a few things:

(1) You may not be happy that the movie starts with letter "H"
already displayed. Right-Click on Frame 1 and Insert
Frame (not a keyframe!) or hit F5. Repeat this 4-5 times. Then
hold down the mouse and drag the black dot in the new frame 1 to
frame 5.

(2) Your Movie may be too slow or too fast. Flash animation made
with the CS3 drawing tools is not time-based (as in SVG for
instance) so you have to fix a frame rate. You can change the frame
rate (number of pictures shown/second) in two ways:


	Click on an empty spot on the stage and change the rate in the
properties panel that you should see below

	Menu Modify->Document (CTRL-J)



For this animation, about 15 frames are about right I think.

(3) You also may align the letters. But you have to do this in
each keyframe, else they will jump around, which actually
may be an effect you like.

To align all letters in all frames: Click on the Edit
multiple frames button.


[image: Select all frames]



Select all frames






	Then, you can select the frames you want to edit together by
moving the "[" "]" sliders on top of the timeline

	Then select letter-by-letter groups, then use the align pane
(Window->Align), but untick To stage.



This tool is quite dangerous, since it's hard to control what
happens in each frame. Make sure to save your file before you
engage in this ! Anyhow, next time make sure to place your
objects where they should be.


	Step 8



Now you can publish this as a web page.


	Make sure to save the animation in some place you can remember,
because Flash will put the exported Flash, HTML and JavaScript
there.

	Then, click on an empty spot in the stage and click the
"Publish Settings" button or menu File->Publish
Settings.

	Click the publish button when you are happy with the
settings. It will put all the necessary files in the same directory
where your *.fla file sits.

	Then click on either the Flash *.swf file or the *.html file
and see if it works.



As an exercise, you now can add extra keyframes after frame
1,5,10, etc. and move up or down letters. Alternatively, read on
...

[bookmark: Frame-by-frame_shaky_animation]
4 Frame-by-frame shaky
animation

Sometimes, e.g. in trailers or in little advertisement boxes you
can see some sort of shaky or jittery icons, like in the example we are going to discuss now.

The *.fla, *.swf and *.html files
flash-cs3-shaking-hello.* can be found here: http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/


	Step 1 - change stage size




	Define size and background color of your stage (I use 400x200
px this time). To do so, click with the selection tool on an empty
spot of the stage and change the properties of the stage in the
properties panel (usually shown below the stage).




	This time, we will use two layers, so create 2 layers, call one
of these "hello".




	Step 2 - draw a hello word




	In the "hello" layer, draw the word "Hello" with the pencil for
a change

	Select the pencil

	Put the Pencil tool into "Smooth mode".

	Put Flash into object mode (circle in the options area of the
tools panel)

	Select a wide stroke (15px or more)







Go back to the drawing tutorial if you don't
how to use object mode and how to set the smooth control for the
pencil.


	Step 3 - fix the hello word




	You may have to fix the Word "Hello", since despite smooth mode
your drawing may not be so hot.

	Firstly use the Free Transform tool to adjust size, rotation,
etc. of each letter.

	Then use the Subselection tool to fix certain letters, probably
your "o" will be ugly.

	To do good work, you need to set magnification to something
like 400 (Menu View->Magnification).

	Then you can drag around the distortion points' (squares)
and kill some of these and/or move the curve control
handles (dots attached to a line).

	You can read further explanation about envelope
transforms





	Finally select all letters with the selection tool and center
them. You may also may make the whole drawing bigger or smaller
(just change the "W" property in the properties panel while
everything is selected, i.e. see the screen capture below).



So now you should have (very) roughly something like this:


[image: Hello with the pencil]



Hello with the pencil






	Step 4 - Draw an oval




	Draw an oval or something around the "Hello" word if you want.
Use another layer for this and lock the "Hello" layer while you do
this. See the Flash layers tutorial if you don't know
how to use layers.

	Again, use the subselection tool to fine tune if needed. If you
need more explanation about object transformation, have a peek at
the Flash object transform
tutorial.




	Step 5 - Make a new keyframe for both layers



Create a new keyframe in frame 2 (as explained above).


	Hit F6 or Right-click; Insert Key Frame for the "hello"
layer

	Hit F6 or Right-click; Insert Key Frame for the "oval"
layer

	Now you should have a copy of both the "hello" word and the
Oval in the new frame.




	Step 6 - Make changes




	Now you can make slight changes to your drawings in
frame 2 (so make sure that frame 2 is selected !)

	I changed color a bit for both the oval and the hello word.

	Unlock the "hello" layer if it's still locked.

	"Edit->Select All"

	Change the color in the properties window





	Then twist a little bit some letters and maybe the Oval

	You can do this for instance with the subselection tool or the
Freetransform tool. (I only used the subselection tool and
basically turned a few Curve control handles).







Below is a picture of the slightly altered graphics:


[image: Hello with the pencil - second frame]



Hello with the pencil - second frame






	Step 7 - Add other frames



Just two frames will do, but you can add more of
course :)

This example was a bit more professional. We tried to
select a good stage size and made some efforts to get the drawings
right.

[bookmark: Rocket_science]
5 Rocket science

Frame-by-frame animation is also quite useful if you want to
create animated objects that you then can reuse in another
animation as a movie clip. Let's first look at this little rocket we shall discuss.

The *.fla, *.swf and *.html files flash-cs3-rocket.* can
be found here: http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/

I imported this rocket from Uncyclomedia Commons:


	http://commons.uncyclomedia.org/wiki/Image:Rocket.svg




	It's an SVG file that I first opened with Illustrator.

	I then copy/pasted it to Flash. See the Clipart article (i.e. the section on Importing to Flash).



Now we would like to animate the flames of this little
rocket.


	Step 1 - Break the rocket into components




	Break the rocket apart (right-click->Break Apart).
You now should see various rectangles drawn around its various
shapes.

	Flames are made with 2 shapes (the two rectangles in the lower
right)




[image: A broken apart imported SVG rocket]



A broken apart imported SVG rocket






	Step 2 - Put the flames into another layer



The easiest way is to use distribute these to other layers


	Select the 2 flames (hold down the SHIFT key and click on the
orange and yellow parts

	Then Right-click->Distribute to layers

	Rename the two layers you created.



Now you should have something like in the screen dump below. I
am positioned in the yellow flame layer and show the other two as
outlines.


[image: Rocket with flames in layers]



Rocket with flames in layers






	Step 3 - Duplicate frame 1 to frames 2 and 3 in these two
layers.




	As explained above, in frame 2: Right-click->Insert
Keyframe. Do this for each of the three layers

	Repeat this for frame 3.




	Step 4 - Change the flames for each frame




	I simply used the Free Transform tool and dragged the rectangle
towards the lower right.

	By doing this you also might have moved the rectangle itself,
just push it back underneath the rocket... (either with the arrows,
or with the selection tool).

	In order to get this right, you should each time put all the
other layers (rocket plus one of the flames) in outline mode with
the layers tool.




[image: Rocket with flames in layers]



Rocket with flames in layers






	Step 5- Tuning




	The animation is now a bit too fast. We would like to get the
kind of effect you see in old and cheap cartoons on TV.

	If you wish you can drag the keyframes (each dot to the right).
I made a keyframe in every 5, but I also adjusted the Framerate to
30/second. That's good TV quality. (click on workspace and adjust
in properties panel)




[image: Rocket frames stretched]
Rocket frames stretched






	Then you also could improve drawing of the flames (see the
Flash object transform
tutorial and/or add more keyframes. Finally, you could add
motion tweens between
the keyframes. I didn't do this since motion tweening is not part
of this tutorial.




	Step 4 - Test and publish




	Test and enjoy :)

	Publish




	Step 5 - Export as a video clip only



File->Export Movie will just save a *.swf Flash
animation file (no HTML and JS).

There are two ways of exporting an *.swf movie.


	"Normal", i.e. compressed. This means that when import this
flash file into another flash file, you can't edit the object
anymore.

	"Uncompressed". This means that after you import the rocket you
can edit it somewhat. To get this option, untick Compress
Movie in the settings dialog that will pop up.




	Step 6 - Turn it into a movie clip symbol (optional)



You also can turn this whole animation into a movie clip symbol.
This is best strategy if you want to build a library of fully
editable flash movie clips you can import into other animations.
Also, as we shall point out later, you actually could start
by creating a movie clip symbol and then create an animation.


	Select all layers and frames (click on the first layer, then
SHIFT-click on the last). Make sure that every frame and layer in
the timeline is black

	Copy all the frames (everything) Menu
Edit->Timeline->Copy Frames

	Menu Insert->New Symbol. Tick the Movie clip
option and give it a good name, e.g. "Rocket".

	Then you should be in Rocket editing mode and just see "Layer
1" on top

	Put the cursor in the first frame

	The paste the whole rocket code: Menu
Edit->Timelines->Paste Frames



You now should see something like this:


[image: Rocket animation made into a symbol]



Rocket animation made into a symbol





Next you can copy this symbol to another flash file which you
may call my_library.fla. We just killed everything in the file
(except the symbol) and saved it under a different name
(flash-cs3-rocket-symbol.fla)


	Result



Now we have two versions of rocket *.swf move clipt that we can
reuse in another Flash animations


	flash-cs3-rocket.swf




	flash-cs3-rocket-uncompressed.swf. This version
also has the improved flames



In addition we have file *.fla file with just a rocket symbol
inside. You can copy/paste symbols from one flash file to another
one.


	flash-cs3-rocket-symbol.fla



Below is a short how-to re-use *.swf files , but you also can
directly go and read the Flash motion tweening
tutorial.

[bookmark: Reuse_frame-by-frame_animations_as_movie_clips]
6 Reuse frame-by-frame animations as
movie clips

[bookmark: Reuse_of_swf_files]
6.1 Reuse of swf files

The swf flash files we just created can be used as components in
new Flash animation.

The *.fla, *.swf and *.html files
flash-cs3-rocking-hello.* can be found here: http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/


	Step 1 - Import *.swf files into the library of a new Flash
file




	Create a new flash file (File->New)

	Then import stuff you made: File->Import->Import to
library

	Select the flash-cs3-rocket.swf file

	Do the same with the flash-cs3-shaking-hello.swf file







You now have a nice rocket and a flashing hello in your
library:


[image: Hello and rocket movies in your library]



Hello and rocket movies in your library






	Step 2 - Drag the symbols (movies) to the stage




	Drag the item in the library onto the stage

	Now your rocket is too big :(

	No problem. Use the Free Transform tool to make it smaller and
to rotate

	Hold down the SHIFT key when you resize it from a
corner !







Here is the result:


[image: Hello and rocket movies used]



Hello and rocket movies used






	Step 3 - Learn about motion animation



Of course, now you should do a moving animation with these
flashing objects. See the Flash motion tweening
tutorial and before this enjoy the flying rocket:


	http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/flash-cs3-rocket-moving.html



[bookmark: Creation_and_reuse_of_embedded_movie_clips]
6.2 Creation and reuse of embedded
movie clips

In the Rocket science
example and in the others too, we created the animation in the main
time line. Alternatively (and better for the future) you should
first start by creating a new symbol:


	Menu Insert->New Symbol. Tick the Movie clip
option and give it a good name, e.g. "Rocket".

	Then you land directly in symbol editing mode and you can
create an animation for just this object as described in all the
examples above.

	Once you are done with symbol editing, double-click on "scene"
in the edit bar (on top of the stage) or click on the little "back
arrow". Always make sure that know whether you edit just a symbol
or whether you are in the main timeline (the whole
scene) !



Read more in the Flash embedded movie
clip tutorial about creating and using embedded movie clips.
This tutorial will also introduce some ActionScript code that is
needed to stop/start embedded animations.

Also remember that you can copy/paste anything from one *.fla
file to another and this includes movie clips. So it's a good idea
to create somewhere a private library (a fla file) that includes
all your major artwork.

[bookmark: Links]
7 Links

[bookmark: Example_materials]
7.1 Example materials

Example files used (including *.fla source) can be found
here:


	http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/




	Click on either an *.html or *.swf file to see.

	Get just the *.fla file if you want to make modifications. The
standard copyright of this wiki applies.



Flash motion tweening tutorial
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[bookmark: Overview]
1 Overview

Motion tweening means motion animation with
interpolation.



	Learning goals

	Learn about basic motion animation, i.e. move an object from A
to B, to C ...

	Add some simple shape transforms to the animated object

	Learn how to to frame-by-frame animations with embedded movie
clips.

	Prerequisites

	Flash CS3 desktop tutorial

	Flash layers tutorial (first
part)

	Flash drawing tutorial (at least
some of it)

	Flash
frame-by-frame animation tutorial (not absolutely needed, but
probably useful)

	Moving on

	Flash shape tweening
tutorial

	Flash animation summary

	After that you should be ready for interactivity. E.g. do the
Flash button tutorial

	Quality and level

	This text should technical people get going. It's probably not
good enough for beginners, but may be used as handout in "hands-on"
class. That is what Daniel K. Schneider made it
for...

	It aims at beginners. More advanced features and tricks are not
explained here.

	Materials (*.fla file you can play with)

	http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/





[bookmark: Introduction]
2 Introduction

[bookmark: Frame-by-frame_vs._tweening]
2.1 Frame-by-frame vs.
tweening

In Flash, you can create several kinds of animations and
associated special effects. To create motion animation, there are 2
options:


	Frame-by-frame animation (ancient technique used for cartoons).
This leads to precise results but is time consuming. Actually,
before doing this tutorial you can do Flash
frame-by-frame animation tutorial first.

	Tweening. Wikipedia, retrieved 20:45, 7 August 2007 (MEST)
defines “Tweening, short for in-betweening, as the process
of generating intermediate frames between two images to give the
appearance that the first image evolves smoothly into the second
image. Inbetweens are the drawings between the keyframes which help
to create the illusion of motion. Tweening is a key process in all
types of animation, including computer animation. Sophisticated
animation software enables one to identify specific objects in an
image and define how they should move and change during the
tweening process. Software may be used to manually render or adjust
transitional frames by hand or use to automatically render
transitional frames using interpolation of graphic
parameters.”. In other contexts, one uses also
"morphing". E.g. PCMag (retrieved 20:45, 7 August 2007 (MEST))
defines tweening as “An animation technique that, based on starting
and ending shapes, creates the necessary "in-between" frames. See
morphing”.



[bookmark: What_can_be_animated_with_motion_tweening_.3F]
2.2 What can be animated with motion
tweening ?

In Flash 9, you can animate all sorts of compound objects:


	Symbols, i.e. any object that is an instance of a library
object, e.g.

	Graphic symbols

	Movies (full *.swf Flash animations or embedded movie
clips)

	Buttons





	Compound objects (things that you grouped together)

	Text boxes




	If you want to work on your own project ...



In this tutorial we will mostly work with graphic symbols. So
the first thing you may have to do - if you want to work on your
own project - is to convert one of your graphics to a graphic
symbol and to put it in a separate layer.


	Right-click on the object (click down the right mouse
button) and then select Convert to Symbol .... Alternatively
just select the object and hit F8.




	Each object to be animated should be in a separate
layer. All the other objects may remain in a single layer.




[image: convert a select object to a symbol]



convert a select object to a symbol





So before we start, make sure that you have a least one graphic
symbol, i.e. the object that you would like to move around in your
library. E.g. the library of the "cat example" we will build now
contains this:


[image: Library items (only graphic symbols)]



Library items (only graphic symbols)






	Use of layers



You must use a different layer for each separate
animation. If you plan to animate several of your objects, there is
a practical shortcut to distribute each object to a new layer:


	Select objects you want to distribute into layers (e.g. with
right-click->select all or shift-click on each
object)

	Then, Modify->Timeline->Distribute to layers

	Finally, rename the layers in order to help you find
things...



[bookmark: Introductory_example_-_moving_a_cat]
3 Introductory example - moving a
cat

In this example, we will use the drawings made for the flash drawing tutorial and move one of
the cats around. If you want to reproduce what we do here, you can
start from file flash-cs3-drawing-trees3.fla. Objects you will
need are already in the library. I am aware that these drawings are
ugly, but it makes these tutorials so much more human ....


	Executive summary



The principle of motion tweening is quite simple:

(1) Firstly position an object in different locations at
different times


	We call these positions keyframes in the timeline, since
objects are frozen in different states.

	Btw, you also can change other features than just the position
of an object (more later)



(2) Then, you have to apply some interpolation method
(tweening) between the two keyframes, i.e. you tell the
computer to generate some in-between picture for each frame between
the 2 keyframes in the timeline.


	Simple motion tweening is a linear path, i.e. the object will
move on a line from x1,y1 to x2,y2.

	You can also apply a motion tween along a random path (but this
is bit more complicated and we will introduce this technique
below).



[bookmark: Moving_a_cat_from_x_to_y]
3.1 Moving a cat from x to
y

You should lock all other layers. This way you are sure
not to edit by mistake a frame of another layer.


	Step 1 - Create a a new layer and insert an object for
animation




	Create a new layer and call it "animation cat" for example (see
the Flash layers tutorial if you
forgot how).

	Select this layer

	Put an tween-able object inside, e.g. drag it from your library
onto the stage, or cut/paste or copy/paste from an other layer or
*.fla document.

	In our case we cut/paste the existing cat that was sitting in
the lower left in the "Objects" layer.





	We move the object (cat) outside of the stage, because the cat
in our scenario will move into the scene.



Remember, that you can not motion tween editable objects, so you
need to turn a drawing into a symbol first.

So you should see something like this:


[image: The cat before animation. It sits outside the stage and waits]



The cat before animation. It sits outside the stage and waits





Now you already have a first keyframe for your animation.
I.e. the cat is waiting in keyframe 1 to be moved.


	Step 2 - Create a second keyframe




	Make sure that you still have the "animation cat" layer
selected.

	Right-click somewhere in the timeline, e.g. at 20 and
Insert Keyframe

	This will create a new keyframe and copy the contents of the
keyframe before, i.e. contents of frame 1 just for this
layer.





	Drag the object (cat) to its final position, e.g. to the right
and which can be outside the stage again.




	Step 3 - Create the motion tween




	Click on a random frame between the two keyframes (still in the
same layer)

	Then right-click and select Create Motion Tween.
Alternatively, you also could have used the Tween pull-down
menu in the properties panel at the bottom and select
motion.




[image: Creation a motion tween with the right-click menu]
Creation a motion tween with the
right-click menu





The timeline for the layer including this object should now
include a solid line with an arrow (if it is dashed something went
wrong).

The result should look like in the screen capture below:


	Between the two keyframes you see a solid line with an arrow
(look at the "Animation cat" layer).

	You should see your object moved to a different position
somewhere in the middle of the two keyframes.




[image: Creating a motion tween for the cat]
Creating a motion tween for the cat






	Step 4 - Replicate contents of the other layers




	As you could see in the screen captures above, the stage is
empty, except for the cat. This is because all other drawings for
the other layers exist only for frame 1.

	For each other layer, right-click on frame 20 (i.e. in
the position of your second keyframe) and hit F5 (Insert
Frame, not insert keyframe !)

	This will "stretch" your drawings from frame 1 to frame 20. The
drawings still sit in frame 1, but they are carried over up-to
frame 20. This is shown in the timeline by a little white
rectangle.



You now should have something like this:


[image: The first result]



The first result






	Step 5 - Test it




	You can glide (left-right) the playhead (red rectangle
on top of the red line that indicates the current frame in the
timeline). It will manually move the object through all positions
within the interpolation path.

	Then try: menu Control->Test Movie or hit CTRL-Enter.
This will open a popup window with a Flash preview.




	Step 6 - Tuning



You may find that the cat moves too fast. First thing you could
do is lower the frame rate/second. Click on the workarea and change
the document properties. However, this will lead to a "jumpy"
animation. It's a better idea to use frame 50 instead of frame 20
as end-point.


	Drag the black dot in the animation layer from frame 20 to
frame 50. Hold down the mouse on the black dot, wait a bit and then
drag.

	For the other layers: hit F5 in frame 50 (same as above).




	You also can accelerate/decelerate the cat's movement. Play
with the "Ease" option in the Properties panel. Click on
layer "animation cat", then select an empty "between frame"
somewhere. You now can make changes in the tweening
properties.




	If your cat moves in front instead of behind objects, then you
can fix this by arranging the layers' order: Grab the objects layer
in the timeline panel and move it before or after the animation
layer (i.e. pull it up or down).




	Results




	You can look at my published result: flash-cs3-motion-tweening.html

	You can grab all the files from this directory:




	http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/



[bookmark: Adding_more_motion_tweens]
3.2 Adding more motion
tweens

We want the cat to move back where it came from.


	Turning the cat



In our case we have an animation from left to right and the cat
will leave the stage. Once it's off the stage we will turn it so
that it can walk back.


	Next to frame 50 I made a third key frame. Click on frame 51
and hit F6.

	Then turn the cat: Click on the cat and use menu
Modify->Transform->Flip Horizontal)




	Add a new motion tween



You can add more motion tweens to an object simply by repeating
the procedure outlined above.


	Add a new fourth keyframe to the right, e.g. in frame 81.
Simply hit F6 again.

	Right-click on an empty frame between keyframe 3 and 4 and add
a motion tween as above

	Of course, you then also adjust the ending frame for the other
layers as above (hit F5) in column 80.



In the screen capture below you can see that we now have several
keyframes. In the "animation cat" layer you can see several dots,
each one represents a keyframe.


[image: Moving a cat]



Moving a cat





You can look at the published result (the cat will walk back
where it came from) here: flash-cs3-motion-tweening2.html

The directory including the *.fla file which you can load into
your Flash and play with is here:


	http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/



[bookmark: Adding_.28some.29_motion_shape_tweening]
3.3 Adding (some) motion shape
tweening

In each frame you can change some properties of the moving
object. In the next example, we will have the cat move up on top of
the hill. We want to implement 2 effects:


	The cat should become smaller (because it's further away)

	It should change color (because it's an effort to run up a
hill).




	Step 1 - Insert a new keyframe




	I inserted a new keyframe in frame 25 (i.e. between the first
two existing key frames)

	In the (new) 2nd keyframe the cat was moved next to the other
little one on top of the hill.




	Step 2 - Change size of cat in keyframe 2




	Go to the frame (click on frame 25 or wherever yours is)

	Select the object (i.e. the little cat)

	Select the Free Transform Tool in the tools panel (see flash drawing tutorial), hold down the
SHIFT key and drag a corner.




	Step 3 - Change the color of the cat in keyframe 2




	Go to the frame

	Select the cat

	In the properties panel you can change the tint (a kind of
color) of the cat.



Here is a screen capture. The animated cat is pink and sits next
to the other cat. It's pink because moving up the hill takes effort
...


[image: Moving a cat and changing its size and color]
Moving a cat and changing its size and
color





You can look at the published result here: flash-cs3-motion-shape-tweening.html

The directory including the *.fla file which you can load into
your Flash and play with is here:


	http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/



[bookmark: Doing_more_informed_work]
4 Doing more informed
work

[bookmark: Edit_bar]
4.1 Edit bar

If you have to do some frequent zooming you can display the Edit
Toolbar (see the screen capture below).


	Get the edit toolbar: Window->Toolbars->Edit
bar



This bar also will allow you to directly edit symbols you got in
your library.

[bookmark: Onion_skins]
4.2 Onion skins

You can display the path an object will take by clicking one of
the onion skin buttons in the Controller toolbar. This is handy if
you have several objects that move.


	Get the controller toolbar:
Window->Toolbars->Controller and then click on either
the Onion Skin or the Onion Skin Outlines icon.




[image: Onion skins for the moving cat]



Onion skins for the moving cat





[bookmark: Grids_and_rules]
4.3 Grids and rules

To achieve what we just did, you don't need these. But for more
precise artwork you certainly will...


	Right-click somewhere on the workarea and play with Rules,
Grids and Guides ...



[bookmark: Rotating_animations]
5 Rotating animations

Instead of moving an object from point A to point B, you also
can rotate it around point A. A good example would be hands in a
clock.


	Step 1 - create the object to animate




	Create a separate layer for the object you want to rotate.

	Draw the object (and don't make any new keyframes yet)

	Transform it into a symbol (right-click and select graphic
symbol).




	Step2 - move the center point




	Then with the free transform tool move its center point
somewhere else if you want. E.g. to rotate an hour hand for clock
move it towards and end (the center of the clock).




[image: Move the center point of the hour hand - Rotating clock]
Move the center point of the hour hand -
Rotating clock






	Step 3 - make a motion tween




	Make a new keyframe, i.e.hit F6 in a new frame. You can leave
the object where it is (depends on the aim of your animation)

	Then create the motion tween (right-click anywhere in between
the two keyframes)

	Now in the parameters panel select Rotate = CW
(clockwise) as in the example shown in the picture. Btw ""CCW"
would mean "countclock wise"

	If you want to rotate it more than once during the animation
time, enter "XX times". E.g. we entered 12 for the minute hand in
the clock animation.




[image: Motion tween around a center - Rotating clock]
Motion tween around a center - Rotating
clock






	Clock example



If you want, you can:


	Look at rotating clock example

	Or get the flash-cs3-rotating-clock.fla file from http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/
and play with it.



[bookmark: You_don.27t_like_my_cats_.3F_.2F_Embedded_movie_clips]
6 You don't like my cats ? /
Embedded movie clips

As we pointed out in the Flash drawing tutorial, you can import
professionally made clipart into Flash. Furthermore, you now should learn
how to move animated objects, i.e. use so-called embedded movie
clips. See also the Flash embedded movie
clip tutorial.

[bookmark: Use_of_embedded_movie_clips]
6.1 Use of embedded movie
clips

Instead of using the main timeline to create all your
animations, you also can animate so-called "movie clips", i.e.
instances of movie clips.


	Menu Insert->New Symbol

	Select Movie Clip (and give a good name)

	Double-click on this newly created movie clip in the library.
You now can edit this object's own timeline.



Alternatively transform an object into a movie clip:


	Select the object (or use the lasso or another appropriate tool
to select several objects)

	Right-click->Convert to Symbol; Select Movie
clip

	Double-click on this object to edit.



There are two ways to edit a movie clip:

(1) In "stand-alone" view, i.e. you only will see the components
of the movie clip. Double click on the movie symbol's icon (not
it's name) in the library. You now can edit, e.g. a add a motion
animation or change its drawings. Most of time, this editing mode
is preferable.

(2) Edit with the scene as background. If you put an instance of
the movie clip on the stage and then double-click on this instance,
you can edit the same movie clip symbol, but you will see the
objects of the stage while you edit.

By editing a movie symbol you basically can do the all the stuff
you have learnt so far, e.g. in the Flash
frame-by-frame animation tutorial. In other words, movie clips
have their own timeline.


	A pulsating moving sun



Let's now create a very simple animation, i.e. a pulsating sun
that is moving from left to right in the sky. First, we will make a
simple motion tween of a yellow circle moving from left to
right:


	Create a new Flash fileand change the size to 800x200
pixels

	Draw a yellow circle and put it to the left of the stage

	Convert it to a movie clip symbol (Right-click->Convert
to Symbol; Select Movie clip)

	Hit F6 in frame 120 and move the circle that is now an instance
of a movie clip to the right of the stage

	Make a motion tween.



Then edit the sun symbol to create a frame-by-frame
animation


[image: Editing a movie clip symbol used in a motion tween]
Editing a movie clip symbol used in a
motion tween






	As you can see, we are editing the sun "symbol". Look at the
Edit bar (that sits between the timeline and the stage). It
displays the editing hierarchy, i.e. "Scene 1" and "Sun".

	This frame-by-frame animation changes both the color and the
size of the circle. Read the Flash
frame-by-frame animation tutorial if you don't know how to
create frame-by-frame animations.



Do not forget to go back to the main timeline (scene)
once you are done, e.g. by double-clicking on the "scene" in the
edit bar (on top of the stage) or by clicking on the little "back
arrow". When you edit a movie clip you are in symbol edit mode and
you should not add anything else by mistake. Make sure that you are
aware at which level you edit and where to place objects !

Finally you also may add a sky in the main timeline (e.g. with a
gradient color, see the flash colors tutorial)


	The example code is in the http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/
directory

	flash-cs3-motion-tweening-sun.html

	flash-cs3-motion-tweening-sun.fla



Note: we use embedded movie clips in many other tutorials. E.g.
see ActionScript 3
interactive objects tutorial or Motion tweening of an
animated object chapter in the Flash animation summary or the
Shape tweens of motion tween elements chapter in the
Flash shape tweening
tutorial

I usually prefer this kind of animation, since I am more
interested in creating interactive application (vs. video clip-like
animations). If you plan to learn this, you also should learn how
to stop/play embedded movie clips, i.e. trigger with the help of a
button or something else an event that will
movie_clip.play() and movie_clip.stop().

[bookmark: Use_of_swf_movie_clips_in_motion_tweens]
6.2 Use of swf movie clips in motion
tweens

You can import ready made flash animations, e.g. a cat that
would have moving legs. In the next chapter we use a simpler
animation that uses a rocket. Rocket making itself is described in
the Flash
frame-by-frame animation tutorial.

To import a Flash movie as object: Use
File->Import->Import to library You then will see the
*.swf files as items and you can drag them on the stage. With the
Transform tools you then can adapt a few features (like size and
rotation) to your needs.


[image: movie clip (*.swf) library items]



movie clip (*.swf) library items





If you want, you can:


	Look at the flying rocket

	Or get the file flash-cs3-rocket-moving.fla from
here:




	http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/



Don't worry about details of *.swf movie clip reuse. The motion
guide tweens chapter below will show how to do this in some more
detail.

[bookmark: Motion_guide_tweens]
7 Motion guide tweens

Instead of having an object move from one point to another in a
straight path, we can make it follow an arbitrary path we
draw, i.e. a motion guide.


	Step 1 - Create a normal motion tween




	Like explained above, create two keyframes, i.e. one for start
and one for the end. Each keyframe should contain a copy of the
same symbol (as above). Then insert a motion tween.

	This is important, else you will fail ...




	Step 2 - Insert a motion guide layer




	Select the first keyframe and layer that starts your
animation

	On the layer edit bar in the time line click on the little
motion guide icon (looks like a slinky) or Right-click->Add
Motion Guide.



You should get something like in the capture below:


[image: A Motion Guide layer]
A Motion Guide layer






	Step 3 - Draw the motion guide in the motion guide layer




	Make sure that you selected the motion guide layer you just
created selected. You may lock the other layers and just display
their outlines.

	Then. with the pencil tool. draw the line your rocket has to
follow. Use "Object mode" and "Smooth drawing" from the tools panel
controls (see the Flash drawing tutorial if you forgot
how to use the pencil).



In the screen capture below, the motion guide would be the red
(fatter) line on top of the hill's outline.



[image: A rocket motion guide drawn with the pencil in the Motion Guide layer]



A rocket motion guide drawn with the pencil in the Motion Guide
layer






	Step 4 - Snap the animated object to the start of the motion
guide




	Unlock all layers

	Select the animation layer (not the motion guide
layer !) and select your start frame.

	Then drag the object (i.e. our rocket) to the start of the line
until the little white circle in the center of the rocket will
"snap" to the line. Just drag, don't click...




[image: A rocket snaps to the motion guide]
A rocket snaps to the motion guide






	Step 5 - Snap it to the end




	Select the end frame first

	Then drag the object (the rocket) to the end of the line until
it snaps. It should snap with the little white circle.




	Step 6 - Orient to path




	You can have the object tilt along the path if you want

	Select the animation layer (not the guide)

	Select a frame in between start and end

	In the properties panel (bottom of the desktop), check the box
"Orient to path"



If you want, you can:


	Look at the flying rocket

	Or get the file flash-cs3-motion-guide-tweening.fla from
here and play with it.




	http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/



[bookmark: Publishing_and_stopping_an_animation]
8 Publishing and stopping an
animation

[bookmark: Publish_settings]
8.1 Publish settings

When you publish a Flash animation, you should first choose the
correct settings.


	Step 1 - Get the settings




	Either click on an empty spot on the workarea, then hit the
Publish button in the properties panel

	Or, menu File->Publish Settings




	Step 2 - Choose the Flash version



If you want to make sure that your animation plays on most every
computer, select Flash Player 8 (the previous version). Otherwise
Flash Player 9 is now widely deployed. You must select "9" if you
use Action Script 3.


	Step 3 - HTML



Then select the HTML tab (also in the Publish settings)


	You can untick the loop button (but see below for a more solid
solution)




	Step 4 - Hit the publish button



This will copy three files to the same directory where
you *.fla file sits.


	A *.swf

	A *.html

	A *.js



Copy all three to your website. Then you can edit the html file
and add some more HTML if you like. (Make sure to save copy of this
HTML file, since when you publish again the html file will be
overwritten).

[bookmark: Stopping_an_animation]
8.2 Stopping an animation

We will improve a bit the flying rocket example, i.e. have the
animation stop and display some friendly "Hello".


	Step 1 -Create a new layer




	Create a new layer and call it "action"




	Add a new keyframe for this layer




	Select the layer

	Right-click after the last frame of your animation and add
Insert Blank Keyframe (in our case this is frame 21) or hit
F7.




	Add some Action Script




	Hit the F9 button

	This will open the Actions-Frame panel in ActionScript 2 (you
can dock it to the properties panel) or the Actions panel in
ActionScript 3.

	Insert this (in either AS2 or AS3):




stop();



	As you can see in the screenshot below, the last frame in the
action layer has a little "a" in it. This means that there is some
scripting attached to it.




	Fine tune




	In our case I dragged the Background layer to the right (or hit
F5).

	Then I inserted a "Hello" movie into this last frame. I took
the one we made in the Flash
frame-by-frame animation tutorial



Here is screen dump with the 2 new layers and the bit of
ActionScript code.



[image: Adding a short action script stop(); instruction to the action layer]



Adding a short action script stop(); instruction to the action
layer








If you want, you can:


	Look at the flying rocket plus the flashing
hello.

	Or get the file flash-cs3-motion-guide-tweening2.fla file from
http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/
and play with it.



[bookmark: Resources_and_discussion]
9 Resources and
discussion

[bookmark: Resources]
9.1 Resources


	clipart

	Follow up the links in Flash and AS3 links -
general and Flash and AS3 links -
tutorials for other tutorials.



[bookmark: Daniel_K._Schneider.27s_opinion]
9.2 Daniel K. Schneider's
opinion

I do have to say that I find the SMIL/SVG time-based animation model including its
interpolation mechanisms more elegant and simpler to understand. In
SVG, you simply decide which property of the object (position,
size, shape, whatever) you want to animate and how interpolation
should be done. That kind of animation can be done in Flash through
ActionScript programming. E.g. by using a tweening library like
TweenLite and its sister
classes.

[bookmark: Software]
10 Software

Besides Flash from Adobe, certain animation software can export
in Flash. I didn't find any software that can export to *.fla, just
*.swf. Therefore using such tools is ok if you just want to produce
animations in an easier way.


	E-Frontier products (commercial)




	E-Frontier home
page

	E.g. Anime Studio Anime Studio (Wikipedia)

	Motion Artist




	Toufee (free online software, needs registration)




	Toufee Home Page

	Toufee (Wikipedia)

	Toufee Wiki




	KToon (not tested)




	Frame-by-frame animation drawing tool for Unix systems
(including Linux).

	Ktoon can export animations in Flash or a series of PNG
images.

	KToon Home Page

	KToon Wikipedia article



[bookmark: Links_to_Video_Tutorials]
10.1 Links to Video
Tutorials

You also can look at some of the videos you can find on the
Adobe web site


	Video tutorials

	Click in the top left window on "Flash CS3 Professional"

	Then view in particular "Creating animations with motion
tweens" and "Understanding the timeline, keyframes and frame
rate.







[bookmark: Other_Links]
10.2 Other Links


	Flash
animation (Wikipedia)



[bookmark: Materials_used]
10.3 Materials used

(including the *.fla's)

Grab stuff from this directory:


	http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/



Flash shape tweening tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !




	Page created by Daniel K. Schneider, 28 September
2007

	Last 
modified by Daniel K. Schneider, 22 April
2009



This entry is part of the Flash tutorials.

[bookmark: Overview]
1 Overview

Shape tweening means transforming an object from one
state into an other. This is usually called morphing.



	Learning goals

	Learn how to create basic Flash 9 (CS3) morphing, i.e. shape
tweening.

	Learn how to use shape hints

	Learn how to use shape tweens within embedded movie clips

	Prerequisites

	Flash CS3 desktop tutorial

	Flash layers tutorial

	Flash drawing tutorial

	Flash object transform
tutorial

	Flash
frame-by-frame animation tutorial or Flash motion tweening
tutorial

	Moving on

	The Flash article has a list of other tutorials.

	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It aims at beginners. More advanced features and tricks are not
explained here.

	Materials (*.fla file you can play with)

	http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/





[bookmark: Introductory_example]
2 Introductory example


	The principle



You can transform any form (shape) into any other form. Shape
tweens work on so-called editable objects, e.g. it will
not work with symbols or grouped objects. You may shape
tween:


	Drawing objects (drawings made in object mode)

	Shapes (drawings made in merge mode)



Also, as in motion tweening, the object(s) to be shaped must be
in a separate layer.


	Step 1 - Draw an object




	We draw an oval with a thick border with the Oval tool and also
set the background.

	Then we center the oval in the stage. To do so, use the
Align panel (Window->Align, or hit Crtl-K)

	Check to stage and click on the Align icons until you
get it right :)







You should have something like this:


[image: A starting frame with an Oval to be morphed]



A starting frame with an Oval to be morphed






	Step 2 - Insert a new blank keyframe




	Right-click on frame 10 and Insert Blank Keyframe
or hit F7 (not "Insert Frame" / "Insert Keyframe" (F6))



This will insert an empty new Keyframe


	Step 3 - Add a new object to the new keyframe



In this frame, draw a new object, i.e. we inserted a Polystar,
also in object mode.


	Select the Polystar tool (It sits below the rectangle tool and
you must hold down the mouse to get at it)

	Then, in the properties panel, select from the Options
pull-down menu: Star and Number of sides = 9

	Then, draw it




	Step 4 - Change its shape and align it with the oval and the
stage



Then make it a bit "oval" and adjust it more or less to the size
of the oval


	Either click on the Free Transform Tool or
Right-click on the polystar; Select Free Transform

	Drag out one sides if needed

	To see the oval you can click on the "Edit multiple frames"
icon in the Timeline control bar.

	Then make again sure that it is centered by using the Align
panel



You should have something like this:


[image: A polystar]
A polystar






	Step 5 - Change colors of the polystar




	Untick the "Edit multiple frames" icon !!

	Then you can change the colors of the stroke and the fill




	Step 6 - Morph




	Click on an empty frame between the two keyframes

	In the properties panel below select Tween: Shape

	Alternatively: Just right-click on an empty frame and select
Create Shape Tween




	Step 7 - Repeat the other way round




	Insert a new empty keyframe

	Copy the picture from frame 1 (select it and hit CTRL-C in
frame 1)

	Paste it to the empty keyframe

	Center it to the stage (or align it with the other
objects)

	Add the shape tween.




	Test;




	Move around the playhead

	Menu Control->Test Movie

	If the animation is too fast, reduce the frame rate in the
properties panel or better drag out the keyframes to the
right.



Done :)


	Result and source

	You can admire the result

	Source: flash-cs3-shape-tweening-intro.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/



Notice: If CS3 refuses to create a shape tween, you probably
work with a symbol (e.g. a movie clip or a graphic symbol) or
another non-editable object. Forget it, it won't work !. To
extract the graphics from a symbol instance:
Right-click->Break apart or double click on the symbol or
symbol instance to enter symbol editing mode, then copy paste the
graphics you need.

[bookmark: Morphing_traced_bitmaps]
3 Morphing traced bitmaps

To morph images there are two kinds of solutions:


	Break images apart (right-click on the picture). This turns it
into a shape. You then can make a copy of it and manipulate all
sorts of things (e.g. size, colors, e.g. with the lasso tool and
the magic wand).

	Trace images, i.e. turn them into vector graphics.



See the Flash bitmap tracing
tutorial for some ugly examples or portrait morphing.

[bookmark: Morphing_a_simple_shape_into_a_monster]
4 Morphing a simple shape into a
monster

In this animation I made three keyframes


	Something like a tear in the first

	Tear decomposing at the bottom

	The bottom will decompose into the beginning of a monster



You can admire the result (files
flash-cs3-shape-tweening-tear.*)

Anyhow, the idea is that for some shape transformations, you
should learn how to to transform shapes. See the Flash object transform
tutorial


	Some design tips




	You should consider doing a shape transform in several steps,
i.e. use several shape tweens in a row (for the same
shape)

	For smooth shape tweening, working with objects without borders
(strokes) is usually a better choice. (set the stroke color to
none, e.g. the white rectangle with a red diagonal bar). Also,
unbreak graphics until the whole thing becomes a shape. You always
can make it graphic again by "union" it (Modify->Combine
Objects->Union).

	You can put several shape tweens in different layers. E.g. I
added a "background" shape tween to the above animation. It's a
simple rectangle with 2 different color gradients.




	Results and source




	Admire the result. It's absolutely dreadful (Ok
it was done in 5 minutes ....)




	flash-cs3-shape-tweening-tear2.fla

	Source directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/



[bookmark: Shape_hints_-_where_should_shapes_go]
5 Shape hints - where should shapes
go

In order to create some slightly better shape animations you can
give Flash hints where a shape should go. “Shape hints
identify points that should correspond in starting and ending
shape. For example, if you are tweening a drawing of a face as it
changes expression, you can use a shape hint to mark each eye.
Then, instead of the face becoming an amorphous tangle while the
shape change takes place, each eye remains recognizable and changes
separately during the shift.” ([1], retr. nov 2008)


	Create one or more shape hints (Modify->Shape->Add
shape hint) or hit CTRL-SHIFT-h.

	You will see some little letters that appear

	Then, drag these onto shapes into a keyframe

	Repeat this in the next keyframe



Let's look at a not so canonical example (shape hints work best
for shapes that do not move a lot). These hints do something
to the animation, but do not ask me what exactly. To do shape
hinting right, each morphed shape should be in a different layer if
I understand right.

Below are three screen captures for keyframe 1, keyframe 2 and
keyframe 3 of an animation that starts with a tear on top. It then
separates into 2 tears. In the third keyframe one becomes a hill
and the other one morphs into a tree. It almost looks good, as you
can see


Shape hints in Flash CS3

	



[image: ]




No shape hint in first keyframe
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Shape hint in middle keyframe
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Shape hint in last keyframe











	To view all shape hints



Shape hints will disappear from view when edit something.


	Select the layer(s) within which you have shape hints (or hit
CTRL-ALT-h)

	Select View->Show Shape Hints.




	Results and source




	Admire the result. It's absolutely dreadful (Ok
it was done in 5 minutes ....)




	flash-cs3-shape-tweening-hints.fla

	Source directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/




	Alternative example



In the Flash bitmap tracing
tutorial we tried shape hints for a portrait morphing. A
2-color portrait was morphed into another. Some objects were given
shape hints.


	Fla file: flash-cs3-shape-picture-morphing2.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/



[bookmark: Shape_tweens_of_motion_tween_elements]
6 Shape tweens of motion tween
elements

[bookmark: A_simple_motion_animation_with_2_shape_changing_objects]
6.1 A simple motion animation with 2
shape changing objects

To use a shape tweened object in a motion tween animation, you
simply can save a shape tween as *.swf (Flash) and then import as
movie. But you also can draw everything in the same *.fla file
using embedded movie clips.


	Step 1 - Draw the object




	anything (but preferably without strokes since shape tweens
don't render these very well) ...




	Step 2 - Turn into movie symbol




	Select the object

	Right-click->Convert to Symbol

	Select Movie clip !



Repeat this for the other objects you want to animate, e.g.
create a blue circle that represents a planet.


[image: Convert an object to movie symbol]
Convert an object to movie symbol






	Step 3 - Edit the movie clip symbols




	Double-click on the instance of the symbol in the stage (or the
movie clip in the library)

	Do shape tweens. Make sure that you really are in symbol edit
mode. E.g. in the screen capture below you can see in the Edit bar
that we are editing "Planet" (a movie) and not "Scene 1".




[image: Edit a Movie Symbol (the planet)]
Edit a Movie Symbol (the planet)





Click on scene 1 (or whatever your scene is called) to get back
to the normal stage (alternatively use the pull-down menus to the
right).


	The planet was made with a simple gradient transform. In the
first keyframe there is some green on the upper left and in the
second keyframe it is on the lower right.

	The star simply changes color from yellow to orange and then
from orange back to yellow.




	Step 4 - Create a motion animation for each of the shape tween
movie clips




	Tip: if you want to move an object around an ellipse, draw a
real ellipse then cut of tiny bit with the eraser. It then becomes
a motion guide line.



The picture below shows the kind of time line in you should get
in the main scene.


[image: Edit a Movie Symbol (the planet)]
Edit a Movie Symbol (the planet)






	Final Tips




	Make sure at which level you are editing (scene or embedded
movie clip) !

	Use a different layer for each motion animation. In each layer
just put one symbol. Then add (if you want) a motion guide
layer to each of these layers... otherwise you met get really
unexpected results (E.g. if you see a "tween" in your library
something went wrong).




	Results




	You can admire the result

	Get files flash-cs3-shape-tweening-in-motion.* from:




	Source: flash-cs3-shape-tweening-in-motion.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/



[bookmark: A_simple_doubly_embedded_motion_animation_with_2_shape_changing_objects]
6.2 A simple doubly embedded motion
animation with 2 shape changing objects

Of course a planet should turn around the star. Therefore we
should embed the planet motion animation with the star motion
animation, e.g. something like this motion-in-motion animation


	Source




	Get files flash-cs3-shape-tweening-in-motion2.* from:




	Source: flash-cs3-shape-tweening-in-motion2.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/



[bookmark: Links]
7 Links

[bookmark: Example_materials]
7.1 Example materials

Example files used (including *.fla source) can be found
here:


	http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/




	Click on either an *.html or *.swf file to see.

	Get just the *.fla file if you want to make modifications. The
standard copyright of this wiki applies.



[bookmark: Adobe_documentation]
7.2 Adobe documentation


	Control shape changes with shape hints (Adobe
Flash C3 Help). There is a nice example morphing "1" into "2".



Flash animation summary
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This entry is part of the Flash tutorials.

[bookmark: Introduction]
1 Introduction

This article in our Flash
series is a summary of: Flash
frame-by-frame animation tutorial, Flash motion tweening
tutorial and Flash shape tweening
tutorial. It also includes some of: Flash CS3 desktop tutorial,
Flash drawing tutorial, Flash CS3 keyboard
shortcuts, Flash object transform
tutorial, Flash arranging objects
tutorial, Flash colors tutorial and Flash bitmap tracing
tutorial.



	Learning goals




	Review some technical design guidelines and procedures
regarding frame-by-frame, motion and shape animations in Flash
CS3




	Flash level




	Flash 9 / CS3




	Public




	Beginners (about week four of a 4h/week Flash
course)





You can use this as self-reviewing aid: If you don't
understand some items, you will have to go over some Flash tutorials again. This entry also
includes two exercises with *.fla files that we used as tasks for
mid-term exams...

[bookmark: General_principles]
2 General principles


	Description of the *.fla file and stage size




	Make sure to start with an appropriate stage size. Change it
via the properties panel or menu Modify->Document

	Fill in a description associated with the *.fla source, also
available through the menu Modify->Document




	Configuration of the desktop



The way you want your desktop configured depends on your screen
size and the type of animation you build. If your screen is big
enough, put as many tools at your finger tips as you can. In
particular:


	All toolbars

	Properties panel at the bottom

	Colors, Swatches, Align, Info and Transform on top right

	Libraries middle right



E.g. something like this:


[image: Example configuration of a CS3 Flash desktop]



Example configuration of a CS3 Flash desktop






	Tips




	You can hide/show panels with F4 (e.g. if stage size is
big)

	You can save a configuration and give it a name



If you are lost: go back to the Flash CS3 desktop tutorial

[bookmark: Layers_and_Frames]
3 Layers and Frames


	Put each object to be animated in a separate
layer ! Yes, do not animate two or more different objects in
one layer (except in frame-by-frame animation)

	To create a new layer click on the insert layer icon (left
underneath the layers)





	Immediately give this layer a meaningful name.

	simply double-click on the layer name





	If objects of one layer should be in front/in the back of an
other layer you can grab a layer with the mouse and move it up or
down.

	When you edit objects in one layer, it's good policy to lock
all the other layers !




[image: The Flash CS3 Layers tool]



The Flash CS3 Layers tool





If you are lost: go back to the Flash layers tutorial

[bookmark: Simple_drawing]
4 Simple drawing

There are two modes: merge mode and object mode:


	In merge mode (default) you draw shapes and over or
under-paint other shapes.

	In object mode you draw graphic objects that you later
can edit again.



Most of your drawings should be in object mode. So make sure
that this icon is on when you select a drawing tool: [image: object button pressed]


	Only use merge mode when you paint like you would with real
paint.

	You then can assemble these shapes with menu
Modify->Combine Objects->Union. The result is a
graphic object.



Other commands:


	To select several objects: either hold down the SHIFT key, use
a selection box or the Lasso tool.

	To break apart a drawing (well anything actually):
right-click; Break Apart. However, to edit the shape inside
a graphic objects you don't need to break it apart. You also can
double-click on the graphic shape. You should see something like
"Drawing Object" in the Edit bar". Make sure to return to main
timeline editing once you are done.



If you are lost: go back to the Flash drawing tutorial and Flash arranging objects
tutorial

[bookmark: Intermediate_drawing]
5 Intermediate drawing


	Tips




	Always lock other frames when you draw on one frame.

	For advanced drawing, you should consider learning how to use
the pen tool (Flash pen tutorial).



[bookmark: Object_transformation]
5.1 Object transformation

To transform an object or shape there are several tools,
most importantly:


	The Select tool: Make sure all objects are de-selected,
then move the cursor close to a stroke of an object or a shape.
When the cursor changes shape you can distort it.

	The Free Transform Tool has three different modes you
can select with the options controls in the tools bar:

	Change size, rotate, skew (by default you get this). Move the
cursor close to lines or corners and watch the cursor change
form.

	Distort tool

	Envelope tool





	The Subselection tool lets you fine tune things you did
with the above tools

	Subselection Tool, Distort Tool and Envelope tool let you
either drag distortion points (squares), turn or drag curve control
handles (circles).



Additional stuff is in the Modify menu. Also see the
Flash CS3 keyboard
shortcuts.


	Make sure you only selected one single object (unless
it's on purpose) before you start transforming.

	Flash changes the cursor when it switches to a given "transform
mode" and it may display additional handles. There are lots and you
should become familiar with these.



If you feel lost, go back to the Flash object transform
tutorial.

[bookmark: Arranging_objects]
5.2 Arranging objects


	To align objects, work with the align panel (menu
Window->Align or Ctrl-k). There are also shortcuts.




	To assemble shapes into a graphic object, use the
Modify->Combine Objects->Union or turn the selected
shapes into a symbol




	To break apart an object, use right-click->Break
Apart. If you want to produce shapes, you may have to repeat
this step.




	Tips



Set snapping preferences right: View->Snapping or
right-click on the workspace. Then Edit snapping

If you need this: see the Flash arranging objects
tutorial.

[bookmark: Colors_and_filters]
5.3 Colors and filters


	You can achieve a lot just by changing colors, color gradients
or by adding filters to movie clip symbols you use in
animations.



See the Flash colors tutorial if needed.

[bookmark: Frame-by-frame_animation]
6 Frame-by-frame
animation

Is useful for several things, e.g.


	To do precision work, e.g. drawing 15 frames for just an arm
movement;

	To make pulsating objects that you can move around;

	To insert/remove objects into the animation




	Procedure



Frame by frame animation works with anything. Just draw any kind
of shapes or graphic objects or whatever else in each keyframe.
Animation simply works because the frames are shown to the user in
rapid succession.

To add new keyframes that are empty:


	In the timeline (in the right layer!) click into the new
frame

	Then hit F7 (or right-click->Insert New
Keyframe)

	Then draw something new or copy/paste from an other frame.



To add new keyframes and copy over contents from the last
keyframe:


	In the timeline (in the right layer!) click into the new
frame

	Hit F6 (or right-click->Insert Keyframe). This will
copy contents from previous keyframe to the new one.




	Tips




	Play with the frame rate

	To slow down animation you also can space out keyframes (click
on a keyframe, then drag it in the timeline or hit F5 to extend a
frame).

	To align objects in several frames, enable Edit multiple
frames in the edit bar. Move the "onion skin" handles on top of
the timeline to select the frames you want to work with (don't
forget to disable this once you are done!).



If you are lost: go back to the Flash
frame-by-frame animation tutorial

[bookmark: Simple_motion_tweening]
7 Simple motion tweening

You only should animate non-editable objects (symbols, text
boxes, etc.). It's best to turn all your animated objects into
movie clips because you then can use Filters. E.g. add a glow
or a bevel to an object.


	Procedure




	Create a new layer

	Draw something in a keyframe (e.g. frame 1) of this new layer
and make it a movie symbol (right-click->Convert to
Symbol)

	Create a new keyframe (e.g. in frame 20) by hitting F6 (this
will copy the object from the previous frame). F7 will create an
empty keyframe and you will have to copy/paste manually.

	Then move the object in the new frame to its new place.

	If you did things right, you now have an object in a start
keyframe and another in the end keyframe. These objects should be
instances of the same symbol in the library or better (you
can copy/paste from frame 1 too).

	Then, click anywhere in the timeline between these 2 frames and
right-click->Create Motion Tween.




	Iron principles




	Every animation object must be in its own layer and it
must be a movie clip (or another non-editable object)

	There must be nothing else in the same layer. Unless you
are an expert, don't put more than one object into an animation
layer and don't use simple graphics or shapes (results are
unpredictable, i.e. you get a tween object in the library and you
won't be able to work properly on your animation).




	Tips




	You can accelerate/decelerate motion in the properties
panel.

	If you see a "tween" object in your library, something went
wrong (!) or you are an expert and know what you do. Break the
tween objects a part, then save all your graphics to symbols
(right-click on each and create symbol. Then, kill
the tween objects in the library and start over again.

	You can have several motion tweens in a row within a layer.
Just hit F6/F7 to extend again.

	If you want to rotate an object (instead of moving it), change
the rotate parameters in the parameters panel.



If you are lost: go back to the Flash motion tweening
tutorial

[bookmark: Motion_tweening_with_shape_modification]
8 Motion tweening with shape
modification

(1) You can add a little bit of shape tweening to motion
tweening if your animation is based (as we told you) on symbols. To
do so:


	Click on the symbol instances in start frame or end frame. Then
you can:

	Change tint, alpha etc. in the properties panel.

	Use the Free transform tool to rotate or change the size of an
instance.

	Add filters in the filters panel (it should sit next to
the properties panel, else add it with menu
Window->Properties-Filters).



This is not shape tweening, but consider using this technique
before you try to do motion with a shape tween (putting shapes in
different positions in the two keyframes will not just move the
shape but also transform it while moving).

(2) Alternatively, add a shape tween inside of the movie
clip. Double click on the item in the library and edit it.

If you are lost: go back to the Flash motion tweening
tutorial

Note: Timeline effects will be covered in a later tutorial.

[bookmark: Motion_guide_tweening]
9 Motion guide tweening


	Procedure




	Select the layer for which you want to create a motion
guide.

	Make sure it includes a motion tween, else create it now.

	Then click on the first (!) keyframe (e.g. frame 1) and insert
a motion guide layer.

	Draw the motion guide line with the pencil in this new motion
guide layer

	In the animation layer snap the object to the line (in frame 1
and the other keyframes).

	Display onion skins if you want to see the animation path while
working on a background for example.



Tips:


	You can have several motion tweens in a row in the animation
layer

	In order to move an object around a perfect circle, draw the
circle with the oval tool in object mode (and without fill). Then
make a tiny somewhere with eraser tool. This will produce a nice
curve.

	Play with acceleration/deceleration, i.e. create several
keyframes and move objects in the intermediate keyframes along the
motion guide.

	Again: Do not create motion tweens for shapes and graphics. Use
symbols !

	Again: You can only have one symbol instance in an animation
layer ! Put all other graphics in a different layer.



If you are lost: go back to the Flash motion tweening
tutorial

[bookmark: Shape_tweening]
10 Shape tweening

You can only animate editable objects, i.e. shapes and
simple drawing objects.

Therefore if you want to morph a graphic symbol, a textbox, a
picture, etc. break it apart. You may have to break it apart
more than once. In case you don't want to break apart a symbol
because you also want to use it in a motion animation, double-click
on it to enter symbol edit mode and copy/paste the graphics. Then,
go back to the main timeline.

Then simply follow the same procedure as for the motion
animation:


	Make a drawing in one frame

	Hit F6 in a distant frame and modify the shape/ simple drawing
in the new frame

	Click in a empty frame in-between and add the shape tween.



Tip:


	To morph simple graphic objects you may want to take the stroke
away (change its color to none).

	Do not try to create a motion animation with shape
tweening !

	Instead, try a motion tween and modify the shape. You can in
the properties panel distort symbols and change their tint. Or
better, create a shape tween within the movie clip
symbol.

	Create several layers if you work with several shapes. Then you
also can use shape hints.

	To morph bitmaps (e.g. *.jpg photographs) you will have to
trace them (see the Flash bitmap tracing
tutorial).



If you are lost: go back to the Flash shape tweening
tutorial

[bookmark: Manipulation_of_frames]
11 Manipulation of frames


	To extend a drawing layer (e.g. a background) so that it
displays until the end of an animation defined in an other layer:
Click on the wanted end-frame position and hit F5 (or
right-click->Insert Frame).




	To move a keyframe, click on it (cursor must now include a
white rectangle) and drag it left or right.




	To kill frames, select all the frames you want (click on one
end, then SHIFT-click on the other end). Then, use
right-click->Remove Frames.



If you are lost: go back to the Flash motion tweening
tutorial.

[bookmark: Motion_tweening_of_an_animated_object]
12 Motion tweening of an animated
object

You can import an *.swf file and move it as a movie clip
symbol.

Alternatively, you can create animations within animations:


	Hit CTRL-F8 to create a new symbol or convert an existing
graphic to a movie clip symbol with F8.

	Make sure to select Movie Clip !

	Give this movie clip an appropriate name

	Then you can drag the symbol from the library to the stage or
directly edit it in the library. Double click on the movie clip
symbol or the instance to edit and create any animation you like.
Make sure that know whether you are editing a symbol or your
scene...



You also can copy/paste a series of frames (e.g. a
frame-by-frame animation or a motion tween to this new embedded
movie symbol from another *.fla file:


	Select all the frames and layers you want (SHIFT click) then
right-click->Copy Frames somewhere in the timeline (not
over the layers !)

	Go to frame one of layer 1 of your new movie symbol and
right-click->Paste Frames.



So it is copy/paste frames, not "normal"
copy/paste !

Important: Make sure where you are when you edit, check
whether are you editing a scene and the main timeline or whether
you are editing a movie clip i.e. in symbol edit mode ! If you
mix up the two (or more) levels of editing you are likely to mess
up things ! This is the same problem as customizing button symbols

If you are interested in working with embedded movie clips,
there is more detailed explanation in the Flash embedded movie
clip tutorial

If you are totally lost: go back to the Flash
frame-by-frame animation tutorial, Flash motion tweening
tutorial and the Flash shape tweening
tutorial (there is some useful information in each of them).
Finally you may have a glance at the ActionScript 3
interactive objects tutorial if you need some more ActionScript
tricks.

[bookmark: Testing_and_Publishing]
13 Testing and Publishing


	Hit Ctrl-ENTER to test

	Menu File->Export->Movie just to export the *.swf
(Flash)

	Menu File->Publish Settings Verify settings, then hit
the PublishButton.



[bookmark: Important_principles_and_tips]
14 Important principles and
tips


	As soon as you are happy with a drawing, save it to the
library as graphic symbol or movie clip.

	Name your layers

	Lock all other layers when you work on one layer.

	Do motion animation with symbols only. Avoid having any "tween"
objects in your library (most likely something went wrong).

	Only use one symbol per motion animation layer.

	Shape animation works with either shapes and/or simple editable
graphics.

	To convert a non-editable object to a shape or simple graphic:
Break it apart (right-click on the object and Break
Apart)

	To convert an editable object or a shape (or several of these)
into a non-editable object select these and
right-click->Create symbol.

	To convert a shape into a graphic object: Modify->Combine
Objects->Union







[bookmark: Self-revision_example_1_-_weather_animation]
15 Self-revision example 1 - weather
animation

[bookmark: Tasks]
15.1 Tasks

Complete a weather animation by using the existing layers
and the objects in the library. You only need to add one extra
motion guide layer to complete the tasks described below.

Download the *.fla file from here:


	flash-cs3-cloud-animation-problem.fla



Then look at the solution (swf file):


	flash-cs3-cloud-animation-solution.html



Notes:


	All drawing objects you need are in the library and instances
are on the stage too. All layers are locked. Unlock as needed.

	This animation has about 50 frames. There is no need to go
further, but the animation layers are only defined for frame 1.
I.e. it is up to you to add motion and shape tweens and insert a
frame-by-frame animation

	Clouds and the sun are not in the right start position when you
open the *.fla file

	This animation is not really professional. We kept it as simple
as possible.




	(1) Cloud animation




	At start, clouds must be very small and then gradually move
forward and become big.



Tip: This is a motion tween animation with a shape transform of
the cloud instance (not a shape tween !)


	(2) Rain animation




	Insert animated rain underneath a big cloud once it is close,
e.g. around frame 40



Tip: Use a frame-by-frame animation (e.g. about 10 frames)


	(3) Sun animation




	The Sun must rise from the left and from behind the hills, then
move to the top and finally set behind the hills to the right.

	The sun must follow a more or less smooth path, i.e. an arc and
not just two lines.



Tip: This is a motion guide tween.


	(4) Sky animation




	Sky should be brighter around the sun

	Bonus: Also make the sky darker when the clouds arrive



Tip: This includes at least 2 shape tweens in a row. Use color
gradients: 1-2 color bands should do. Do the gradient transform
before you start duplicating the sky of frame 1. Alternatively you
also can add a glow to the sun with a filter ...


	(5) Extra effect




	Add one other animation effect somewhere. Whatever you
like.



[bookmark: Advice_and_Cheatsheet]
15.2 Advice and
Cheatsheet


	Frames




	F5 will extend a frame

	F6 will make a new keyframe and copy its contents

	F7 will make a new empty keyframe




	Scaling




	ALT-CTRL-S will allow to scale a selected object




	Shape tweening




	Right-click->Break Apart will turn a symbol instance into
its components. E.g. the sky as symbol instance will become a
Drawing Object.

	Alternatively, double click on a symbol object to edit its
graphics.




	Advice




	Always lock layers you are not working on.

	Backtrack (ctrl-Z) as soon as you see a "tween" object in your
library. None is needed.

	Do not kill library objects !

	If you completely messed up a layer, lock all layers, unlock
the bad one, select all frames (use SHIFT-click) and remove them
(right-click menu). Then restart again with a library object.



[bookmark: Solution]
15.3 Solution

You can find the solution here:


	http://tecfa.unige.ch/guides/flash/ex/animation-summary/

	File: flash-cs3-cloud-animation-solution.fla



Note: some vector graphics, i.e. the trees and the cloud have
been taken from the Open Clip Art Library. You can find the SVG files in
the same directory. Before importing to Flash I made some
modifications with Illustrator

[bookmark: Self-revision_example_2_-_tux_and_manga]
16 Self-revision example 2 - tux and
manga

[bookmark: Tasks_2]
16.1 Tasks

Complete this animation by using the existing layers and
the objects in the library. It should take you no more than 70
minutes (about 10 minutes for each task).

Please complete the six tasks described below. Most of
the work is already done, you only need to complete animations and
change properties:


	All drawing objects you need are in the library

	All layers are locked. Unlock as needed.

	Symbol instances are on the stage and in the right frame, but
you may have to break these apart.

	Key frames are also predefined.

	This animation has about 110 frames. In principle, there is no
need to go further.




	Look at a possible solution first




	flash-cs3-tux-manga-solution.html




	Download the *.fla file




	flash-cs3-tux-manga-problem.fla




	(1) Background animation (shape tween of gradient color)




	At start, it is rather dark and it should stay dark at
start.

	However, the sky should become clearer during the
animation.

	At the end of the animation, the background should be lighter
and the upper sky should become some sort of yellow



Tip: This is a shape tween (morphing) of a gradient color
rectangle (frame 1 to frame 100)


	(2) Pumpkin to Girl animation (shape tween)




	Transform the pumpkin into the Manga girl

	The Manga girl should appear at the same position as the
pumpkin (roughly)

	Animation should start around frame 50 and end at frame
100



Tip: Remember that you only can morph shapes (paint) and
graphics, but not symbols. The manga girl and the pumpkin are
symbols (and this is a first problem).


	(3) Penguin size (motion animation)




	The Penguin should be really small when it starts walking



Tip: This is a motion tween of a movie clip symbol (frame 1 to
frame 49). Shape of an instance (the Penguin in a given frame) can
be changed in the properties panel.


	(4) Penguin feet animation (frame-by-frame animation)




	The Penguin should "move" its "feet" while it walks (frame 1 to
49). This is not necessary for Penguin2 (frame 50 - 100).



Tip: This is a frame-by-frame animation of an embedded movie
clip (double click on the Penguin in the library). Four frames will
do.


	(5) Moon animation (guided motion)




	The Moon must rise from the left then move to the top (around
frame 50) and finally set down to the right.

	The moon must follow a more or less smooth path, i.e. an arc
and not just two lines.



Tip: This is a motion guide tween, i.e. same logic as the
(almost finished) penguin walk


	(6) Extra animation




	Add one other animation effect somewhere that would
improve the overall animation. Whatever you like.

	I for myself added a credits button (don't try, it's not part
of this test)



[bookmark: Cheatsheet_and_advice]
16.2 Cheatsheet and
advice


	Frames




	F5 will extend a frame without adding keyframes

	F6 will make a new keyframe and copy contents from the prior
keyframe in the timeline

	F7 will make a new empty keyframe




	Scaling




	ALT-CTRL-S will allow to scale a selected object. Else just use
the properties panel.




	Embedded movie clip animation




	To edit a movie clip, double click in the library on the symbol
(e.g. do this for the penguin feet)




	Shape tweening




	Right-click->Break Apart will turn a symbol instance into
its components. You cannot morph symbols !!

	To align objects across frames: Lock all layers (!) except the
ones you work on. Click on "Edit multiple Frames" on the Edit bar
(underneath the timeline). Move onion skin delimiters. Select the
objects (hold down the SHIFT key) and use for example the align
panel. Be careful with this method, e.g. don't forget to untick
"Edit multiple Frames"...




	Other Advice




	Always lock layers you are not working on.

	Make sure the select tool is "on" in the tools panel, before
you think about moving objects or changing their size or color

	Backtrack (ctrl-Z) as soon as you see a "tween" object in your
library. None is needed.

	Do not kill library objects (except these bad tween objects
after you saved the graphics inside) !

	If you completely messed up a layer, lock all layers, unlock
the bad one and remove all unwanted stuff (including bad tweens).
Then restart again with a library object or one from the backup
folder.

	Use F4 to hide / show panels if you need more drawing space.
You also can zoom in/out



[bookmark: Solution_2]
16.3 Solution


	flash-cs3-tux-manga-solution.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/animation-summary/



[bookmark: Links]
17 Links


	Open Clip Art
Library (SVG clipart to play with, but you will need to pass
trough Illustrator to import to Flash)

	Example directory referenced in the various tutorials: http://tecfa.unige.ch/guides/flash/ex/



Flash special effects tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !




	Page created by Daniel K. Schneider, 28 September
2007

	Last 
modified by Daniel K. Schneider, 22 April
2009



This entry is part of the Flash CS3
tutorials.

[bookmark: Introduction]
1 Introduction



	Learning goals




	Learn how to add special effects to animations




	Prerequisites




	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash object transform
tutorial

	Flash colors tutorial

	Flash
frame-by-frame animation tutorial

	Flash motion tweening
tutorial

	Flash shape tweening
tutorial

	Flash embedded movie
clip tutorial for guided masks




	Moving on




	The Flash tutorials article has a list of
other tutorials. E.g. you could start learning how to make
interactive programs with the Flash button tutorial.

	You also may achieve more sophisticated special effects with
ActionScript libraries that you can download. E.g. if you want
snowflakes for example, try the FLiNT particle
system and read the Flash using
ActionScript libraries tutorial.




	Level and target population




	Beginners (but see the prerequisites)




	Quality




	Rather low. This tutorial doesn't contain many details, just
some short "how to"s and feature demonstrations.




	To Do




	Filters





In Flash there are several built-in special effect features.


	You can create some kinds of combined shape/motion/duplication
animations (timeline special effects)

	You can work with masks

	You can apply filters



Some of these effects may be very demanding on your CPU. Try to
work with simpler objects or space out generated keyframes if this
happens.

[bookmark: Timeline_effects]
2 Timeline effects

Timeline effects are effects that are automatically generated by
the Flash environment from an object. You only can parameterize
these effects, but not hand-edit generated objects and
frames !

[bookmark: Summary_of_the_procedure]
2.1 Summary of the
procedure


	Step 1 - Select an object and open the effects tool




	Create a new layer

	Insert an object (i.e. text, shapes, simple graphics, groups,
graphic symbols and button symbols, bitmap images)

	Select this object

	Right-click->Timeline Effects or else Menu
Insert->Timeline Effects , then see next step




	Step 2 - Select an effect




	Select an effect and adjust parameters

	You can preview the effect within the Effects tool.



NB: Ignore error warnings about Flash 7 etc.


	Step 3 - Start over




	Right-click on the object: Timeline Effects; Remove
Effect or Edit Effect



There are three sub-menus for effects:


	(1) Assistants




	Copy to Grid (not a timeline effect, just a multiplication of
drawing to a grid)

	Distributed Duplicate. Will make "tumbling copies" of an
element.




	(2) Effects




	Blur (object will blur and change size in all or one chosen
direction)

	Drop Shadow (just draws a static drop shadow)

	Expand (object will expand/shrink)

	Explode (object will explode and draw different fragments on an
configurable arc)




	(3) Transform/Transition




	Transform (A shape tween with extra options, e.g. duration,
position, scale, rotation, spin, ...)

	Transition (A motion tween with extra options, e.g. direction,
duration, fading, motion ease)



For each of these effects you can set certain parameters, in
particular:


	Number of copies

	Offset and rotation parameters, i.e. where the generated images
will display and if/how they rotate

	Offset start frame: Keyframes in which the images will be
drawn



Important: Using the special effects means that you can
not change anything Flash will generate. Also, do not make
modifications to the object. Flash will:


	rename the layer (do not choose a "better" name)

	add stuff to a Effects Folder in the library

	Add an item to the library



If you want to remove an effect, it is best to
Right-click->Remove on an object ! You also can
delete all the generated objects, but this is more work and you may
by mistake delete something else ....

[bookmark: An_example_with_timeline_effects]
2.2 An example with timeline
effects

The following (ugly) example contains three effects:

(1) Distributed duplicate (tumbling): An object will
tumble and be reproduced with X copies. You may set several
parameters like:


	Number of copies

	Offset of copies in x an y position (in pixels)

	Rotation of copies (in degrees)

	Offset start frame (keyframes across the timeline that will
have this animation). So "number of copies" * "offset start frame"
will define the total length (frames) of this animation.

	Linear scaling in x and y direction (in percentage)

	Alpha and color change.



(2) Blur: Motion blur that may include change of alpha,
position or scale of an object


	Total duration (in frames)

	Scale (in percentage): Object will become bigger or
smaller.

	Resolution, i.e. number of steps: How many times should the
object be duplicated during the blurring process.

	Horizontal/vertical blur on/off and direction



(3) Explode


	Effect duration (frames)

	Direction of explosion

	Arc size (x/y pixels)

	Rotation of fragments and change of fragments

	Final alpha (in percentage)




[image: Timeline effects example]



Timeline effects example





To edit create special effects animation, you will work with a
tool available from the Time-line effects menu. Below we show a
screenshot of "Distributed duplicate". You then have to play with
the parameters until you get it right. Remember that you cannot
make any changes to the object or the generated objects!

The only way you can change an effect is through the edit
effects tools. There are two methods:


	Click somewhere in the frames of the layer where an effect is
defined, the use Modify->Timeline Effects->Edit
Effect

	Select the animated object on the stage, then
Right-click-Timeline Effects->Edit
Effect.



This way you also can remove an effect.


[image: Distributed duplicate timeline effect]



Distributed duplicate timeline effect





Example:


	flash-cs3-special-timeline-effects-1.html

	Source: flash-cs3-timeline-effects-1.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/special-effects




	Same example that will start animation a bit later

	flash-cs3-special-timeline-effects-2.html

	Source: flash-cs3-timeline-effects-2.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/special-effects



An other example that uses tumbling is this "enhanced"
video.


	flash-cs3-video-timeline-embedd.html

	Source: flash-cs3-video-timeline-embedd.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Masks]
3 Masks

“For spotlight effects and transitions, use a mask
layer to create a hole through which underlying layers are visible.
A mask item can be a filled shape, a type object, an instance of a
graphic symbol, or a movie clip. Group multiple layers under a
single mask layer to create sophisticated effect”
(About mask layers, retrieved 16:51, 8 October
2007 (MEST)).

[bookmark: Mask_and_masked_layers]
3.1 Mask and masked
layers

Masks are layers that will allow you to see what is underneath
through a sort of hole (i.e. a drawing). You then can animate this
hole with a motion tween for example. Masked layers are the layers
underneath.

In the following picture, a mask lets you see part of bookshelf
through an oval.


[image: A mask with an oval]



A mask with an oval





Step 1 - Create some contents:


	Put these contents in one or several layers. We will turn these
layers "masked" in step 3.



Step 2 - Add a mask layer:


	On top of these layers, create a new layer

	Right-click on the layer name and select Mask.
This layer will mask the others and it should contain a single
graphic element (shape, graphic symbol or group).



Step 3 - Define the masked layers:


	The layer just beneath the Mask layer already should be masked.
If it is not, right-click on the layer name and select
Masked.

	You can turn other layers underneath to be masked with the same
procedure. Move normal layers to a position after the mask layer or
an already masked layer or create new ones...



To undo a masked layer, just right-click and revert back it to
"normal". We show a picture of mask and masked layers further down.
Such static masks are of course not very interesting, so let's move
on ...

[bookmark: Masks_animated_by_a_simple_motion_tween]
3.2 Masks animated by a simple motion
tween

Step 1 - Add a simple motion tween:


	Select the mask layer

	Draw a non-editable object (graphic object, symbol)



Step 2 - Do a motion tween


	Like in a normal motion tween as explained in the Flash motion tweening
tutorial.



The user will only see things that will lie underneath the
tweened object. E.g. if you move a circle, only the stuff that sits
under the moving circle will be shown.

Example:


	flash-cs3-mask.html

	Source: flash-cs3-mask.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/special-effects



[bookmark: Shape_tween]
3.3 Shape tween


	Step 1 - Draw a shape in the mask layer




	Step 2 - Do a shape tween



The tweened shape will determine what parts of the drawing in
the masked layer(s) you can see.

[bookmark: Guided_motion_tween]
3.4 Guided motion tween

The principle is not the same as for the simple motion
tween. You will have to created an embedded movie clip in
the mask layer. If you don't understand embedded movie clips, read
the Flash embedded movie
clip tutorial.

Step 1 - Create a movie symbol


	Select the mask layer

	Create an embedded movie clip, e.g. in frame 1

	E.g. Create first a drawing then Right-click->Convert to
Symbol, select Movie Clip

	E.g. Menu Insert New Symbol (CTRL-F8), then draw the
object in symbol edit mode.







Timeline might look like this:


[image: Movie clip in a mask]
Movie clip in a mask





Step 2 - Edit the movie symbol


	Double click on the symbol

	Create a guided motion tween (this implies that you should
again make the graphic into symbol, then proceed in the same
way as normal guided motion tweening).



Your embedded movie clip might look like this:


[image: A guide motion animation of a movie clip as mask]
A guide motion animation of a movie clip
as mask





Example:


	flash-cs3-mask-2.html

	flash-cs3-mask-2.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/special-effects



[bookmark: Filters]
4 Filters

This section needs to be written, but filters are also
introduced in the Flash colors tutorial.

Look at the options in the parameter panel when you do a
"normal" motion or shape tween and play with these ...

[bookmark: Links]
5 Links


	Timeline effect settings (Adobe Using Flash Manual]).




	Work with mask layers, a section of "creating
animation - animation basics" of the Adobe Using Flash Manual].



Flash video component tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !



This is part of Flash tutorials

[bookmark: Introduction]
1 Introduction

Video components are prebuilt interface elements (widgets) that
will speed up video integration. In particular, the FLVPlayBack
Video Component allows to render videos without any
ActionScript programming. It includes a nice choice of skins for
user controls. Videos also can be enhanced with captioning or they
may interact with the rest of the animation. Some of these
techniques require some more technical skills, e.g. knowledge of
XML
and some ActionScript.



	Learning goals

	Learn how to encode *.flv files

	Learn how to use the Flash 9 (CS3) video component for simple
video playback

	Learn how to insert and use cue points for various
purposes

	Learn how to create text captions

	Learn how to integrate videos with animations and interactive
elements

	Learn some more ActionScript 3.0




	Prerequisites for the first part

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash component button
tutorial

	Timed Text (only for captions).




	Prerequisites for the second part

	Flash button tutorial

	Flash motion tweening
tutorial, Flash shape tweening
tutorial, Flash special effects
tutorial

	Flash embedded movie
clip tutorial




	Moving on

	The Flash article has a list of other tutorials.




	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It both aims at beginners (FLV encoding, using the video
playback component and embedding a video in the timeline) and
intermediate Flash designers (inserting captions and using cue
points to trigger animations).






	The executive summary about Flash Videos



Flash has built-in video management components.


	The FLVPlayBack Video Component is really easy to use since it
provides a series of ready-made skins (user interfaces) from which
you can choose.

	The Caption component requires some XML Editing.

	For more sophisticated video-animation interaction you need to
code with ActionScript.




	The executive how-to summary for simple video playbacks




	Encode your video with the Video Encoder. Flash has its own
*.flv video format.

	Drag the FLVPlayBack Video Component to the stage.

	Open the component inspector panel. Choose a skin and provide
the file name or URL of the *.flv video



[bookmark: Preparing_your_video]
2 Preparing your video

Flash uses a special video format (*.flv) to render videos. You
may directly encode your formats with the CS3 video encoding tool
(that's what I suggest) or wait until Flash will prompt you to
encode when you import a video in non *.flv format.

[bookmark: Video_encoding_with_Flash_CS3]
2.1 Video encoding with Flash
CS3

The Flash package includes a video encoder with which you can
transcode various video formats into *.flv format. It also lets you
define cue points and edit (somewhat) the video.


[image: The Flash CS3 Video encoder tool]
The Flash CS3 Video encoder tool





Now, open the Flash CS3 Video encoder program directly
from the Desktop (i.e. not from Flash!).

[bookmark: Video_transcoding]
2.1.1 Video transcoding

The tool supports most current video formats. You can for
example import *.mov, *.avi, *.mpeg, *.dvi, *.wmv, *.3pg and *.mp4
formats in this tool. If you need a video file to play with see the
Artwork links at the end of this
tutorial.


	Opening a video file




	Open the Flash CS3 Video Encoder tool

	Click on the Add ... button to add a new video.




	Edit




	Click Settings to define output settings and to add
video cues, etc. You can just leave the defaults if you like,
unless your video file is long and/or big and you want to trim it
down.




	Encoding




	Click Start Queue to encode your video. By default, the
resulting *.flv file will be saved in the same directory as the
source video. Flash will not overwrite an older *.flv version but
rather renumber the new version.



[bookmark: Video_Editing]
2.1.2 Video Editing

The Flash Video Encoder tool has some limited editing capacity
you can access through the settings button. Since videos quickly
can become huge, you may want to crop off space from top, bottom or
left and right and also make it shorter. You also can choose from
various levels of video and audio quality.


	Look at the contents




	Move the horizontal glider (yellow triangle) from left to
right.




	To resize and crop




	Select the "Crop and Resize" tab

	You can crop the video (i.e. take of space on top, bottom,
right, left.



See the screen capture below.


	To crop off frames at start and at the end




	You cut off frames from the beginning and the end of the
original video (move the little triangles below the playhead as
shown in the screen capture below.





[image: Cropping and resizing the length of a video - listening to sound with QuickTime Player]



Cropping and resizing the length of a video - listening to sound
with QuickTime Player





Tip: If you want to hear the video, just listen to it with an
other tool, e.g. the QuickTime Player if your source is *.mp4. Both
tools show time in seconds.

It is import to make a video as small as possible if you plan to
do timeline animations as shown in the Importing a video to
the timeline section.


	Typical quality settings




	Select "video" and "audio" tabs

	Video: For short videos I use the medium Flash quality with
default codecs

	Audio: If video quality is bad from start (e.g. made with your
cell phone) you can reduce audio to 64 kpbs mono or even less since
it can't get worse than it already is.



[bookmark: Cue_Points]
2.1.3 Cue Points

“Cue points cause the video playback to start
other actions within the presentation. For example, you can create
a Flash presentation that has video playing in one area of the
screen while text and graphics appear in another area. A cue point
placed in the video starts an update to the text and graphic, while
they remain relevant to the content of the video. (Adobe CS3 Video
Encode Help, sept. 2007)”

You don't need cue points for just playing a video, so you may
come back later and read about inserting cue points.

There are several ways of adding cue points.


	(1) Adding Cue points in the video encoder




	Select the Cue Points Tab

	Glide forwards and backwards the video playhead to select
positions you'd like to mark

	Click on the + to add a new cue point.

	Event cue points are used to trigger ActionScript
methods when the cue point is reached, and let you synchronize the
video playback to other events within the Flash presentation.

	Navigation cue points are used for navigation and
seeking.



I don't think that there are any real differences between these
two kinds of cue points. At least from an ActionScript point of
view, the difference is simply that you can identify with which
category a cue point is labelled (type property).


[image: Adobe CS3 Video Encoder Cue Points]



Adobe CS3 Video Encoder Cue Points





Each cue point consists of a name, a type and the time at which
it occurs and we then can retrieve this information in Flash as you
will see in handling events from the movie section below. Anyhow, I
rather suggest to add cue points through the component's
parameters, since you then can add/remove cue points whenever there
is a need.


	(2) Adding cue points with other methods




	Trough the FLVPlayBack component's parameters, i.e. open the
parameter or the component inspector panel (see below). I recommend
this method for beginners.

	In ActionScript with the addASCuePoint() method

	With an XML file.



The advantage of the ActionScript and the XML method is that you
easily can change these cue points when adjustments are needed.
E.g. you may notice at some point that your video file is too big
and you may want to shorten it down. It's faster to change AS code
or XML descriptors than entering the cue points again with the
encoding tool.

[bookmark: Other_transcoding_tools]
2.2 Other transcoding
tools

Your modern cell phone may encode video with MP4. Flash 9 (CS3)
can not directly import this format. If you don't have access to
the CS3 Flash Video Encoder tool (an older Flash version may not
encode newer formats), you may download the free SUPER tool (it has
more features than many commercial tools).

Read the MP4 article to see how I managed to use this free (and
excellent) SUPER encoder to go from MP4 to MPV with
MPEG3-v2/MP3.

[bookmark: Using_the_FLVPlayback_component]
3 Using the FLVPlayback
component

Let's now import a video and use it the simple way. In this
example we will show how to import a video I (quickly) made with my
Nokia N73 cell phone. The easiest strategy is to directly import a
*.flv file.

[bookmark: Using_the_video_with_the_component_first_method]
3.1 Using the video with the
component first method

The most simple procedure to use a video with the
FLVPlayBack component is the following one:


	Step 0 - Get/create a *.flv file




	See above.

	Put it in the same directory as your Flash file.




	Step 1 - Open the component library




	Menu Window->Components or hit Ctrl-F7.

	Dock it next to your library.




	Step 2 - Drag the video component to the stage




	Drag the FLVPlayBack component from the components
library to the stage.




	Step 3 - Tell FLVPlayBack where to find the video




	Open the Component Inspector panel
(Window->Component Inspect) and dock it next to the
library.

	Add the name of a video file in the source field of the
parameters. Click on the field and then either type the file name
or use the file chooser menu.

	Tick match source FLV dimensions. This will adjust the
size of the video control widget to your video.

	Make sure to remove the directory path from the file name. For
example, instead of:




	
E:\schneide\te\coap2110\ex\component-video-intro\office-dks3.flv



just keep the file name


	office-dks3.flv



Else when you copy both the *.sfw and the *.flv file to some
other place you flash file won't find the video anymore and the
playback will break.


	Step 4 - Adjust the skin




	Play around with various skins in the component inspector
panel. Basically you can add/remove various user controls.

	Click on the value of the "skin" parameter. A popup menu will
let you select from various skins.

	Finally, you can change the color of the component.




[image: Select the video component skin]



Select the video component skin





Enjoy ....

[bookmark: Importing_the_video_with_the_import_method]
3.2 Importing the video with the
import method

Here is an alternative and longer method for using the
FLVPlayBack component.


	Step 1 - FLV files




	Encode the video as *.flv file as described above.

	If you directly import other formats, i.e. *.mov, *.avi,
*.mpeg, *.dvi, *.wmv, *.3pg (but not MP4), Flash will at some point
open the Video encoder tool. So the result is the same: a *.flv
file. It will be saved by default in the same directory as your
original video file.




	Step 2 - Import the video




	Create a new layer and call it "video"

	Menu File->Import->Import Video



You then can from a popup menu choose how the video should be
deployed (see next step).


	Step 3 - Choose "Standard web server / progressive
download"




	If you only have access to a standard web server: Choose
"progressive download" from a web server.

	You then can choose from a variety of built-in video control
skins for the FLVPlayBack Video Component which will be
automatically added to your library (you later can change the skin
again, so don't worry now).



The video you will import will simply use the standard video
playback component that you also can find in the "Components"
panel.


	Step 4 - Fine tune the stage




	Change the background

	Adjust stage size to video size or alternatively add some text
or graphics if the stage is bigger. Create a new layer for
these.

	You also can change the skins for the video control skin.
Simply open the Parameters panel. Scroll down to the skin field and
select another one from the popup menu. Same thing for other
parameters. You can quite safely play around with them.




	Step 5 - Fix the source file location



You must tell Flash where the video file will sit on your server
(see also the next step)


	Click on the video component

	Open the parameter panel (menu
Window->Properties->Parameters in case it's not
already docked) or the open the Property inspector panel. I
prefer the latter since I have it docked next to library and don't
need to scroll as much as in the bottom panels.

	Change the source field, scroll down if needed (!). In
our case I killed everything in front of the file name
office-dks.flv.



For example, instead of:


	
E:\schneide\te\coap2110\ex\component-video-intro\office-dks3.flv



I only kept the file name since I plan to put all files in the
same directory on the server. Also on my desktop the files sit in
the same directory.So I shortened down the path:


	office-dks3.flv




[image: Configuring the video component]



Configuring the video component






	Step 6 - Tune some parameters



In the property inspector or parameters panel you may set
things like:


	Volume: I suggest to turn it down to 0.3 since you will be fed
up listening to your video after a while

	AutoPlay: True means that the video will start playing after it
loads. False requires the user to press the play button




	Step 7 - Copy the *.flv and *.swf skin file to your web server
(optional)




	I suggest to put all files in same directory since they will be
easier to manage that way. If you don't, go back to step 5. Also
remember that the *.flv file may sit in the same directory where
you original video is.

	Do not forget to copy the "*.swf skin file, for example
SkinUnderAllNoFullscreen.swf.




	If the video doesn't play...




	Most likely you forgot to define the right source path, either
a full URL, a relative URL, or a *.flv file name that sits in the
same directory.

	File names are case sensitive on most Web servers ! Also
avoid using blanks and other strange characters in your file name.

	Good = myvideo.flv - Bad = my Video.flv








	Results




	flash-cs3-video-simple-server.html

	Source: flash-cs3-video-simple-server.fla

	Video file: office-dks.flv

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Making_use_of_captions]
4 Making use of captions

A caption is a text that is displayed dynamically while
the video is playing. Captions may serve several purposes:


	You can deploy videos to people with hearing disabilities

	Users can look at videos without making noise

	You can emphasize important passages, or paraphrase or comment
voice tracks.



In order for captions to work, you must do three things:


	Use a skin for the playback component that includes a Caption
button, e.g. SkinUnderAllNoFullscreen.swf.

	Make use of the FLVPlayback Captioning component (in
addition to the playback component)

	Encode captions in an XML file (there are at least two
options). This XML file then must be registered with the captioning
component.



To import the video, use the same procedure as in Using the FLVPlayback
component

[bookmark: The_caption_component_with_timed_text]
4.1 The caption component with timed
text


	The Timed Text standard and XML



If you are not familiar with XML, you may have a glance at the
XML
article and maybe the DTD tutorial. Then, we also suggest to work with
an XML editor in order to insure that your file is
well formed. We suggest the free Exchanger XML
Lite. If you don't feel learning XML, just make very sure that
you exactly use a template as described below. One missing tag or
or some syntax mistake like a missing ">" will make your
animation fail.

Flash doesn't support the full Timed Text specification and the documentation at
Adobe is rather shaky. For those who are familiar with XML I wrote
a little DTD that helps editing. Just grab it from the Timed Text article and also copy/paste the XML
template.

Note: Timed Text is defined with a complex XML
Schema but since Adobe Flash only implements a subset, it's not
worth using this.


	Figuring out time for captions



In order to write this XML file you must know what caption to
insert at which time and for how long. The CS4 Adobe Media player
does show time and maybe other *.flv video players too.


	Get Adobe Media
Player. It is free.

	Under Ubuntu, the Totem player works well.



If you want high precision, you also can load the *.flv file
into the timeline (see below) and then play it with
View->Bandwidth Profiler on. Write down the frame number
for captions and then divide by the frame rate. Hit:


	'.' to stop and then to go forward one frame,

	',' to go back one frame,

	'Enter' to start playing again.




	A minimal example XML captioning file



As a minimum we suggest to enter the following data. For each
caption enter:


	A <p> </p> tag. Each "p" should
include:

	a begin attribute that defines when the caption
should appear,

	a dur attribute that defines how long it will
stay on screen.



Time is in seconds, but also may use a more complex format
like


02:30.5


meaning 2 minutes, 30 seconds and a half.

Here is the file we called timed-text.xml and that we used in
this example


<?xml version="1.0" encoding="UTF-8"?>
<tt xml:lang="en" xmlns="http://www.w3.org/2006/04/ttaf1"
    xmlns:tts="http://www.w3.org/2006/04/ttaf1#styling">
  <head>
    <styling>
    </styling>
  </head>
  <body>
   <div xml:lang="en">
      <p begin="1" dur="4">Daniel's Office</p>
      <p begin="5" dur="5">My Palm Tree (from NYC)</p>
      <p begin="11" dur="7">My Bookshelf</p>
      <p begin="18" dur="5">My favorite Flash Drawing Book</p>
      <p begin="25" dur="5">My DELL XPS Laptop Flash machine</p>
      <p begin="30" dur="5">My Ubuntu Linux workstation</p>
      <p begin="33" dur="5">Working hard on Flash Tutorials using the Xemacs Editor</p>
      <p begin="42" dur="5">The outside (not my bike)</p>
    </div>
  </body>
</tt>


Note: Captions may overlap, i.e. Flash will display a new
caption on a new line if the previous one is still on. You can see
this in the example we present in the next section.

For now, just grab the template below and add "p" tags, make
sure to close them as in the example above. Replace "Let's start"
by your own caption of course.


<?xml version="1.0" encoding="UTF-8"?>
<tt xml:lang="en" xmlns="http://www.w3.org/2006/04/ttaf1"  xmlns:tts="http://www.w3.org/2006/04/ttaf1#styling">
  <head><styling></styling></head>
  <body>
   <div xml:lang="en">
      <p begin="1" dur="4">Let's start</p>
      
    </div>
  </body>
</tt>



	Using the FLVPlayback Captioning component




	Create a new layer and call it "Caption" or something like
that. Go there.

	Then drag the "FLVPlayback Captioning component" somewhere to
the workspace or even to the stage.

	Unlike the playback component, this component will not show, so
it can be anywhere.




	Customization of the component

	Click on the component and edit the parameters (either in the
Parameters or the Component Inspector panel). Then,

	set showCaptions to true if you want all users to see
captions (probably most users don't know how to turn it on or off,
so turn it on)

	specify the source of the Timed Text XML file to
download. So, create the xml file now, if you didn't so far. Make
sure to get the spelling right.




[image: The FLVPlayback Captioning component and its parameters]



The FLVPlayback Captioning component and its parameters






	The example




	flash-cs3-video-simple-server-caption.html

	flash-cs3-video-simple-server-caption.fla

	XML file: timed-text.xml

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/




	Tuning




	You can style text and background of the Caption Box (see
below)

	Put down the volume: Set it to 0.5 in the parameters of the
FLVPlayer or even lower. I am fed up listening to my own voice,
really.



[bookmark: CaptionsBox_and_Style]
4.2 CaptionsBox and Style

As explained in Tom Greens' Captions for Video with Flash CS tutorial, you can
use a different text box to display the captions.


	Step 1 - Draw a textbox for the captions to appear




	Create a captions layer if you don't already have one

	Draw a textbox

	Give it the instance name caption_box

	Select font size, color etc.

	Select Multiline

	Make it Dynamic Text (if it is not)








	Step 2 - Configure the component



Tell the captioning component to use the textbox you just made
to display captions:


	Open the parameter or inspector panel for the FLVPlayback
Captioning component

	Set captionTarget = caption_box

	Set autoLayout = false




	Step 3 - Add some style to the XML File



Just look at this example (file timed-text2.xml). I don't really
understand how some styling tags work. I'd expect for instance to
behave backgroundColor within a span like in HTML but it doesn't. I
don't know this behavior is a feature or a bug or my
misunderstanding of the manual.

If something is not clear, please download the *.fla file and look at it. Make sure to verify
that both the playback and the captioning component parameters are
ok and that you put all the files in your computer or the server
(including the skin *.swf, the *.flv and the *.xml file) in the
same directory. Do not forget to copy the skin !


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE tt SYSTEM "mini-tt.dtd">
<tt xml:lang="en" xmlns="http://www.w3.org/2006/04/ttaf1"  xmlns:tts="http://www.w3.org/2006/04/ttaf1#styling">
  <head>
    <styling>
      <style id="title" tts:backgroundColor="transparent" tts:color="red" tts:fontSize="24"/>
    </styling>
  </head>
  <body>
   <div xml:lang="en">
      <p begin="0" dur="9" style="title">Daniel's Office</p>
      <p begin="5" dur="4">My Palm Tree (from NYC)</p>
      <p begin="10" dur="13" style="title">Books ....</p>
      <p begin="11" dur="7">My Bookshelf</p>
      <p begin="18" dur="5">My favorite Flash Drawing <span tts:color="red">Book</span></p>
      <p begin="24" dur="16" style="title">Computers ....</p>
      <p begin="25" dur="5">My DELL XPS Laptop Flash machine</p>
      <p begin="30" dur="5">My <span tts:backgroundColor="yellow" tts:color="black">Ubuntu Linux workstation</span></p>
      <p begin="35" dur="5"><span tts:backgroundColor="transparent"></span>Working hard on Flash Tutorials using the Xemacs Editor</p>
      <p begin="40" dur="4">The outside (not my bike)</p>
    </div>
  </body>
</tt>



	The result




	flash-cs3-video-simple-server-caption2.html

	Source: flash-cs3-video-simple-server-caption2.fla

	XML file: timed-text2.xml

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Adding_captions_with_Cue_Points]
4.3 Adding captions with Cue
Points

There is an alternative method. Read Captions for Video with Flash CS3 (Part Two), by Tom
Green, Digital Web Magazine, June

[bookmark: Importing_a_video_to_the_timeline]
5 Importing a video to the
timeline

Now we will look at a very different way of using videos.
Instead of using the playback component we will include the video
into the timeline (each video frame will be a timeline frame). This
will allow us to create videos augmented with animations in an easy
way.

[bookmark: Embed_into_timeline_version]
5.1 Embed into timeline
version

If you embed a video into the timeline, then you don't get the
ready-made video control as above. Only embed video in the timeline
if you plan to add animations the simple way and if the video file
is really small. Also you shouldn't care about smaller
synchronization problems with the audio track.

Embedded video will make your timeline really long, although you
can choose to have it its own timeline. Anyhow, in this example we
took the "hundreds of frames" timeline option.

We will insert the video in frame #2. We also will add a play
button that will jump to frame 2 and play the video.


	Step 1 - FLV files




	Create one




	Step 2 - Import the video as embed




	Create a new layer and call it "video"

	Insert a new empty keyframe in frame 2 (since we don't want the
video play on load in this case).

	Go there

	Menu File->Import->Import Video

	In the video deployment dialog, choose "Embed video in SWF and
play in timeline".




[image: Deployment dialog]



Deployment dialog






	Step 3 - Add some simple controls




	You need at least a play button, but adding some extra
buttons that will allow a user to jump to given frames also may be
handy.

	We just used the button component described in the Flash components
tutorial.



In our example we added three buttons:


	The "play button" will move the playhead in frame 2 where the
video starts.

	The "Go to Book Scene" button will move it to frame 230
something.

	The "Credits" button will go to the very end.



The ActionScript code:


/* This will stop Flash from playing all the frames
   User must stay in Frame 1 */
stop();

/* Associate a handler function for each button instance */

btn_credits.addEventListener(MouseEvent.CLICK, clickHandler);
btn_play.addEventListener(MouseEvent.CLICK, clickHandler);
btn_book.addEventListener(MouseEvent.CLICK, clickHandler);

/* Instead of writing a function for each button, we just create one.
   In order to understand which button was clicked, we ask from the event
   the label of the button(event.currentTarget.label).
   Then we gotoAndStop(x) to Frame 374 for Credits
   Or we can play the movie that sits in frame 2
*/
function clickHandler(event:MouseEvent):void {
        switch (event.currentTarget.label)
        {
                case "Credits" :
                        gotoAndStop(609);
                        break;
                case "PLAY" :
                        gotoAndPlay(2);
                        break;
                case "Go to Book Scene" :
                        gotoAndPlay(230);
                        break;
        }
}

/* This shows how to open an URL in a WebBrowser */
btn_edutech_wiki.addEventListener(MouseEvent.CLICK, GoToUrl);

function GoToUrl(event:MouseEvent):void {
        var url:String = "http://edutechwiki.unige.ch/en/Flash_video_component_tutorial";
        var request:URLRequest = new URLRequest(url);
        try
        {
                navigateToURL(request, '_blank');
        }
        catch (e:Error)
        {
                trace("Error occurred!");
        }
}


The "embed in timeline option" is probably only useful if you
plan to play around with fine grained frame-by-frame jumping around
or if you plan to add animations that synchronize with the video as
described in the next example. Otherwise it is better to use a
external video with the video playback component as described
above.


	Results




	flash-cs3-video-simple-embedd.html

	Source: flash-cs3-video-simple-embedd.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



Note: I noticed that when you import more than once a movie,
file size will grow a lot ! Probably a side-effect of the undo
mechanism. So 'do not do this. If you notice this problem,
save the file with "save as". The new version will be ok. (Maybe
there is another solution to trim down file size).

[bookmark: Enhanced_video_embedding_into_timeline]
5.2 Enhanced video embedding into
timeline

Embedding video into the timeline makes sense (IMHO) if you are
looking for an easy way to synchronize other animations with the
video. This requires no more additional ActionScript knowledge than
you need for simple animation and navigation.

In this example, we add various animations (e.g. two motion
tweens and a shape tween) to the project. Below you can see that
books are tumbling out of a bookshelf while the video shows a
"real" bookshelf.


[image: Embedded video with some animations]



Embedded video with some animations





Here is the action script code that we use to implement a simple
play button, plus two other ones that are not really necessary. All
the rest is just simple Flash animation


/* This will stop Flash from playing all the frames
   User must stay in Frame 1 */
stop();

/* Associate a handler function for each button instance */

btn_credits.addEventListener(MouseEvent.CLICK, clickHandler);
btn_play.addEventListener(MouseEvent.CLICK, clickHandler);

/* Instead of writing a function for each button, we just create one.
   In order to understand which button was clicked, we ask from the event
   the label of the button(event.currentTarget.label).
   Then we gotoAndStop(x) to Frame 572 for Credits
   Or we can play the movie that sits in frame 2
*/
function clickHandler(event:MouseEvent):void {
        switch (event.currentTarget.label)
        {
                case "Credits" :
                        gotoAndStop(572);
                        break;
                case "PLAY" :
                        gotoAndPlay(2);
                        break;
        }
}

/* This shows how to open an URL in a WebBrowser */
btn_edutech_wiki.addEventListener(MouseEvent.CLICK, GoToUrl);

function GoToUrl(event:MouseEvent):void {
        var url:String = "http://edutechwiki.unige.ch/en/Flash_video_component_tutorial";
        var request:URLRequest = new URLRequest(url);
        try
        {
                navigateToURL(request, '_blank');
        }
        catch (e:Error)
        {
                trace("Error occurred!");
        }
}



	Results




	flash-cs3-video-timeline-embedd.html

	Source: flash-cs3-video-timeline-embedd.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Using_cue_points_for_navigation_and_to_trigger_animations]
6 Using cue points for navigation and
to trigger animations

Working with cue points is another way to have your video
interact with other animation. It's a more difficult solution than
using timeline videos, but more elegant.

[bookmark: Jumping_to_cue_points]
6.1 Jumping to cue points

Code for jumping to cue points is fairly easy if you know how to
use buttons or button components.


	Insert a video playback component like above

	Give it an instance name like video

	Then copy paste the code below (or do something similar)



As a bonus I added some invisible trees that will become visible
when the user jumps to the cue point.


	I imported a SVG drawing and called it trees.



To adapt this code to your needs: Change "XPS" to the name of
your cue point. Remove the lines with trees if you don't want this
...


btn_laptop.addEventListener(MouseEvent.CLICK, jumpLapTop);

function jumpLapTop(event:MouseEvent):void {
        video.seekToNavCuePoint ("XPS");
        trees.visible = true;
}
trees.visible = false;


Without trees:


btn_laptop.addEventListener(MouseEvent.CLICK, jumpLapTop);
function jumpLapTop(event:MouseEvent):void { video.seekToNavCuePoint ("YOUR_CUEPOINT"); }



	Example




	flash-cs3-video-goto-cues.html

	Source: flash-cs3-video-goto-cues.fla

	Directory http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Handling_events_from_the_movie]
6.2 Handling events from the
movie

Implementing animation that is triggered by the video's
encounter of cue points was a bit harder since documentation wasn't so easy to find.

The following code will display a trace of all your cue points
in the Flash CS3 output window. To make it work:


	Insert a video component on the stage and add a *.flv source
(as explained before)

	Give it an instance name. I called it video_component.
If give your component an other name you will have to change the
ActionScript code below.




// You must import this class (even when you just script the timeline !!)
import fl.video.MetadataEvent;

video_component.addEventListener(MetadataEvent.CUE_POINT, cp_listener);

function cp_listener(eventObject:MetadataEvent):void {
        trace("Elapsed time in seconds: " + video_component.playheadTime);
        trace("Cue point name is: " + eventObject.info.name);
        trace("Cue point type is: " + eventObject.info.type);
}



When you play the *.flv video you can see these kinds of
messages in the output window:


Elapsed time in seconds: 7.485
Cue point name is: palm_tree
Cue point type is: event
Elapsed time in seconds: 9.888
Cue point name is: books
Cue point type is: navigation
Elapsed time in seconds: 20.52
Cue point name is: missing_manual
Cue point type is: event
Elapsed time in seconds: 26.188
Cue point name is: XPS
Cue point type is: navigation
Elapsed time in seconds: 31.674
Cue point name is: ubuntu
Cue point type is: event


Now let's put this information to use and rewrite the code.
Since this is near the end of this tutorial we shall make it
slightly more complicated. But the resulting animation is still
quite ugly. I am just teaching some Flash and I do not have time
for decent artwork or even good design. Students should aim
at both :)

Let's create some Flash movie clips:


	Hit CTRL-F8 (menu Insert->New Symbol) and select
"movie clip"

	Then, double click on the new library item to get into symbol
edit mode. Create any animation you like. Make sure that you are
aware at which level you edit, i.e. make sure to return to the
scene when you are done !!

	Alternatively, you also may import simple Flash animations you
made before as movie clips.



Once you got one or more of these animations:


	Create an instance of each on the stage and give it an instance
name, e.g.




movie_books



	Then in the AS code you may want to stop() each movie
clip instance and also make some of them invisible, e.g.:




movie_books.stop();
movie_books.visible=false;


At the heart of cue point events management is an event handler
that is registered, i.e. we use exactly the same principle as for
user interaction with buttons (Flash button tutorial).

The cuepoint_listener function includes a switch statement that
deals with each event it receives.


	For most of these events we play some movie clip. If the movie
clip was hidden, make it visible too, e.g.




movie_books.visible=true;
movie_books.play();



	Also we have to stop previous movies or even make them
invisible again (as you like)



If you want music textures, you can for example import a sound
file into the library and then export it for action script
(Right-click on it). Make sure you remember its class name. Else
you can dynamically import sound from external files as shown in
the Flash drag and drop
tutorial.

So here is the complete code you can find in the *.fla file of
this example:


import fl.video.MetadataEvent;
// Stop all the animations of the various movie clips
// Make the bookshelf invisible
movie_trees.stop();
movie_books.stop();
movie_books.visible=false;
movie_penguin.stop();
movie_manual.stop();
movie_manual.visible=false;

// This is a sound of the class music
// Was defined by exporting the music file in the library
var music:Music = new Music();
var volume = new SoundTransform(0.2, 0);

// Add a cuepoint for the end and which is not in the flv movie
video_component.addASCuePoint(40, "End");

video_component.addEventListener(MetadataEvent.CUE_POINT, cuepoint_listener);

function cuepoint_listener(obj:MetadataEvent):void {
        switch (obj.info.name)
        {
                case "palm_tree" :
                        movie_trees.play();
                        break;
                case "books" :
                        movie_trees.stop();
                        movie_books.visible=true;
                        movie_books.play();
                        break;
                case "missing_manual" :
                        movie_books.stop();
                        movie_books.visible=false;
                        movie_manual.visible=true;
                        movie_manual.play();
                        break;
                case "XPS" :
                        movie_manual.stop();
                        movie_manual.visible=false;
                        var song = music.play(0,3,volume);
                        break;
                case "ubuntu" :
                        movie_penguin.play();
                        break;
                case "End" :
                        // song.stop();
                        movie_penguin.stop();
                        movie_penguin.visible=false;
                        movie_books.visible=false;
        }
}

/* This shows how to open an URL in a WebBrowser */
btn_edutech_wiki.addEventListener(MouseEvent.CLICK, GoToUrl);

function GoToUrl(event:MouseEvent):void {
        var url:String = "http://edutechwiki.unige.ch/en/Flash_video_component_tutorial";
        var request:URLRequest = new URLRequest(url);
        try
        {
                navigateToURL(request, '_blank');
        }
        catch (e:Error)
        {
                trace("Error occurred!");
        }
}




	Example




	flash-cs3-video-cue-events.html

	Source: flash-cs3-video-cue-events.fla




	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Links]
7 Links

[bookmark: Manual_entries]
7.1 Manual entries


	For Designers

	Using the FLVPlayback Component

	Using the FLVPlayback Captioning Component (Flash
CS3 Documentation).

	Listening for cue point events - Read this!
Including the comment



Below some more technical links which so far are not really used
much in this tutorial.


	ActionScript overview documentation for programmers



Note: (URLs seem to be unstable if they don't work go to
Programming ActionScript 3.0


	Working with video (Flash CS3 documentation /
Programming AS 3.0)

	Using cue points

	Writing callback methods for onCuePoint and
onMetaData

	Set the NetStream object's client property to an
Object

	Extend the NetStream class and add methods to handle the
callback methods








	ActionScript documentation for programmers

	video package-detail.html

	MetadataEvent.html

	FLVPlayback Component. The class for component.
Can generate a cuePoint event. It does not extend UIComponent, so
using it is a bit more difficult.

	VideoPlayer.html. The FLVPlayback class wraps
the VideoPlayer class.





	NetStream.html. This one has the onCuePoint
Event.




	Timed Text (TT)




	Timed-Text, W3C Specification

	Timed Text Tags (List of supported tabs, Adobe)



[bookmark: Tutorials]
7.2 Tutorials


	For designers




	Captions for Video with Flash CS by Tom Green,
Digital Web Magazine, June 2007

	Captions for Video with Flash CS3 (Part Two), by Tom
Green, Digital Web Magazine, June2007.




	For programmers




	Cue points and Flash CS3, by Flep, Jul
2007.



[bookmark: Artwork]
7.3 Artwork

All Artwork (clipart) is from:


	http://www.openclipart.org/ (sorry I didn't write
down names of individual creators). These are SVG files in
the public domain I imported via Illustrator (I really can't
understand why Flash doesn't support SVG in some ways...)



Sound (except voice track on videos) is from:


	http://simplythebest.net/sounds/MP3/MP3_sounds.html



Videos


	I made them myself

	You may download videos from the Internet (make sure that
copyright allows you to do so). Getting videos from sites like
YouTube is not easy, you either have to download a program or use a
specialized web site for this (watch out for viruses and porn):
Search for "download youtube". You also may dig in your computer's
temporary files.

	To download from youtube, I use this Firefox extension:
https://addons.mozilla.org/en-US/firefox/addon/3006

	http://video.google.com/ Some videos on google are
free to use. They come in various formats. Use advanced search in order to restrict search to
duration, particular formats, etc. Then, underneath the video,
click on the link watch this video on video.google.com.
Else you won't be able to download it. Finally to download, click
on "Download video -iPod/PSP.

	http://vids.myspace.com/ Needs special tools to
download

	http://youtube.com/ Needs
special tools to download



Flash sound tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !
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This entry is part of the Flash tutorials.

[bookmark: Overview]
1 Overview



	Learning goals

	Learn how to use sound (attach sound to frames and button
frames)

	Learn how to edit sound with the Flash tool

	Play sound with Action Script 3




	Prerequisites

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	flash layers tutorial

	flash button tutorial




	Moving on

	The Flash article has a list of other tutorials.

	Flash
Video component tutorial




	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It aims at beginners. More advanced features and tricks are not
explained here.




	Learning materials



Grab the various *.fla files from here:


	http://tecfa.unige.ch/guides/flash/ex/sound-intro/





[bookmark: Basics]
2 Basics

[bookmark: Sound_types]
2.1 Sound types

Flash can handle several sound formats:


	AAC (Advanced Audio Coding):

	AIFF (Audio Interchange File Format) - Mac only ?

	MP3 (Moving Pictures Expert Group Level-Layer-3 Audio)

	AVI (Audio Video Interleave)

	WAV (Waveform Audio Format)

	AU (Sun)



(Some formats may depend on whether QuickTime is installed on
your computer).

Best bet is to use MP3 format, since it is very popular. E.g. it
is easy to find music or sound textures on the Internet.

[bookmark: Sound_imports_to_frames_of_the_timeline]
3 Sound imports to frames of the
timeline

[bookmark: Background_sounds]
3.1 Background sounds


	To import (smaller) sound files




	File->Import->Import To library (or drag and drop).



[bookmark: Attaching_sound_to_a_frame]
3.2 Attaching sound to a
frame


	Step 1 - Create a new layer and import sound to a frame



You can attach sound to any frame via the properties panel


	Create a new layer for this sound

	Insert a keyframe (F7) where you want the sound to
start

	Select a sound from the sound pull-down menu in the properties
panel.

	Configure it in the same panel (see next)



Ideally, each sound should have its own layer. This way it is
much easier to control fade in/outs, when to stop etc. You also can
see exactly how far the sound will extend on the timeline. Hit F5
or F7 (if you want to stop the sound) somewhere to the right.


[image: Flash sound layers]



Flash sound layers






	Step 2 - Configuration of sounds



In the configuration panel you can change certain parameters and
also edit a bit.

Sync: Will defined how sound is synchronized with the
timeline.


	Event: Sound plays until it is done (independently of
the rest). It has its own "timeline". Also, if this sound is
triggered again (e.g. a user enters the same frame), a new sound
will play even if the old one is not over.

	Start: Similar as event. Will play the sound when the
frame loads but will not play it if the old sound is still playing.
Note: This doesn't always work as expected. Probably best to use
together with the Stop (see below).

	Stop : Will stop the sound of a layer at this frame
(therefore include it after a sound frame). Insert a new
keyframe (F7) where you want it to stop and just edit the
properties.

	Stream: Will try to match the length of sound with the
other layers, e.g. 20 frames of sound should play during animation
of 20 frames. After that it should stop. Sound as stream should not
be looped. Use this for example for comic strips (talking
characters).



Repeat:


	You can repeat the sound as many times as you like (or even
have it loop forever).



Effect:


	You can choose from various fade in/out and left/right options,
but you probably want to do your own custom fades (see next).



[bookmark: Attaching_sound_to_buttons]
3.3 Attaching sound to
buttons

You can attach sounds to buttons in the same manner as
above.


	Double-click on the button in the library panel

	Edit the button's timeline (e.g. the mouse over, down and hit
frames )

	For each sound you want to attach, create a layer

	Then insert a new keyframe (F7) and attach the sound

	You may try to stop a sound (insert a new keyframe)
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3.4 Editing sounds


	Editing sound with the Edit Envelope editor




	Click in the sound layer in some frame where you have
sound

	In the Properties Panel, Click the Edit ... button next
to the Effect: field

	This opens the Edit Envelope editor.




	Manipulation of the sound envelope




	You can drag left/right Time In and Time Out
controls in middle pane. I.e. you can cut off sound from the either
the beginning or the end of the sound track.

	You can drag down volume controls (black lines on top) for the
left and the right stereo channel

	Click to insert a new distortion point for these volume
controls

	Up: means louder / maximum sound

	Down: means more silent / no sound





	Use the arrow (down left) to test

	At bottom right there are zoom buttons and a switch that either
shows seconds or frames.
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Flash CS3 Sound envelope editor





[bookmark: Examples]
3.5 Examples


	Animation with sound




	You can look at my publishedanimation with sound example. It shows a motion
animation with a global music sound track and 4 layers with sound
"textures" that are limited in time.

	Source: flash-cs3-cloud-animation-sound.fla

	You can grab all the files flash-cs3-cloud-animation-sound.*
from this directory:




	http://tecfa.unige.ch/guides/flash/ex/sound-intro/




	Button with sound




	See the button with sound.

	Source: flash-cs3-button-sound.fla



[bookmark: Load_and_play_sounds_with_ActionScript]
4 Load and play sounds with
ActionScript

It is better to load sounds with ActionScript if your sound file
is large, e.g. a background music or if you want to to trigger a
sound as a result of some complex user interaction.


	Embedded ActionScript 3



Insert this kind of code with F9 in the frame where you want if
to load. Typically, use a frame in a layer called "action" or
"script".

To load a sound from an external file


var request:URLRequest = new URLRequest("track.mp3");
var your_sound:Sound = new Sound();
your_sound.load(request);


To play it:


your_sound.play();


To play 5 loops:


your_sound.play(0,5);


To stop all sounds (this is a static method, just insert the
line as is).


SoundMixer.stopAll();


For an example used in the Flash drag and drop
tutorial, look atflash-cs3-drag-and-drop-matching-3.*


	Source: flash-cs3-drag-and-drop-matching-3.fla




	Note

	ActionScript 2 is different (!)



This code snippet would start playing sound on load


var mySound:Sound= new Sound();
mySound.loadSound("track.mp3" , true);
mySound.onLoad = function() {
mySound.start();
}


[bookmark: Links]
5 Links


	Sound Assets (look this up if you need websites
with free sounds)



[bookmark: Documentation]
5.1 Documentation


	Working with sound (Adobe), Using sounds, some
AS2, no AS3




	Sound (Adobe AS3 reference)




	SoundMixer (Adobe AS3 reference)



Flash button tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !
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This entry is part of the Flash tutorials.
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1 Overview

Buttons are interactive interface elements on which a user can
click. As an alternative you also could use component buttons (see
the Flash components tutorial).



	Learning goals

	Learn how to use built-in buttons (from library
buttons.fla).

	Learn how to create your own buttons.

	Learn some ActionScript 2 and 3 to jump around in the
timeline.

	Applications: Simple Flash "web sites", e.g. slide shows.




	Flash level




	Flash CS3 - Flash 9 - Actionscript 3




	Prerequisites

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash layers tutorial

	Flash
frame-by-frame animation tutorial

	Flash motion tweening
tutorial (for the rocket launcher and the animated
buttons)




	Moving on

	The Flash article has a list of other tutorials.

	We suggest firstly the Flash components tutorial (working
with component buttons is actually easier, but the choice is
limited).

	Then you can move to other interactivity tutorials, e.g.
Flash drag and drop
tutorial, ActionScript 3
interactive objects tutorial, or ActionScript 3 event
handling tutorial.




	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It aims at beginners. More advanced features and tricks are not
explained here.




	Learning materials (*.fla and *.swf files)

	http://tecfa.unige.ch/guides/flash/ex/buttons-intro/






	The executive summary - buttons



Buttons are interface components to add simple interactivity,
such as displaying extra information, launch a movie clip etc.

(1) To create a button:


	either draw an object and make it a button (Right-click
Convert to Symbol and select Button);

	or get a button from the built-in Library -
buttons.fla



(2) To make use of a button:


	You have to do add some ActionScript code and that will react
to a user "gesture" like a mouse click.




	A word of warning



ActionScript 2.0 and ActionScript 3.0 (Flash CS3/9 and later) do
not work the same way !


	ActionScript 2.0: Attach some action script to the button and
that will launch something called an "action".

	ActionScript 2.0 to prepare for easy migration: Only write code
in the timeline.

	ActionScript 3.0: Write ActionScript code in the timeline. It
must include an Event Listener for the button, plus some code that
is triggered by the event listener.



In this tutorial we only will cover ActionScript 3 (three)
programming elements. Read the flash button tutorial - AS2 if
you must use the older version (Flash 8/ActionScript 2)


	Tip



If you lack any sort of programming experience, then download
the source files I made and play with them, e.g. add an extra
picture and fix the code if needed...
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2 Overview of the built-in Flash
button symbols

Flash contains a good variety of pre-built buttons. To use
these, your first should dock the Library-Buttons.fla panel
next to your libraries panel: Menu Window->Common
Libraries->Buttons. (See the Flash CS3 desktop tutorial on how
to dock a panel).

In this section we will first just discuss the architecture of a
Flash button.

In built-in buttons library, buttons are arranged in folders.
Double click to open these. Then, you may may inspect various
button symbols by clicking on a button. In the upper part of the
library panel you will get a preview. Click on the arrow to see how
the button behaves.
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The Flash buttons library





For use in your own animation I suggest to copy a button first
to your own library (else Flash will do it for you too)


	Right-click on the Symbol and Copy

	Paste it to your own library. Open the library panel and hit
crtl-V



Next, from your library panel simply drag the button on the
stage. This will create an instance of the button. To remove
it from the stage, select it and hit the delete key. You will see
in the properties panel something like Instance of: rounded
orange and you now should give it a name, e.g. my_button.

[bookmark: Customizing_button_symbols]
2.1 Customizing button
symbols


	Editing buttons



To customize a button symbol, double-click on the icon of the
symbol library panel. This will let you work just on this object,
i.e. it puts you into a Symbol editing mode. There are other
ways to get into this editing "inside" (via the general menu or
double-click or right-click on an instance).

You now could for instance change the font or the color of a
symbol or make changes to its frame-by-frame animations. Anyhow, we
suggest to leave the buttons as is for the moment.


	Finding your workspace again



There are several solutions:


	Select Edit->Edit Document (Ctrl-E).

	But I suggest to add the Edit bar:
Window->Toolbars->Edit bar. It will show you exactly
at what level you are editing, e.g. scene or the button
symbol.



As you can see in the picture below, on the Edit Bar from left
to right you can see the cascade of editing levels. Right now we
are editing the "bubble to red" button.
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Symbol editing mode






	Editing the label of a button



While you can use these buttons "as is" (except making them
larger or smaller maybe), you only need to know how to insert a
label for starters.

A symbol is basically something that you can use several times
over, but its fundamental look and feel properties will remain the
same, including its the label. So if you need buttons with other
labels you must create copies of these symbols. In your library
panel right-click on the icon of the symbol and select
duplicate from the popup menu. Choose an appropriate name,
e.g. "do not press"

To change the label (and font) of a button symbol:


	Double click to get in the symbol editing mode. You will see a
kind of frame-by-frame animation movie (read the Flash
frame-by-frame animation tutorial if you are not familiar with
this).

	Lock and hide all layers, except the layer with label (e.g.
text).

	Change the text

	You also can change font properties of course

	Then you may have to adjust its position. Click on the select
tool and move the text box with the cursors until it looks right
(look at your library panel).
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Symbol editing mode
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2.2 The four frames and the button
layers

Built-in button symbols contain four frames and several layers.
For each frame, different drawings may be defined but some, e.g.
the label text may be reused in several layers. Look at the various
frames. The four mandatory frames for button symbols (including the
ones you may create) are:


	Up

	The button, i.e. the drawing that appears "as is" when the
button is displayed in a frame of your animation.




	Over

	The button graphics as it appears when the user moves the mouse
over it. E.g. it defines highlighting.




	Down

	The button as it appears when the user presses the mouse (just
during the time the mouse button is held). It shows the pressing
down effect.




	Hit

	This frame allows to define the sensible area (usually the
complete button) with a graphic. Its contents will not be
shown.



Various kinds of buttons have various layers (usually between
three and five) depending on the complexity of the drawings. These
layers contains just drawing for these four button frames. The
Flash engine will then select the appropriate frame for display
according to user action (mouse over, mouse down, etc.).

Beginners just should use built-in buttons. There is no
need to change anything in the keyframes or the layers except the
label. However, you later can change any drawings in any way you
like. A button can be made of any sort of graphics you like (even
pictures as you shall learn below) and you even may add animation
with embedded movie clips.
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2.3 Using the built-in
buttons

You can attach behaviors in various ways to buttons but there is
no difference between built-in buttons and the ones you can create
yourself. The most obvious one is to jump to a different frame in
the main timeline after the user clicks on a button.

In the next section we will use a button to launch a rocket.

[bookmark: A_button_in_frame_1_to_start_animation_in_frame_2]
3 A button in frame 1 to start
animation in frame 2

[bookmark: Rocket_launcher]
3.1 Rocket launcher

The goal is make a flash animation that stops at frame one when
the file loads. The user then will see a button on which he can
click. The animation should restart in frame 2 after the user
clicked.


	Drag a button to the stage




	You can adjust its size with the Free Transform Tool
(but make sure that you are not in symbol edit mode, i.e. working
on the button graphics)

	Edit the textfield (double click twice) on the text for
example, make this label "Go!" for example.




	Name the button instance



We have to give the launch button (not the symbol in the library
but the thing we got on stage) a name. Once you drag a
library item to the stage you produce an instance of the
symbol. In order to find this instance, Flash needs to know it by
name. It's like in magic: you name it - you control it ;)


	Let's call it:




launch_button



	Open the properties panel and fill in the field (see
below):




[image: Give a name to an symbol instance]
Give a name to an symbol instance





Make sure that the name is doesn't have any blanks or special
symbols inside (actually Flash will complain if you define an
illegal name).


	Add AS3 stopping code to the timeline




	Add another layer and call it "Action" or "Script"

	Click on Frame 1, hit F9 and in the Actions-Frame panel
insert:




stop();


This will just stop the execution of the main movie. I.e. Flash
will only display the contents of the first frame (all layers) and
then wait.


	Add AS3 code for navigation




	Now we will add some more code below the stop ();
line. So click again in frame 1 of the Action Layer and hit
F9:
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Some ActionScript 3 code to associate an action with a user
event





Add this below the "stop();":


launch_button.addEventListener(MouseEvent.CLICK,launchRocket);

function launchRocket(event:MouseEvent) { gotoAndPlay(2); }


We can not really explain event driven programming here (see the
ActionScript 3 event
handling tutorial), but the principle is the following:


	For each object that can react to user actions you have to
define what will happen when the user does something, e.g. click
with the mouse.

	Firstly you define a function that "does something", e.g. move
the playhead in the timeline to another frame. In our case we
called the function launchRocket.

	Second, you have to associate this function with the user click
on the button. The addEventListener method let's you define
what function will be called when a user does something with the
button (in this case, clicking on it). In other words, you add an
Event Listener to the button (e.g. one that will observe button
clicks) and you tell this Event Listener what function to call when
this happens.




	Code reuse



Of course you can reuse this code for a similar problem, i.e.
moving the animation to another spot on the timeline when the user
presses a button. All you need to do is this:


	Put a button on your stage (e.g. one from the Flash
library)

	Then give this instance a name

	Then change the number in gotoAndPlay(2);. E.g.
change it to 5 if you want it jump to frame 5.



Tip: If your code is getting bigger, undock the Actions Frame
panel and pin it down. Hit F9 to to hide it again.


	Results




	You can look at my published result (works only with Flash
9!)here

	You can grab the flash-cs3-rocket-launcher-as3.fla file to
play.

	Directory:




	http://tecfa.unige.ch/guides/flash/ex/buttons-intro/
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3.2 Exercise - Enter button for an
animation


	Get one of your motion animations

	Drag all animation keyframes from frame 1 to frame 2. Click and
drag when you see the white rectangle attached to the mouse
cursor.

	Add a new layer and call it Action

	Insert some graphics / text on frame 1 (else your flash
animation will look really empty)

	Then add a button that will allow a user to jump to frame 2
when he hits the button

	Add the ActionScript (don't forget to also add a
"stop();".



If this sounds too complicated, you can start with less:


	Create a new layer and select frame 1

	Drag a button from the button library to the stage and name
this button instance "start" in the properties panel.

	Hit F9 and copy/paste this code:




stop();
start.addEventListener(MouseEvent.CLICK,launch);
function launch (ev){ gotoAndPlay (2); }


We now have an "Enter" button in the first frame of the
animation. As soon as the user will click on it, the animation will
move to frame 2 and play the rest. Of course, this means that you
have to put something in frame 2 (and beyond) that users can look
at.
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4 Menu-based flash sites

You can build little flash "web" sites with buttons with what
you just learned. The principle is simple:


	Put contents in in various frames (you can use multiple layers
of course).

	We will stop Flash from playing all the frames by inserting the
"stop();" instruction in frame 1.

	We then will create a button for each "page" X (i.e. keyframe
X) and then write some code for each button that will transport the
user to frame "Y".



We show you how to do this step-by-by with ActionScript 3:


	Step 1 - create "pages"




	Create a "Pages" layer

	Put each "page" into a frame (text, pictures, videos, whatever
static information)

	If you don't want menus to overlap with contents, make sure to
leave an empty area for the menu on each of these pages (e.g. on
top or to the left of the picture)




	Step 1b - variant with animations




	You also can add animations if you like. But put these in
different layers or alternatively and better create these as movie
clips, i.e create a movie symbol first, then edit it. But make sure
that no frames from different layers overlap. The principle of a
simple flash web site is that a user will jump to different
frames.




	Step 2 - Create the menu




	Create a new layer and call it "Menu" for example

	Insert in frame #1 of this "Menu" layer all the buttons that
will lead to each of the "pages". Extend this layer to the last
frame of your "pages" layer (hit F5). We want the navigation menu
to visible all the time.



For each button:


	Drag a button from the buttons library to the stage

	Change the label: Double click on the button, then unlock the
text layer, then change it.

	Give it also an instance name in the parameters panel, e.g.
sunrise_btn.

	Once you are done, use the align tool to distribute and align
them correctly.




	Step 4 - name your frames



You may not have heard of "named frames" so far, but they are
quite practical and using named frames is good development policy.
If you use names for frames, you later can move them around. Also
it is easier to remember names.

To name a frame:


	Click in each frame that marks the start of a "page" in your
flash site (i.e. where buttons will lead to) and insert a name in
the properties inspector at the bottom.




[image: Naming Frames]
Naming Frames






	Step 5 - Verify




	Each button instance must have name.

	Each frame which you want the user to reach with a
button click, should have a name.




	Step 6 - Create the script




	Create a new layer and call it "scripts" for example

	Edit frame 1 of this layer ("scripts): Hit F9

	Extend this layer if needed (e.g. hit F5 in frame 8), else you
won't see your buttons.

	Insert Action Script for each button as below.



We basically use two actions:


	gotoAndStop ("your_frame_name"); to jump to
a frame and stop

	gotoAndPlay (...); to jump to a frame and let it
play until it runs into a stop.



The script then should look something like this. I think I made
it as simple as possible for non-programmers. Code inserted between
/* .... */ is just comment, i.e. information that Flash will not
interpret but that is useful to you as a developer.


/* This will stop Flash from playing all the frames
   User must stay in Frame 1 */
stop();

/* Associate a different handler function for each button instance:
   Syntax: button_name.addEventListener(Event.type, function_name
   Lines below mean:
   * If the user clicks on the palmtree_btn with the mouse,
     then the function clickHandler3 defined below will execute
*/

home_btn.addEventListener(MouseEvent.CLICK, clickHandler1);
lake_btn.addEventListener(MouseEvent.CLICK, clickHandler2);
palmtree_btn.addEventListener(MouseEvent.CLICK, clickHandler3);
sunrise_btn.addEventListener(MouseEvent.CLICK, clickHandler4);

/* Each function defines where to move the playhead in the animation.
   E.g. clickHandler2 will go to frame 3 and then stop   */

function clickHandler1(event:MouseEvent) { gotoAndStop("home"); }
function clickHandler2(event:MouseEvent) { gotoAndStop("lake"); }
function clickHandler3(event:MouseEvent) { gotoAndStop("palmtree"); }

/* This one does not stop, it will play the animation */
function clickHandler4(event:MouseEvent) { gotoAndPlay("sunrise"); }



	If it doesn't work




	There may be syntax errors and Flash will tell you so in the
Output panel that will pop up. Look at the line numbers.

	You many have misspelled the button and frame names in the
script. ActionScript is case-sensitive !




	Results




	You can look at my published result here

	Source: flash-cs3-simple-menu-site.fla

	You can grab all the files flash-cs3-simple-menu-site.*
from this directory:




	http://tecfa.unige.ch/guides/flash/ex/buttons-intro/




	Next steps




	You can do the same thing with so-called button components. You
can't change the button form easily, but it's a slightly faster
procedure. See the Flash components tutorial.
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5 A simple slide show with your own
buttons


	Objectives




	We will first show how to create your own simple buttons.

	Then we show some ActionScript code that demonstrates how to
make a simple slide show with only two buttons (forward/backward)
and that extend throughout the animation.



The purpose of this application is again to explain buttons and
some Action Script, not to make the perfect slide show tool.

To create a slideshow, we will first import the pictures and
adjust the stage. This way we we can get a feel for the size of
buttons needed. Then we draw the buttons. Finally we will make it
interactive


	Step 0 - Open a new file




	Select Action Script 3 (This code will not run with Action
Script 2.0 !).




	Step 1 - prepare some pictures




	Before importing the pictures, it's a good idea to make them
all the same size, e.g. I made my pictures 640x480. If you work
under windows, simply use the MS Office Picture manager. It's
better to start with right (small) size, since this will reduce the
size of the Flash file you later will deliver.

	Then import these pictures to the library: Menu
File->Import->Import to Library. Select all the
pictures you would like to import, then click OK. (Alternatively,
just drag the pictures into the library panel from Windows).

	Importing to the library will turn them into symbols. That way
we can later reuse them if we want to.




	Step 2 - Adjust the stage size




	Create a new layer, called "Pictures". In the first keyframe
you may insert some text with the TextTool, e.g. "Picture show"
(you can fix this later)

	Create a new keyframe in frame 2 (hit F7)

	Drag a picture on the stage of frame 2, then make the stage as
big (at least) as the picture. You also can make the stage a big
bigger and then select for instance a black background

	To adjust the pictures' position, use the properties panel
below, i.e. set W and H to 0 (else use the align panel).




	Step 3 - Put your pictures into different keyframes




	If you have 8 pictures you need to add 7 new keyframes.

	One way to do this is to put your cursor in frame 2 of the
picture layer, then hit F7 ("Insert new blank keyframe") 7
times

	Then drag a picture into each of these keyframes and align them
too (as above).

	Control if all pictures are ok and in place by moving the
playhead from left to right (red rectangle on top of the
timeline)



So you should have something like this.
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The Flash buttons library






	Step 4 - Draw a forward, a home and a backward button




	Create a new layer and name it Buttons and select it (also lock
the pictures layer).

	To draw buttons, you may use the Polystar tool and a variety of
transform tools, or just simply draw a triangle and get done with
it ...

	Then you also want to reduce the alpha channel (i.e. make these
buttons transparent). In the color panel, put Alpha to 40%.

	Once you got a forward button, make a copy and flip it
horizontally (menu Modify->Transform->Flip
Horizontal).




	Step 5 - convert these graphics into to symbols




	Save both buttons as button symbols (right-click on each
graphic you made).

	Use decent names for these, e.g. "button_forward"




[image: Turn a graphic into a button symbol]
Turn a graphic into a button symbol






	Remove the graphics from the stage (yes kill them!)




	Step 6 - place the buttons and name them




	Select the buttons layer (the one with the single frame).

	Drag a forward and backward button from the library to the
stage

	Move both buttons into an a appropriate position.

	Then give a name to each of these 2 instances in the properties
panel: "forward_btn" and "back_btn".



So now you should have something like 2 button symbols in the
library and an named instance of each on the stage.
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Two button symbol instances on the stage






	Step 7 (optional) - Add some highlighting




	Double-click on the backward button in the library. This will
get you in symbol editing mode.

	Hit F6 in frame 2 ("Over")

	Change the color of the button.



As you will see, the button will change color when you move the
mouse over it. Do the same with the other button.


[image: Painting the "over" state of a button]
Painting the "over" state of a
button






	Step 8 - Add action script code to the timeline




	Insert a new layer, call it "Action"

	Go to frame one of this layer and hit F9



Firstly insert a stop to the animation:


stop();


This is ActionScript code that will stop the animation right
after frame one is loaded. Only by clicking the buttons can the
user then go forward or backward.

Then insert this slide show code:


forward_btn.addEventListener(MouseEvent.CLICK,forward);
back_btn.addEventListener(MouseEvent.CLICK,backward);

function forward(event:MouseEvent) {
        if (this.currentFrame == this.totalFrames)
        {
                gotoAndStop(1);
        }
        else
        {
                nextFrame();
        }
}

function backward(event:MouseEvent) {
        if (this.currentFrame == 1)
        {
                gotoAndStop(this.totalFrames);
        }
        else
        {
                prevFrame();
        }
}


This ActionScript 3.0 code firstly adds Event Listeners to each
button as we have seen before.

The forward function has some "if-then-else" logic inside. Let's
look at its "if-then-else" statement.


        if (this.currentFrame == this.totalFrames) { gotoAndStop(1); }
        else { nextFrame(); }


Meaning: When the user clicks on the forward button, the
Flash engine will check if the current frame is the last frame then
move to frame 1 else just move to the next frame.

The backward function implement the following:


        if (this.currentFrame == 1) { gotoAndStop(this.totalFrames); }
        else { prevFrame(); }


Meaning: If we are on the first frame then go to last
frame, else go to the previous frame.

In order to use this slide-show code for your own slide show you
do not need to understand it. Just copy and paste it, but make sure
that your forward button instance is called "forward_btn"
and the backward button instance "back_btn".

Tip: If this doesn't work, make sure that your Publish settings
say ActionScript 3. It won't work with ActionScript 2. Also
make sure that your button instances are named and that these names
correspond to the ones you use in the script. It doesn't matter how
you name the button symbols, we talk about button
instances here !


	Step 9 - Make sure your buttons extend to all frames



Finally, make sure that these buttons are displayed throughout
the "movie"


	Select the buttons layer, click the last frame (where the last
picture sits) and Right-click->Insert Frame (or hit F5).
A the end you should see little white rectangle.



Your timeline should roughly look like this:


[image: The final time line for a simple slideshow]
The final time line for a simple
slideshow






	Step 10 - Tuning



You may want to fix the title page.


	Results




	You can look at my published resulthere

	Source: flash-cs3-simple-slide-show-as3.fla

	You can grab all the files
flash-cs3-simple-slide-show-as3.* from this directory:




	http://tecfa.unige.ch/guides/flash/ex/buttons-intro/



This slide show was fairly simple. Now you maybe would like to
use fancier buttons. See Animated buttons below.
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6 Image maps with
pictures

You can make image maps from bitmaps too. I.e. you could use a
picture and then insert "hot spots".

Steps (more details when I have time):


	Prepare an image




	Put an image on the stage




	Break it apart




	Carve out a fragment




	Deselect the image !




	Grab some region with the Lasso tool




	Right-click -> Convert to symbol. Select
button !. You now should have an image fragment in the
libraryflash-cs3-simple-slide-show-as3.fla.




	Edit this button and change the "mouse-over" and "mouse down"
pictures




	Double-click on this button in the library. You should be in
symbol edit mode. Alternatively you can click on the button in the
stage. This will show you the whole picture ... I prefer the first
method for this job.




	Hit F6 three times to produce copies in the same positions




	In Frame 2 and 3 make a copy of the shape, then move it while
the cursor is still on to an empty space




	Modify->Union this copy into a graphic




	Make it a color with a low alpha




	Move it over the picture shape (but do not move the shape in
any way).



.... This gets you a roll-over region :)


	Results




	You can look at my published resulthere

	The source file:




	flash-cs3-image-map.fla




	Directory:




	http://tecfa.unige.ch/guides/flash/ex/buttons-intro/



[bookmark: Animated_buttons]
7 Animated buttons

If you like the idea of crazy buttons, you really can use all
your graphics and animation skills. Buttons can include any kind of
graphics, including embedded movie clips.

In order to use animations within button symbol frames, you
simply create an embedded movie clip (see Flash motion tweening
tutorial or Flash embedded movie
clip tutorial) and then put it in one of the "up", "over" or
"down" frames of the button symbol.


	Results




	You can look at my published resulthere

	The source file:




	flash-cs3-image-map.fla




	Directory:




	http://tecfa.unige.ch/guides/flash/ex/buttons-intro/



[bookmark: ActionScript_summary]
8 ActionScript summary

First, create a layer in the timeline called "Script" or
"Action". Use frames in this layer to script behaviors. You
can extend the scope of a script by hitting F5 in the timeline
(same principle as for backgrounds).

To attach some behavior to a mouse click, use code like
this:


button_instance_name.addEventListener(MouseEvent.CLICK,function_name);



function function_name(event:MouseEvent):void {
  gotoAndPlay(2);
}


Replace button_instance_name' and
'function_name' by whatever naming is appropriate.


	'button_instance_name' refers to the name of the button
instance (in the properties panel !

	'function_name can be anything you like (but do
no use spaces or special characters in function names,
except the underscore "_".



Here is a good example:


go_button.addEventListener(MouseEvent.CLICK,goFrameA);
function goFrameA (event:MouseEvent) { gotoAndPlay(2); }


Here is a bad example ("go-button" has a dash, and "go Frame" is
two words)


go-button.addEventListener(MouseEvent.CLICK,goFrameA);
function go FrameA (event:MouseEvent) { gotoAndPlay(2); }



	Some useful ActionScript "instructions"

	stop(); - will stop the animation. You can insert
stops(); wherever you like in your timeline.

	gotoAndStop(4); - will jump to frame #4 and stop.
Use this for still pictures.

	gotoAndPlay("my_frame"); - will jump to frame
called "my_name" and play that frame and the following ones. Use
this for animations that extend over several frames. But then
consider inserting a "stop();" in the last frame of that
animation.

	gotoAndPlay(4); - will jump to frame #4 and play
the rest (as above).



[bookmark: Links]
9 Links

[bookmark: Manuals]
9.1 Manuals


	Working with button symbols, a chapter of the
Using Flash CS3 documentation.






[bookmark: Slide_shows]
9.2 Slide shows

If you search the Internet you can find lots of Flash
slide shows. Some commercial, some tutorials, some good, some
outdated. Here are a few:


	Text tutorials




	http://www.toxiclab.org/tutorial.asp?ID=79

	http://maclab.guhsd.net/flash/mx/slideshow_01.html

	http://www.flashvault.net/tutorial.asp?ID=118

	http://www.lukamaras.com/tutorials/actionscript/ultimate-dynamic-image-gallery.html
(advanced)




	Video tutorials




	Creating slideshows in Flash CS3 by Craig Campbell.
The basic version is free.




	Examples of slide show tools




	Slideshowpro
(commercial kit)



Flash components tutorial


	REDIRECT Flash components overview



Flash video component tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !



This is part of Flash tutorials

[bookmark: Introduction]
1 Introduction

Video components are prebuilt interface elements (widgets) that
will speed up video integration. In particular, the FLVPlayBack
Video Component allows to render videos without any
ActionScript programming. It includes a nice choice of skins for
user controls. Videos also can be enhanced with captioning or they
may interact with the rest of the animation. Some of these
techniques require some more technical skills, e.g. knowledge of
XML
and some ActionScript.



	Learning goals

	Learn how to encode *.flv files

	Learn how to use the Flash 9 (CS3) video component for simple
video playback

	Learn how to insert and use cue points for various
purposes

	Learn how to create text captions

	Learn how to integrate videos with animations and interactive
elements

	Learn some more ActionScript 3.0




	Prerequisites for the first part

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash component button
tutorial

	Timed Text (only for captions).




	Prerequisites for the second part

	Flash button tutorial

	Flash motion tweening
tutorial, Flash shape tweening
tutorial, Flash special effects
tutorial

	Flash embedded movie
clip tutorial




	Moving on

	The Flash article has a list of other tutorials.




	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It both aims at beginners (FLV encoding, using the video
playback component and embedding a video in the timeline) and
intermediate Flash designers (inserting captions and using cue
points to trigger animations).






	The executive summary about Flash Videos



Flash has built-in video management components.


	The FLVPlayBack Video Component is really easy to use since it
provides a series of ready-made skins (user interfaces) from which
you can choose.

	The Caption component requires some XML Editing.

	For more sophisticated video-animation interaction you need to
code with ActionScript.




	The executive how-to summary for simple video playbacks




	Encode your video with the Video Encoder. Flash has its own
*.flv video format.

	Drag the FLVPlayBack Video Component to the stage.

	Open the component inspector panel. Choose a skin and provide
the file name or URL of the *.flv video



[bookmark: Preparing_your_video]
2 Preparing your video

Flash uses a special video format (*.flv) to render videos. You
may directly encode your formats with the CS3 video encoding tool
(that's what I suggest) or wait until Flash will prompt you to
encode when you import a video in non *.flv format.

[bookmark: Video_encoding_with_Flash_CS3]
2.1 Video encoding with Flash
CS3

The Flash package includes a video encoder with which you can
transcode various video formats into *.flv format. It also lets you
define cue points and edit (somewhat) the video.


[image: The Flash CS3 Video encoder tool]
The Flash CS3 Video encoder tool





Now, open the Flash CS3 Video encoder program directly
from the Desktop (i.e. not from Flash!).

[bookmark: Video_transcoding]
2.1.1 Video transcoding

The tool supports most current video formats. You can for
example import *.mov, *.avi, *.mpeg, *.dvi, *.wmv, *.3pg and *.mp4
formats in this tool. If you need a video file to play with see the
Artwork links at the end of this
tutorial.


	Opening a video file




	Open the Flash CS3 Video Encoder tool

	Click on the Add ... button to add a new video.




	Edit




	Click Settings to define output settings and to add
video cues, etc. You can just leave the defaults if you like,
unless your video file is long and/or big and you want to trim it
down.




	Encoding




	Click Start Queue to encode your video. By default, the
resulting *.flv file will be saved in the same directory as the
source video. Flash will not overwrite an older *.flv version but
rather renumber the new version.



[bookmark: Video_Editing]
2.1.2 Video Editing

The Flash Video Encoder tool has some limited editing capacity
you can access through the settings button. Since videos quickly
can become huge, you may want to crop off space from top, bottom or
left and right and also make it shorter. You also can choose from
various levels of video and audio quality.


	Look at the contents




	Move the horizontal glider (yellow triangle) from left to
right.




	To resize and crop




	Select the "Crop and Resize" tab

	You can crop the video (i.e. take of space on top, bottom,
right, left.



See the screen capture below.


	To crop off frames at start and at the end




	You cut off frames from the beginning and the end of the
original video (move the little triangles below the playhead as
shown in the screen capture below.





[image: Cropping and resizing the length of a video - listening to sound with QuickTime Player]



Cropping and resizing the length of a video - listening to sound
with QuickTime Player





Tip: If you want to hear the video, just listen to it with an
other tool, e.g. the QuickTime Player if your source is *.mp4. Both
tools show time in seconds.

It is import to make a video as small as possible if you plan to
do timeline animations as shown in the Importing a video to
the timeline section.


	Typical quality settings




	Select "video" and "audio" tabs

	Video: For short videos I use the medium Flash quality with
default codecs

	Audio: If video quality is bad from start (e.g. made with your
cell phone) you can reduce audio to 64 kpbs mono or even less since
it can't get worse than it already is.



[bookmark: Cue_Points]
2.1.3 Cue Points

“Cue points cause the video playback to start
other actions within the presentation. For example, you can create
a Flash presentation that has video playing in one area of the
screen while text and graphics appear in another area. A cue point
placed in the video starts an update to the text and graphic, while
they remain relevant to the content of the video. (Adobe CS3 Video
Encode Help, sept. 2007)”

You don't need cue points for just playing a video, so you may
come back later and read about inserting cue points.

There are several ways of adding cue points.


	(1) Adding Cue points in the video encoder




	Select the Cue Points Tab

	Glide forwards and backwards the video playhead to select
positions you'd like to mark

	Click on the + to add a new cue point.

	Event cue points are used to trigger ActionScript
methods when the cue point is reached, and let you synchronize the
video playback to other events within the Flash presentation.

	Navigation cue points are used for navigation and
seeking.



I don't think that there are any real differences between these
two kinds of cue points. At least from an ActionScript point of
view, the difference is simply that you can identify with which
category a cue point is labelled (type property).


[image: Adobe CS3 Video Encoder Cue Points]



Adobe CS3 Video Encoder Cue Points





Each cue point consists of a name, a type and the time at which
it occurs and we then can retrieve this information in Flash as you
will see in handling events from the movie section below. Anyhow, I
rather suggest to add cue points through the component's
parameters, since you then can add/remove cue points whenever there
is a need.


	(2) Adding cue points with other methods




	Trough the FLVPlayBack component's parameters, i.e. open the
parameter or the component inspector panel (see below). I recommend
this method for beginners.

	In ActionScript with the addASCuePoint() method

	With an XML file.



The advantage of the ActionScript and the XML method is that you
easily can change these cue points when adjustments are needed.
E.g. you may notice at some point that your video file is too big
and you may want to shorten it down. It's faster to change AS code
or XML descriptors than entering the cue points again with the
encoding tool.

[bookmark: Other_transcoding_tools]
2.2 Other transcoding
tools

Your modern cell phone may encode video with MP4. Flash 9 (CS3)
can not directly import this format. If you don't have access to
the CS3 Flash Video Encoder tool (an older Flash version may not
encode newer formats), you may download the free SUPER tool (it has
more features than many commercial tools).

Read the MP4 article to see how I managed to use this free (and
excellent) SUPER encoder to go from MP4 to MPV with
MPEG3-v2/MP3.

[bookmark: Using_the_FLVPlayback_component]
3 Using the FLVPlayback
component

Let's now import a video and use it the simple way. In this
example we will show how to import a video I (quickly) made with my
Nokia N73 cell phone. The easiest strategy is to directly import a
*.flv file.

[bookmark: Using_the_video_with_the_component_first_method]
3.1 Using the video with the
component first method

The most simple procedure to use a video with the
FLVPlayBack component is the following one:


	Step 0 - Get/create a *.flv file




	See above.

	Put it in the same directory as your Flash file.




	Step 1 - Open the component library




	Menu Window->Components or hit Ctrl-F7.

	Dock it next to your library.




	Step 2 - Drag the video component to the stage




	Drag the FLVPlayBack component from the components
library to the stage.




	Step 3 - Tell FLVPlayBack where to find the video




	Open the Component Inspector panel
(Window->Component Inspect) and dock it next to the
library.

	Add the name of a video file in the source field of the
parameters. Click on the field and then either type the file name
or use the file chooser menu.

	Tick match source FLV dimensions. This will adjust the
size of the video control widget to your video.

	Make sure to remove the directory path from the file name. For
example, instead of:




	
E:\schneide\te\coap2110\ex\component-video-intro\office-dks3.flv



just keep the file name


	office-dks3.flv



Else when you copy both the *.sfw and the *.flv file to some
other place you flash file won't find the video anymore and the
playback will break.


	Step 4 - Adjust the skin




	Play around with various skins in the component inspector
panel. Basically you can add/remove various user controls.

	Click on the value of the "skin" parameter. A popup menu will
let you select from various skins.

	Finally, you can change the color of the component.




[image: Select the video component skin]



Select the video component skin





Enjoy ....

[bookmark: Importing_the_video_with_the_import_method]
3.2 Importing the video with the
import method

Here is an alternative and longer method for using the
FLVPlayBack component.


	Step 1 - FLV files




	Encode the video as *.flv file as described above.

	If you directly import other formats, i.e. *.mov, *.avi,
*.mpeg, *.dvi, *.wmv, *.3pg (but not MP4), Flash will at some point
open the Video encoder tool. So the result is the same: a *.flv
file. It will be saved by default in the same directory as your
original video file.




	Step 2 - Import the video




	Create a new layer and call it "video"

	Menu File->Import->Import Video



You then can from a popup menu choose how the video should be
deployed (see next step).


	Step 3 - Choose "Standard web server / progressive
download"




	If you only have access to a standard web server: Choose
"progressive download" from a web server.

	You then can choose from a variety of built-in video control
skins for the FLVPlayBack Video Component which will be
automatically added to your library (you later can change the skin
again, so don't worry now).



The video you will import will simply use the standard video
playback component that you also can find in the "Components"
panel.


	Step 4 - Fine tune the stage




	Change the background

	Adjust stage size to video size or alternatively add some text
or graphics if the stage is bigger. Create a new layer for
these.

	You also can change the skins for the video control skin.
Simply open the Parameters panel. Scroll down to the skin field and
select another one from the popup menu. Same thing for other
parameters. You can quite safely play around with them.




	Step 5 - Fix the source file location



You must tell Flash where the video file will sit on your server
(see also the next step)


	Click on the video component

	Open the parameter panel (menu
Window->Properties->Parameters in case it's not
already docked) or the open the Property inspector panel. I
prefer the latter since I have it docked next to library and don't
need to scroll as much as in the bottom panels.

	Change the source field, scroll down if needed (!). In
our case I killed everything in front of the file name
office-dks.flv.



For example, instead of:


	
E:\schneide\te\coap2110\ex\component-video-intro\office-dks3.flv



I only kept the file name since I plan to put all files in the
same directory on the server. Also on my desktop the files sit in
the same directory.So I shortened down the path:


	office-dks3.flv




[image: Configuring the video component]



Configuring the video component






	Step 6 - Tune some parameters



In the property inspector or parameters panel you may set
things like:


	Volume: I suggest to turn it down to 0.3 since you will be fed
up listening to your video after a while

	AutoPlay: True means that the video will start playing after it
loads. False requires the user to press the play button




	Step 7 - Copy the *.flv and *.swf skin file to your web server
(optional)




	I suggest to put all files in same directory since they will be
easier to manage that way. If you don't, go back to step 5. Also
remember that the *.flv file may sit in the same directory where
you original video is.

	Do not forget to copy the "*.swf skin file, for example
SkinUnderAllNoFullscreen.swf.




	If the video doesn't play...




	Most likely you forgot to define the right source path, either
a full URL, a relative URL, or a *.flv file name that sits in the
same directory.

	File names are case sensitive on most Web servers ! Also
avoid using blanks and other strange characters in your file name.

	Good = myvideo.flv - Bad = my Video.flv








	Results




	flash-cs3-video-simple-server.html

	Source: flash-cs3-video-simple-server.fla

	Video file: office-dks.flv

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Making_use_of_captions]
4 Making use of captions

A caption is a text that is displayed dynamically while
the video is playing. Captions may serve several purposes:


	You can deploy videos to people with hearing disabilities

	Users can look at videos without making noise

	You can emphasize important passages, or paraphrase or comment
voice tracks.



In order for captions to work, you must do three things:


	Use a skin for the playback component that includes a Caption
button, e.g. SkinUnderAllNoFullscreen.swf.

	Make use of the FLVPlayback Captioning component (in
addition to the playback component)

	Encode captions in an XML file (there are at least two
options). This XML file then must be registered with the captioning
component.



To import the video, use the same procedure as in Using the FLVPlayback
component

[bookmark: The_caption_component_with_timed_text]
4.1 The caption component with timed
text


	The Timed Text standard and XML



If you are not familiar with XML, you may have a glance at the
XML
article and maybe the DTD tutorial. Then, we also suggest to work with
an XML editor in order to insure that your file is
well formed. We suggest the free Exchanger XML
Lite. If you don't feel learning XML, just make very sure that
you exactly use a template as described below. One missing tag or
or some syntax mistake like a missing ">" will make your
animation fail.

Flash doesn't support the full Timed Text specification and the documentation at
Adobe is rather shaky. For those who are familiar with XML I wrote
a little DTD that helps editing. Just grab it from the Timed Text article and also copy/paste the XML
template.

Note: Timed Text is defined with a complex XML
Schema but since Adobe Flash only implements a subset, it's not
worth using this.


	Figuring out time for captions



In order to write this XML file you must know what caption to
insert at which time and for how long. The CS4 Adobe Media player
does show time and maybe other *.flv video players too.


	Get Adobe Media
Player. It is free.

	Under Ubuntu, the Totem player works well.



If you want high precision, you also can load the *.flv file
into the timeline (see below) and then play it with
View->Bandwidth Profiler on. Write down the frame number
for captions and then divide by the frame rate. Hit:


	'.' to stop and then to go forward one frame,

	',' to go back one frame,

	'Enter' to start playing again.




	A minimal example XML captioning file



As a minimum we suggest to enter the following data. For each
caption enter:


	A <p> </p> tag. Each "p" should
include:

	a begin attribute that defines when the caption
should appear,

	a dur attribute that defines how long it will
stay on screen.



Time is in seconds, but also may use a more complex format
like


02:30.5


meaning 2 minutes, 30 seconds and a half.

Here is the file we called timed-text.xml and that we used in
this example


<?xml version="1.0" encoding="UTF-8"?>
<tt xml:lang="en" xmlns="http://www.w3.org/2006/04/ttaf1"
    xmlns:tts="http://www.w3.org/2006/04/ttaf1#styling">
  <head>
    <styling>
    </styling>
  </head>
  <body>
   <div xml:lang="en">
      <p begin="1" dur="4">Daniel's Office</p>
      <p begin="5" dur="5">My Palm Tree (from NYC)</p>
      <p begin="11" dur="7">My Bookshelf</p>
      <p begin="18" dur="5">My favorite Flash Drawing Book</p>
      <p begin="25" dur="5">My DELL XPS Laptop Flash machine</p>
      <p begin="30" dur="5">My Ubuntu Linux workstation</p>
      <p begin="33" dur="5">Working hard on Flash Tutorials using the Xemacs Editor</p>
      <p begin="42" dur="5">The outside (not my bike)</p>
    </div>
  </body>
</tt>


Note: Captions may overlap, i.e. Flash will display a new
caption on a new line if the previous one is still on. You can see
this in the example we present in the next section.

For now, just grab the template below and add "p" tags, make
sure to close them as in the example above. Replace "Let's start"
by your own caption of course.


<?xml version="1.0" encoding="UTF-8"?>
<tt xml:lang="en" xmlns="http://www.w3.org/2006/04/ttaf1"  xmlns:tts="http://www.w3.org/2006/04/ttaf1#styling">
  <head><styling></styling></head>
  <body>
   <div xml:lang="en">
      <p begin="1" dur="4">Let's start</p>
      
    </div>
  </body>
</tt>



	Using the FLVPlayback Captioning component




	Create a new layer and call it "Caption" or something like
that. Go there.

	Then drag the "FLVPlayback Captioning component" somewhere to
the workspace or even to the stage.

	Unlike the playback component, this component will not show, so
it can be anywhere.




	Customization of the component

	Click on the component and edit the parameters (either in the
Parameters or the Component Inspector panel). Then,

	set showCaptions to true if you want all users to see
captions (probably most users don't know how to turn it on or off,
so turn it on)

	specify the source of the Timed Text XML file to
download. So, create the xml file now, if you didn't so far. Make
sure to get the spelling right.




[image: The FLVPlayback Captioning component and its parameters]



The FLVPlayback Captioning component and its parameters






	The example




	flash-cs3-video-simple-server-caption.html

	flash-cs3-video-simple-server-caption.fla

	XML file: timed-text.xml

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/




	Tuning




	You can style text and background of the Caption Box (see
below)

	Put down the volume: Set it to 0.5 in the parameters of the
FLVPlayer or even lower. I am fed up listening to my own voice,
really.



[bookmark: CaptionsBox_and_Style]
4.2 CaptionsBox and Style

As explained in Tom Greens' Captions for Video with Flash CS tutorial, you can
use a different text box to display the captions.


	Step 1 - Draw a textbox for the captions to appear




	Create a captions layer if you don't already have one

	Draw a textbox

	Give it the instance name caption_box

	Select font size, color etc.

	Select Multiline

	Make it Dynamic Text (if it is not)








	Step 2 - Configure the component



Tell the captioning component to use the textbox you just made
to display captions:


	Open the parameter or inspector panel for the FLVPlayback
Captioning component

	Set captionTarget = caption_box

	Set autoLayout = false




	Step 3 - Add some style to the XML File



Just look at this example (file timed-text2.xml). I don't really
understand how some styling tags work. I'd expect for instance to
behave backgroundColor within a span like in HTML but it doesn't. I
don't know this behavior is a feature or a bug or my
misunderstanding of the manual.

If something is not clear, please download the *.fla file and look at it. Make sure to verify
that both the playback and the captioning component parameters are
ok and that you put all the files in your computer or the server
(including the skin *.swf, the *.flv and the *.xml file) in the
same directory. Do not forget to copy the skin !


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE tt SYSTEM "mini-tt.dtd">
<tt xml:lang="en" xmlns="http://www.w3.org/2006/04/ttaf1"  xmlns:tts="http://www.w3.org/2006/04/ttaf1#styling">
  <head>
    <styling>
      <style id="title" tts:backgroundColor="transparent" tts:color="red" tts:fontSize="24"/>
    </styling>
  </head>
  <body>
   <div xml:lang="en">
      <p begin="0" dur="9" style="title">Daniel's Office</p>
      <p begin="5" dur="4">My Palm Tree (from NYC)</p>
      <p begin="10" dur="13" style="title">Books ....</p>
      <p begin="11" dur="7">My Bookshelf</p>
      <p begin="18" dur="5">My favorite Flash Drawing <span tts:color="red">Book</span></p>
      <p begin="24" dur="16" style="title">Computers ....</p>
      <p begin="25" dur="5">My DELL XPS Laptop Flash machine</p>
      <p begin="30" dur="5">My <span tts:backgroundColor="yellow" tts:color="black">Ubuntu Linux workstation</span></p>
      <p begin="35" dur="5"><span tts:backgroundColor="transparent"></span>Working hard on Flash Tutorials using the Xemacs Editor</p>
      <p begin="40" dur="4">The outside (not my bike)</p>
    </div>
  </body>
</tt>



	The result




	flash-cs3-video-simple-server-caption2.html

	Source: flash-cs3-video-simple-server-caption2.fla

	XML file: timed-text2.xml

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Adding_captions_with_Cue_Points]
4.3 Adding captions with Cue
Points

There is an alternative method. Read Captions for Video with Flash CS3 (Part Two), by Tom
Green, Digital Web Magazine, June

[bookmark: Importing_a_video_to_the_timeline]
5 Importing a video to the
timeline

Now we will look at a very different way of using videos.
Instead of using the playback component we will include the video
into the timeline (each video frame will be a timeline frame). This
will allow us to create videos augmented with animations in an easy
way.

[bookmark: Embed_into_timeline_version]
5.1 Embed into timeline
version

If you embed a video into the timeline, then you don't get the
ready-made video control as above. Only embed video in the timeline
if you plan to add animations the simple way and if the video file
is really small. Also you shouldn't care about smaller
synchronization problems with the audio track.

Embedded video will make your timeline really long, although you
can choose to have it its own timeline. Anyhow, in this example we
took the "hundreds of frames" timeline option.

We will insert the video in frame #2. We also will add a play
button that will jump to frame 2 and play the video.


	Step 1 - FLV files




	Create one




	Step 2 - Import the video as embed




	Create a new layer and call it "video"

	Insert a new empty keyframe in frame 2 (since we don't want the
video play on load in this case).

	Go there

	Menu File->Import->Import Video

	In the video deployment dialog, choose "Embed video in SWF and
play in timeline".




[image: Deployment dialog]



Deployment dialog






	Step 3 - Add some simple controls




	You need at least a play button, but adding some extra
buttons that will allow a user to jump to given frames also may be
handy.

	We just used the button component described in the Flash components tutorial.



In our example we added three buttons:


	The "play button" will move the playhead in frame 2 where the
video starts.

	The "Go to Book Scene" button will move it to frame 230
something.

	The "Credits" button will go to the very end.



The ActionScript code:


/* This will stop Flash from playing all the frames
   User must stay in Frame 1 */
stop();

/* Associate a handler function for each button instance */

btn_credits.addEventListener(MouseEvent.CLICK, clickHandler);
btn_play.addEventListener(MouseEvent.CLICK, clickHandler);
btn_book.addEventListener(MouseEvent.CLICK, clickHandler);

/* Instead of writing a function for each button, we just create one.
   In order to understand which button was clicked, we ask from the event
   the label of the button(event.currentTarget.label).
   Then we gotoAndStop(x) to Frame 374 for Credits
   Or we can play the movie that sits in frame 2
*/
function clickHandler(event:MouseEvent):void {
        switch (event.currentTarget.label)
        {
                case "Credits" :
                        gotoAndStop(609);
                        break;
                case "PLAY" :
                        gotoAndPlay(2);
                        break;
                case "Go to Book Scene" :
                        gotoAndPlay(230);
                        break;
        }
}

/* This shows how to open an URL in a WebBrowser */
btn_edutech_wiki.addEventListener(MouseEvent.CLICK, GoToUrl);

function GoToUrl(event:MouseEvent):void {
        var url:String = "http://edutechwiki.unige.ch/en/Flash_video_component_tutorial";
        var request:URLRequest = new URLRequest(url);
        try
        {
                navigateToURL(request, '_blank');
        }
        catch (e:Error)
        {
                trace("Error occurred!");
        }
}


The "embed in timeline option" is probably only useful if you
plan to play around with fine grained frame-by-frame jumping around
or if you plan to add animations that synchronize with the video as
described in the next example. Otherwise it is better to use a
external video with the video playback component as described
above.


	Results




	flash-cs3-video-simple-embedd.html

	Source: flash-cs3-video-simple-embedd.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



Note: I noticed that when you import more than once a movie,
file size will grow a lot ! Probably a side-effect of the undo
mechanism. So 'do not do this. If you notice this problem,
save the file with "save as". The new version will be ok. (Maybe
there is another solution to trim down file size).

[bookmark: Enhanced_video_embedding_into_timeline]
5.2 Enhanced video embedding into
timeline

Embedding video into the timeline makes sense (IMHO) if you are
looking for an easy way to synchronize other animations with the
video. This requires no more additional ActionScript knowledge than
you need for simple animation and navigation.

In this example, we add various animations (e.g. two motion
tweens and a shape tween) to the project. Below you can see that
books are tumbling out of a bookshelf while the video shows a
"real" bookshelf.


[image: Embedded video with some animations]



Embedded video with some animations





Here is the action script code that we use to implement a simple
play button, plus two other ones that are not really necessary. All
the rest is just simple Flash animation


/* This will stop Flash from playing all the frames
   User must stay in Frame 1 */
stop();

/* Associate a handler function for each button instance */

btn_credits.addEventListener(MouseEvent.CLICK, clickHandler);
btn_play.addEventListener(MouseEvent.CLICK, clickHandler);

/* Instead of writing a function for each button, we just create one.
   In order to understand which button was clicked, we ask from the event
   the label of the button(event.currentTarget.label).
   Then we gotoAndStop(x) to Frame 572 for Credits
   Or we can play the movie that sits in frame 2
*/
function clickHandler(event:MouseEvent):void {
        switch (event.currentTarget.label)
        {
                case "Credits" :
                        gotoAndStop(572);
                        break;
                case "PLAY" :
                        gotoAndPlay(2);
                        break;
        }
}

/* This shows how to open an URL in a WebBrowser */
btn_edutech_wiki.addEventListener(MouseEvent.CLICK, GoToUrl);

function GoToUrl(event:MouseEvent):void {
        var url:String = "http://edutechwiki.unige.ch/en/Flash_video_component_tutorial";
        var request:URLRequest = new URLRequest(url);
        try
        {
                navigateToURL(request, '_blank');
        }
        catch (e:Error)
        {
                trace("Error occurred!");
        }
}



	Results




	flash-cs3-video-timeline-embedd.html

	Source: flash-cs3-video-timeline-embedd.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Using_cue_points_for_navigation_and_to_trigger_animations]
6 Using cue points for navigation and
to trigger animations

Working with cue points is another way to have your video
interact with other animation. It's a more difficult solution than
using timeline videos, but more elegant.

[bookmark: Jumping_to_cue_points]
6.1 Jumping to cue points

Code for jumping to cue points is fairly easy if you know how to
use buttons or button components.


	Insert a video playback component like above

	Give it an instance name like video

	Then copy paste the code below (or do something similar)



As a bonus I added some invisible trees that will become visible
when the user jumps to the cue point.


	I imported a SVG drawing and called it trees.



To adapt this code to your needs: Change "XPS" to the name of
your cue point. Remove the lines with trees if you don't want this
...


btn_laptop.addEventListener(MouseEvent.CLICK, jumpLapTop);

function jumpLapTop(event:MouseEvent):void {
        video.seekToNavCuePoint ("XPS");
        trees.visible = true;
}
trees.visible = false;


Without trees:


btn_laptop.addEventListener(MouseEvent.CLICK, jumpLapTop);
function jumpLapTop(event:MouseEvent):void { video.seekToNavCuePoint ("YOUR_CUEPOINT"); }



	Example




	flash-cs3-video-goto-cues.html

	Source: flash-cs3-video-goto-cues.fla

	Directory http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Handling_events_from_the_movie]
6.2 Handling events from the
movie

Implementing animation that is triggered by the video's
encounter of cue points was a bit harder since documentation wasn't so easy to find.

The following code will display a trace of all your cue points
in the Flash CS3 output window. To make it work:


	Insert a video component on the stage and add a *.flv source
(as explained before)

	Give it an instance name. I called it video_component.
If give your component an other name you will have to change the
ActionScript code below.




// You must import this class (even when you just script the timeline !!)
import fl.video.MetadataEvent;

video_component.addEventListener(MetadataEvent.CUE_POINT, cp_listener);

function cp_listener(eventObject:MetadataEvent):void {
        trace("Elapsed time in seconds: " + video_component.playheadTime);
        trace("Cue point name is: " + eventObject.info.name);
        trace("Cue point type is: " + eventObject.info.type);
}



When you play the *.flv video you can see these kinds of
messages in the output window:


Elapsed time in seconds: 7.485
Cue point name is: palm_tree
Cue point type is: event
Elapsed time in seconds: 9.888
Cue point name is: books
Cue point type is: navigation
Elapsed time in seconds: 20.52
Cue point name is: missing_manual
Cue point type is: event
Elapsed time in seconds: 26.188
Cue point name is: XPS
Cue point type is: navigation
Elapsed time in seconds: 31.674
Cue point name is: ubuntu
Cue point type is: event


Now let's put this information to use and rewrite the code.
Since this is near the end of this tutorial we shall make it
slightly more complicated. But the resulting animation is still
quite ugly. I am just teaching some Flash and I do not have time
for decent artwork or even good design. Students should aim
at both :)

Let's create some Flash movie clips:


	Hit CTRL-F8 (menu Insert->New Symbol) and select
"movie clip"

	Then, double click on the new library item to get into symbol
edit mode. Create any animation you like. Make sure that you are
aware at which level you edit, i.e. make sure to return to the
scene when you are done !!

	Alternatively, you also may import simple Flash animations you
made before as movie clips.



Once you got one or more of these animations:


	Create an instance of each on the stage and give it an instance
name, e.g.




movie_books



	Then in the AS code you may want to stop() each movie
clip instance and also make some of them invisible, e.g.:




movie_books.stop();
movie_books.visible=false;


At the heart of cue point events management is an event handler
that is registered, i.e. we use exactly the same principle as for
user interaction with buttons (Flash button tutorial).

The cuepoint_listener function includes a switch statement that
deals with each event it receives.


	For most of these events we play some movie clip. If the movie
clip was hidden, make it visible too, e.g.




movie_books.visible=true;
movie_books.play();



	Also we have to stop previous movies or even make them
invisible again (as you like)



If you want music textures, you can for example import a sound
file into the library and then export it for action script
(Right-click on it). Make sure you remember its class name. Else
you can dynamically import sound from external files as shown in
the Flash drag and drop
tutorial.

So here is the complete code you can find in the *.fla file of
this example:


import fl.video.MetadataEvent;
// Stop all the animations of the various movie clips
// Make the bookshelf invisible
movie_trees.stop();
movie_books.stop();
movie_books.visible=false;
movie_penguin.stop();
movie_manual.stop();
movie_manual.visible=false;

// This is a sound of the class music
// Was defined by exporting the music file in the library
var music:Music = new Music();
var volume = new SoundTransform(0.2, 0);

// Add a cuepoint for the end and which is not in the flv movie
video_component.addASCuePoint(40, "End");

video_component.addEventListener(MetadataEvent.CUE_POINT, cuepoint_listener);

function cuepoint_listener(obj:MetadataEvent):void {
        switch (obj.info.name)
        {
                case "palm_tree" :
                        movie_trees.play();
                        break;
                case "books" :
                        movie_trees.stop();
                        movie_books.visible=true;
                        movie_books.play();
                        break;
                case "missing_manual" :
                        movie_books.stop();
                        movie_books.visible=false;
                        movie_manual.visible=true;
                        movie_manual.play();
                        break;
                case "XPS" :
                        movie_manual.stop();
                        movie_manual.visible=false;
                        var song = music.play(0,3,volume);
                        break;
                case "ubuntu" :
                        movie_penguin.play();
                        break;
                case "End" :
                        // song.stop();
                        movie_penguin.stop();
                        movie_penguin.visible=false;
                        movie_books.visible=false;
        }
}

/* This shows how to open an URL in a WebBrowser */
btn_edutech_wiki.addEventListener(MouseEvent.CLICK, GoToUrl);

function GoToUrl(event:MouseEvent):void {
        var url:String = "http://edutechwiki.unige.ch/en/Flash_video_component_tutorial";
        var request:URLRequest = new URLRequest(url);
        try
        {
                navigateToURL(request, '_blank');
        }
        catch (e:Error)
        {
                trace("Error occurred!");
        }
}




	Example




	flash-cs3-video-cue-events.html

	Source: flash-cs3-video-cue-events.fla




	Directory: http://tecfa.unige.ch/guides/flash/ex/component-video-intro/



[bookmark: Links]
7 Links

[bookmark: Manual_entries]
7.1 Manual entries


	For Designers

	Using the FLVPlayback Component

	Using the FLVPlayback Captioning Component (Flash
CS3 Documentation).

	Listening for cue point events - Read this!
Including the comment



Below some more technical links which so far are not really used
much in this tutorial.


	ActionScript overview documentation for programmers



Note: (URLs seem to be unstable if they don't work go to
Programming ActionScript 3.0


	Working with video (Flash CS3 documentation /
Programming AS 3.0)

	Using cue points

	Writing callback methods for onCuePoint and
onMetaData

	Set the NetStream object's client property to an
Object

	Extend the NetStream class and add methods to handle the
callback methods








	ActionScript documentation for programmers

	video package-detail.html

	MetadataEvent.html

	FLVPlayback Component. The class for component.
Can generate a cuePoint event. It does not extend UIComponent, so
using it is a bit more difficult.

	VideoPlayer.html. The FLVPlayback class wraps
the VideoPlayer class.





	NetStream.html. This one has the onCuePoint
Event.




	Timed Text (TT)




	Timed-Text, W3C Specification

	Timed Text Tags (List of supported tabs, Adobe)



[bookmark: Tutorials]
7.2 Tutorials


	For designers




	Captions for Video with Flash CS by Tom Green,
Digital Web Magazine, June 2007

	Captions for Video with Flash CS3 (Part Two), by Tom
Green, Digital Web Magazine, June2007.




	For programmers




	Cue points and Flash CS3, by Flep, Jul
2007.



[bookmark: Artwork]
7.3 Artwork

All Artwork (clipart) is from:


	http://www.openclipart.org/ (sorry I didn't write
down names of individual creators). These are SVG files in
the public domain I imported via Illustrator (I really can't
understand why Flash doesn't support SVG in some ways...)



Sound (except voice track on videos) is from:


	http://simplythebest.net/sounds/MP3/MP3_sounds.html



Videos


	I made them myself

	You may download videos from the Internet (make sure that
copyright allows you to do so). Getting videos from sites like
YouTube is not easy, you either have to download a program or use a
specialized web site for this (watch out for viruses and porn):
Search for "download youtube". You also may dig in your computer's
temporary files.

	To download from youtube, I use this Firefox extension:
https://addons.mozilla.org/en-US/firefox/addon/3006

	http://video.google.com/ Some videos on google are
free to use. They come in various formats. Use advanced search in order to restrict search to
duration, particular formats, etc. Then, underneath the video,
click on the link watch this video on video.google.com.
Else you won't be able to download it. Finally to download, click
on "Download video -iPod/PSP.

	http://vids.myspace.com/ Needs special tools to
download

	http://youtube.com/ Needs
special tools to download
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This is part of the flash tutorials

[bookmark: Introduction]
1 Introduction



	Learning goals




	Learn how to fill the the DataGrid component with data




	Flash level




	CS3 and ActionScript 3




	Prerequisites




	Flash components overview

	To use the DataGrid component, you should know some
ActionScript, e.g. from the ActionScript 3
interactive objects tutorial or the Flash drag and drop
tutorial. This includes some basic programming skills
(conditionals, loops and arrays).

	Flash button tutorial and a
little bit how event handling works (ActionScript 3 event
handling tutorial).

	Some XML (for some sections)




	Moving on




	The Flex datagrid component
tutorial shows how to do this with Flex.

	See the Flash tutorials




	Level and target population




	Beginners




	Quality




	Not done yet, but this piece should help you solve some easy
how to display data problems.




	To do




	Interact with the data grid





[bookmark: Data_Grid_level_0_-_Creating_a_DataGrid_and_filling_it_with_data]
2 Data Grid level 0 - Creating a
DataGrid and filling it with data

“The DataGrid class is a list-based component that
provides a grid of rows and columns. You can specify an optional
header row at the top of the component that shows all the property
names. Each row consists of one or more columns, each of which
represents a property that belongs to the specified data object.
The DataGrid component is used to view data; it is not intended to
be used as a layout tool like an HTML table. (DataGrid, retrieved 10:12, 30 October 2008
(UTC)).”

Let's create a table to display information about Learning management systems, i.e.
a data grid with 3 columns. Column 1 is called "Name", column 2 is
"License", column 3 is "Description. We then also will add 4 rows
of data.


[image: Two simple Flash DataGrids]



Two simple Flash DataGrids





You may have a look at the data-grid-0 example now or open the thumbnail of
the screen dump to the right.

Below we will show three solutions and point to a forth one:


	Creating a most simple DataGrid with Flash CS3 by dragging a
component to the stage.

	Doing it with CS3 but using only ActionScript

	Doing it with AS3 only through CS3

	Doing it with Flex: see the Flex datagrid component
tutorial



[bookmark: Adding_code_to_a_DataGrid_instance]
2.1 Adding code to a DataGrid
instance


	Step 1 - Make a DataGrid instance




	Open the components library (e.g. hit CTRL-F7)

	Drag a DataGrid to the stage

	Give it an instance name, e.g. datagrid



You now will see an empty square on the stage without any visual
appeal.


	Step 2 - Resize



In the properties panel, make it a big bigger, e.g. w:300 and
H:200


	Step 3 - Fill in some data with ActionScript



If your instance name is datagrid then hit F9 in frame 1
(or wherever you want it to be) and copy/paste this code. The
result is a three column table with headers.




datagrid.addColumn("Name");
datagrid.addColumn("License");
datagrid.addColumn("Description");
datagrid.addItem({Name:"Moodle", License:"GPL (free)", Description:"Good for blended activity-oriented teaching"});
datagrid.addItem({Name:"ATutor", License:"Free", Description:"Good for content-oriented teaching"});
datagrid.addItem({Name:"Blackboard", License:"Commercial", Description:"Good for content and exercice-oriented teaching"});
datagrid.addItem({Name:"MediaWiki", License:"GPL (free)", 
  Description:"Good for writing-to-learn and technical mini-projects teaching"});





The result is not absolutely convincing, since you can't read
the contents of column three. It shows the minimum AS code you need
to know in order to fill in DataGrid tables.

You can tune some properties of this grid within the Component
Inspector (Shift-F7) or the properties panel. E.g. we made the
cells editable. But most tailoring has to be done through
ActionScript coding. There are dozens of properties and methods. In
addition since the DataGrid is an assembly of Column and Cell
objects you also may change things at these levels.

You can find the link to the *.fla source after the slightly
improved version which we shall discuss now.

[bookmark: Alternative_-_data_grid_creation_through_AS3]
2.2 Alternative - data grid creation
through AS3

Instead of opening the component library, then dragging the
component to the stage and giving it an instance name, you could
just enter the code below in frame 1 of the main timeline. However,
you still need a DataGrid component in your library ! (E.g.
drag the component to the stage, then kill the instance).

Firstly we have to import some standard packages that we will
need.


 // Import the necessary packages
 import fl.controls.DataGrid;
 import fl.controls.ScrollPolicy



 // Now create a a new instance of DataGrid and name it "datagrid_AS"
 var datagrid_AS:DataGrid = new DataGrid();


We also tailor the size of column three and make the whole
widget horizontally scrollable. To do so we have to assign the
column instance we want to change to a variable. This way, we can
change its properties:


 // this is to make col. 3 a bit bigger
 var col3 = datagrid_AS.addColumn("Description");
 col3.minWidth = 350;


Then we have to set the size for the whole Grid


 // Fix the size
 datagrid_AS.width = 400;
 // Set the height to the number of rows + 1 (for the header).
 datagrid_AS.rowCount = datagrid_AS.length + 1;


Finally, we position this instance relative to the stage and put
it on the stage for real.


 // Position it at x=300 and y = 70
 datagrid_AS.move(300, 70);
 // Then add it to the stage
 addChild(datagrid_AS);


Here is the complete code (that also can be found in the *.fla
source file below):




// Import the necessary packages
import fl.controls.DataGrid;
import fl.controls.ScrollPolicy
 
// Now create a a new instance of DataGrid and name it "datagrid_AS"
var datagrid_AS:DataGrid = new DataGrid();
 
datagrid_AS.addColumn("Name");
datagrid_AS.addColumn("License");
// this is to make col. 3 a bit bigger
var col3 = datagrid_AS.addColumn("Description");
col3.minWidth = 350;
datagrid_AS.addItem({Name:"Moodle", License:"Free", Description:"Good for blended activity-oriented teaching"});
datagrid_AS.addItem({Name:"ATutor", License:"Free", Description:"Good for content-oriented teaching"});
datagrid_AS.addItem({Name:"Blackboard", License:"Commercial", Description:"Good for content and exercise-oriented teaching"});
datagrid_AS.addItem({Name:"MediaWiki", License:"GPL (free)", Description:"Good for writing-to-learn and technical mini-projects teaching"});
 
// Fix the size
datagrid_AS.width = 400;
// Set the height to the number of rows + 1 (for the header)
datagrid_AS.rowCount = datagrid_AS.length + 1;
 
// Position it at x=400 and y = 50
datagrid_AS.move(300, 70);
 
// Horizontal scrolling is on
datagrid_AS.horizontalScrollPolicy = ScrollPolicy.ON ;
 
// Then add it to the stage
addChild(datagrid_AS);






	Example code - Creating and filling with data (CS3)




	Directory: http://tecfa.unige.ch/guides/flash/ex/data-grid/

	File: data-grid-0.fla



[bookmark: Creating_a_DataGrid_and_filling_it_with_data_using_pure_ActionScript]
2.3 Creating a DataGrid and filling
it with data using pure ActionScript

This is a section that non-programmers or persons who don't want
to learn a lot of ActionScript programming should skip.


[image: A Flash DataGrid with pure ActionScript in CS3]



A Flash DataGrid with pure ActionScript in CS3





In order to do this you first should also read:


	The Writing and using AS Code
chapter of the Flash ActionScript 3 overview in order to understand
the general AS development perspective.

	The AS3 Compiling a program tutorial in
order to learn how to compile AS code with CS3



Here is the executive summary:


	Add the DataGrid component to the library.

	Save this code as DataGridFill.as in the same directory as your
FLA file.

	Set the Document class in the FLA file to DataGridFill. You can
do this in the properties panel.



As you can in the screen capture to the right, there is
nothing on the stage nor in some frame. The only object we
need is the DataGrid component in the library

You may have a look at the DataGridFill-CS3.html example now or open the
thumbnail of the screen dump to the right.

Here is the ActionScript code. It is quite similar to the AS
code above, except that we work with a class structure and that we
also add a label on top of the data grid.




package {
    // Only works with CS3 - i.e. the DataGridFill.as file must be in the library
    //   1. Add the DataGrid component to the library.
    //   2. Save this code as DataGridFill.as in the same directory as your FLA file.
    //   3. Set the Document class in the FLA file to DataGridFill.
 
    import flash.display.Sprite;
    import fl.controls.DataGrid;
    import fl.controls.ScrollPolicy;
    import flash.text.TextField;
 
    public class DataGridFill extends Sprite {
 
        var data_grid:DataGrid;
        var textLabel:TextField;
 
        public function DataGridFill () {
            createTitle ();
            createDataGrid ();
            // fixStage (); // too complicated
        }
 
        private function createTitle():void {
            textLabel = new TextField();
            textLabel.text = "DataGrid entirely made with AS3 through CS3";
            textLabel.x = 10;
            textLabel.y = 10;
            textLabel.width = 400;
            textLabel.selectable = false;
            textLabel.textColor = 0xFF0000;  
            addChild (textLabel);
        }
 
        private function createDataGrid():void {
            // Create a a new instance of DataGrid and name it "data_grid"
            data_grid = new DataGrid();
 
            data_grid.addColumn("Name");
            data_grid.addColumn("License");
            // this is to make col. 3 a bit bigger
            var col3 = data_grid.addColumn("Description");
            col3.minWidth = 350;
 
            data_grid.addItem({Name:"Moodle", License:"Free", Description:"Good for blended activity-oriented teaching"});
            data_grid.addItem({Name:"ATutor", License:"Free", Description:"Good for content-oriented teaching"});
            data_grid.addItem({Name:"Blackboard", License:"Commercial", Description:"Good for content and exercise-oriented teaching"});
            data_grid.addItem({Name:"MediaWiki", License:"GPL (free)", Description:"Good for writing-to-learn and technical mini-projects teaching"});
 
            // Fix the size
            data_grid.width = 500;
            // Set the height to the number of rows + 1 (for the header)
            data_grid.rowCount = data_grid.length + 1;
 
            // Position it at x=400 and y = 50
            data_grid.move(10, 70);
 
            // Horizontal scrolling is on
            data_grid.horizontalScrollPolicy = ScrollPolicy.ON ;
 
            // Then add it to the stage
            addChild(data_grid);
        }
    }
}





Notice: see the Flex datagrid component
tutorial for the Flex equivalent.

[bookmark: Data_Grid_level_1_-_Dynamic_fill-in]
3 Data Grid level 1 - Dynamic
fill-in


[image: A dynamic data grid growing with user interaction data]



A dynamic data grid growing with user interaction data





We now shall see how to fill in a DataGrid with data from user
interaction. E.g. we built a simple application that let's the user
select three colors from a list of buttons which then will show up
in the Grid. This is totally useless application, but it allows to
show the principle.

You may have a look at the data-grid-1 example now or open the thumbnail of
the screen dump to the right. On the stage we have 6 buttons and
they have instance names like "red", "blue" etc.

This time we call our data grid instance "data_grid":


 var data_grid:DataGrid = new DataGrid();


We firstly introduce a new way to define colums. E.g. we want to
distinguish between the short internal property name ("c1") and
what the users will see ("1st choice:").


 var col1:DataGridColumn = new DataGridColumn ("c1");
 col1.headerText = "1st choice:";
 data_grid.addColumn(col1);


The rest of the DataGrid definition code is more or less the
same as above.

Now let's look at the buttons (and if this really new to you,
you should read the Flash button tutorial). We put all the
button's instance names into an array. Then we register the same
"colorPick" event handling function for the mouse click event.


 // This is the list of instance names we create in CS3
 var button_list:Array = [blue,cyan,green,pink,red,yellow];
 // For all we register the same Event Handler function
 for (var i:Number=0; i<button_list.length; i++) {
   button_list[i].addEventListener(MouseEvent.CLICK, colorPick);
 }


The colorPick function does the following:


	line 2: The object (button) on which the user clicked

	line 4: After a user clicked on button it will be
invisible

	line 5: we add the picked color to the end of a list

	line 7: If the user has picked three colors then we will act

	line 9: Add the three picked colors to the DataGrid

	line 11-13: Make all buttons visible again

	line 13: Reset the list of picked colors










	

function colorPick(evt:MouseEvent):void {



	

    var obj = evt.target;



	

    // A picked object goes hidden



	

    obj.visible = false;



	

    selected_colors.push(obj.name);



	

    // Once the user got three, we display and reset all buttons to visible



	

    if (selected_colors.length==3) {



	

        // fill in the three cols. Warning: it's the "c1" etc. property defined above



	

        data_grid.addItem({c1:selected_colors[0], c2:selected_colors[1], c3:selected_colors[2]});



	

 



	

        for (var i:Number=0; i<button_list.length; i++) {



	

            button_list[i].visible = true;



	

        }



	

        selected_colors = new Array ();



	

    }



	

}









Here is the complete AS code as in the downloadable *.fla file
(see below).




// Import the necessary packages
import fl.controls.DataGrid;
import fl.controls.ScrollPolicy;
import fl.controls.dataGridClasses.DataGridColumn;
 
// --------------------- DataGrid init ----------------------------
 
// Now create a a new instance of DataGrid and name it "data_grid"
var data_grid:DataGrid = new DataGrid();
 
var col1:DataGridColumn = new DataGridColumn ("c1");
col1.headerText = "1st choice:";
var col2:DataGridColumn = new DataGridColumn ("c2");
col2.headerText = "2nd choice:";
var col3:DataGridColumn = new DataGridColumn ("c3");
col3.headerText = "3rd choice:";
 
data_grid.addColumn(col1);
data_grid.addColumn(col2);
data_grid.addColumn(col3);
 
// Fix the size
data_grid.width = 300;
// data_grid.height=300;
// Set the height to five rows
data_grid.rowCount = 5;
 
// Position it on the stage
data_grid.move(250, 70);
 
// Then add it to the stage
addChild(data_grid);
 
// ----------------------- Buttons code
 
// This is the list of instance names we create in CS3
var button_list:Array = [blue,cyan,green,pink,red,yellow];
// For all we register the same Event Handler function
for (var i:Number=0; i<button_list.length; i++) {
    button_list[i].addEventListener(MouseEvent.CLICK, colorPick);
}
 
// A an array of max 3 elements (i.e. what the user picked)
var selected_colors = new Array ();
 
function colorPick(evt:MouseEvent):void {
    var obj = evt.target;
    // A picked object goes hidden
    obj.visible = false;
    selected_colors.push(obj.name);
    // Once the user got three, we display and reset all buttons to visible
    if (selected_colors.length==3) {
        // fill in the three cols. Warning: it's the "c1" etc. property defined above
        data_grid.addItem({c1:selected_colors[0], c2:selected_colors[1], c3:selected_colors[2]});
 
        for (var i:Number=0; i<button_list.length; i++) {
            button_list[i].visible = true;
        }
        selected_colors = new Array ();
    }
}






	Directory: http://tecfa.unige.ch/guides/flash/ex/data-grid/

	File: data-grid-1.fla



[bookmark: Data_Grid_-_using_external_data_sources]
4 Data Grid - using external data
sources

Typically data that should go for display and editing in a data
grid may sit in data structures produced by a server-side
application. The best way to deal with these data sources is
probably exporting/importing as XML.

The well-formed kind of XML structure you can use is list of
elements with attributes or a list of elements with
subelements. Translated in XML, this
means that you need structure like this (element and attribute
names don't matter of course as you shall see):




 <list>
  <line attr1="xxx" attr2="yyy" attr3="zzz"/>
 </list>








 <list>
  <line>
     <element1>xxx</element1> <element2>yyy</element2> <element3>zzz<element3>
  </line>
 </list>





[bookmark: A_list_of_LMSs_using_elements]
4.1 A list of LMSs using
elements

You first can have a look at the data-grid-xml.html example. It's just a simple
DataGrid table as introduced above. The only difference is that
data is imported from a lms-list.xml file. The XML inside looks like
this:




<?xml version="1.0"?>
<list>
  <entry>
    <Name>Moodle</Name>
    <Type>LMSware</Type>
    <License>GPL</License>
    <Description>Good for blended activity-oriented learning</Description>
  </entry>
  <entry>
    <Name>PageFlakes</Name>
    <Type>Webtop service</Type>
    <License>Free to use</License>
    <Description>A minimal persona learning environment</Description>
  </entry>
  <entry>
    <Name>Drupal</Name>
    <Type>Portalware</Type>
    <License>GPL</License>
    <Description>Good for project-oriented teaching</Description>
  </entry>
</list>





Here is the ActionScript code. As you can see need some lines of
codes to get the XML into the table. Unless you want to do some
data filtering, e.g. the XML file structure doesn't match the
DataGrid structure, you can copy/paste the code as is:




// Import the necessary packages
import fl.controls.DataGrid;
import fl.data.DataProvider;
 
// --------------------- DataGrid init ----------------------------
 
// Create a a new instance of DataGrid and name it "data_grid"
var data_grid:DataGrid = new DataGrid();
 
data_grid.addColumn("Name");
data_grid.addColumn("Type");
data_grid.addColumn("License");
var col4 = data_grid.addColumn("Description");
col4.minWidth = 300;
// Fix the size
data_grid.width = 600;
// Set the height to five rows
data_grid.rowCount = 5;
// Position it on the stage
data_grid.move(10, 70);
// Then add it to the stage
addChild(data_grid);
 
// ------ DataProvider and XML loading code
 
var dp:DataProvider;
 
// define a URL and make it a request instance
var url:String = "lms-list.xml";
var request:URLRequest = new URLRequest(url);
 
// define a loader and have it load the request
var url_loader:URLLoader = new URLLoader();
url_loader.addEventListener(Event.COMPLETE, completeHandler);
url_loader.load(request);
 
// define a function that will execute after data has finished loading
function completeHandler(event:Event):void {
    var ldr:URLLoader = event.currentTarget as URLLoader;
        // create XML datastructure from loaded XML
    var xmlDP:XML = new XML(ldr.data);
        // create a new data provider with this and register it with the DataGrid
    dp = new DataProvider(xmlDP);
    data_grid.dataProvider = dp;
}






	Source code

	Directory: http://tecfa.unige.ch/guides/flash/ex/data-grid/

	FLA file: data-grid-xml.fla



[bookmark: A_list_of_LMSs_using_attributes]
4.2 A list of LMSs using
attributes

You first can have a look at the data-grid-xml-attrs.html

The AS code is exactly the same. Only, as you can see below, the
XML code uses attributes instead of elements. We also changed the
formatting of each entry a bit (just to see if Adobe did a good job
- it did).




<?xml version="1.0"?>
<list>
  <entry
    Name="Moodle"
    Type="LMSware"
    License="GPL"
    Description="Good for blended activity-oriented learning"
    />
  <entry Name="PageFlakes" Type="Webtop service" License="Free to use" 
       Description="A minimal personal learning environment"
       />
  <entry 
      Name="Drupal" Type="Portalware"
      License="GPL" Description="Good for project-oriented teaching"/>
  <entry 
      Name="Blackboard" Type="LMS"
      License="Commercial" Description="Good for grading exercises"/>
</list>





We will not show the AS code here, since it's the same (except
for the file name).


	Source code

	Directory: http://tecfa.unige.ch/guides/flash/ex/data-grid/

	FLA file: data-grid-xml-attrs.fla




	Moving on exercice



Generate some XML data with PHP that comes from a database.
That's just a PHP coding exercise.


	Interested in the Flex equivalent ?



See the Flex datagrid component
tutorial

[bookmark: Editing_DataGrids]
5 Editing DataGrids

(to do ....)

[bookmark: Links]
6 Links


	Directory: http://tecfa.unige.ch/guides/flash/ex/data-grid/

	FLA file: data-grid-xml-attrs.fla




	Adobe tutorials




	Creating, populating, and resizing the DataGrid
component

	Customizing and sorting the DataGrid component

	Filtering and formatting data in the DataGrid
component

	Flex Quick Starts: Handling data (not very
useful)

	Reading an XML file into an XML object (not very
useful)

	Working with XML (Programming ActionScript
3)




	Other tutorials




	Using the DataGrid Component by Kirupa (July
2006).




	Official documentation for Flash and AS3




	Using the DataGrid Adobe Flash CS3
Documentation




	DataGrid (AS3 Language and components
reference)




	fl.controls.dataGridClasses. Includes classes
that the DataGrid component uses to maintain and display
information. (ActionScript 3.0 Language and Components
Reference)

	fl.controls.dataGridClasses. Similar. (Adobe
ActionScript 3.0 Language and Components Reference)




	fl.data Reference manual for data associated
(Adobe ActionScript 3.0 Language and Components Reference)



More needed and some cleanup too ...

Flash CS4 inverse kinematics tutorial
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This is part of the Flash tutorials

[bookmark: Introduction]
1 Introduction



	Learning goals




	Insert bones in shapes

	Connect symbols with bones

	Create a motion animation with bones

	Attach envelope points to bones




	Flash level




	Flash CS4 - Flash 10 (!)

	Some examples work with the Flash 9 player




	Prerequisites




	Basic drawing and animation (e.g. the level of Flash animation summary)




	Moving on




	See the Flash tutorials




	Level and target population




	Beginners




	Quality




	This is a first draft. I will have to complete things, add some
more screen captures, rewrite some stuff, and add more examples,
etc.





The bones tool is an inverse kinematics (IK) tool
with which one can create armatures for shapes or
connected symbols instances. These armatures connect objects or
parts of shape in a hierarchical tree. These parts can be called
bones or limbs. "Outer" (or child) limbs that are
moved also will move "inner" (or parent) limbs. E.g. In a human
avatar, if you pull a finger, the hand will move too and the hand
in turn will move the lower arm, etc. So in contrast to "forward
kinematic animation", where each movement for each component must
be planned, only the starting and ending locations of a limb are
necessary to get a basic animation going.



[image: A group of several symbols with IK bones attached. Copyright: Adobe License: Creative Commons by-nc-sa]



A group of several symbols with IK bones attached. Copyright:
Adobe License: Creative Commons by-nc-sa







[image: A shape with an IK armature added. Copyright: Adobe License: Creative Commons by-nc-sa]



A shape with an IK armature added. Copyright: Adobe License: Creative Commons by-nc-sa





“Inverse kinematics is the process of determining
the parameters of a jointed flexible object (a kinematic chain) in
order to achieve a desired pose. Inverse kinematics is a type of
motion planning. Inverse kinematics are also relevant to game
programming and 3D animation, where a common use is making sure
game characters connect physically to the world, such as feet
landing firmly on top of terrain.” (Wikipedia, retrieved 27 November 2008 ).

“Inverse kinematic animation (IKA) refers to a
process utilized in 3D computer graphic animation, to calculate the
required articulation of a series of limbs or joints, such that the
end of the limb ends up in a particular location. In contrast to
forward kinematic animation, where each movement for each component
must be planned, only the starting and ending locations of the limb
are necessary.” (Inverse kinematic animation, retrieved 17:52, 28
November 2008 (UTC)).

“The characters in a game have skeletons. Similar
to our own skeleton, this is a hidden series of objects that
connect with and move in relation to each other. Using a technique
called parenting, a target object (the child) is assigned to
another object (the parent). Every time the parent object moves,
the child object will follow according to the attributes assigned
to it. A complete hierarchy can be created with objects that have
children and parents [...] Once the skeleton is created and all of
the parenting controls put in place, the character is animated.
Probably the most popular method of character animation relies on
inverse kinematics. This technique moves the child object to where
the animator wants it, causing the parent object and all other
attached objects to follow.” (How stuff works, retrieved 27 November 2008).

Adobe CS4 fully integrates inverse kinematics modelling with
their drawing tools. “Inverse kinematics (IK) is a method for animating
an object or set of objects in relation to each other using an
articulated structure of bones. Bones allow symbol instances and
shape objects to move in complex and naturalistic ways with a
minimum of design effort. For example, inverse kinematics lets you
create character animation, such as arms, legs, and facial
expressions much more easily.

You can add bones to separate symbol instances or to the
interior of a single shape. When one bone moves, the other
connected bones move in relation to the bone that initiated the
movement. When animating using inverse kinematics you need only
specify the start and end positions of objects. Inverse kinematics
lets you create natural motion much more easily.”
(Using inverse kinematics, retrieved 27 November
2008).


	Simple demo



The following application shows the difference between an IK
structure (armature) made with red symbols and an another made with
a blue shape.


[image: Symbol vs. shape IK structures]
Symbol vs. shape IK structures





Load the symbol-vs-shape-armature.html application and
drag the tips (or other parts of the shapes around. Make sure that
you have a Flash 10 player installed. Else, it will not work.
Notice: The armatures have been defined as type "Runtime", meaning
that we let the user do the animation (manipulate the IK
structure).

Source:


	symbol-vs-shape-armature.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex4/inverse-kinematics/



[bookmark: A_simple_armature_with_symbol_instances]
2 A simple armature with symbol
instances

[bookmark: Creation_of_a_simple_IK_animation_with_symbol_instances]
2.1 Creation of a simple IK animation
with symbol instances

Have a look at the symbols-ik-armature-intro example first.


[image: A simple IK animation with symbol instances]



A simple IK animation with symbol instances






	A connected balls and ovals example




	Step 1 - create the symbols




	Create a new layer

	Create a movie clip symbol, draw a red ball and right-click
convert to symbol. Select "Movie clip".

	Then adjust the instance on stage (e.g. fix its color and size
or add a bevel filter)

	Then create copies of this instance. The fastest way is to hold
down CTRL-ALT and drag.

	Repeat this with a rounded rectangle.



In your library you now should have two Movie clip symbols, e.g.
Red ball and Red rectangle


	Step 2 - move the symbols into an initial position




	E.g. try to reproduce the example. Make sure that you have
all the symbols you need on the stage. You won't be able to add
additional symbols once you start defining the armature.




	Step 3 - create the chain




[image: Creating bones for symbol IK structures with Flash CS4]



Creating bones for symbol IK structures with Flash CS4





The chain should be going from parent to children, from children
to great children etc. In our case, this means that we start with
the rectangle that is attached to the floor.


	Select the bone tool and click on the first shape to
designate it as the parent shape. The spot where you click
first will be the one that attaches the armature to the scene. I
our case we selected it close to the floor.

	Then, from from the end point of first point, i.e.
the joint', drag the bone tool to the next shape and
release the mouse where you want your bone to end. If you release
the mouse outside of a symbol (shape) nothing will happen.

	Repeat this step until all of the symbols are linked. Always
start from a joint. In our case, always the "outer" joint, since we
want to create a chain.



You now will see that Flash now created an armature layer
(called "Armature_1" and you can't edit your objects anymore. They
have been copied to the armature layer and did become
ikNodes. You may change the name of that layer if you
like.

A note on terminology: Each bone will get a name like
"ikBoneName1" (that you can change) and each connected symbol will
get a name like "ikNode1" (that you also can change). So in a IK
armature we got bones and nodes.

Now you can play a bit, e.g. drag the last child in the IK
structure around and see if the joints are in the right place. If
not, adjust (see below)

[bookmark: Adjustments]
2.2 Adjustments


	Adjust center points




	If the start of a bone is in the wrong place, you can move the
rotation point with the free transform tool. You also could turn
the shape, move it or adjust its size, so that it would adjust to
the new rotation and length of the bone, but that's a bit tricky.
You will learn move about bone and node manipulation later, but for
starters this it is enough to move bones up and down.



The picture below shows what happens if you move a shape and
change its rotation point. The result is not entirely convincing
(compare with the previous picture above) ...



[image: Adjusting joints (enter points) with the Free Transform tool in Flash CS4]
Adjusting joints (enter points) with the
Free Transform tool in Flash CS4





[bookmark: Animation]
2.3 Animation

Let's now create an IK animation. Before you start, make sure
that the IK structure is what you want. It must be complete.
You won't be able to change the structure itself later on. You only
can change poses, do some transformations and other more
advanced tuning. So here is the procedure.


	Hit F5 somewhere in the timeline

	Use the select tool

	Move all the joints wherever you want in any frame you like.
Each time you do this, it will create a new keyframe with a
pose. Keyframes are represented by little lozenges.

	You can copy/paste poses: Right-click directly in the timeline
on a keyframe (i.e. an existing pose) and copy pose. Then
right-click in a different frame and paste pose. Make sure
to directly right-click (no click first), else it won't work.



What if you got it all wrong ?


	Select the armature layer by clicking on it. This selects the
whole IK structure

	Kill the parent bone (in our example it its on the bottom)

	The select all symbols and copy them back to the initial layer
("plaything" in our case). You could use ctrl-shift-v to
"copy in place".

	Then delete the armature layer and start again.



[bookmark: Adjustment_of_the_time_line]
2.4 Adjustment of the time
line


	Just drag the latest frame out or in. Make sure that you see a
horizontal double arrow, i.e. don't click in the last frame. In the
latter case you would just move the whole animation chain to the
right.




	Result and source




	symbols-ik-armature-intro.html

	Source: symbols-ik-armature-intro.fla (Notice: Selection
of elements behaves strangely, maybe because I changed features of
the symbols or because of the bevel. Simply magnify to 400% if you
want to play with it ...).

	Directory: http://tecfa.unige.ch/guides/flash/ex4/inverse-kinematics/



[bookmark: Adding_armatures_to_shapes]
3 Adding armatures to
shapes

You also can add an armature to a shape as we have seen in the
initial demo shown at the start. I recommend the
following steps:


	Step 1 - Create a new layer with a single shape




	Draw a shape or a simple drawing in object mode. Make sure to
finish the drawing, later you only can adjust its shape.

	Make that you only have a single shape, else CS4 will sort of
freak out, e.g. freeze a bit or create more than one armature
layers ....



I suggest the following procedure for drawing:


	Draw all the parts of the shape in object mode

	Once you are happy, you should save a copy of your artwork in
case you want to come back to it later: CTRL-A and Right-click;
Create Symbol.

	Then break a part the symbol instance on the stage and make
a union' of all graphics: CTRL-A, then menu
Modify->Combine Objects->Union. This is
necessary because you do need a single shape or drawing
object.




	Step 2 - Add the inverse kinematic structure (bones)




	Select the bone tool from the tool panel

	Click inside the shape where you the the armature to be
attached to the scene. The parent point will not move.

	Then hold down the mouse at the same spot and drag out a
bone

	Click at the end point of this new bone and drag again

	etc.



You now will see an armature layer and you can't edit your
objects anymore since they all have been moved to the armature
layer.


	Step 3 - Add another shape.




	If you want to create an other IK structure (shape or
symbol-based) just create a new layer and start again.




	Step 4 - Create the animation and adjust various poses in
keyframes




	Rotate bones as explained abouve. If you turn on the circle
close to the joint you will just move the joint without turning the
parents.

	To adjust the shape in poses, see just below. Also consult the
tools and objects
overview.




	Two flowers example



This example is really ugly. I would have to do it again. It
seems that using the pencil tool (strokes), for the blue flower was
not such a good idea. If you need fat lines, rather use the
rectangle tool or the paint tool. Then you could adjust the
envelope later on.


	bones-in-shape-intro.html

	Source: bones-in-shape-intro.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex4/inverse-kinematics/




	Shape stickman example




[image: Shape-based IK structure of a stickman]



Shape-based IK structure of a stickman





This shape has been drawn with the Paint tool in object mode.
Once the drawing was done, we made a union of all its parts
(Modify->Combine Objects->Union) and
then optimized (Modify->Shape-Optimize) at 100%.


	The stickman has many joints as you can see in the
picture.

	The parent bone starts in the hip area.

	We not only animated the poses but also move the stickman in
different positions in various keyframes.




	shape-ik-stickman-animation.html

	Source: shape-ik-stickman-animation.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex4/inverse-kinematics/



The result isn't great, but given the time we spent on it
(little) it's ok.


	Fixing the shape in poses



You sometimes can see that the shape doesn't really follow the
bones (I mean these sharp edges that can appear). Such behavior can
be fixed:


	Use the Subselection tool to move shape control to a different
place. Firstly, magnify the scene (at least 400%). Then you can
move or kill the blue control points or adjust them with the
red curve control handlers. Take it slowly and wait to see
the result of a manipulation since Flash recomputes the whole
interpolations ! Even my DELL M1740 high-end laptop needs to
think about it, before it let's me see a deletion, a move or a
curve change happen. Also bones may be shown displaced. Click in
another keyframe and come back ...

	Use the bind tool to associate shape controls with bones.




[image: Fixing a curve of the shape in a IK pose with the subselect tool]
Fixing a curve of the shape in a IK pose
with the subselect tool





Unless you are looking for a "snake-like" behavior, it is
probably better to use a symbol-based armature as in the next
chapter.

[bookmark: A_stickman_avatar]
4 A stickman avatar

(not done yet !)

Let's now create a stickman avatar that roughly has human
proportions. In order to create a "human" stick man we need a few
objects to represent body parts. Here are a few rules of thumbs
regarding size of body parts:


	Total body height should be about 6-8 times the size of the
head

	Head to crotch and crotch to feet is about the same size

	shoulders and hips are about the same (shoulder is smaller for
females and bigger for males)

	Waist (if you have one is midway between shoulders and
crotch

	Arm length: From shoulder to mid-thigh (or shorter)

	Feet length: About the same as forearm

	Face is an oval, about 6-8 smaller than the total size. Eyes
are roughly in the middle.




	Adjust properties



Select a bone and play with the options in the properties
panel


	Speed refers to the rotation speed in relation to the rest
(default is 100%)

	Joint rotation constraints are rotational constraints on the
joints of an artificial bone system



[bookmark: Animation_by_user_action]
5 Animation by user
action

You can produce a inverse kinematics armature that the user can
manipulate. To do so:


	Only use frame 1 of the Armature layer, i.e. don't do any
animation (kill all the other frames in the Armature layer)

	In the properties panel, choose Type -> Runtime.

	You now can play the movie (publish it) and play as in the demo
that we showed at the beginning of this tutorial




	Demo: symbol-vs-shape-armature.html

	Source: symbol-vs-shape-armature.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex4/inverse-kinematics/



[bookmark: Tools_and_objects_overview]
6 Tools and objects
overview

This is a sort of short manual for the IK tools an objects

[bookmark: Tools_overview]
6.1 Tools overview

Below is a list of tools you may use and their function. See
further down for "how to".


	The Bones tool




	Define bones




	The Bind tool




	Associate envelope points with a given bone. (more later)




	The Select tool




	Select bones or associated ikNodes (shapes) for further
manipulation, either by dragging, ALT-dragging or via the
properties or transform panel.




	The Subselection tool




	Allows you to move joints of bones (i.e. make them longer or
shorter and rotate) of bones within a shape armature. I.e.
this won't work with IK structures that use symbols. To move bones
for symbol armatures, use the Free Transform tool.

	Allows to adjust shapes




	The pen tool




	As alternative tool to add/remove control points to a
shape.




	The Free Transform tool




	Allows to move joints (starting points of bones) of an
symbol-based armature.




	The Transform panel




	Change size and rotation of both bones and associated ikNodes
(shapes).



[bookmark: Dealing_with_the_armature_layer]
6.2 Dealing with the armature
layer

An armature is defined in a special Armature layer. By
clicking on the layer, you then can change some of its properties
in the properties panel:


	Ease: You can define ease-in and ease-out parameters as
in other tweening animations

	Options:

	Change type: Authortime to animate yourself in
the armature layer, runtime to allow the user move the IK
structure. In the latter case, you can't have your own animations.
I.e. you only can define frame 1.

	Style: This will display the bone structure in various
ways. Use solid for simple stuff and wire to be able
to work on finer details.








[image: Flash CS4 armature properties]



Flash CS4 armature properties





Flash automatically moves all the object from the drawing layer
to the armature layer as soon as you create an IK. Therefore if you
want to break the armature, make sure to copy first all your stuff
from the armature layer to another layer or much better,
before you start adding an armature, simply save your drawings as a
symbol in the library (break apart the instance on stage again
after you saved).

Also, armatures can only be edited after you created it,
i.e. you may edit the structure of the initial pose. If you
have more than one pose, i.e. more than one frame, you
can't. In the other frames you only can change and copy/paste
poses. That makes sense, since the armature must be the same
throughout the animation.

[bookmark: Dealing_with_the_whole_IK_structure]
6.3 Dealing with the whole IK
structure


	To select the whole IK structure or shape, click on it.

	You then can change its position in the parameters panel. I.e.
it will move the parent joint to a new origin.

	Alternatively you can select the free transform tool and then
move it.

	You can't change its size, so think before, i.e. when you draw
it.



[bookmark: Editing_Bones]
6.4 Editing Bones

After creating bones, there are many ways of editing them. You
can reposition the bones and their associated objects, move a bone
within an object, change the length of a bone, delete bones, and
edit the objects containing the bones.

Remember that you should edit the bones before you start
adding poses !


	To select a bone, use the select tool. shift-select will
select several and double-click will select all bones.

	To kill a bone, select it and hit delete. This
will also kill its children.

	To edit properties of a selected (or several selected bones)
use the parameters panel.



You can define 3 sets of parameters for each bone (or set of
bones)


	Joint translation is disabled by default, i.e. the size of
limbs remains the same. To allow stretching of bones edit the
child's Joint: X translation and Joint: Y
translation parameters. You then may define how far in x/y
direction you can stretch the joint, i.e. the start of the bone.
Basically, when you move a joint in x/y direction (which normally
you can't) the parent bone will grow/or shrink and change its
angle.

	To limit rotation (by default you can rotate in 360 degrees)
edit the Joint: rotation parameters. Positive numbers mean
"clockwise".



To rotate a bone (turn it), use the selection tool to drag the
bone (or the shape). All bones that are in the same branch also
will move. But if you select a spot closer to the joint,
they will move less.

To rotate a bone without moving the parents,
shift-drag (hold down the shift key).

To move a joint, select the joint with the free transform
tool. In other words, you simple move the rotation point, i.e.
little white circle you should know from old style CW motion
animation. You also can play with the transform panel. If
you want to stretch the bone of parent A, select child B.

I did not manage to move bone ends with the Subselection tool
for symbol-based armatures, only within a shape-based IK.

[bookmark: IK_nodes_in_symbol-based_armatures]
6.5 IK nodes in symbol-based
armatures

Symbol instances connected with bones become ikNodes.
I.e. when you click on a shape with the select tool, you will see
something like ikNode_3 in the properties panel.


	In the transform panel you now can change its size (x
and y) and also it's rotation. E.g. if you did some wild bone
manipulation stuff you can realign a shape with the bone.

	Alternatively, you also can drag the ikNode (shape) with
ALT-drag.



In both cases the bones will adapt, i.e. stretch and rotate.

[bookmark: Dealing_shape-based_IK_shapes]
6.6 Dealing shape-based IK
shapes


	To edit a shape in a shape-based IK structure, use the
Subselection tool

	If you click on the stroke (the border of the shape) you will
see control points. You then can drag control points or
click on one and adjust the shape with the curve controls
that will appear.

	To add a new control point click somewhere on the stroke.

	To delete a control point, select it and hit delete



Tip: Magnify a lot (e.g. 400%), it's really hard to get the
right point. Also CS4 behaves a bit erratically, i.e. I sometimes
have trouble inserting a new control point vs. moving a curve
control. Therefore you also can use the pen tool and its
sub-tools to add/remove controls.

[bookmark: Bind_bones_to_shape_points]
6.7 Bind bones to shape
points

When you move the bone structure to a different pose, you may
not be happy with the result, but you can fix that. By default, the
control points of a shape are connected to the bone that is nearest
to them, but you can change that with the bind tool (that
sits underneath the bone tool in the tools panel).

If you click on a bone it will show all associated control
points (i.e. parts of the shape that go with a bone). The bone will
be red and the associated control points yellow.
Points that are associate with just one bone are yellow
squares. The ones that connect to more than one bone are
yellow triangles.


	To remove a control point association with a bone,
CTRL-click on the yellow.

	To associate a control point with a bone, SHIFT-click on
a red (not associated) control point.

	To add a control point, use the Subselection tool.



The other way round. If you click on a control point
(blue if no bone is selected) it will become red and
show the associated bones in yellow.

[bookmark: Links]
7 Links


	Introductions to inverse kinematics




	Inverse kinematics (Wikipedia)

	Inverse kinematic animation (Wikipedia).

	Inverse Kinematics - Improved Methods by Hugo Elias,
2004. Very technical.

	How do the characters in video games move so
fluidly? (Howstuffworks.com).




	Adobe documentation




	Using inverse kinematics (Using Flash CS4
Professional)




	Introductions




	Flash Downunder - The Bone Tool and the Deco Tool
Video by Paul Burnet.

	Using inverse kinematics by Chris Georgenes.
Includes a video, examples files and text. This is a really useful
tutorial that explains all the basics.




	Examples




	Dress up dolls (Flash)




	Avatars (theory, technology and design)




	See the avatar article



ActionScript 3 event handling tutorial


This article
or section is a stub.

A stub is an entry that did not yet receive substantial
attention from editors, and as such does not yet contain enough
information to be considered a real article. In other words, it is
a short or insufficient piece of information and requires
additions.



[bookmark: Overview]
1 Overview


	Learning goals

	Learn some essentials of the event handling model of Flash 9
(CS3) / ActionScript 3.

	Learn some Action Script 3 (to be used within the Flash
IDE)




	Prerequisites

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash button tutorial

	Flash components tutorial




	Moving on

	ActionScript 3
interactive objects tutorial (you also may directly read this
piece)

	The Flash article has a list of other tutorials.




	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It aims at Flash design beginners, not beginning
ActionScript 3 programmers, although programmers can read this to
get a quick overview before digging into a real documentation like
Adobe's Flash 9 reference manual




	Learning materials



Grab the various *.fla files from here:


	http://tecfa.unige.ch/guides/flash/ex/action-script-3-intro/



[bookmark: Introduction]
2 Introduction

According to the Flash CS3 documentation, retrieved 12:43, 7
September 2007 (MEST):


Every component broadcasts events when a user interacts with it.
When a user clicks a Button, for example, it dispatches a
MouseEvent.CLICK event and when a user selects an item
in a List, the List dispatches an Event.CHANGE event.
An event can also occur when something significant happens to a
component such as when content finishes loading for a UILoader
instance, generating an Event.COMPLETE event. To
handle an event, you write ActionScript code that executes when the
event occurs.



Below a few basic principles

[bookmark: Principles_of_event_driven_programming]
2.1 Principles of event driven
programming

[bookmark: Events_are_detected_by_some_object]
2.1.1 Events are detected by some
object

Usually, events are broadcasted by an instance of an interactive
object, typically a graphic on the screen that is a symbol
instance. User interactions are, technically speaking, events
generated by Flash objects. You then have to write code that can
deal with these events. Firstly you must give a name to each symbol
instance, users interact with. Otherwise your AS code can't find
them.


	So before you code anything in ActionScript that deals with
events generated by some user interaction with an object, click on
this instance, open the parameters window and fill in label
parameter.



This name must be legal:


	Start the label name with a letter

	Do not use whitespaces or punctuation characters or
dashes



[bookmark: ActionScript_for_Flash_designers]
2.1.2 ActionScript for Flash
designers


	All ActionScript goes to the timeline




	Always put AS code into a separate layer, e.g. call it
"Action"

	Note: AS2 also would allow you to attach code to instances. You
can't do this.




	Action script code extends to frames in the same way as
drawings



E.g. if you want the user to interact with buttons after the
animation loads:


	Click on frame 1 of the "Action" layer

	Hit F9, then code :)



Code will only work within the frames the layer extends to. So
if your code is supposed to be valid throughout the animation.


	Go to the last frame in your timeline

	Hit F5



[bookmark: Event_registration]
2.1.3 Event registration

For each event (user action or something else) you would like to
intercept, you must register a so-called event listener
function.

The syntax is the following:


addEventListener(Type_of_event.Name_of_event, Name_of_function_YOU_define);


Example:


	Let's say you have a button instance. In the parameters panel
you named it hello_button.

	If you want to tell the button to watch out for user clicks
then you have to write something like to register the event with a
function (see below).

	So goto the ActionScript layer and hit F9. Then type:




hello_button.addEventListener(MouseEvent.CLICK, click_handler);


Programmers (only): You should be aware that a a component's
events inherit from the parent classes. You also can remove a
listener with the removeEventListener(). Also the correct
explanation is "Registers an event listener object with an
EventDispatcher object so that the listener receives notification
of an event".

[bookmark: The_event_object]
2.2 The event object

Let's recall that when an event happens, Flash will create an
object that will be sent to the registered function. This object
contains at least the following information:


	type - a string indicating the type of event

	target - the instance that sent the event (i.e. a reference to
it).



Since target refers to an object you then can also extract
information about the target, e.g. its label (if it has one).

[bookmark: The_Event_handler_function]
2.2.1 The Event handler
function

The event handler function (also called a callback function)
will be called by Flash as soon as the event happens. Think a
function as a kind of recipe that will do something with a given
event. This function that you have to define yourself will
receive the following information:


	A single event object (just described before) that will contain
information about the event type and the instance (e.g. the
hello_button in our case).

	In other words, the function will know "what" happened and
"where".



Now you must write some code that deals with it, e.g. moves to
playhead in the timeline to another frame.

Note: about multiple events and multiple listeners:


	You can register multiple listeners to one instance.

	You can register the same listener to multiple instances.



After you registered an event handling function like


hello_button.addEventListener(MouseEvent.CLICK, click_handler);


you then have to define this function. E.g. if we called our
function click_handler we get the following template:


function click_handler(event_object:MouseEvent) {

 /* Do something with this event */

}


event_object is a variable name (we came up with) and
that will contain the name of instance we defined, e.g.
hello_button in our case.


	A simple example



From the Flash button tutorial. When a user
clicks on the "launch_button", then the launchRocket
function is called. It will move the animation to Frame 2 and let
it play.


launch_button.addEventListener(MouseEvent.CLICK,launchRocket);



function launchRocket(event:MouseEvent) { gotoAndPlay(2); }



	An example



This is the copy/pasted example from the Flash components tutorial.

We first register an event handling function with five different
buttons.


btn_rainbow.addEventListener(MouseEvent.CLICK, clickHandler);
btn_tecfa.addEventListener(MouseEvent.CLICK, clickHandler);
btn_bosses.addEventListener(MouseEvent.CLICK, clickHandler);
btn_my_computers.addEventListener(MouseEvent.CLICK, clickHandler);
btn_credits.addEventListener(MouseEvent.CLICK, clickHandler);


The function itself looked like this:


function clickHandler(event:MouseEvent):void {
        switch (event.currentTarget.label)
        {
                case "Rainbow" :
                        gotoAndStop(2);
                        break;
                case "TECFA" :
                        gotoAndStop(3);
                        break;
                case "Bosses" :
                        gotoAndStop(4);
                        break;
                case "My computers" :
                        gotoAndStop(5);
                        break;
                case "Credits" :
                        gotoAndStop(6);
                        break;
        }
}


The function will receive an object that contains information
about the event.

Let's now look at the first line. What does it mean ?


function clickHandler(event:MouseEvent):void {



	The function is called clickHandler (we can give it any name we
like)

	The event object it will receive for processing when something
happens is associated with event. In more technical terms
event is a parameter that you can use as a variable in
subsequent code.

	MouseEvent is the type of the event variable and
we should declare this.

	:void means that the function will not return any
information.



Non-programmers: Just insert these last two elements the same
way and don't worry.

Note: Flash also allows Flash designers who typically just
insert little bits of code to ignore typing, e.g. you just could
write:


function clickHandler(event)


but this is considered bad practice, it makes your program less
secure.

switch is a programming statement that is use to organize
program flow. In other words, we need to take different action for
different user input. Its syntax is the following:


switch (value) {
  case value_1 :
    /* do something */
    break;
  case value_2 :
    /* do something */
    break;
  ....
  }


So event.currentTarget.label means that we ask the event
object event its current target (i.e. the button on which
the user clicked) and from this its label (i.e. what the user
sees). This will allow us to figure out which button was
clicked.

[bookmark: Events_obverview]
3 Events obverview

All display objects with which you can interact can produce
events: mouse, keyboard, and focus.


	InteractiveObject (Adope ActionScript 3.0
Language and Components Reference)






[bookmark: List_of_events]
3.1 List of events

Here is a short list of all (most?) events that can be generated
by interactive objects with which a user can interact through
mouse, keyboard, and the more general concept of focus. It also
includes loading/modification events like animation entering a
frame or an object being inserted to the stage.

For (very) technical information, consult in Adope ActionScript
3.0 Language and Components Reference: InteractiveObject (see also its subclasses) and
Event (and subpages like MouseEvent)

Here is a list of events and mouse/keyboard/focus event
properties:



	Event
	Description
	Happens in target
	Event property



	activate
	Dispatched when Flash Player gains operating system focus and
becomes active.
	EventDispatcher
	



	added
	Dispatched when a display object is added to the display
list.
	DisplayObject
	



	addedToStage
	Dispatched when a display object is added to the on stage
display list, either directly or through the addition of a sub tree
in which the display object is contained.
	DisplayObject
	



	click
	Dispatched when a user presses and releases the main button of
the user's pointing device over the same InteractiveObject.
	InteractiveObject
	MouseEvent.CLICK



	deactivate
	Dispatched when Flash Player loses operating system focus and
is becoming inactive.
	EventDispatcher
	



	doubleClick
	Dispatched when a user presses and releases the main button of
a pointing device twice in rapid succession over the same
InteractiveObject when that object's doubleClickEnabled flag is set
to true.
	InteractiveObject
	MouseEvent.DOUBLE_CLICK



	enterFrame
	Dispatched when the playhead is entering a new frame.
	DisplayObject
	



	focusIn
	Dispatched after a display object gains focus.
	InteractiveObject
	FocusEvent.FOCUS_IN



	focusOut
	Dispatched after a display object loses focus.
	InteractiveObject
	FocusEvent.FOCUS_OUT



	keyDown
	Dispatched when the user presses a key.
	InteractiveObject
	KeyboardEvent.KEY_DOWN



	keyFocusChange
	Dispatched when the user attempts to change focus by using
keyboard navigation.
	InteractiveObject
	FocusEvent.KEY_FOCUS_CHANGE



	keyUp
	Dispatched when the user releases a key.
	InteractiveObject
	KeyboardEvent.KEY_UP



	mouseDown
	Dispatched when a user presses the pointing device button over
an InteractiveObject instance in the Flash Player window.
	InteractiveObject
	MouseEvent.MOUSE_DOWN



	mouseFocusChange
	Dispatched when the user attempts to change focus by using a
pointer device.
	InteractiveObject
	FocusEvent.MOUSE_FOCUS_CHANGE



	mouseMove
	Dispatched when a user moves the pointing device while it is
over an InteractiveObject.
	InteractiveObject
	MouseEvent.MOUSE_MOVE



	mouseOut
	Dispatched when the user moves a pointing device away from an
InteractiveObject instance.
	InteractiveObject
	MouseEvent.MOUSE_OUT



	mouseOver
	Dispatched when the user moves a pointing device over an
InteractiveObject instance in the Flash Player window.
	InteractiveObject
	MouseEvent.MOUSE_OVER



	mouseUp
	Dispatched when a user releases the pointing device button over
an InteractiveObject instance in the Flash Player window.
	InteractiveObject
	MouseEvent.MOUSE_UP



	mouseWheel
	Dispatched when a mouse wheel is spun over an InteractiveObject
instance in the Flash Player window.
	InteractiveObject
	MouseEvent.MOUSE_WHEEL



	removed
	Dispatched when a display object is about to be removed from
the display list.
	DisplayObject
	



	removedFromStage
	Dispatched when a display object is about to be removed from
the display list, either directly or through the removal of a sub
tree in which the display object is contained.
	DisplayObject
	



	render
	Dispatched when the display list is about to be updated and
rendered.
	DisplayObject
	



	rollOut
	Dispatched when the user moves a pointing device away from an
InteractiveObject instance.
	InteractiveObject
	MouseEvent.ROLL_OUT



	rollOver
	Dispatched when the user moves a pointing device over an
InteractiveObject instance.
	InteractiveObject
	MouseEvent.ROLL_OVER



	tabChildrenChange
	Dispatched when the value of the object's tabChildren flag
changes.
	InteractiveObject
	Event.TAB_CHILDREN_CHANGE



	tabEnabledChange
	Dispatched when the object's tabEnabled flag changes.
	InteractiveObject
	Event.TAB_ENABLED_CHANGE



	tabIndexChange
	Dispatched when the value of the object's tabIndex property
changes.
	InteractiveObject
	Event.TAB_INDEX_CHANGE




[bookmark: Events_decomposed]
4 Events decomposed

Each generated event contains different information, but some is
inherited by all kinds of events:

[bookmark: All_events]
4.1 All events

Technical note: The basic event class includes total (included
inherited ) 8 properties, 26 constants and 13 public methods.

The most interesting property of an event is


	currentTarget, the object that is actively processing
the Event object with an event listener. E.g. the button on which a
user clicked. You probably will use this one a lot.



Now let's look at mouse events. Flash defines 10 different types
of mouse events (see the event overview table above). Each of these
events contains extra information the may be useful. Let's have a
look at the click event ojbect (as defined in the Adobe reference manual. This object conatins
about 12 different properties that describe the event.



	Property
	Value



	bubbles
	true



	buttonDown
	true if the primary mouse button is pressed; false
otherwise.



	cancelable
	false; there is no default behavior to cancel.



	ctrlKey
	true if the Control key is active; false if it is
inactive.



	currentTarget
	The object that is actively processing the Event object with an
event listener.



	localX
	The horizontal coordinate at which the event occurred relative
to the containing sprite.



	localY
	The vertical coordinate at which the event occurred relative to
the containing sprite.



	shiftKey
	true if the Shift key is active; false if it is inactive.



	stageX
	The horizontal coordinate at which the event occurred in global
stage coordinates.



	stageY
	The vertical coordinate at which the event occurred in global
stage coordinates.



	target
	The InteractiveObject instance under the pointing device. The
target is notalways the object in the display list that registered
the event listener. Use the currentTarget property to access the
object in the display list that is currently processing the
event.




What this technical documentation means is that we can extract
extra information from the generated event object, e.g.


	if the user pressed the CTRL or SHIFT key

	where the target object sits, either relative to the stage or
relative to a parent object.

	Of course, we also can extract the target itself, since a Mouse
Click Event is a kind of general Event described above.



[bookmark: Event_propagation_and_bubbling]
5 Event propagation and
bubbling

(to do, see http://www.adobe.com/devnet/actionscript/articles/event_handling_as3_03.html
for now ...)




[bookmark: Links]
6 Links

[bookmark: Tutorials]
6.1 Tutorials


	Introduction to event handling in ActionScript
3.0 by Trevor McCauley, Adobe Developer Connection (good
tutorial)



[bookmark: Important_manual_pages]
6.2 Important manual
pages

These are almost impossible to understand for non programmers,
but otherwise the documentation at Adobe is excellent.


	InteractiveObject. This InteractiveObject class
is the abstract base class for all display objects with which the
user can interact, using the mouse and keyboard. Most Events are
documented here. (Make sure to list also the inherited
events).




	Event. The Event class is used as the base class
for the creation of Event objects, which are passed as parameters
to event listeners when an event occurs.




	EventDispatcher. This is the page you should
consult when you want to look up details for methods like
addEventListener().




	Summary of All Flash Player Classes,



ActionScript 3 interactive objects tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !




	Page created by Daniel K. Schneider, 28 September
2007

	Last 
modified by Daniel K. Schneider, 22 April
2009





This is part of the flash tutorials

[bookmark: Overview]
1 Overview



	Learning goals



The purpose of this tutorial is go a little bit beyond dealing
with mouse clicks, buttons and button components as seen in
previous tutorials, i.e. you will learn how to change properties of
objects (such as position, size and visibility) and how to play
embedded movie clips:


	Learn about how to use mouse and key-press events.

	Learn about some object properties you can easily change with a
little ActionScript code

	Learn some ActionScript control statements (if-then-else clause
and assignments)

	Learn how to play embedded Flash movie clips.

	Learn how to use embedded Flash movie clips for multiple
animations




	Prerequisites

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash button tutorial

	Flash component button
tutorial

	Flash embedded movie
clip tutorial

	Other recommended prior tutorials (not necessary, but can
help)

	Flash video component
tutorial

	Flash sound tutorial

	ActionScript 3 event
handling tutorial

	Moving on

	Flash drag and drop
tutorial

	Flash games tutorial

	Flash ActionScript 3
overview

	The Flash tutorials index has a list of
other tutorials.

	Level and target population




	It aims at Flash designers, not beginning
ActionScript 3 programmers, although programmers can read this to
get a feeling for object properties before digging into a real
documentation like Adobe's Flash 9 reference manual. Also, some of the
code should be rewritten a bit. I skipped type declarations on
purpose and should even rip off more. These don't make sense for a
few lines of code written by/for non-programmers. The goal is to
keep code as simple as possible. I should at some point decide
whether I should remove all type declarations from the examples or
consistenly leave the ones that might be useful in order to receive
compiler warnings.




	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...






	Learning materials



Grab the various *.fla files from here:


	http://tecfa.unige.ch/guides/flash/ex/action-script-3-intro/



[bookmark: Manipulating_objects]
2 Manipulating objects

The principle of (simple) object manipulation is fairly simple:
change properties of a display object. The tricky thing is
to know what you can change on a given kind of object. Some
changes are easy to make, others are really hard. Typically, most
objects are non-editable (its component objects maybe are). It's
easy to change size and position of a display object, i.e.
operations you could do on grouped objects and symbol instances
with the transform tool or the parameters panel.

Below, we show a few little examples that demonstrate how to
manipulate objects with mouse events (see the ActionScript 3 event
handling tutorial for more details). All the objects on the
stage (e.g. black_cat) are instances of movie clip symbols. These
are a kind of interactive object and react to mouse and keyboard
events. The kind of tricks will we show act on named
instances of library symbols. In technical terms: we will work
with display objects that are assigned to a variable.


[image: Symbol instances you want to manipulate must be named]
Symbol instances you want to manipulate
must be named





You could imagine dozens of other simple examples, but it's not
so easy to understand the technical ActionScript documentation
which is made for programmers and not designers. If you feel more
adventurous, you may have a look at the class hierarchy described
in the Flash ActionScript 3
overview and in particular the Display Object and its
children. Follow up a link to the Flash documentation and see if
you can find other properties that are easy to manipulate...

To understand what is goining on below, you may want to load
this fla file.

[bookmark: Simple_repositioning_example]
2.1 Simple repositioning
example

To reposition an object, just change its x and y
properties. In the following example, when you click on the
interactive object (a symbol instance that is called "black_cat")
it will move itself to position x= 200 and y=200. Note: Position is
defined by the center of the display object (i.e. the little "+"
sign who's value depends on how you made it).


black_cat.addEventListener(MouseEvent.CLICK, moveCat);

function moveCat(event:MouseEvent):void {
 black_cat.x = 200;
 black_cat.y = 200;
}


A statement like


cat.x = 100;


is called an assignment and means: The x property of the
cat object will become "100".

If you want to move the cat forth and back you'd rather use this
code:


black_cat.addEventListener(MouseEvent.CLICK, moveCat);
// cat can be in original position or not (true,false)
var black_cat_ori_pos = true;

function moveCat(event:MouseEvent):void {
        if (black_cat_ori_pos == true)
        {
                black_cat.x += 200;
                black_cat.y += 200;
                black_cat_ori_pos = false;
        }
        else
        {
                black_cat.x -= 200;
                black_cat.y -= 200;
                black_cat_ori_pos = true;
        }
}


In this function we use a so-called if-then-else
statement. The line


if (black_cat_ori_pos == true)


checks if the variable black_cat_ori_pos has the value of true.
If this is true we then execute the clause { black_cat.x +=
... ; black_cat.y ..... } that follows. If it is not
true we execute the other {...} clause after the else.

Also note the difference between an assignment ("=") and
an equality test ("=="). The latter will test if two
values are the same. Note to beginners: never use just the "="
inside the conditional of an "if". Use "==".

Let's describe this at a more conceptual level:
black_cat_ori_pos can be called a "flag" variable since it
will register whether the cat is in a new position or the original
old position. If it's in the new one, we will move it back, and the
other way round. So


black_cat_ori_pas == true


tests if the cat sits in its original position.

X and Y positions are defined with respect to the upper left
corner. E.g. if x is 100 and y is 100, the registered center point
of the object is 100 pixels to the right and 100 pixels down. The
instruction:


x += 100;
x -= 100;


means "add 100 to x" or "substract 100 from x". So it's a
shortcut for x = x + 100;, i.e. "new value of x
becomes old value of x plus 100".

[bookmark: Change_size]
2.2 Change size

Changing size, means to change width and height
properties. In the following example, when you click on the
interactive object (a symbol instance that is called "blue_cat") it
will double its size when you hold down the mouse button and go
back to normal when you release it. Note: If you hold down the
button and then move the mouse out (still holding down), and only
then release the button, the mouse will stay big since it never
will catch the mouse up event.


blue_cat.addEventListener(MouseEvent.MOUSE_DOWN, resizeCat);

function resizeCat(event:MouseEvent):void {
 blue_cat.width =  blue_cat.width * 2;
 blue_cat.height =  blue_cat.height * 2;
}

blue_cat.addEventListener(MouseEvent.MOUSE_UP, resizeCat2);

function resizeCat2(event:MouseEvent):void {
 blue_cat.width =  blue_cat.width / 2;
 blue_cat.height =  blue_cat.height / 2;
}


This code may not exactly do what you want. As we said, if the
user holds down the mouse button and moves it out, the
MOUSE_UP event will never happen, i.e. the cat will grow
permanently. A better solution can be found in the example code
that we included at the end of this section.

[bookmark: Visibility]
2.3 Visibility

In the following example, we will make a white cat invisible
when you click on it. Technical note: It is still there, but the
user can't click on it.


white_cat.addEventListener(MouseEvent.CLICK, hideCat);

function hideCat(event:MouseEvent):void {
  white_cat.visible = false;
}


Once the cat is hidden, the user never will be able to bring it
back. Therefore, in the next example we decided to implement a
switch between a cat and a dog:


// can't see the dog for starters
brown_dog.visible=false;

brown_dog.addEventListener(MouseEvent.CLICK, hideShow);
white_cat.addEventListener(MouseEvent.CLICK, hideShow);

function hideShow(event:MouseEvent):void {
  // instead of using white_cat.visible = false; we just switch it to the opposite
  white_cat.visible = !white_cat.visible;
  brown_dog.visible =!brown_dog.visible;
}




white_cat.visible = !white_cat.visible;


"!" means that the "visible" property will be set
to its opposite. E.g. if the value is true it will become
false, and the other way round. Same technique for the dog
(which is invisible for starters).

[bookmark: Let_the_user_drag_example]
2.4 Let the user drag
example

The next example shows how to let a user drag the red cat object
with the mouse (button pressed down) and then drop the cat when the
user releases the mouse button.


red_cat.addEventListener(MouseEvent.MOUSE_DOWN, startDragging);
red_cat.addEventListener(MouseEvent.MOUSE_UP, stopDragging);

function startDragging(event:MouseEvent):void
 {
    red_cat.startDrag();
 }

function stopDragging(event:MouseEvent):void
{
    red_cat.stopDrag();
}


For a tutorial on dragging and dropping, see the Flash drag and drop
tutorial that demonstrates how to implement a simple children's
educational game. You will learn for instance how to test if a
dropped object will sit on top of another one.

[bookmark: Transformations]
2.5 Transformations

So-called "transforms" of a non-editable display object are more
tricky. We just will demonstrate how to change the tint with a
color transform. You also could skew an object with a similar
strategy. However, this kind of code is really a bit too difficult
to understand without some prior introduction to object-oriented
programming.

Color: The ColorTransform class lets you adjust the color
values in a display object. The color adjustment or color
transformation can be applied to all four channels: red, green,
blue, and alpha transparency. Here are the formula according to the
manual, retrieved 20:58, 8 October 2007
(MEST):


	New red value = (old red value * redMultiplier) +
redOffset

	New green value = (old green value * greenMultiplier) +
greenOffset

	New blue value = (old blue value * blueMultiplier) +
blueOffset

	New alpha value = (old alpha value * alphaMultiplier) +
alphaOffset



The tricky thing is that you have to program transformations
with a temporary ColorTransform object and then copy this object to
the display object's colorTransform property if I understood the
manual right. See the code towards the end of the full example code
below.

[bookmark: Cat_example_file]
2.6 Cat example file

The (all-in-one) file with the examples we discussed above is
here:


	actionscript3-simple-object-manipulation.html




	Directory with files
actionscript3-simple-object-manipulation.*:




	http://tecfa.unige.ch/guides/flash/ex/action-script-3-intro/





[image: Demonstration of some mouse events and implementation of property changes]



Demonstration of some mouse events and implementation of property
changes





Here is the complete ActionScript code:


/* ---- moving ---- */
black_cat.addEventListener(MouseEvent.CLICK, moveCat);
// cat can be in original position or not (true,false)
var black_cat_ori_pos = true;

function moveCat(event:MouseEvent):void {
        if (black_cat_ori_pos == true)
        {
                black_cat.x += 200;
                black_cat.y += 200;
                black_cat_ori_pos = false;
        }
        else
        {
                black_cat.x -= 200;
                black_cat.y -= 200;
                black_cat_ori_pos = true;
        }
}

/* ---- resizing ---- */
blue_cat.addEventListener(MouseEvent.MOUSE_DOWN, resizeCat);
var cat_size = 1;

function resizeCat(event:MouseEvent):void {
        blue_cat.width =  blue_cat.width * 2;
        blue_cat.height =  blue_cat.height * 2;
        cat_size = 2;
}

// We have to test both mouse up and mouse out since user can
// press mouse and move out. Cat in this case would stay big.
// Also we have to test if cat is already big when user moves in.
blue_cat.addEventListener(MouseEvent.MOUSE_UP, resizeCat2);
blue_cat.addEventListener(MouseEvent.MOUSE_OUT, resizeCat2);

function resizeCat2(event:MouseEvent):void {
        if (cat_size > 1)
        {
                blue_cat.width =  blue_cat.width / 2;
                blue_cat.height =  blue_cat.height / 2;
                cat_size = 1;
        }
}

/* ---- dragging ---- */
red_cat.addEventListener(MouseEvent.MOUSE_DOWN, startDragging);
red_cat.addEventListener(MouseEvent.MOUSE_UP, stopDragging);

function startDragging(event:MouseEvent):void {
        red_cat.startDrag();
}

function stopDragging(event:MouseEvent):void {
        red_cat.stopDrag();
}

/* ---- Hiding ---- */
// can't see the dog for starters
brown_dog.visible=false;

brown_dog.addEventListener(MouseEvent.CLICK, hideShow);
white_cat.addEventListener(MouseEvent.CLICK, hideShow);

function hideShow(event:MouseEvent):void {
        // instead of white_cat.visible = false; we just switch it to the opposite
        white_cat.visible = !white_cat.visible;
        brown_dog.visible =!brown_dog.visible;
}

/* ---- transforms ---- 
   This is a bit more difficult.... */
empty_cat.addEventListener(MouseEvent.CLICK, transformCatColor);
// R,G,B,A multipliers and R,G,B,A offsets
// We start with a light grey cat
var resultColorTransform = new ColorTransform (0.1,0.1,0.1,1,120,120,120,255);
empty_cat.transform.colorTransform = resultColorTransform;

function transformCatColor(event:MouseEvent):void {
        var resultColorTransform = empty_cat.transform.colorTransform;
        // Create a new color transform object and change it
        // red color will peak at 255, blue color offset will cycle from +255 to -100
        resultColorTransform.redOffset = Math.min(resultColorTransform.redOffset+10,255);
        resultColorTransform.redMultiplier = Math.min(resultColorTransform.redMultiplier+0.1,1);
        resultColorTransform.blueOffset += 10;
        if (resultColorTransform.blueOffset >= 255)
        {
                resultColorTransform.blueOffset = -100;
        }
        resultColorTransform.blueMultiplier = 0.1;
        // Copy that to the cat
        empty_cat.transform.colorTransform = resultColorTransform;
        //trace("redOffset="+resultColorTransform.redOffset + 
        //   " blueOffset="+resultColorTransform.blueOffset);
}


/* ---- permanent size change ---- */
; Learning goals:


;Prerequisites:


;Moving on

;Level

grey_mouse.addEventListener(MouseEvent.MOUSE_WHEEL, changeMouse);

function changeMouse(event:MouseEvent):void {
        grey_mouse.width += event.delta*3;
        grey_mouse.height += event.delta*3;
}



[bookmark: Remote_cat_control_example]
2.7 Remote cat control
example

Here is another example that demonstrates the following
principles:


	You can modify an object's properties from an event triggered
on another object (e.g. button components)

	Play an embedded animation



I also simplified the way functions are written, i.e. I ripped
off argument type declarations and the return type. This is not
necessarily a good thing, but it should demonstrate to designers
that a little bit of ActionScript is not necessarily very complex
....

The example can be viewed here:


	actionscript3-simple-object-manipulation-buttons.html

	Source: actionscript3-simple-object-manipulation-buttons.fla

	Directory:




	http://tecfa.unige.ch/guides/flash/ex/action-script-3-intro/
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Demonstration II of some mouse events and implementation of
property changes





Here is the complete code: On the stage are several buttons
(named like "bigger", "smaller", etc.), a cat movie clip instance
called "cat" and a dog called "brown_dog".


/* ---- moving ---- */
move.addEventListener(MouseEvent.CLICK, moveCat);
// cat can be in original position or not (true,false)
var cat_ori_pos = true;

function moveCat(ev) {
        if (cat_ori_pos == true)
        {
                cat.x += 200;
                cat.y += 200;
                cat_ori_pos = false;
        }
        else
        {
                cat.x -= 200;
                cat.y -= 200;
                cat_ori_pos = true;
        }
}

/* ---- resizing ---- */
bigger.addEventListener(MouseEvent.MOUSE_DOWN, growCat);

function growCat(ev) {
        cat.width =  cat.width * 2;
        cat.height = cat.height * 2;
}

smaller.addEventListener(MouseEvent.MOUSE_DOWN, shrinkCat);

function shrinkCat(ev) {
        cat.width =  cat.width / 2;
        cat.height = cat.height / 2;
}

/* ---- dragging ---- */
cat.buttonMode = true;
cat.addEventListener(MouseEvent.MOUSE_DOWN, startDragging);
cat.addEventListener(MouseEvent.MOUSE_UP, stopDragging);

function startDragging(event:MouseEvent) {
        cat.startDrag();
}

function stopDragging(event:MouseEvent) {
        cat.stopDrag();
}


message_text.visible=false;
instructions.addEventListener(MouseEvent.CLICK, messageText);
function messageText(ev) {
        message_text.visible = !message_text.visible;
}

/* ---- Hiding ---- */
// can't see the dog for starters
brown_dog.visible=false;

hide.addEventListener(MouseEvent.CLICK, hideShow);

function hideShow(ev) {http://edutechwiki.unige.ch/en/Help:COAP-2110#Final_exam
        // we just switch visibility to the opposite
        cat.visible = !cat.visible;
        brown_dog.visible =!brown_dog.visible;
}

/* ----- Playing ---- */
// There is a little problem here. If the cat movie gets bigger, the motion guide also
// will grow big. Size does not refer to the cats drawing but to the composite object.
// Changing just the cat requires much more advanced AS.

playcat.addEventListener(MouseEvent.CLICK, playCat);

function playCat(ev) {
        // make sure cat is visible
        cat.visible = true;
        brown_dog.visible = false;
        cat.play ();
        }


Notice on function definitions:

If you want to write clean AS 3 code, you should define
functions like this:


function growCat(ev:MouseEvent):void {
        cat.width =  cat.width * 2;
        cat.height = cat.height * 2;
 }


The following line


function growCat(ev:MouseEvent):void {


means that we define a function (i.e. a recipe) called growCat.
When an event happens, this function will be called (invoked) and
given a mouse event argument to process. We called
this argument i.e. the information to process ev and
declared it of type MouseEvent. In our code we actually
never use this event information but we could for instance figure
out at what exact position the user clicked. :void
means that the function will not return any result. The function
will in fact just modify properties of the cat when the event
happens. We do not care about the event itself ...

If you script in the timeline, this simplified code will also
do


function growCat(ev) {
        cat.width =  cat.width * 2;
        cat.height = cat.height * 2;
}


As you can notice, in the above code we use (for demonstration
purposes) both the easy "scripting" syntax and the more
object-oriented one you need to adopt if you write external
ActionScript code that could be loaded into your *.fla file.

[bookmark: Stop_.2F_start_movie_clips]
3 Stop / start movie
clips

You can stop or start an embedded movie clip like this:


movie_clip.start();
movie_clip.stop();



	Flying Kite Example



This example is discussed in the Flash embedded movie
clip tutorial. Here we just include the AS code snippet that
will allow you to start and stop a movie clip animation with two
buttons.


kite.stop();

start_button.addEventListener(MouseEvent.CLICK,start_kite);
stop_button.addEventListener(MouseEvent.CLICK,stop_kite);

function start_kite(event:MouseEvent) {
        kite.play();
}

function stop_kite(event:MouseEvent) {
        kite.stop();
}



	kite-movie.html

	Source: kite-movie.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/embedded-movie-clips/




	Example from an exam (to be improved and documented at some
point)




	final-exam-coap2110-solution-2007.html

	Source: final-exam-coap2110-solution-2007.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/exams2007/



[bookmark: Dealing_with_keypress_events]
4 Dealing with keypress
events

Flash lets you intercept key presses in the same way you can
intercept and deal with mouse clicks. There are some subtle
differences though and I find key press events more difficult to
deal with because figuring out how Flash focuses on buttons is a
bit tricky.

[bookmark: Moving_an_object_with_arrow_keys_example]
4.1 Moving an object with arrow keys
example

The goal is to implement some code that lets you move around an
object with the left/right/up/down arrow keys.

The basic event handling code is very much the same as for
buttons:


instance_of_symbol.addEventListener(KeyboardEvent.KEY_DOWN, key_even_handler);

function key_event_handler(event:KeyboardEvent):void {
        move_it .....
}


The following example is based on the assumption that somewhere
on the stage you have a sprite, e.g. a movie clip or a component
button that is called missile and that you want to be able
to move it around with around with the arrow keys.

You need to implement the following things


	A event listener registration like we just explained.

	Tell the stage to focus on the missile




stage.focus = missile;



	The event handler function has to decide what to do with which
key.



Let's look at a clause of the switch statement like the
following one.


case Keyboard.LEFT :
  missile.x -= big_step;
  break;


This means the following: If the user presses the left arrow
key, then we will change the "x" (horizontal) position of the
missile to x minus big_step (set to 9). So if the
missile was in position x=100, after a mouse press event it will be
in position x=91.


// how many pixels to move left/right
var big_step = 9;

// Put initial focus on missile
// Focus will change when user clicks on another object (so don't)
stage.focus = missile;

missile.addEventListener(KeyboardEvent.KEY_DOWN, missile_control);

function missile_control(event:KeyboardEvent):void {
        var key = event.keyCode;
        switch (key) {
                case Keyboard.LEFT :
                        missile.x -= big_step;
                        break;
                case Keyboard.RIGHT :
                        missile.x += big_step;
                        break;
                case Keyboard.UP :
                        missile.y -= big_step;
                        break;
                case Keyboard.DOWN :
                        missile.y += big_step;
                        break;
        }
}


Here is an alternative take of the same code. The difference is
that the code that will move the missile also will work for an
other object, e.g. a button. The following fragment will ask from
the event on which target (e.g. the missile) it was used and then
move the target.


// how many pixels to move left/right

var big_step = 9;  // User clicked on missile

// Put initial focus on missile
// Focus will change when user clicks on another object (so don't)
stage.focus = missile;

missile.addEventListener(KeyboardEvent.KEY_DOWN, missile_control);

function missile_control(event:KeyboardEvent):void {
        var key = event.keyCode;
        var target = event.target;
        // trace(event + "CODE=" + event.keyCode);
        switch (key) {
                case Keyboard.LEFT :
                        target.x -= big_step;
                        break;
                case Keyboard.RIGHT :
                        target.x += big_step;
                        break;
                case Keyboard.UP :
                        target.y -= big_step;
                        break;; Learning goals:


;Prerequisites:


;Moving on

;Level

                case Keyboard.DOWN :
                        target.y += big_step;
                        break;
        }
}


Sadly, this example will not work in a web browser, only
in the Flash player. The missile will never receive focus. So it's
probably a good idea to move to the next example.

Example code:


	actionscript3-keypress-move-0.html

	actionscript3-keypress-move-0.swf

	Source: actionscript3-keypress-move-0.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/action-script-3-intro/



[bookmark: Dealing_with_the_tab_list_problem]
4.2 Dealing with the tab list
problem

Flash has the feature that when you press an arrow up/left/right
key it will by default move the focus on the next button. In order
to inhibit this behavior I found that I had to add some extra code
which is below. I don't guarantee that this is the most simple
solution.



/* ActionScript for timeline scripting
   Shows how to move around a flash movie with keypresses and not loose focus
   Works ONLY if you have 2 objects on the stage:
 * A movie clip instance called "missile"
 * A button component instance called "button"
 */

// FocusManager package has to be imported.
import fl.managers.FocusManager;

// how many pixels to move left/right
var big_step = 9;// User clicked on missile

/* If you have buttons in addition to missile on stage, then the
 the missile will not work as expected, i.e. it will loose focus.
 Extra code needed is: Tell the missile it's a button and put it on the
 list of "tab" buttons and also some code to put it in focus when the
 user clicks on it.
 */

// Create a focus manager. Will help to set us the right focus
var manager = new FocusManager(this);

// Put initial focus on missile
// since focus will change when user clicks on another object
// stage.focus = missile; // works also in principle
manager.setFocus(missile);

// The line below is absolutely bloody vital. Missile must be on the
// "tab" list, else focus will move to the button when key is hold down
missile.tabEnabled = true;
missile.buttonMode = true;

// The missile will listen to a mouse click we will use to put focus on it again.
missile.addEventListener(MouseEvent.CLICK, change_focus);
function change_focus(ev:MouseEvent) {
        manager.setFocus(missile);
        // stage.focus = missile;
}

/* Managing keyboard events
 We register keyboard events for missile and the button component. The
 listener function is the same for both. The move_it function will ask the
 target over which key was pressed who it is and then move it
 */

missile.addEventListener(KeyboardEvent.KEY_DOWN, missile_control);
button.addEventListener(KeyboardEvent.KEY_DOWN, missile_control);

function missile_control(event:KeyboardEvent):void {
        move_it(event);
}

function move_it(event) {
        var key = event.keyCode;
        var target = event.target;
        // trace(event + "CODE=" + event.keyCode);
        switch (key) {
                case Keyboard.LEFT :
                        target.x -= big_step;
                        break;
                case Keyboard.RIGHT :
                        target.x += big_step;
                        break;
                case Keyboard.UP :
                        target.y -= big_step;
                        break;
                case Keyboard.DOWN :
                        target.y += big_step;
                        break;
        }
}



[image: Moving a Missile with key presses]
Moving a Missile with key presses





Example code:


	actionscript3-keypress-move-1.html

	Source: actionscript3-keypress-move-1.fla

	Directory: http://tecfa.unige.ch/guides/flash/ex/action-script-3-intro/



Note: This code is not optimal for gaming, since Flash has to
wait for each key press event that the keyboard will send in order
to move the missile one more step. It's probably a better idea to
have the rocket keep moving as long as there isn't any keyUP event,
but this requires more coding.

[bookmark: Properties_of_the_keyDown_event]
4.3 Properties of the keyDown
event

The keyDown event is dispatched when the user presses a key. The
most important properties you may use are:


	keyCode (a special code for the key, used above)

	charCode (the character code value)

	ctrlKey, shiftKey (know if either one of these has been pressed
too)

	target (the target in focus over which a key has been pressed,
used above).

	currentTarget (object that is processing the key event)



KeyCodes are represented as numbers or constants. I prefer to
use constants.


	See the Keyboard class documentation at Adobe.



So instead of using something like:


if (key == 37) ... 


use


if (key === Keyboard.LEFT) ....


[bookmark: Summary_of_essential_events_and_action_script_tricks]
5 Summary of essential events and
action script tricks

Let's summarize a few events and actionscript tricks that might
be useful for starters and that should not be very difficult to
use.

[bookmark: Events]
5.1 Events

Here is a short summary of mouse events that can be intercepted
by a registered event handler for a given object. So these events
are only useful if you define both an event handler function and
register it with an object. In the following example "cat" is an
interactive object, e.g. a movie clip symbol with which we shall
register a function for a mouse down event.


 cat.addEventListener(MouseEvent.MOUSE_DOWN, resizeCat);

 function resizeCat(event:MouseEvent) {
    cat.width =  blue_cat.width * 2;
 }




	MouseEvent.MOUSE_DOWN
	User holds mouse button down over the object



	MouseEvent.MOUSE_UP
	User releases mouse button



	MouseEvent.MOUSE_OUT
	User moves mouse away from the object



	MouseEvent.MOUSE_WHEEL
	User turns mouse wheel



	MouseEvent.MOUSE_OVER
	User moves mouse over the object



	MouseEvent.CLICK
	User clicks on object




Note: Technically speaking these are actually event properties
(see the ActionScript 3 event
handling tutorial if you want to know more).

[bookmark: ActionScript_tricks]
5.2 ActionScript tricks

Playing movie clips: Movie clips symbols are embedded
Flash animations.


	To edit: Double click on the symbol on the stage (to see the
context) or in the library (to work with an empty background)

	To create

	CTRL-F8 to create a new empty movie clip

	Right-click->Create Movie Symbol; 'Movie Clip on a
graphic to transform it





	To play an stop a movie clip instance called "movie_books"




movie_books.stop();
movie_books.play();


Making objects visible/invisible, works with any display
object but you should work with an object that you can name, i.e. a
symbol instance.


	If you have an object called cat:




cat.visible = true;
cat.visible = false;


Moving position of an object, works with any display
object


	If you have an object called cat you can set both its x
and y position. x starts from the left and y means "down".
Therefore, x=0 y=0 means the upper left corner of the stage.



Example - position cat at x is 100 and y is 200 pixels:


cat.x = 100; cat.y = 200;


Example - add 50 px to cat's current position


cat.x += 50; cat.y += 50;


Resize an object, works with any display object


	If you have an object called cat:



Example, cat will be 100 px wide and 120px tall


cat.width = 100;
cat.height = 120;


Example, cat will double its size. Expression below means, set
cat.width to old cat.width times 2.


cat.width =  cat.width * 2;
cat.height = cat.height * 2;


Dragging an object, works with any interactive object


	If you have an object called cat, you can start/stop
dragging. Usually these are bound to MOUSE_DOWN and MOUSE_UP.




cat.startDrag();
cat.stopDrag();


Moving around in the timeline. You can either go to a
frame and play it (until it encounters a stop) or go there and
stop.

If you want to go to frame 12 of the same scene:


gotoAndPlay(12);
gotoAndStop(12);


If you want to go to frame 13 of a scene called "test":


gotoAndPlay(13,"test");
gotoAndStop(13,"test");


[bookmark: Links]
6 Links

[bookmark: Important_manual_pages]
6.1 Important manual
pages

These are almost impossible to understand for non programmers,
but otherwise the documentation at Adobe is excellent.


	InteractiveObject. This InteractiveObject class
is the abstract base class for all display objects with which the
user can interact, using the mouse and keyboard. Most Events are
documented here. (Make sure to list also the inherited
events).




	DisplayObject Describes the display object, e.g.
properties you can change. Note that there are additional
properties for each specific kind of objects, i.e. see the class hierarchy described
in the Flash ActionScript 3 Overview.



[bookmark: Clip_Art]
6.2 Clip Art


	Free Clip Art. Original cat and dog




	Open Clip Art
Library. The grey mouse and the original rocket.



Flash drag and drop tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !




	Page created by Daniel K. Schneider, 28 September
2007

	Last 
modified by Daniel K. Schneider, 22 April
2009
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1 Overview

Dragging and dropping objects is a popular brick in edutainment
programs. This is part of Flash CS3
tutorials. It is probably not suitable for Flash designers without
any programming experience.


	Learning goals

	Learn how to create simple drag and drop programs with Flash 9
(CS3) components

	Learn a little bit of Action Script 3




	Prerequisites

	Flash CS3 desktop tutorial

	Flash drawing tutorial

	Flash layers tutorial

	flash button tutorial

	ActionScript 3
interactive objects tutorial




	Moving on

	The Flash article has a list of other tutorials.

	Flash Video component
tutorial




	Quality

	This text should technical people get going and may not be good
enough for self-learning beginners. It can be used as handout in a
"hands-on" class. That is what Daniel K. Schneider made it
for...

	Level

	It aims at beginners. More advanced features and tricks are not
explained here.




	Learning materials



Grab the various *.fla files from here:


	http://tecfa.unige.ch/guides/flash/ex/drag-and-drop-intro/



Tip: This page contains more code than screen dumps. You should
download the source code and play with it.


	The executive summary




	Draw something on the canvas

	Transform it to a movie symbol (buttons don't work)

	Assign an instance name

	Instance_name.startDrag()

	Instance_name.stopDrag()

	Test if the object sits over another object (target) and then
script some action.



[bookmark: Introduction_-_simple_dragging_code]
2 Introduction - simple dragging
code


	Step 1 - Draw an object




	Anything you like




	Step 2 - Transform it into a Movie Clip




	Select all if you got several objects, then assemble maybe

	Right-click on the object

	Give it a name in the properties panel !




	Step 3 - Adapt code below




[image: Most simple drag and drop]



Most simple drag and drop






// Register mouse event functions
blue_btn.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
blue_btn.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);

red_btn.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
red_btn.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);

// Define a mouse down handler (user is dragging)
function mouseDownHandler(evt:MouseEvent):void {
        var object = evt.target;
        // we should limit dragging to the area inside the canvas
        object.startDrag();
}

function mouseUpHandler(evt:MouseEvent):void {
        var obj = evt.target;
                obj.stopDrag();
}



	Results




	Admire the result

	Get the source from http://tecfa.unige.ch/guides/flash/ex/drag-and-drop-intro/
(files flash-cs3-drag-and-drop-intro.*)



[bookmark: Drag_and_drop_over_another_object]
3 Drag and drop over another
object

The goals is to write a little Flash application that will tell
the user whether he correctly dragged and dropped an object over
another one.


	Step 1 - Start from the file above




	I.e. we want to have the user drag the red circle over the blue
rectangle.




	Step 2 - Add a text box



This textbox should initially display instruction, then display
feedback: "made it" and "missed".


	Use the Textool in the tools panel to enter the text.

	Then in the properties panel, change the type to Dynamic
Text.




[image: Dynamic Text]
Dynamic Text






	Step 3 - Action script code




// Register mouse event functions
blue_btn.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
blue_btn.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);

red_btn.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
red_btn.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);

// Define a mouse down handler (user is dragging)
function mouseDownHandler(evt:MouseEvent):void {
        var object = evt.target;
        // we should limit dragging to the area inside the canvas
        object.startDrag();
}

function mouseUpHandler(evt:MouseEvent):void {
        var obj = evt.target;
        // obj.dropTarget will give us the reference to the shape of
        // the object over which we dropped the circle.
        var target = obj.dropTarget;
        // If the object exists AND it is the blue button, then we change
        // the text in the TextBox. 
        // Since obj.dropTarget is a Shape, we need its parent.
        if (target != null && target.parent == blue_btn)
        {
                textField.text = "Made it !!";
        }
        else
        {
                textField.text = "Missed :(";
        }
        obj.stopDrag();
}




	Results




	Admire the result

	Get the source from http://tecfa.unige.ch/guides/flash/ex/drag-and-drop-intro/
(files flash-cs3-drag-and-drop-intro2.*)




	Improvements to be made




	Styling of the textbox: You can do this with the filters panel.
Click on the + sign to add filters and then play around with the
options.

	Move the red circle back to its initial position

	Special effects maybe
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4 Drag and match learning application
- dumb version

The goal is to move objects to a textbox containing the first
letter of its name. E.g. "Cat" should be moved to the "C" box. If
there is a hit, the user will get some success message and can't
move the object anymore. If he is done, he should get an extra
message.


	Step 1 - Create movie clips for object to be moved




	As above with the red and blue circle

	Each object should have an instance name




	Step 2 - Create textboxes




	Also as above

	Create one for each object (E.g. a "C" for the cat, etc.)

	Make sure they are dynamic and they have a name.




	Step 3 - Foreground/Background



Make sure that the textboxes are in the background or the movie
clips in the foreground. Otherwise a dropped object will not find
its target.


	Select all the movie clips, then
right-click->Arrange->Bring to Front.




	Step 3 - Write Action Script code



Code below is fairly awful since it lacks abstraction, but it
has the advantage to use a minimal variety of AS3.


var hits = 0;

// Register mouse event functions

dog.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
dog.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
rocket.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
rocket.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
cat.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
cat.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
bat.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
bat.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);

// Define a mouse down handler (user is dragging)
function mouseDownHandler(evt:MouseEvent):void {
        var object = evt.target;
        // we should limit dragging to the area inside the canvas
        object.startDrag();
}

function mouseUpHandler(evt:MouseEvent):void {
        var obj = evt.target;
        // obj.dropTarget will give us the reference to the shape of
        // the object over which we dropped the circle.
        var target = obj.dropTarget;
        // If the target object exists the we ask the test_match function
        // to compare moved obj and target where it was dropped.
        if (target != null)
        {
                test_match(target, obj);
        }
        obj.stopDrag();
}

function test_match(target,obj) {
        // test if either one of the four pairs match
        if ( (target == box_c && obj == cat) ||
             (target == box_d && obj == dog) ||
             (target == box_r && obj == rocket) ||
             (target == box_b && obj == bat) )
        {
                // we got a hit
                hits = hits+1;
                textField.text = "Yes ! You got one !";
                // make the object transparent
                obj.alpha = 0.5;
                // kill its event listeners - object can't be moved anymore
                obj.removeEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
                obj.removeEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
                // Test if we are done
                if (hits == 4)
                {
                        textField.text = "Made it !!";
                }
        }
        else
        {
                textField.text = "Missed :(";
        }
}



	Results




	Look at the result

	Get the source from http://tecfa.unige.ch/guides/flash/ex/drag-and-drop-intro/
(files flash-cs3-drag-and-drop-matching.*)



[bookmark: Drag_and_match_learning_application_-_better]
5 Drag and match learning application
- better

Instead of writing an application just for four matching pairs,
we can write code that is more general. This code only needs slight
modifications to adapt to other named instances and text boxes and
you can insert as little/many pairs you like. Just make sure that
the target textboxes are in the background.

Btw this is the first AS3 code that includes a tiny bit of
programming I ever made (I probably also should type variables but
then I am not a real programmer ....)



var dict = new Dictionary ();

// =================== START USER Config =====================
// Insert as many "dict[text_box] = movie;" statements you like
//  Replace: text_box by the name of a matching dynamic text_box
//           movie by the name of movie instances users can move around.

dict[box_c] = cat;
dict[box_d] = dog;
dict[box_r] = rocket;
dict[box_b] = bat;
dict[box_a] = apple;

// Do NOT change/delete any other line. Also make sure to respect
// the syntax, e.g. dont forget the ";" at the end of each line.
// ===================== END USER Config ==================== 

var hits = 0; // counts succesful hits
var max = 0;  // used to compute dictionary length

// For each item in the dictionary we add event listeners
// "for each" will loop through the values ... not the keys

for each (var item in dict)
{
        item.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
        item.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
        item.buttonMode = true; //needed for the hand cursor to work
        max = max + 1;
}


// Define a mouse down handler (user is dragging)
function mouseDownHandler(evt:MouseEvent):void {
        var object = evt.target;
        // we should limit dragging to the area inside the canvas
        object.useHandCursor = true;
        object.startDrag();
}

function mouseUpHandler(evt:MouseEvent):void {
        var obj = evt.target;
        // obj.dropTarget will give us the reference to the shape of
        // the object over which we dropped the circle.
        var target = obj.dropTarget;
        // If the target object exists the we ask the test_match function
        // to compare moved obj and target where it was dropped.
        if (target != null)
        {
                test_match(target, obj);
        }
        obj.stopDrag();
}

function test_match(target,obj) {
        // test if the pairs match
        if (dict[target] == obj)
        {
                // we got a hit
                hits = hits+1;
                textField.text = "Yes ! You got one !";
                // make the object transparent
                obj.alpha = 0.5;
                // kill its event listeners - object can't be moved anymore
                obj.removeEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
                obj.removeEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
                // Test if we are done
                if (hits == max)
                {
                        // here we should play an animation
                        textField.text = "Made it !!";
                }
        }
        else
        {
                textField.text = "Missed :(";
        }
}



	Results




	Look at the result

	Get the source from http://tecfa.unige.ch/guides/flash/ex/drag-and-drop-intro/
(files flash-cs3-drag-and-drop-matching-2.*)




	Improvements to be made




	Make it more flashy when there is a hit / miss and when it's
over.

	Add sound. A child can not read instructions, but a parent
could tell :)

	Move the object back to its origin when there is a miss.



[bookmark: Drag_and_match_learning_application_-_still_better]
6 Drag and match learning application
- still better

Our last version for now includes some more features.


	It has sound (though the initial "talk" is missing)

	Objects go back where they came from




// Daniel K. Schneider - TECFA - sept 2007
// Copyright: See http://edutechwiki.unige.ch/en/

var dict = new Dictionary ();

// =================== START USER Config =====================
// Insert as many "dict[text_box] = movie;" statements you like
//  Replace: text_box by the name of a matching dynamic text_box
//           movie by the name of movie instances users can move around.

dict[box_c] = cat;
dict[box_d] = dog;
dict[box_r] = rocket;
dict[box_b] = bat;
dict[box_a] = apple;

// Do NOT change/delete any other line. Also make sure to respect
// the syntax, e.g. dont forget the ";" at the end of each line.
// ===================== END USER Config ==================== 

// Sound
// should I preload this somehow ?

var request:URLRequest = new URLRequest("applause_3.mp3");
var applause:Sound = new Sound();
applause.load(request);

var request2:URLRequest = new URLRequest("music.mp3");
var music:Sound = new Sound();
music.load(request2);

var request3:URLRequest = new URLRequest("baby_laugh.mp3");
var laugh:Sound = new Sound();
laugh.load(request3);

// Drag and match code
var hits = 0; // counts succesful hits
var max = 0;  // used to compute dictionary length

var ori_x;
var ori_y;

// For each item in the dictionary we add event listeners
// "for each" will loop through the values ... not the keys

for each (var item in dict)
{
        item.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
        item.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
        max = max + 1;
        item.buttonMode = true;
}


// Define a mouse down handler (user is dragging)
function mouseDownHandler(evt:MouseEvent):void {
        var object = evt.target;
        ori_x = object.x
        ori_y = object.y
        object.useHandCursor = true;
        object.startDrag();
}

function mouseUpHandler(evt:MouseEvent):void {
        //stop all sounds
        SoundMixer.stopAll();
        var obj = evt.target;
        // obj.dropTarget will give us the reference to the shape of
        // the object over which we dropped the circle.
        var target = obj.dropTarget;
        // If the target object exists the we ask the test_match function
        // to compare moved obj and target where it was dropped.
        if (target != null)
        {
                test_match(target, obj);
        }
        obj.stopDrag();
}


function test_match(target,obj) {
        // test if the pairs match
        if (dict[target] == obj)
        {
                // we got a hit
                hits = hits+1;
                textField.text = "Yes ! You got one !";
                applause.play();
                // make the object transparent
                obj.alpha = 0.5;
                // kill its event listeners - object can't be moved anymore
                obj.removeEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
                obj.removeEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
                // Test if we are done
                if (hits == max)
                {
                        textField.text = "Made it !!";
                        music.play(0,5);
                }
        }
        else
        {
                obj.x = ori_x;
                obj.y = ori_y;
                textField.text = "Missed :(";
                laugh.play();
        }
}




	Results




	Look at the result

	Get the source from http://tecfa.unige.ch/guides/flash/ex/drag-and-drop-intro/
(files flash-cs3-drag-and-drop-matching-3.*)




	Improvements to be made




	Add a restart button

	Rewrite this as an ActionScript 3 application that would take
random pairs and play several scenes

	The word of an object should be told aloud when the user picks
it up

	etc ....



[bookmark: Reference]
7 Reference

I may move these to some other article sometimes soon.

[bookmark: Sprites_and_DisplayObjects]
7.1 Sprites and
DisplayObjects

Objects that you can drag around are Movie Clips. These are
children of Sprites. Sprites have associated graphics.

From the ActionScript 3.0 Language and Components
Reference:

The class hierarchy looks like this: MovieClip -> Sprite -> DisplayObjectContainer -> InteractiveObject -> DisplayObject -> EventDispatcher -> Object

When you drop a sprite over another sprite, the Flash will give
the shape of the target object. This shape is a DisplayObject and
from a DisplayObject we can get its parent, i.e. a Movie Clip in
our case.

Important: When you look at the definition of Class, there are
buttons to open inherited properties and methods. Mostly likely
you need these.

[bookmark: Event_Listener_Interface]
7.2 Event Listener
Interface

Movie clips can use normal Event Handling:


	EventDispatcher (Adobe AS3 reference)



[bookmark: Graphics]
7.3 Graphics


	Graphics (Adobe AS3 reference)



[bookmark: Dictionaries]
7.4 Dictionaries


	AS3: Dictionary Object (gskinner.blog)



[bookmark: TextFields]
7.5 TextFields

The TextField class is used to create display objects for text
display and input.


	TextField (Adobe AS3 reference)




	Basics of working with text - for
designers.



[bookmark: Sounds]
7.6 Sounds


	Sound (Adobe AS3 reference)




	SoundMixer (Adobe AS3 reference)
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8 Tutorials


	Drag and Drop in ActionScript 3.0 A very easy to
follow tutorial on how to implement drag and drop in AS3 by
MonkeyFlash.com. FLA file provided.



Flash using ActionScript libraries tutorial


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !




	Page created by Daniel K. Schneider, 28 September
2007

	Last 
modified by Daniel K. Schneider, 22 April
2009





This entry is part of the Flash tutorials.

[bookmark: Introduction]
1 Introduction



	Learning goals




	Learn how to reuse example code that illustrate features of
ActionScript libraries.

	Learn how to be able to import 3rd party packages by defining
an ActionScript classpath.




	Prerequisites




	Basic interactivity, i.e. some very limited ActionScript 3
coding experience. See for example the Flash button tutorial or the Flash component button
tutorial and theFlash embedded movie
clip tutorial.

	In addition, you also could start from "pure" Actionscript 3 coding (but we will
provide no explanations here for flex style development...)




	Environment




	Flash CS3




	Moving on




	See the Flash tutorials.




	Level and target population




	Beginners (but see the prerequisites)




	Quality




	useable, but under progress.




	To Do




	Other examples





There exist several free high quality ActionScript libraries
available and that can be used by Flash designers that only possess
very little programming skills.

Typical examples of such libraries are:


	Flash 3D libraries that allow a CS3 developer to
create animated and interactive 3D scenes.

	Special purpose animation libraries like the FLiNT particle
system that allows you to create stuff like fireworks and
snowflakes.

	Tweening libraries like TweenLite that allow you to define sophisticated
animations with a few method calls (instead of spending hours of
drawing).



[bookmark: The_FliNT_particle_system]
2 The FliNT particle
system

“Flint is an open-source project to create a
versatile particle system in ActionScript 3. The aim is to create a
system that handles the common functionality for all particle
systems, has methods for common particle behaviour, and lets
developers extend it easily with their own custom behaviours
without needing to touch the core code. ([1])”. That may sound very technical
and it actually is. Such libraries are meant primarily for "real"
ActionScript programmers. However, Flash designers with a little
bit of ActionScript programming know-how can also use such code. In
particular, they simply may slightly adapt the excellent examples
that are for download.

Flint is developed by Richard Lord and is released under the free open
source MIT licence.

Firstly have a look at what this particle system can do. Cool
isn't it ?

[bookmark: Let.27s_snow]
2.1 Let's snow

You might want snowflakes. Creating a nice snowing animation
with lots of snowflakes by drawings would be very tedious
and programming them yourself is a bit difficult (unless you are a
"real" programmer). You now have two options:


	Finding some special purpose snowflakes code on the web

	There is for example the Creating Falling Snowflakes in Flash Using ActionScript
2 video tutorial. We also have a flying kites example in the
Flash embedded movie
clip tutorial that you could repurpose.





	Using a more general purpose library that will create the whole
animation (including the snowflakes), something that you will learn
now. Basically we just copy/paste the code from Introducing Flint with a snow effect. Or more
precisely we took the example code from the downloaded Flint_2_0_0_b_examples.zip on oct 23, 2008 and
made 2-3 tiny modifications.




	Step 1 - download the FliNT particle system



So, get FliNT from http://flintparticles.org/. I took:


	Flint_2_0_0_b.zip



... At the present time, there may be a more recent version.
E.g. a 2.0 final.

You also may download extra stuff, e.g.


	Flint_2_0_0_b_examples.zip

	Flint_2_0_0_b_docs.zip



Dezip these three archives in a new directory.

Now since we are interested in snowflakes were are actually
really lucky. There is both example code (in the example zip file)
and a nice Introducing Flint with a snow effect tutorial made
by Richard Lord the author of the Flint system.


	Step 2 - create a new Flash (ActionScript 3.0) file




	Create a new directory for this project

	Make sure that you really use ActionScript 3.0, else change
that in the File->PublishSettings - Flash tab too.

	If you want you can the "src" sub-directory of the Flint system
to the root of this new directory and rename it to something like
"flint"




	Step 3 - Fix the classpath




	Open the File->Publish Settings - Flash tab

	Then click on the Settings ... button next to the
ActionScript version. You should see something like this now:




[image: Setting the classpath in Flash CS3]



Setting the classpath in Flash CS3







In these ActionScript 3.0 settings, you then have to add the name
of the subdirectory where the flint system sits.


	If you copied the FliNT system "src" directory to the same
directory and renamed it, click on the "+" sign and e.g. type
"./flint" (not tested)

	If you you didn't, then click on the "target" "Browse to Path"
icon and select the "src" directory of the FliNT system
(recommended since I did this)



Basically, what you have to understand at this point is that
your application has to know in which directory to look for the
FliNT code. The "org" subdirectory must be a direct sub-directory
of the classpath directory you just defined. If you want to
understand more about packages and classes you'll have to dig
fairly deeply into ActionScript programming, something we will not
do here ...


	Step 4 - Create a frame for which you want snowfall.




	Firstly you need a typical winter scene, e.g. a nice photo,
such as the one that you can see in the original example made by Richard Lord. A local copy of the
swf is here).



Personally, I'd like to have some snow in my Office as you can
see in our own version. So firstly we need to import a
picture. I made the orginal much darker with higher contrasts in
order to be able to see the snowflakes. It may be too dark on your
screen, but on my DELL M1730 laptop it looks just fine.


	This picture is now in frame one of layer 1. Rename the layer
to picture.

	Add a new layer and call it script.




	Step 5 - Add the Action Script




	Click in frame 1 of the script layer, hit F9 and copy/paste the
following code. You also must include the copyright notice. I
believe that we really are lucky to be able to use such
libraries. So please, be respectful !




/*
 * FLINT PARTICLE SYSTEM
 * .....................
 * 
 * Author: Richard Lord
 * Copyright (c) Big Room Ventures Ltd. 2008
 * http://flintparticles.org/
 * 
 * Licence Agreement
 * 
 * Permission is hereby granted, free of charge, to any person obtaining a copy
 * of this software and associated documentation files (the "Software"), to deal
 * in the Software without restriction, including without limitation the rights
 * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
 * copies of the Software, and to permit persons to whom the Software is
 * furnished to do so, subject to the following conditions:
 * 
 * The above copyright notice and this permission notice shall be included in
 * all copies or substantial portions of the Software.
 */

import org.flintparticles.common.counters.*;
import org.flintparticles.common.displayObjects.RadialDot;
import org.flintparticles.common.initializers.*;
import org.flintparticles.twoD.actions.*;
import org.flintparticles.twoD.emitters.Emitter2D;
import org.flintparticles.twoD.initializers.*;
import org.flintparticles.twoD.renderers.*;
import org.flintparticles.twoD.zones.*;

// We keep the same here - unlike the original
// addChild( new SnowBackground() );

var emitter:Emitter2D = new Emitter2D();

emitter.counter = new Steady( 150 );

emitter.addInitializer( new ImageClass( RadialDot, 2 ) );
// Modified DKS - our picture is a bit larger
// emitter.addInitializer( new Position( new LineZone( new Point( -5, -5 ), new Point( 605, -5 )) ) );
emitter.addInitializer( new Position( new LineZone( new Point( -5, -5 ), new Point( 645, -5 ) ) ) );
emitter.addInitializer( new Velocity( new PointZone( new Point( 0, 65 ) ) ) );
emitter.addInitializer( new ScaleImageInit( 0.75, 2 ) );

emitter.addAction( new Move() );
// Modified DKS - our picture is a bit larger
// emitter.addAction( new DeathZone( new RectangleZone( -10, -10, 620, 420 ), true ) );
emitter.addAction( new DeathZone( new RectangleZone( -10, -10, 645, 485 ), true ) );
emitter.addAction( new RandomDrift( 20, 20 ) );

var renderer:DisplayObjectRenderer = new DisplayObjectRenderer();
renderer.addEmitter( emitter );
addChild( renderer );

emitter.start();
emitter.runAhead( 10 );

// We keep the same here - unlike the original
// addChild( new SnowForeground() );


That was really easy. We just took the code from the Flint_2_0_0_b_examples.zip archive and made 2
little modifications. We only use a single background and commented
out 2 lines. Also, we changed two parameters since our picture is a
bit bigger.


	Step 6 - Error messages ?



If you see something like this:


Scene1, Layer 'Script', Frame 1, line 22 
1172: Definition org.flintparticles.common.counters could not be found.


then you most likely got your classpath definition wrong. See
above !

If it isn't snowing all over your picture, then you will have to
adjust 2 lines in the AS3 code. Figure it out yourself by looking
at our inserted comments in the AS code above. Also you should get
the DeathZone right. This is a hidden area underneath the picture
where the falling down flakes are killed.


	Result and source code



The result: flint-snowflakes.html

Get the flint-snowflakes.fla file from http://tecfa.unige.ch/guides/flash/ex/flint/, but
please recall that you will have to set the classpath for the FLiNT
library. It will not work "as is" !


	Want to understand a bit more ?



Read the Introducing Flint with a snow effect tutorial made
by Richard Lord.

Our only contribution was to add some explanations on how to
define a classpath, i.e. the very basics about how to reuse such an
example and which R.L. doesn't explain (since he made this library
for programmers and not designers in the first place).

[bookmark: Burning_Logos]
2.2 Burning Logos

Something else you can with this particle system is to create
burning Logos, e.g. something that symbolizes how hot the master program you should join is.

The example below is just a adaptation of the example
distributed in the Downloads. You also can look at the maybe
different online version of the burning Flint Logo.

To create your own burning logo you need two things:


	A *.png file with a logo. This file must have the following
properties

	Background color should be Alpha channel. In GIMP for example,
menu Colors->Color to Alpha, then select the color, e.g.
white if your drawing is orange on white. Else your whole picture
will burn.

	Color of the letters should be orange (FF9900) unless you make
more changes to the code.





	A "fireblob", i.e. a small graphic with a radial color gradient
(see the Flash colors tutorial). You can just
copy the one that you will find in the source code of this
example.




	Step 1 - Import logo and the fireblob to your library




	Create a logo and put in the library (just the drag the png
from the file explorer into the library)

	Copy the blob from our fla file




	Step 2 - Make these linkable classes




	This is already done for the fireblob

	Right click on the icon of the *.png bitmap in the library and
select linkage

	Type "Logo" (not LOGO or anything else) and check "Export for
ActionScript" then hit OK




 Class: Logo


You now should have a setup that looks like this (minus the fire
log which we shall create below). Enlarge the picture below if you
can't make out the details.


[image: Setting up a linkage property for the Logo to set on fire]



Setting up a linkage property for the Logo to set on fire









	Step 3 - Copy some ActionScript code and make a few
adjustments




	Click on Frame 1 and hit F9, then paste the code you will find
below



You then have to make adjustments where I inserted comments:


	Set the size of the Logo (just look it up in the properties of
the graphic in the library)




var bitmapData:BitmapData = new Logo( 332, 99);



	Position the Logo, wherever you want it to be




bitmap.x = 35;
bitmap.y = 35;



	Position the Fires, should be the same as above




emitter.x = 35;
emitter.y = 35;


Code to copy/paste:


/*
 * FLINT PARTICLE SYSTEM
 * .....................
 * 
 * Author: Richard Lord
 * Copyright (c) Big Room Ventures Ltd. 2008
 * http://flintparticles.org/
 * 
 * Licence Agreement
 * 
 * Permission is hereby granted, free of charge, to any person obtaining a copy
 * of this software and associated documentation files (the "Software"), to deal
 * in the Software without restriction, including without limitation the rights
 * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
 * copies of the Software, and to permit persons to whom the Software is
 * furnished to do so, subject to the following conditions:
 * 
 * The above copyright notice and this permission notice shall be included in
 * all copies or substantial portions of the Software.
 * 
 */

import org.flintparticles.common.debug.*;
import org.flintparticles.common.actions.*;
import org.flintparticles.common.counters.*;
import org.flintparticles.common.displayObjects.RadialDot;
import org.flintparticles.common.initializers.*;
import org.flintparticles.twoD.actions.*;
import org.flintparticles.twoD.emitters.Emitter2D;
import org.flintparticles.twoD.initializers.*;
import org.flintparticles.twoD.renderers.*;
import org.flintparticles.twoD.zones.*; 
import org.flintparticles.common.energyEasing.TwoWay;

// Look up the dimensions of your logo (Right-click in the library->Properties)
var bitmapData:BitmapData = new Logo( 332, 99);
var bitmap:Bitmap = new Bitmap();
bitmap.bitmapData = bitmapData;
addChild( bitmap );
// Position the bitmap graphic on the scene
bitmap.x = 35;
bitmap.y = 35;

var emitter:Emitter2D = new Emitter2D();
emitter.counter = new Steady( 600 );

emitter.addInitializer( new Lifetime( 0.8 ) );
emitter.addInitializer( new Velocity( new DiscSectorZone( new Point( 0, 0 ), 10, 5, -Math.PI * 0.75, -Math.PI * 0.25 ) ) );
emitter.addInitializer( new Position( new BitmapDataZone( bitmapData ) ) );
emitter.addInitializer( new ImageClass( FireBlob ) );

emitter.addAction( new Age( TwoWay.quadratic ) );
emitter.addAction( new Move() );
emitter.addAction( new Accelerate( 0, -20 ) );
emitter.addAction( new ColorChange( 0xFFFF9900, 0x00FFDD66 ) );
emitter.addAction( new ScaleImage( 1.4, 2.0 ) );
emitter.addAction( new RotateToDirection() );

var renderer:BitmapRenderer = new BitmapRenderer( new Rectangle( 0, 0, 500, 200 ) );
renderer.addEmitter( emitter );
addChild( renderer );

// The fire must be in the same position as the bimap
emitter.x = 35;
emitter.y = 35;
emitter.start( );



	Step 4 - Admire the result and play with the source code




	the result

	The source code: flint-firelogo.fla

	Other files are also in the same http://tecfa.unige.ch/guides/flash/ex/flint/
directory.




	Step 5 - Change colors



Maybe you may rather want to demonstrate how burning cool your
institutions is. All you need to do is make a Logo in blue and then
change a line in the AS3 code.

To change the color of the fire emitter, you have to understand
that the ColorChange class wants 2 arguments: The color of Logo and
the color of the bright parts of the flames. That being said, you
can use any colors you want of course. So we change this orange
fire:


 emitter.addAction( new ColorChange( 0xFFFF9900, 0x00FFDD66 ) );


into a blue cool fire:


 emitter.addAction( new ColorChange( 0xFF0000FF, 0x00DDFFFF ) );



	the result

	The source code: flint-blue-fire-logo.fla




	Step 6 - reuse these logos as movie clips



In principle you should be able to import *.swf "movies" to the
library and then use them like internal movie clips, but I wasn't
able to import these into the library for a reason I don't
understand yet (Flash doesn't give any feedback, it just doesn't
import).

Instead I'll show you how to have multiple Logos on fire within
a same Flash file. All you need is to create embedded movie clips
for each Logo and then attach an AS3 script to each of these. See
the Flash embedded movie
clip tutorial if don't know how to create embedded movie
clips.

Some hints (for the rest, please dig into the fla file
below):


	Registration point of the embedded movie clips should be in the
upper left

	x and y coordinates for the fire animation should be 0 (see the
AS3 code in the Fla file)

	Also in one AS code the Class representing the Bitmap was
renamed to Logo2. This also requires a change in one of the
scripts.



Results:


	the result

	The source code: flint-fire-ad.fla



Of course, this needs some tuning, e.g. it's too fast and the
frame rate is too low and it's otherwise ugly. Anyhow, I wouldn't
join a degree program that banks on the effect of a Flash
Logo ;)

[bookmark: Playing_around_with_the_other_FliNT_examples]
2.3 Playing around with the other
FliNT examples

The Flint examples all come in two versions, either Flash or
PureAS3. Go for the Flash version (unless you want to learn how to
play with Flex in which case you will have to start reading the
Adobe Flex and AS3 Compiling a program tutorials in
this wiki).

The Flash version examples usually have just a single line in
the script code that you insert in frame 1:


include Frame1.as


This instruction simply includes the contents of the file
"Frame1.as" that you will find in the same directory. In our
examples above we just copy/pasted the contents of these *.as files
into the AS script. The result is the same, but the strategy of
including an *.as file is smarter if you plan to reuse your code
and if your prefer to use a different editor. We included the code
in the *.fla for the simple reason that this way you only need to
grab a single file.

To play with the examples in the Flash CS3 environment, the only
thing you will have to do is to open the respective *.fla and then
fix the classpath, i.e. tell Flash where the Flint_xxxx/src
directory is located. E.g. if you need a firework, open in CS3
the


Flint_2_0_0_b_examples/examples2D/Firework/Flash/Firework.fla


Then fix the classpath as described in the Let's snow example

Finally hit CTRL-Enter or publish.

Notice: The resulting swf always will include all the necessary
ActionScript code, i.e. you won't have to copy the Flint files to
the server.

[bookmark: TweenLite]
3 TweenLite

TweenLite, TweenFilterLite and TweenMax are tweening
libraries

See AS3 TweenLite tweening
engine. For the moment it's more of a cheat sheet, but there
are 1-2 examples.

[bookmark: A_note_one_classes_and_packages]
4 A note one classes and
packages

All ActionScript code that you will import is defined with
classes (see the Actionscript 3 tutorials if you really
want to learn how programming works.). Theses classes can then be
bundled together in so-called packages which allows to organize
code into discrete groups that can be imported by other scripts.
E.g.


package packageName {
   class someClassName { 
   } 
}


More information about setting the Class path can be found at
Adobe, i.e. here and here in the "Using Flash documentation".

More information about packages can be found in Adobe's Packages and namespaces chapter in the Programming ActionScript 3.0 tutorial which is
very technical.

Flash CS3 keyboard shortcuts



Authors: Daniel K. Schneider (TECFA) and
Marielle Lange
(WidgEd)

This page contains the most important Flash CS3
keyboard shortcuts. There may be some mistakes and omissions for
now (e.g. programming/debugging is not covered). Table size
optimized for Mozilla/Windows.



	[bookmark: The_useful_list]
1 The useful list

Standard windows commands not shown here




	F5 - Add simple frame

	F6 - Add new Keyframe

	F7 - Add blank Keyframe

	CTRL+ENTER - Test a Movie






	F9 - Action Panel

	F4 - Show/Hide All Panels

	F10 - Keystroke Menu command mode



[bookmark: Tools_Panel]
2 Tools Panel

While drawing on the stage you quickly can change tools that
way.




	V - Selection Tool

	A - Sub Selection Tool

	Q - Free Transform tool

	F - Gradient Transform Tool

	L - Lasso Tool






	P - Pen Tool

	N - Line Tool

	T - Text Tool

	R - Rectangle Tool

	O - Oval Tool

	Y - Pencil Tool

	B - Paint Brush






	S - Ink Bottle

	K - Paint Bucket

	I - EyeDropper

	D - Dropper

	E - Eraser






	H - Hand Tool

	M,Z - Magnifier (Zoom)




	[bookmark: Modifying_and_editing]
3 Modifying and editing




	CTRL+G - Group

	CTRL+SHIFT-G - Ungroup

	CTRL+B - Break Apart






	CTRL+A - Select All

	CTRL+SHIFT+A - Deselect All

	CTRL+C - Copy

	CTRL+V - Paste

	CTRL+SHIFT+V - Paste in Place

	CTRL+D - Duplicate






	CTRL+SHIFT+O - Optimize Curves






	CTRL+T - Modify Font

	CTRL+SHIFT+T - Modify Paragraph

	CTRL+left Arrow - Narrower Letter Spacing (kerning)

	CTRL+right Arrow - wider Letter Spacing (kerning)






	CTRL+SHIFT+9 - Rotate 90° Clockwise

	CTRL+SHIFT+7 - Rotate 90° Counter clockwise

	CTRL+SHIFT+Z - Remove Transform






	CTRL+ALT+S - Scale and Rotate

	CTRL+SHIFT+Z - Remove Transform



[bookmark: Arranging]
4 Arranging


	CTRL+Up Arrow - Move Ahead

	CTRL+Down Arrow - Move Behind

	CTRL+SHIFT+Up Arrow - Bring to Front

	CTRL+SHIFT+Down Arrow - Send to Back






	CTRL+ALT+1 - Left Align

	CTRL+ALT+2 - Horizontal Center

	CTRL+ALT+3 - Right Align

	CTRL+ALT+4 - Top Align

	CTRL+ALT+5 - Vertical Center

	CTRL+ALT+6 - Bottom Align

	CTRL+ALT+7 - Distribute Widths

	CTRL+ALT+9 - Distribute Heights

	CTRL+ALT+SHIFT+7 - Make Same Width

	CTRL+ALT+SHIFT+9 - Make Same Height

	CTRL+ALT+8 - Set "Align to stage"
















	[bookmark: Windows_and_Panels]
5 Windows and Panels

Open/close various Panels




	F1 - Help

	F4 - Show/Hide Panels

	CTRL+K - Align Panel

	CTRL+T - Transform

	SHIFT+F9 - Color Mixer

	CTRL+F9 - Color Swatches

	CTRL+L - Show/Hide Library

	F9 - Actions





If your screen is big enough you won't need these a lot ...


	CTRL+F3 - Properties Inspector

	CTRL+F2 - Tools Panel

	CTRL+ALT-T - Timeline

	CTRL+M - Modify Movie Properties

	CTRL+E - Toggle between Edit Movie& Edit Symbol Mode

	CTRL+SHIFT+L - Show/Hide Timeline

	CTRL+SHIFT+W - Show/Hide Work Area





[bookmark: Frames_and_Symbols]
6 Frames and Symbols

(most of the time, position first inside the timeline)




	F5 - Add frame (extend the timeline)

	SHIFT+F5 - Delete Frame

	F6 - Add Key Frame (and copy over old contents)

	SHFIT-F6 - Clear Key Frame

	F7 - Add Blank Key Frame (and leave the stage empty)






	F8 - Turn into Symbol

	CTRL+F8 - Make new Symbol






	CLICK DRAG - Move keyframe (Select, release - then
drag !)

	CTRL-DRAG - Select several Frames




	[bookmark: Timeline]
7 Timeline




	Enter - Play Movie

	CTRL+0 (zero) - Rewind Movie

	< - Previous Frame

	> - Next Frame






	CTRL+ENTER - Test Movie

	CTRL+SHIFT+ENTER - Debug Movie






	Home - Goto First Scene

	End - Goto Last Scene

	Page Up - Goto Previous Scene

	Page Down - Goto Next Scene





[bookmark: Files]
8 Files




	CTRL+N - New File

	CTRL+O - Open File

	CTRL+S - Save File






	CTRL+R - Import Image/Sound/etc...

	CTRL+SHIFT+O - Open as Library






	SHIFT+F12 - Publish

	CTRL+SHIFT+R - Export to .swf/.spl/.gif/etc...





[bookmark: View]
9 View




	CTRL+1 - View movie at 100% size

	CTRL+2 - Show Frame

	CTRL+3 - Show All





[bookmark: Generate_shortcut_table]
10 Generate shortcut
table


	Menu Edit->Keyboard shortcuts

	Click on the little icon on top right (Export Set as HTML).
This will generate a single HTML file with several tables, showing
all commands that can have a shortcuts plus the shortcuts currently
defined.








[bookmark: Links]
11 Links


	What Are the Flash Shortcut Keys? by Adobe, a good
short list.

	Most useful Flash 8 Shortcut Keys by Anders
Bergmann.



[bookmark: Conventions]
12 Conventions


	On a Mac replace "Control" by "Command"

	In this table, "+" means hold down both (usually I just use a
"-" for this)



























[bookmark: Other_tricks]
13 Other tricks

(from Adobe, to sort out)

With the arrow cursor: Control + Click and Drag - Duplicates a
shape By hitting the control key first (Macintosh & Windows)
and THEN clicking and dragging on a selected shape or group of
shapes, you will create a duplicate of those shapes at the spot
where you release the mouse button.



CTRL+Clicking a keyframe to move frame: CTRL+clicking a frame in
the timeline switches the cursor to a slider, and allows you to
click and drag that frame to a new place in the timeline within
that same layer. Useful if you want to stretch out tweens for
example

With the magnifier tool:

Control + Click - Toggles to the opposite magnifier. If the +
magnifier (zoom in) is active, and you hit Control while clicking,
you will switch to the - magnifier and actually zoom OUT.

With the dropper tool:

Shift + Click - Select a color for both fill and outline tools
Clicking a red fill will do the same, giving you the Bucket tool,
and switching fill colors to red. But the outline tool colors are
not changed. Clicking on text switches the text tool to that color,
and gives you the text tool. Shift clicking with the dropper makes
the color you click on active for ALL tools, and doesn't
automatically switch you to any tool. It leaves the dropper
active.

This is one of the least well known short cuts in Flash, and is
the ONLY way to use the dropper on an outline for example, and then
be able to switch to the fill tool and have that color
automatically active already.

Flash formats and objects overview


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !
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[bookmark: Introduction]
1 Introduction

This articles lists a few file formats and objects you can have
on the stage or in the library and explains some of the
terminology. It is part of the Flash
series.

It's purpose is to help you identify objects you are working
with as a Flash designer. We don't use the term "object" here in
the sense of an ActionScript object !

Note: This text is a rough draft. Some things may be
wrong or missing.

[bookmark: Flash_related_file_formats_and_extensions]
2 Flash related file formats and
extensions

Copyright notice: The table below has been copied more or
less as it from Wikipedia's Macromedia Flash article on July 12,
2007. Its contents are available under the GNU Free Documentation License.



	Ext.
	Explanation



	.swf
	.swf files are completed, compiled and published files that
cannot be edited with Adobe Flash. However, many '.swf decompilers'
do exist. Attempting to import .swf files using Flash allows it to
retrieve some assets from the .swf, but not all.



	.fla
	.fla files contain source material for the Flash application.
Flash authoring software can edit FLA files and compile them into
.swf files.



	.as
	.as files contain ActionScript source code in simple source files. FLA
files can also contain Actionscript code directly, but separate
external .as files often emerge for structural reasons, or to
expose the code to versioning applications. They sometimes use the
extension .actionscript



	.swd
	.swd files are temporary debugging files used during Flash
development. Once finished developing a Flash project these files
are not needed and can be removed.



	.asc
	.asc files contain Server-Side ActionScript, which is used to
develop efficient and flexible client-server Macromedia Flash
Communication Server MX applications.



	.flv
	.flv files are Flash video files, as created by Adobe Flash,
ffmpeg, Sorenson Squeeze, or On2
Flix. It's container format that uses (mostly) h.263 for
video and MP3 for audio.



	.swc
	.swc files are used for distributing components; they contain a
compiled clip, the component's ActionScript class file, and other
files that describe the component.



	.jsfl
	.jsfl files are used to add functionality in the Flash
Authoring environment; they contain Javascript code and access the
Flash Javascript API.



	.swt
	.swt files are 'templatized' forms of .swf files, used by
Macromedia Generator.



	.flp
	.flp files are XML files used to reference all the document
files contained in a Flash Project. Flash Projects allow the user
to group multiple, related files together to assist in Flash
project organization, compilation and build.



	.spl
	.spl files are FutureSplash documents.



	.aso
	.aso files are cache files used during Flash development,
containing compiled ActionScript byte code. An ASO file is
recreated when a change in its corresponding class files is
detected. Occasionally the Flash IDE does not recognize that a
recompile is necessary, and these cache files must be deleted
manually. They are located in %USERPROFILE%\Local
Settings\Application
Data\Macromedia\Flash8\en\Configuration\Classes\aso on Win32 /
Flash8.



	.avi
	AVI file is a video file, standing for Audio Video Interleave.
Flash includes several compression codecs, including some from
Radius.



	.gif
	A GIF image; either a single static frame or multi-frame
animation.



	.png
	A 
PortableNetworkGraphic image.







[bookmark: On_the_stage]
3 On the stage

On the stage you can have various kinds of graphics objects,
i.e. objects that you can move, copy, delete, transform, stack,
align, and group.

See also the Flash drawing tutorial, Flash object transform
tutorial and Flash arranging objects
tutorial for more details.

[bookmark: Shapes]
3.1 Shapes

Shapes are the most primitive objects. When you draw shapes that
overlap each other in the same layer, the topmost shape cuts away
the part of the shape according to your drawing controls. When you
draw a graphic like a rectangle in merge mode with both stroke (the
outline) and a fill (paint), they become separate shapes and can be
moved independently.

You can transform a shape into graphic object with menu
Modify->Combine objects union

Tip: As a general rule, avoid shapes (unless you work
like a painter or a drawing artist). In other words, put the
controls of the Tools panel in object mode: [image: object button pressed]

[bookmark: Graphic_objects]
3.2 Graphic objects

When you draw in object mode, then you will produce graphic
objects. You can transform a graphic object into a shape
(right-click->break Apart).

[bookmark: Composite_objects]
3.3 Composite objects

When select several objects you have a composite object. When
you group them together too.

There exist different variants:


	Group: A group of graphics object and shapes

	Mixed: A group of graphics and e.g. a component instance.



Tip: Make sure that you don't work on a composite object when
you believe that you just edit a simple object. E.g. watch out what
you have selected before you turn it into a symbol ...

[bookmark: Instances]
3.4 Instances

Instances are made from objects that you have in your
library. You only can apply certain transformations to these
(without changing the library objects). E.g. you can


	Change its tint or brightness and alpha (transparency)

	You can scale, rotate and skew it with a transform tool. But
can not apply envelope transforms

	you can move them of course.



You can attach behaviors to instance object in ActionScript 2.
In ActionScript 3 you can also do this, but only via the
timeline.

Some instances let you edit parameters, i.e. compiled clips

[bookmark: Special_objects]
3.5 Special objects

Modifying lines and shapes can alter other lines and shapes on
the same layer. See Flash motion tweening
tutorial for example.

[bookmark: In_your_library]
4 In your library

[bookmark: Graphic_symbols]
4.1 Graphic symbols

Graphic symbols are named graphic objects. You can transform a
drawing or shape into a graphic symbol with the right-click
menu. Actually, as soon as you are happy with a creation you should
do this.

[bookmark: Movie_symbols]
4.2 Movie symbols

Movie symbols are Flash animations that you can edit by
double-clicking. You can use them as components for more
sophisticated animations.

[bookmark: Button_symbols]
4.3 Button symbols

Button symbols are special movies that implement the graphics or
button touching, pressing, releasing, etc.

[bookmark: Bitmaps]
4.4 Bitmaps

Bitmaps Are imported bitmaps of various formats, e.g. *.jpg,
*.gif, *.png

[bookmark: Tweens]
4.5 Tweens

Represent motion tweens. I never use these. If you have these in
your library it means either:


	You are an advanced Flash designer

	Something went wrong when you made a motion animation (e.g. you
animated more than a single object or an editable object).



[bookmark: Movie_clips]
4.6 Movie clips

Movie clips are simply imported Flash files *.swf. You can drag
them on the stage and for example use them in a motion
animation.

[bookmark: Compiled_clips]
4.7 Compiled clips

Compiled clips are ActionScript objects exported/imported trough
the *.swc format. If you drag an instance to the scene you then can
edit its particular parameters through the properties or the
component inspector panels.

[bookmark: Flash_videos]
4.8 Flash videos

These are Flash video containers in *.flv format. When you drag
these to the stage, they will integrate to the timeline. E.g. a
short movie may extend over several hundred frames. Most often
you'd rather use the FLV playback component to play such videos.
See the Flash video component
tutorial.

Flash - being organized


This article or
section is incomplete and its contents need further attention.

Some sections may be missing, some
information may be wrong, spelling and grammar may have to be
improved etc. Use your judgement !



This reminder of a few simple "how to work with the Flash
environment" is part of Flash CS3
tutorials.

[bookmark: The_workspace]
1 The workspace


	Learn how to dock panels and how to save the workspace (menu
Windows)

	Learn about F4 (hiding/showing panels)

	Learn how to pin down the AS panel (use pin at the bottom of
the panel).



[bookmark: Drawings]
2 Drawings

Unless you are gifted,


	keep your drawings simple

	Use external clipart.



Always make sure:


	to lock layers you don't work with

	to know at which level you edit ! (scene level or symbol
edit mode).



[bookmark: Layers]
3 Layers

Use a separate layer


	for each object you want to animate

	for each script

	for each sound

	for each complex background drawing



Use layer folders if you get too many layers

[bookmark: Names]
4 Names

Always name things:


	Layers

	Scenes

	Keyframes into which users can navigation

	Symbols in the library

	Instances



Use conventions for naming (more later)

[bookmark: Scenes]
5 Scenes

If you can divide an animation into scenes, use different
scenes


	Name each scene



[bookmark: Library]
6 Library


	Use folders




	at least for complex projects




	Create your own external library




	If you work on several projects copy your important artwork to
a separate *.fla file.

	You can use your own *.fla file as library: Menu
File->Import->Open External library.

	Dock it next to the "normal" library.




	Remove junk




	Remove really useless stuff from the library of each
project

	Remove teen objects made by error (but make sure that
they are not used in an animation). If they are, break these apart,
insert the object as symbol in the library, then rebuild your
animation with these symbols. Only then kill the tween.



[bookmark: Quality]
7 Quality

Even for small projects:


	Identify clear goals, i.e. what the user should experience

	Work with a simple but effective user-centered design method.

	Make sure that he will be able to experience (cognitive ergonomics)

	Make sure your application is usable.

	Make sure you understand what you did (use explit names for
instances, library objects and AS variables and function
names)

	Remove errors (broken tweens for example)

	Document your code, i.e. use comments in AS code, fill in the
documentation (menu Modify-Document).
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