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1 Flash CS3 desktop tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

1.1  Definition

This is part I of some Flash tutorials.

Learning goals:

Learn about various components of the Flash Desktop• 
Learn how to configure and how to save configurations• 

Prerequisites:

none• 

Next steps:

Flash drawing tutorial• 
Flash layers tutorial• 

Notice: As of November 2008 you should acquire CS4. It offers various new features, such as 3D support or better motion tweening
support. However, if you don't find a good CS4 desktop tutorial, you still may profit from this. The overall logic of the interface remains
the same.

1.2  Opening the desktop from the Flash welcome screen

When you launch Flash you will see a welcome screen. This screen offers a few shortcuts. It looks like this:
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Flash CS3 Welcome Screen
To start working with a Flash file, you now can use either the File Menu or you can click on an item in the welcome screen. E.g.

Use File->Open to open a *.fla file you are working on• 
Open a "recent" item either through the File Menu or the button• 
Create a new Flash file• 
...• 

If you tick Don't show again you won't see the welcome screen anymore, but the same options are available through the File Menu. If
you want it back: Edit->Preferences.

To start learning the Flash desktop, we suggest to click on Flash File (ActionScript 3.0) since this the most recent Flash standard.

ActionScript 2 would let you use some built-in behaviors (i.e. do some action script without programming). Action Script 3.0 does not
support this, but then it's probably a bad idea to work with something that is outdated ...

Now you really entered the Flash Desktop working environment. Read on...

1.3  Layout and configuration of the Flash Desktop

Definition: By Flash Desktop (Desktop in short) we mean the whole authoring environment that you can see when you work on some
Flash animation.

1.3.1  The default desktop

When you first open a the Flash Desktop you will not see all the tools you later will use. Your initial desktop configuration should look a
bit like the screenshot below (I am not so sure about the right-hand side panel area). This annotated screenshot already conveys an
idea of the kinds of tools you get, but we will introduce them later.
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The Default Flash CS3 Desktop
You can arrange the Flash Desktop in various ways (see below), but for the rest of this tutorial we will try to stay with a somewhat
stable environment, i.e. leave the main tool panel to the left and the timeline on top.

1.3.2  Configuring the desktop layout

Before we explain some tools components I suggest that you learn how to arrange your Desktop.

Firstly, we'd like to show how to display some more panels (tools and libraries). Having tools at your fingertip is IMHO always a good
idea if your screen is big enough. BTW, if you can afford to buy CS3 it maybe is also a good idea to invest in monitor that can display
1900x1200 pixels....

Always display the tools panel (if hidden by mistake)

You most of the time will need the main drawing tool panel (leave it to the left). You then can add two other tools panels that include
some of the most commonly used menu commands.

To display all the toolbars

Window->Toolbar• 
Check/tick all three, i.e. Main, Controller, Edit Bar.• 

Adding and moving panels
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Panels are tools and libraries that contain special editing functionalities. Some of these you can't find in any menu, therefore at some
point you have to learn what kind of panels exist. Btw, if at some point panels you put on the desktop disappeared, hit F4 or
Window->Show Panels). So F4 toggles between more space for drawing and more tools

Now let's see how you can organize the workspace. CS3 lets you arrange panels in various ways:

They can be floating (undocked, usually you would move them outside the Flash Desktop)• 
They can be docked to the panel area to the right, to the bottom or even to the left.• 
They can be docked in groups of panels (each one will show as a tab)• 

To dock a panel, simply grab it with the mouse (press the left-mouse button on a empty area in its top bar) and then drag it to a "place"
that will "light up" in some light blue color.

If you see a blue line (vertical or horizontal) and then release the mouse the panel will dock below or to the right of the line as
a "lone" panel

• 

If the top bar of another panel turns blue, you can dock your panel next to the other panel, i.e. it will appear in a tab.• 

The two screenshots below should illustrate the principle.

Docking against a line example

The Swatches panel (shown in transparent color) is being dragged to the empty and therefore reduced right hand panel area. There is
a faint blue vertical line. Note, that you also may encounter horizontal blue lines against which you can dock ...

Undocked color and library panels and swatches panel to be docked.

Docking together with an other panel example

The (transparent) Color panel is in the process of being docked together with the library panel. The top bar of the library panel is light
blue, i.e. ready for docking (see also the next picture) ...
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Docking the color panel as a tab
Now the color panel is firmly docked as a "tab" grouped together with the library panel

Docking the color panel as a tab

To undock a panel

Drag it to some place that doesn't light blue.

1.3.3  Saving an environment

To make sure that you can find a configuration again you may save it under a given name. If you do different kind of work with Flash
you can save several working environments.

Window->Workspace->Save Current ...• 

If you are happy with what you did, save your configuration now ...
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1.3.4  An example configuration

Here is an example configuration Daniel K. Schneider is using. I like to have most tools at my fingertips and I have a big enough
monitor to allow for this. My real workspace is bigger than the one shown in the screen capture, which I made smaller in order to fit into
this text.

Example configuration of a CS3 Flash desktop
Of course, you also may choose to work with less visible panels and only open them when you need them, like in the following example
that you can enlarge if you wish. Finally, you may save different configurations for different kinds of work you do...

A simple desktop configuration

1.4  Built-in and online Help

There are two sorts of support:

Built-in help• 
Help from Adobe's website• 

Built-in Help is quite good, although contextual help could be better (like being a systematic option on the right-click menu).

For some stuff you can get context-dependent help, i.e. learn something about certain objects, an item, etc. It will open a more or less
appropriate section in the help tree. Select an item first (e.g. in the Workspace or in a panel), then either get Help from the Menu / hit
F1 / or click on the little help icon in the properties panel.
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In addition, in the built-in help menu you can find links to external sites. It doesn't work for me, maybe because my default browser is
Firefox.

Within the built-in help texts there are also links to Adobe's on-line resources, but they do not necessarily work as they should (e.g. the
link www.adobe.com/go/learn_fl_tutorials doesn't lead to a text tutorial as advertised. Quite typical of Adobe on-line support I should
say.

However there is good stuff on Adobe's website, e.g.

the video tutorials are truly useful to beginners:
Video tutorials at Adobe♦ 

• 

The overall Flash Help page
Flash resources♦ 
In particular, you can find HTML and PDF versions of the built-in help. You may find HTML more practical than the
internal help window since the built-in window can not be detached from the Flash workspace and will hide your
workspace area while your are reading. An good trick to help quickly open/close the built-in help is to dock it against
the Main tool panel (as shown in the screen capture above). Finally, PDF versions of the on-line site can printed,
consider printing in some cases.

♦ 

Consult Flash and AS3 links - documentation♦ 

• 

1.5  Moving on

In this section we will summarize functionalities of some Flash components. We will introduce more functionalities in other tutorials.
This is just a short overview.

1.5.1  The Work area and the stage

The stage in the middle (white by default) is the area where you work on your Flash contents. It is part of the work area. The gray part
of the work area (also called backstage) can contain graphic elements on which you are working and that you plan to integrate into the
stage sometimes, i.e. make them visible to the user. In deployed Flash "movies" this area will hold motion animation objects that later
will "walk" into the scene.

Setting up the size of the stage and other parameters

With Modify->Document menu you can make several modifications:

You can redefine the size of the stage. Stage size is the size you final Flash application will have. Therefore you may think
about the size before you start composing...

• 

You may change the background color (per default it is white and it will display as white in your animation).• 
You also should give your work a title and a short description• 

1.5.2  The Menu Bar

On top of the desktop is the menubar (on the Mac it will be on top of the screen of course). Flash lets do you things in three different
ways:

Interact through the menu• 
Use shortcuts• 
Interact through panels• 

Available operations in menus and panels are context dependent, i.e. they differ in function of what you are working on in the
workspace and also in function of the Flash "Publish Setting" (e.g. ActionScript 2 vs. ActionScript 3).

Here is a short and incomplete summary of the menu groups' functionalities:

File
Opening and creating new files
Definition of Publication Settings (you may change settings you initially defined)

Edit
Editing the scene
Editing elements that are active
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View
Define zoom level, grids, snapping (i.e. how the workspace displays)
Note: Other important "view" items are in the Windows menu

Insert
Add new layers, frames, symbols etc. into the timeline
Add a new scene

Modify
Modify elements on the workspace, e.g. convert a graphic to a symbol (make it a reusable object) or change the shape of a
drawing
Modify timeline elements

Text
Change text properties
Spell checking

Commands
Run macros
XML export / import

Control
Test animation in various ways (including just sub-elements)

Debug
Tools to find errors in your scripts

Window
Configure the workspace (add/remove panels)

Help
Built-in help and links to useful on-line resources

1.5.3  Toolbars and Panels

We will introduce panels as we need them in other tutorials. Here we only would like to introduce the library: It contains all the objects
you use in a Flash document.

For example, in the flash drawing tutorial we used five different reusable objects, i.e so-called graphic symbols. Once you defined
something as symbol (either a graphic, a button or a movie clip) you can reuse these as many times as you like in a flash document.

The library panel with a few reusable graphics
Now you should be ready to start learning how to create drawings with Flash. Move on to the Flash drawing tutorial.

8

http://edutechwiki.unige.ch/en/Flash_drawing_tutorial
http://edutechwiki.unige.ch/en/Image:Flash-cs3-library-panel.png
http://edutechwiki.unige.ch/en/Flash_drawing_tutorial


2 Flash drawing tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This entry is part of the Flash tutorials.

2.1  Introduction

Learning goals
Learn about some features of the Flash CS3 drawing environment
Learn painting and drawing simple (!) objects

Prerequisites
Flash CS3 desktop tutorial
Flash layers tutorial (first part)

Related pages
texture and clipart (import media elements)

Materials (*.fla files you can play with)
http://tecfa.unige.ch/guides/flash/ex/drawing-intro/

Quality and level
This text should technical people get going. It's probably not good enough for beginners, but may be used as handout in
"hands-on" class. That is what Daniel K. Schneider made it for.

Next steps

More about drawing: Flash object transform tutorial and Flash arranging objects tutorial• 
Any other introductory tutorial indexed in the Flash article.• 

2.2  Setting up the stage

Besides choosing the right settings for publication (Flash version) with which we shall not deal here, you should select the right size for
your your stage, i.e. the size of your future flash document. You can do this either when you create a new file or later.

2.2.1  Defining document size

Creating a new document

Flash lets you create a new document from various templates: File->New. Then choose from General or Templates.

These templates may predefine several things:

Size of the stage• 
Version of Flash (based on Actionscript 1,2 or 3)• 
Sometimes other things, e.g. the Photoslideshow contains photos and tools to make slideshow.• 

In any case, to learn Flash's drawing feature, you don't have to worry much about what template to choose from. Just make sure that
you have enough space to draw. If an initial size turns out to be too small or too big, you simply can modify the document's size (see
next)

Modification of a document

With Modify->Document (or by clicking on an empty spot in the stage and then changing the properties) you can:

Redefine the size of the stage.• 
Change the background color• 
Give it a title and a short description• 
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2.2.2  What size for a Flash document ?

Size of your Flash document depends on its purpose. Since Flash documents (unlike well made HTML pages) have a fixed size, you
must find a good compromise between readability (user should be able to read and distinguish all elements) and horizontal/vertical
space you take up).

Larger flash documents

The default documents takes up 550x400px. This makes the document viewable without scrolling on a computer with a bad screen
resolution of 800x600px. Do not forget that a screen also contains a tools bar (in most Operating systems) and that Flash is usually
viewed within a web browser that also contains menu bars, a bottom bar and some pixels to the left and right.

Anyhow, most people today have bigger screen resolutions so you certainly can go bigger than 550x400.

Banners and other embedded items

Just don't make menu bars too large ....

2.3  Configuration of the drawing environment

Firstly you should know that there are two kinds of drawing tools:

Tools in the main tools panel (that appears by default to the left of the desktop)1. 
Tools available through various panels2. 

Here is screen-dump that I made while drawing a red "ray" with the Pencil tool (the mouse pointer is missing from the drawing).

You can see that the properties panel (lower left) will display properties of the object being drawn. E.g. when you use the
pencil, it will display color of the stroke, size of the stroke, type of the line, fill color, etc.

• 

The same is true for the color panel that we display in the upper right.• 
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The Flash CS3 drawing environment
Since these panels give you shortcut access to features of objects you are drawing, it's a good idea to keep them open while you draw.

2.4  Some definitions

2.4.1  Strokes vs. fills

When you draw something with a pencil or another drawing tool like the pencil or the line tool (see below), then the lines you
draw are called strokes.

• 

The outlines of shapes you create with the rectangle, oval, etc. tools are also called strokes. The insides of these shapes
can have fills (various forms of color). All geometric shapes therefore have both strokes (the outline) and fills.

• 

When you use the paint tool (brush), then you usually just create fills (no strokes).• 

2.4.2  Colors

There are several types of colors:

None: You may choose to draw without fill or stroke• 
Solid: Standard colors• 
Linear: Gradient color changes that go from one side to another• 
Radial: Gradient color changes that goes from inside out• 
Bitmap: You can paint with an imported bitmap. This is particular useful with textures. E.g. to draw floors, walls or outdoors
scenes with repetitive tiles.

• 

To select a color type, there is a pull-down menu in the color panel.
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To work with gradients is not very easy and the interface doesn't help that much. To change a gradient you need 2 tools:

The color panel (select type=linear or type=radial), then play with the sliders. You can remove slider buttons by dragging them
outside the area or if you leave the mouse down for a while, you can change color of gradient controller. You also may try to
start from the swatches pane.

• 

To change orientation (e.g. from linear horizontal to linear vertical), use the Gradient Transform Tool (usually hidden below the
Free Transform Tool). Catch the little circle and turn around the object. Only the gradient will turn.

• 

Read the [[Flash colors tutorial] if you want to know more colors and gradients ...

2.5  The main tools panel

Items of the Flash CS3 tools panel
The main tools panel contains the major drawing tools. We suggest to leave this panel docked to the left side (since it's frequently
used). But depending on your screen size, you can display it either in a single column or as a double column, click the ">>" on its top
bar to change this.

The main tools panel organizes tools by different categories:

On top, selection and transformation tools1. 
Below Drawing tools2. 
Next, Painting, color picking and erasing tools3. 
After that, various configuration, view and options tools that are context dependent.4. 

Options change according to tool that is selected. E.g. in the screen capture to the left you can see how the tools panels shows with the
selection tool (left) and the brush tool (right).

Tools may have variants (in this case you can see a little down arrow in the icon). To see variants you must press the left mouse for a
while or Shift-click. E.g. instead of the Rectangle tool you can display/access the Polystar tool.

2.5.1  Merge (shape) vs. object drawing

Flash has two drawing models:

The merge model will erase shapes below something you draw (but not graphic objects as defined next)• 
The object drawing model draws shapes as separate objects (that you later can manipulate like in a typical vector graphics
program).

• 
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Usually, you rather should work with the object model since the shape of each object can be easily modified later on. However the
merge model can be used to draw complex shapes, e.g. you can draw a circle and then carve off things by drawing over it. The merge
mode is also useful when you "paint" things (as opposed to drawing). You later can convert "paintings" to objects of course.

By default, the object model may be turned off, so turn it on by clicking on the Object drawing button. You can find in the options
section of the tools panel after clicking on some drawing tool (e.g. the Pencil). You can see if it's on when there is a rectangle drawn
around the button, like this: 

You can see the difference between the 2 kinds of objects created in the Properties Panel:

Objects are called Drawing Objects• 
Simple drawings (from the merge model) are called Shapes.• 

The behavior of tools changes according to mode used and it's not so obvious to remember what Flash does.

In merge mode

In merge mode, when you draw a shape over another shape, it erases the shape underneath by default. You can change this
with the control options (see later)

• 

When you draw another object (line, pencil, etc.) it will draw over the painting, but not erase it.• 

In object mode

Shapes drawn in object mode with the brush tool are drawn either within, on top or behind objects depending on how to set
the controls of the brush tool.

• 

Shapes drawn in object mode with the pencil, the pen tool etc. are drawn on top of other objects. But in the object mode they
can be moved behind with the right-click->Arrange context menu.

• 

If you already tried to draw more complex shapes, you noticed that it is difficult to work with a single layer (e.g. to select objects), so
you now have to learn how to work with layers.

If you are not familiar with layers, please read the Flash layers tutorial now.• 

Conversions

To convert an object (instance) into its original components : Right click->Break apart• 
To convert some shapes into a drawing object: Select them first (e.g. with the Lasso), then select Menubar Modify->Combine
Objects->Union

• 

To convert some shapes into a symbol, Right-click; Convert to Symbol• 

2.5.2  List of standard tools

Also see the figure "Items of the Flash CS3 tools panel" above in order to identify the corresponding icons in the tools panel. Some
tools are stacked on top of each other. Hold down the mouse button for while to see the hidden ones.

2.5.2.1  Selection tool

This tool lets you select elements (shapes, strokes, fills, symbols, bitmaps) in the workarea by clicking on it (simple click). If you wish to
select several objects together hold down the SHIFT key or use a selection box or the lasso (see next).

You also can drag the mouse pointer to select an area with one or several objects. You certainly have to do this for a drawing made in
merge mode, i.e. a collection of simple shapes). If you want to select a non-rectangular area, use the Lasso tool.

Double-clicking would put you into object editing mode for various parts (depending on where you click). To return from this mode
(which we will not explain here), double-click in some empty area in the workspace.

Warning: This tool also can act as a distortion tool ! See the Flash object transform tutorial. Always make sure that you see a big
"cross-hair" cursor before you start moving around anything.
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2.5.2.2  Subselection tool

The subselection tool allows you to select paths of an object so that you can make more sophisticated modifications. Click on the
outlines of objects. You then can drag around the little squares and dots that will appear, i.e. modify portions of shapes. See the Flash
object transform tutorial for details.

If you want to modify a symbol (in the properties panel you can see something like "Instance-of") you have to break it apart:
Right-click->Break Apart.

2.5.2.3  Free Transform and Gradient Transform tools

The Free Transform tool will allow you to make several kinds of transformations. When you select an object with this tool and then
move the mouse over different spots, you will that the mouse cursor changes shapes. Each one will allow you do different
transformations:

Scale an object: double-ended arrow• 
Rotate an object: circle arrow• 
Skew (distort an object): double ended double arrow• 

To do a proportional scale, hold down the SHIFT key and then drag a corner.

There are more options to the free transform tool, e.g. so-called envelope transform, see the Flash object transform tutorial if your are
curious about this.

The Gradiant Transform tool is hidden below the free transform tool (by default) and allows you to change the ways in which color
gradients flow. Hold down the mouse for a while and then change the tool. See the Flash colors tutorial.

2.5.2.4  Lasso tool

Select several objects or parts of a shape. Remember: to transform an object into a shape, break it apart. This tool also includes a
"magic wand" mode (see the controls)

2.5.2.5  Pen tool

This is the tool that allows you to make the most complex drawings, i.e. pathes with Bezier curves.

(not explained here ....)

2.5.2.6  Text tool

Add text.

In the properties panel you may define various text properties such as fonts, color and positioning, alignment, etc. If you click on the
paragraph symbol, you can define indent, line spacing and margins.

2.5.2.7  Line tool

Draws simple lines.

2.5.2.8  Rectangle and other tools

On the same spot of the tools panel you got several tools. By default you will see the rectangle tool. To select another tool: hold the left
mouse button down for while and then select the one you want.

Rectangle tool (by default): Draw simple rectangles. In the parameter's panel you can define strokes and filling properties.• 
Rectangle primitive tool: Lets you define additional properties like rounded corners• 
Oval tool: Draw ovals• 
Oval primitive tool: Define in addition other features, such as start/end angle, inner radius etc.• 
Polystar tool: Define polygons and stars (there is a small pull-down menu in the properties panel that you should not
overlook !)

• 
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Below you can see a few drawings. The screen capture has been taken with the Polystar tool activated.

Various drawings with the rectangle, oval, polystar tools

2.5.2.9  Pencil tool

With the Pencil tool you make drawings like with a Pen. However, there is optional support to draw straight or smooth lines since
drawing with a mouse isn't very obvious. You can define various options.

"Line" drawing Options

In the options section you can select different ways of drawing support. I.e. the the straight icon looks like this: . Below is a
screen-dump that demonstrates the difference between straight, freehand and smooth drawing.

15

http://edutechwiki.unige.ch/en/Image:C3_tool_polystar.png
http://edutechwiki.unige.ch/en/Image:Cs3_tool_pencil.png
http://edutechwiki.unige.ch/en/Image:Cs3_tool_pencil_straight.png


The three pencil drawing modes

Stroke, color and line properties.

In the properties panel you can define various options like stroke (pen) color, fill color, various dashes or not, and how the end of lines
should look.

2.5.2.10  Brush tool

The brush tool lets you paint. There are several special effects and several modes.

Object or merge mode

In merge mode you only can paint fills• 
In object mode you can add a stroke to your painting (by default it is off). Look at the properties panel.• 

The Brush Mode

With the "Brush Mode" in the options section (not the properties panel) you can select the paint mode. Make sure to understand these
and to verify that the wanted mode is on, else you likely run into frustrations ...

Paint Normal: paints over lines and fills on the same layer. Like painting with a "heavy" paint.• 

Paint Fills: Fills empty areas leaving lines unaffected.• 

Paint Behind: Paints in blank areas of the Stage on the same layer, leaving lines and fills unaffected (this may be be default, I
am not sure).

• 

Paint Selection: Applies a new fill to a selection. Therefore, before you start painting select a fill color first, then select the
object with the selection tool, then paint. This is the quickest way to color drawings.

• 

Paint Inside: Fills the area within a "fill" (i.e. where you start paining) and does not overpaint lines. If you start painting in an
empty area outside a fill, painting will not affect existing filled areas.

• 

Selection of brushes and size

Choose from the options in the options section ....
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2.5.2.11  Ink Bottle tool

This tool allows you to apply color changes to the strokes of drawings.

Select the ink bottle• 
Then select either a Stroke color (and/or a Fill Color if the object is a graphic) from controls in the main tools panel. If want to
make more sophisticated changes (e.g. apply a gradient) do this through the color panel.

• 

The click on objects you want to change.• 

You also can change the color of a fill or stroke through the properties panel or the color panels, but make sure to select the object(s)
you want to change first.

2.5.3  Paint bucket tool

The paint bucket tool works like the ink bottle tool but it is used to change colors of paintings. You also can fill in empty areas (insides
of drawings made with the pencil for example)

First, click on the paint bucket tool• 
Select fill color (and style)• 
If you want to fill an area that is not entirely closed, you can do so by modifying the gap size by changing the "Gap size"
control in the tool panel options. E.g. choose "Close medium gaps".

• 

Then click on the shape or the area you want to fill• 

Again, you also can change paint of shapes and object, by first selecting the thing in the stage, and then by making changes in the
properties or the colors panels.

2.5.3.1  Eyedropper tool

You can select a color from some spot on the workarea. The tool will then automatically change to the paint bucket tool (see above).

2.5.3.2  Erasor tool

Erase stuff. See the Flash object transform tutorial for details.

2.6  Option controls and tools configuration

Some option tools are always displayed, some only for certain tools.

2.6.1  Hand tool

Move the stage around (useful for big drawings/small screens or with a strong zoom)• 

2.6.1.1  Zoom tool

Zoom in/out• 

2.6.1.2  Pen color

Select the pen (stroke) color• 

2.6.1.3  Fill color

Select the fill color• 
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2.6.1.4  Swap color

Change fill color to stroke color• 

2.6.2  Configuration of the Tools panel

The Tools panel can be configured via Edit->Customize Tools Panel (but for now I suggest not to change anything there).

2.6.3  Configuration of drawing settings

Select Edit->Preferences and then change parameters in the section Drawing. (no need to do this now). Basically you can modify how
Flash helps you drawing objects (e.g. connected lines, vertical/horizontal) and how it identifies objects when you click on them.

2.7  Painting simple objects

In this chapter we will show how to make a complete (but simple!) drawing. Disclaimer: Daniel K. Schneider doesn't even remotely feel
to be graphics designer. If you are not familiar with layers, you now really should have a look at the Flash layers tutorial

Firstly, you can find lots of free clipart (drawings) on the Internet. As a principle it is a better idea to search for vector graphics as
opposed to bitmaps and for three reasons:

Vector graphics are smaller• 
They can be re-edited• 
They adjust nicely to size. A smaller or bigger version still looks as good as the original.• 

To find vector objects you can for instance type in Google "free clipart download" or see the links in the clipart article (finding good and
free clipart on the web is not easy).

Most often, clipart is distributed in *.wmf format (Windows Meta File format). Flash can handle this format. It also can handle Illustrator
*.ai format, Enhanced Windows Metafile *.emf, Freehand, Flash *.swf, and Autocad *.dxf. It can not handle SVG (but you can open
SVG files with Illustrater and then copy/paste).

You also can import a series of bitmap formats like the "standard" *.png, *.jpg, *.gif, but also Photoshop *.psd and a variety of
Quicktime formats if it is installed on your computer.

2.7.1  Drawing fuzzy objects

An apple tree drawn in merge mode
The basic principles for paint-challenged people like me is the following:

Create a new layer. It is usually a good policy to create a new layer for each drawing. Do not worry about size and position at
this stage, since you can later move the drawing around and resize it.

• 

Zoom in (like 200%), e.g. with View->Magnification• 
Select merge mode from the Object Drawing tool and set the brush tool to overpaint.• 
Keep the painting as simple as possible• 
Use large Pencils or brushes for starters, then small ones to work on borders if needed.• 
Use the eraser to trim off strokes that went too far• 
Draw stuff that will go to the background first and then overpaint• 

E.g. To the right is a simple apple tree with a green snake (I later erased).
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2.7.2  Drawing animals and such

A really ugly cat drawn mostly in object mode

Find a recipe to draw these, e.g. on Google type: "how to draw a cat"• 
Then reproduce if you can ;)• 
Rather use object mode and disable stroke since these models often ask you to overlay ovals. Without stroke you may overlay
various geometric shapes of the same color.

• 

E.g. here is a cat made as explained in Creature Features.

Alternatively you also can first draw the object with the pencil tool (or the pen tool) and then use the Paint Selection or Paint inside
mode of the brush tool to apply colors.

Of course in the same drawings you can mix pencil, pre-built objects like rectangles and paint. E.g. draw the outline of house with the
pencil and then draw the roof with the paint tool.

2.7.3  Save each object as symbol

Once you are happy with a drawing, you should convert it to a (reusable graphic symbol): Right-click->Convert to Symbol; Graphic. E.g.
call it "cat". You then can remove the layer you used to draw this object, since the raw drawing is no longer needed.

convert a select object to a symbol
Once you have it in the library you can use several times, in various sizes and distortions. You also can copy the object and e.g. make
a new one with different colors ... If you are unhappy with the results (as I ought to be), you can just break a graphic apart and restart
again...

When you insert a library object into stage you can make it smaller. Drag it from your library into the stage (but onto another layer) and
then select the Free Transform tool; Press Shift (proportional reduction) and make it as small (or big) as you like.

2.7.4  Importing clipart

Flash can handle various vector formats and even better: you can modify these within Flash.

To import:

File->Import->Import to Stage or alternatively Import to Library• 
If you import it to the stage and like it, then save it to the library with Right-click->Convert to Symbol; Graphic as explained
above.

• 
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A cat from www.free-clip-art.com. Copyright: Personal and educational use
E.g. here is a cat I imported from Free Clip Art. This site has free clipart images for personal use. You can use them for school, fun,
non-profit Web sites, and other personal needs.

2.7.5  Adding background and Sky

I suggest to draw background stuff with a new layer You can do this beforehand or after. In order to see either background or objects
you can put all other layers in "outline mode". Click on rectangles near each layer or on the rectangle on top.

Making use of the "Layer Outline Mode"

First of all you can change the background of the stage: Modify->Document; then change the background color.• 
If the layer with your background drawings (e.g. sky) is drawn over the objects instead of the other way round, just move this
layer (either to the top or to the bottom depending on your settings).

• 

2.7.6  A result (sort of)

Here is the result of a three times two trees, two of my cats, an imported cat and a little house.
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A flash document with trees and cats

2.7.7  Using textures

Of course, you may find the grass to be too ugly. A good solution might be to replace a background color with textures. Search on the
web for "free textures grass" and save the file (usually a *.jpg).

You should be aware that there are textures and textures meant to be tiled. Simple pictures (if smaller than the stage) will produce tiles
that you can see (not exactly what you want). So instead you can search for something "free tileable grass textures". If you can't find
good tiles, you may learn how to do this with this Photoshop from DadyyCool.

You then can resize the image if it is too big and/or crop it.• 
After that, deselect all objects (click in the gray area) or select the object you want to paint.• 
Then open the color panel and select type: Bitmap from the pulldown menu. Import the bitmap and select it (you also will find
a copy of the bitmap in your library).

• 

Then paint the outline of your textured area with the brush tool (in the "Paint behind mode" (see brush tool above)• 
Then fill the rest with the paint bucket.• 
You can change the way textures are applied with the free transform tool (see Flash colors tutorial).• 
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A flash document with trees and cats
This result is not exactly better, but it's different and you can see that you can draw with bitmaps :). Of course one now also should
repaint the house and the trees. I also rotated the gradient for the sky by the way.

Of course, one can do better graphics and colors. See more advanced Flash tutorials on drawing, e.g. the Flash object transform
tutorial, the Flash arranging objects tutorial or the Flash colors tutorial

2.7.8  Files to download

You can download the *.fla files here:

http://tecfa.unige.ch/guides/flash/ex/drawing-intro/
flash-cs3-drawing-trees.fla is the one with a simple background♦ 
flash-cs3-drawing-trees3.fla uses gradients and drawings outside the stage are clipped away (so it's a clean version
of the above and I will use this one in the Flash motion tweening tutorial).

♦ 

flash-cs3-drawing-trees2.fla is the one with the textures.♦ 

• 
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3 Flash layers tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This entry is part of the Flash tutorials.

3.1  Introduction

Learning goals
Learn how to use layers

Flash/CS level
Flash CS3

Prerequisites
Flash CS3 desktop tutorial. It's probably a good idea to use a layout similar to the ones I suggest there.
You also may first look at the first part of the Flash drawing tutorial.

Next steps

One of the basic animation tutorials• 

Quality and level
This text should technical people get going. It's probably not good enough for beginners, but may be used as handout in
"hands-on" class. That is what Daniel K. Schneider made it for...
It aims at beginners. More advanced features and tricks are not explained here.

3.2  Introduction

Layers help you deal with more complex Flash projects. Working with layers has several advantages:

You can draw and edit objects in one layer without affecting objects in another layer.• 
You can lock layers (to protect their embedded objects from unwanted editing)• 
You can hide layers, make them visible (i.e. you can see their objects in the workspace), or you can display just the outlines of
their objects.

• 

The layers tool is part of the Timeline panel.

3.2.1  Overview picture

The layers tool is in the left part of the timeline. Annotations in the following screen capture highlight a few functionalities we will further
explain below.
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The Flash CS3 Layers tool

3.2.2  Drawing in a layer

To draw, paint, or otherwise modify a layer simple click on the the layer name in the Timeline to make it active. A pencil icon next to it
indicates that the layer is active.

3.2.3  Creating new layers and deleting layers

When you create a Flash document, it only contains a single layer, i.e. less than you need.

To create a new layer, either:

Insert->Timeline->Layer• 
Click on layer icon (left most item in the Edit bar just below the timeline)• 
Right-click on an existing layer, then Insert Layer• 

Inserting a new layer
As soon as you create a new layer, you should give it meaningful name. Right-click on its name (something like Layer 2) select
Properties and change the name. Alternatively, to display this properties panel, just double-click on the layer name.

To delete a layer and its contents: Right-click->Delete Layer. You also can lock/hide other layers with this menu. Before you delete a
layer make sure that you save its objects if you plan to keep them. You can insert them in the library as symbols or copy them to
another layer.
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3.2.4  Show only outlines of a layer

Click on the rectangle next to the layer name. If this rectangle turns empty then you only should see outlines of its objects.• 

You also can change the outline color by double-clicking on the rectangle. E.g. if your background is green (like the grassy
hills in our example), the outline should be of a different color.

• 

3.2.5  Lock and hide layers

Click on the dots below the appropriate hide/lock/display icons in the panel to apply locking/hiding/displaying to a single layer, or on the
icons themselves to apply an operation to all layers (e.g. lock them all).

TIP: Always lock all layers and then just unlock the layer on which you are working. This way you can prevent yourself from making
mistakes.

3.2.6  Moving layers

To move a layer in the stack simply grab it with the mouse and drag it up or down. Position of the layer has an influence on the order
objects are drawn. E.g. if a moving object should pass in from of a tree and it doesn't, then drag the animation layer up or down.

Drawing order depends on the load order defined in the Publish Settings (File menu)

3.2.7  Example

The following screen capture shows hidden and locked layers:

The painting layer is active (the pencil is shown)• 
The objects layer only shows outlines and in addition it is locked (the lock sign is on and the rectangle is empty. Its objects are
drawn in light green, i.e. the color of the rectangle)

• 

The Sky layer is hidden (The red "X" sign is on).• 

The Flash CS3 Layers tool, shown with outlines of layer and a hidden layers

3.3  Layer folders

Once your documents get really complex, you can organize layers into folders, e.g. one folder per task: Static objects, animations,
background etc.

To create layer folders, either:

click on the folder icon in the Edit bar (third item)• 
or use Insert->Timeline->Layer Folder• 
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You then can drag around layers. Hiding, locking etc. works more or less like with folders (try it out ...)

However, at some point you also will have to decide whether you really want to work with an "everything is in the main time line model".
Consider organizing and planning your project with embedded movie clip objects (see the Flash embedded movie clip tutorial). Putting
everything in the main time line is like programming with "goto's"...

3.4  Scenes

Once your animation gets bigger, you most certainly should break it down to several scenes. There is no urgency to work with scenes if
you are new to Flash, but you should know about this now. Scenes are played in the order you defined them.

To insert a new scene
Menu Insert->Scene

To rename/reorder the scenes

Menu Window->Other Panels->Scene (SHIFT-F2)• 
Then drag up or down the scenes• 
To rename, double-click on a scene name in this panel.• 

To navigate between scenes

Either via the scenes panel, or the Edit Bar (displayed below the timeline). If you can't see it: Window->Toolbars->Edit Bar.• 

One advantage of using scenes is that you can just test a single scene (menu Control->Test->Scene).
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4 Flash object transform tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This entry is part of the Flash tutorials.

4.1  Overview

Learning goals
Learn about basic Flash 9 (CS3) object transformations with various tools.

Prerequisites
Flash CS3 desktop tutorial
Flash drawing tutorial

Moving on
Select one from the Flash tutorials.
Probably you'd like to animate shapes (Flash shape tweening tutorial)

Quality
This text should technical people get going and may not be good enough for self-learning beginners. It can be used as
handout in a "hands-on" class. That is what Daniel K. Schneider made it for...

Level
It aims at beginners. More advanced features and tricks are not explained here.

Materials
None, just play with your own objects :)

Flash has quite powerful object transformation tools. You should learn about these in order to create more sophisticated drawings
and/or morphing (shape tweening) animations animations.

Executive summary - Various drawing strategies for complex objects

Draw/paint in merge mode (overpaint shapes), then transform to graphic object.1. 
Draw in object mode, then group or convert to symbol.2. 
Carve shapes with the eraser.3. 
Transform a simple shape with select tool, envelope transforms and sub-selection tool.4. 
Assemble objects (see Flash arranging objects tutorial), then any of the above.5. 

Executive summary - transform tools in the tools panel

Tools for transformations in the tools panel

The Select tool allows to quickly distort an unselected object by moving the cursor close to it until it changes to curve or edge
shape. The you simply drag the mouse. (BTW this is a very dangerous tool, by mistake you can dammage your drawings if
you don't lock the other layers ...)

• 

Use the Free Transform tool and its variants to make complex transforms of the envelope of a shape, e.g. learn how to use
the envelope transform.

• 

The Subselection tool allows you drag squares (distortion points) and turn/drag circles (curve control handlers). I view it
more as a "repair" and "fine tuning" tool.

• 

With the Eraser you can "carve" out objects (like a woodcutter or a chainsaw artist).• 

Executive summary - transform tools in other places

The menu Modify->Transform can get you directly into the modes of one of these tools.• 
The Transform panel (Window->Transform) lets do you the default free transforms by entering property values for size, rotate
and skew.

• 
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Hit CTRL-ALT-S to resize or rotate a selected object by entering a number.• 
The menu Modify->Shape has a few tools to automatically adjust shape.• 
Finally, there are also transformation icons on the main toolbar (which is not shown by default, use Window->Toolbars->Main).• 

... a rather confusing amount of tools. Probably I forgot something ;)

4.2  The select tool

The select tool (arrow on top) strangely enough has two functions. These are entirely different and may lead to confusion.

Select objects• 
Distort objects• 

To distort objects the easy way, read on ...

4.2.1  Default behavior of the select tool

If you click on an object or if you select it with a selection box you see this:

A hooked cross icon• 
A white circle in the middle of the selected object (or selected objects)• 

You then can move it around, but that's not what we are interested in right now. The only important thing you may remember is the
following:

when you see a cross, it means that you successfully selected the object.• 
The white dot represents the center, e.g the point where an object will snap to a motion guide line.• 

A simple oval
... this is not what you want.

4.2.2  Let's now make a banana

Ok, now let's distort an object. Let's start with an oval drawn in object mode. See the picture above or below.

Make a rounded banana with the selection tool

First, deselect everything (including the banana), e.g. click on the gray workspace area.• 
Select the select tool.• 
Then move it close to the stroke (outline).• 
When the cursor turns into a curve, then hold down the mouse and drag• 

Select tool - curve icon
Here is a result, a nice banana:

28

http://edutechwiki.unige.ch/en/Image:Flash-cs3-hooked-cross-icon.png
http://edutechwiki.unige.ch/en/Image:Flash-cs3-curve-icon.png


A simple oval turned into a banana

Make sharper ends

Copy/paste the banana, if you like the old one. (select, ctrl-c, ctrl-v)• 
Again, deselect everything• 
Then hold down the ALT key and slowly search around the ends of the banana.• 
If you see the angle icon, then drag. The angle icon won't show up everywhere, it's basically meant to drag corners.• 

Select tool - curve icon
Result: two bananas of different shape:

A sharp and a round banana
You then can fine tune things with the subselection tool (see below).

4.2.3  Turning lines

To turn a line use the select tool and move to one end. When the edge icon shows up, you can turn/stretch a line.• 

Edge/angle icon - turning/stretching a line
Hint: To rotate around a random rotation point, see the free transform tool below

4.3  The Free transform tool

Make sure that you understand drawing basics, i.e. have an idea what kinds of tools you got in the tools panel. If you don't, please go
read the Flash drawing tutorial.

4.3.1  Features of the free transform tool

The free transform tool allows you to do several things
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By default: Scale, rotate, skew and distort• 
Envelope transforms• 
Distorts (but see the selection tool)• 

So again, you face a multipurpose tool. You can define its different variants by selecting different mode in the options part of the tools
panel (lower end). Read on ...

The Transform panel

Instead of dragging around handles as explained below, you also may type in transformation values in the Transform panel. That's
useful for technical drawings.

Get it with the Window->Transform menu. I usually have this docked next to the color panels (top right) as in the following screen
capture. (If you don't know how to dock, please read the Flash CS3 desktop tutorial).

A screenshot of tools related to the Free Transform tool

Lots of transform tools ...

4.3.2  Simple transformations

By default the free transform tool let's you scale, rotate, skew.

To select an object for transforms

Select the Free Transform tool• 
Click on an object (or the other way round)• 

The transformation controls

You object will be in a rectangular box with a distortion control in each corner and one in the middle of each line.• 

To scale in both directions (x and y)

Grab a corner and drag as in the screen dump below:• 

30

http://edutechwiki.unige.ch/en/Flash_CS3_desktop_tutorial
http://edutechwiki.unige.ch/en/Image:Flash-cs3-transform-tool-picture.png


X and Y size transform

If you want to scale a graphic and keep the proportions, hold down the SHIFT key.• 

To scale into one direction (x or y)

Drag one of the points in the center of a line (of the surrounding box).• 

To rotate an object

Move your mouse outside near a corner. You will see a rotation icon.• 
You then can turn around the object.• 

Rotate with the transform tool
You also will see the changes in the transformation panel. Btw. you can move the rotation point (see next section).

To skew an object

Move your mouse over a stroke (line), but not over a distortion box• 
You will see some vertical or horizontal double arrow (skew icon)• 
Then drag ...• 

Skew with the transform tool

4.3.3  Rotations

By default an object will rotate around the white circle in the middle. But you can move this rotation point. Grab it with the
mouse and move it where ever you want. Flash also gives some help. E.g. if the drawing is a line it will display the center of
the line and you then can move the point to one of its ends for example.

• 

In the following screendump we have a picture of a stick man and we'd like turn his right arm. To do so:

Click on the Free Transform tool (standard options as above)• 
Then move the little dot in the right arm towards the "inner end" of the stick man. The cursor should have a little circle next to it
in this mode. See the screen shot below.

• 
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Change rotation point with the Free Transform Tool
After that you can rotate the arm around its new rotation point (as described in the previous section).

Again, use the Free Transform tool (standard options)• 

Rotate around the new rotation point with the Free Transform Tool
The standard options of the transform tool allows to rotate, resize and distort an object. You have to work with options for more
complex transforms.

4.3.4  Envelope transforms

Envelope transforms allow to change the shape of an object in a more controlled way. It works on both shapes and objects. Let's now
make a designer chair.

Step 1 - Draw a rectangle

Do it with the rectangle tool.• 

Step 2 - Go into envelope transform

Select the object first, i.e. the rectangle.• 
Click on the Free Transform Tool.• 
Select the Envelope option (see the screen capture below). So this tool is an option of the "free transform tool"• 
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Envelope Transform with the Free transform tool

Step 3 - Transform

Drag any little square. These are called distortion points.• 
Once you start transforming you also get curve control handles (the little circles). You can turn these in order to smoothen
out curves. See the screendump just below. Or you can drag them to add new distortion (or combine both movements of
course)

• 

Envelope transforming to make a designer chair

4.4  The transform menu

The Transform Tools

The Menu Modify->Transform gives you the choice of several kinds of transformations

Select the object(s) to be transformed first• 
Then select from several options• 
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The transform menu
Basically it let's you all you can do with

The Free Transform tool and its options• 
The Subselection tool• 

The Shape Tools

You can smoothen out shapes, make them blurry or straigthen, etc.

Menu (Modify->Shape) has a few tools• 

You can for example:

Smooth, i.e. take away some edges• 
Reduce the amount of edges (optimize)• 
Add soft edges, i.e. make the borders "blurry"• 
Straigthen• 

Here is an example of soft edges and straighten:

Modify->Shape Tools
You can not do everything with composite objects. E.g. to add soft edges, ungroup / break groups apart first, then union...

4.5  The Subselection tool

This tool allows envelope transformations or rather fixing envelope transforms made with the selection tool or with the transform tool in
envelope or distortion mode. Handles work like in the Envelope transform tool.

Distortion points

The little squares are distortion points

You can drag these anywhere to change the shape of the object• 
You also can drag them along the stroke before you drag them out• 
You can delete these. Move the cursor over one of these and when the cursor changes shape, click first, then hit delete. This
will simplify a stroke.

• 

Curve control handlers
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The little dots are curve control handles with which you can adjust the curves in two ways:

You can turn them to change the curve: smooth or sharpen.• 
But you also can drag them to some place to distort the shape ....• 
To get curve control handles click on a distortion point or move it.• 

Dragging out a shape with a curve control
If you can't see well what your are doing (I can't in 100% mode), zoom in like 200 or 400% ...

4.6  The Eraser tool

The eraser tool allows you to carve objects. In the options / controls in the tool panel, you can change the way the eraser works.

Erasing shapes (drawn in merge mode) and graphics objects (drawn in object mode) doesn't lead exactly to the same results. When
you carve an object it remains an object. When you carve a (single) shape, it will divide into other shapes.

We shall not explain much here, better try it out ...

Draw three nice fat ovals with a fat stroke. Two of them overlapping• 
Then, select the eraser mode. This works like the paint tool• 
Use Ctrl-Z to undo what you have done .... so you can try other options.• 

Eraser modes

Here are the modes:

Erase normal: Will erase as you paint• 
Erase fill: Will only erase fills (paint)• 
Erase lines: Will only erase strokes (lines, contours of objects)• 
Erase selected fills: Will only erase fills that you have selected (hold down the SHIFT key to select several)• 
Erase inside: Will erase fills inside an object if you start erasing inside the object.• 

In the following screen dump we used the 'erase fill option to take out fills from the oval and the rectangle.
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Eraser options

The faucet

Will kill any shape on which you click. It makes a distinction though between the stroke and the fill of an object.• 

Eraser shape

You can select different sizes of circles and rectangles• 
Use rectangles to carve off rectangles and circles to carve of round stuff.• 

4.7  The Lasso tool

Includes a magic wand (see the controls at the bottom of the tools panel)

(to be continued some day)

4.8  Moving on

If you already didn't do it, try the Flash shape tweening tutorial, i.e. learn how to do morphing animations.
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5 Flash arranging objects tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This is part of the Flash tutorials.

5.1  Overview

Learning goals
Learn to align, stack, combine, break objects in Flash CS3

Flash level
CS3

Prerequisites
Flash CS3 desktop tutorial
Flash layers tutorial (first part)
Flash drawing tutorial (at least some of it)

Quality and level
This text should technical people get going. It's probably not good enough for beginners, but may be used as handout in
"hands-on" class. That is what Daniel K. Schneider made it for...
It aims at beginners. More advanced features and tricks are not explained here.

5.2  Snapping

Snapping refers to a kind of assistance you may get for technical drawings. It helps to position an object with respect to the others and
without using the Align Panel.

You can tune the desktop to various snapping modes

Menu View->Snapping or right-click on the workspace• 
Then turn on/off snapping modes or better click on Edit snapping• 

I usually just have these ones. (But more often I turn snapping off and then rather align objects with the align panel).

Snap align• 
Snap to objects• 
Horizontal and Vertical Center alignment (will also allow to snap against centers of objects, otherwise you only can snap
against sides)

• 
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Edit Snapping

Snap to Objects

Will snap an object you move against parts of an object. Move slowly...• 

Snap Align (when snap objects is also on)

Will snap to dotted lines that will appear• 

Snap to Grid

Works when you turn on the Grid with menu View->Grid• 
Useful when you do technical drawings for instance.• 

Snap to Guides

Same principle as snap to grid. (View->Guides).• 

Snap to Pixels

For high precision work. Magnify the stage to at least 400%.• 

Object spacing does what its name says:

If horizontal or vertical spacing defines the snapping distance in relation to the edges of other objects• 
Note: This means snapping to the center of a line ! E.g. if distance is 0px and your lines are 5px, your objects will overlap.• 

Disclaimer: I am not sure what certain combinations do. Here is for example what happens if you drag the red rectangle close to the
yellow one in snap align / snap objects mode with zero object spacing:

Align object snapping

5.3  Aligning objects

To align objects on the stage, there exist three solutions:

Use the align panel (Open it with Window->Align or CTRL-K and dock it next to the Colors panel• 
Use menu Modify->Align• 
Use the shortcuts (see Flash CS3 keyboard shortcuts)• 
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Various align interfaces of Flash CS3
With the align panel, you can align, distribute or resize a series of selected objects.

There are two fundamental modes:

Align/distribute referring to the stage. I.e. you may want to align a picture in the center of the stage.• 
Align one or several objects with the first selected, or distribute among the first two selected objects.• 

The align panel (with "to stage" option unticked):

Various align interfaces of Flash CS3
To see what each icon does, move your mouse cursor over it. The align panel icons convey the following kind of message:

The line represents the border against which alignment or distribution will be made (left, right, middle, top, bottom, etc.)1. 
The dark and the white rectangle represent the selected objects2. 

Match size will change the size (either width, height or both) of smaller objects with a larger object. Space works a bit like distribute.

5.4  Aligning objects in several frames

You also may align objects in several frames. For example, to align letters in all frames: Click on the Edit multiple frames button in the
bar below the timeline.
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Select all frames

Then, you can select the frames you want to edit together by moving the "[" "]" sliders on top of the timeline• 
Then select groups of objects you want to align (e.g. different letter groups in our case), then use the align pane
(Window->Align), but untick To stage (!)

• 

This tool is quite dangerous, since it is hard to control what happens in each frame. Make sure to save your file before you engage in
this ! Also, when you are done, untick the Edit multiple frames button.

5.5  Stacking

When you draw a new object it is drawn on top of the others.

You can move forward or backwards any selected object(s)

Use the right-click->Arrange menu or:• 

CTRL+Up Arrow - Move Ahead
CTRL+Down Arrow - Move Behind

5.6  Grouping

5.6.1  Turning shapes into objects

To combine several shapes into an object:

Menu Modify->Combine Objects->Union• 

To break apart an object:

Menu Modify->Break Apart or Right-click->Break Apart or CTRL-B• 

Tip: This operation is not innocent, i.e. it creates a new single editable object. If you just want to group vector graphics into a composite
object use "grouping" (see below).

5.6.2  Creating a new object from others

Menu Modify->Combine Objects lets you combine objects in several ways:

Union as above: It will create a new object and respect the stacking (i.e. as you see it on the stage)• 
Intersect will only the take the common area• 
etc ...• 

To break apart an object:

Menu Modify->Break Apart or Right-click->Break Apart or CTRL-B• 
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The result will be shapes, not the original objects.• 

5.6.3  Grouping Objects

Use this feature, if you plan to re-edit hierarchies of grouped objects as you may have in complex drawings. To group several objects:

Select the objects you want to group.• 
Hit CTRL-g or menu Modify->Group• 

To ungroup an object

Select it• 
Hit CTRL-SHIFT-g or menu Modify->UnGroup• 

Note: Flash will allow you to animate grouped objects in a motion tween, but it will create tweening objects in the library (like it does for
simple, editable objects). You can't ungroup these anymore, except by breaking them apart. I suggest alwaysusing movie clip symbols
for motion animation! Tween objects are bad (at this stage).

5.6.4  Grouping Objects into a symbol

Select several objects• 
Right-click->Convert to Symbol or hit F8• 

Then you have to select the type:

"Graphic" means a graphic (i.e. an named group of objects)• 
"Button" will create a button symbol (you then can fine tune the button frames)• 
"Movie Clip" will allow you to use the object for motion animation• 

All these symbols can later be edited (double click in the library or the stage to land in symbol editing mode).

Tips:

Use movie clips, unless you have a reason to do otherwise. A movie clip is really not the same kind of object as button for
example.

• 

Always give your symbols a meaningful name !• 

5.7  Conclusion / more

If you draw a lot, you may want to print the list of Flash CS3 keyboard shortcuts• 
At some point you also should learn about the various kinds of objects you can have in a *.fla file. They all have different
purposes, e.g. various kinds of tweens only work on certain kinds of objects. See the Flash formats and objects overview.

• 

There is more stuff in the Modify Menu, but that's its enough for now ... :)
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6 Flash colors tutorial
Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

6.1  Introduction

This is part of the Flash tutorials.

Learning goals
Learn about the color types (normal, gradient and bitmaps)
Learn about color models (RGB and HSB)

Prerequisites
Flash CS3 desktop tutorial
Flash layers tutorial
Flash drawing tutorial (at least some of it)

Quality and level
This text should technical people get going. It's probably not good enough for beginners, but may be used as handout in
"hands-on" class. That is what Daniel K. Schneider made it for...
It aims at beginners. More advanced features and tricks are not explained here.

Materials (*.fla files you can play with)

http://tecfa.unige.ch/guides/flash/ex/colors-intro/• 
The Colors SWF includes a short demo of bitmap colors, the alpha channel, gradients and filters.• 

Color types overview

In Flash there are three kinds of colors

Normal colors (solid)• 
Gradients (linear and radial)• 
Bitmaps• 

Both RGB and HSB model is supported for colors

6.2  Tools overview

6.2.1  Color related tools

Flash CS3 has several color tools and controls

In the tools panel

Paint bucket and ink buckets• 
Stroke color and fill color (for most tools). Select colors before you choose a tool to draw• 

In the properties panel

Stroke color and fill color• 

Color panel

Color selection• 

Swatches
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Preset colors• 

6.2.2  How to use the color selection popups

When you select (or change) fill or stroke color, a color popup swatches pane will pop up. You then can select a color with the
eye-dropper tool or alternatively from any color in the Flash workspace.

You also can change alpha channel or type a 6 digit hexadecimal RGB Code (see color panel explanation below)

6.2.3  How to use the color and the swatches panel

Color panel - Gradients
To work with the color or the swatches panel, select an object on the stage (or decide to modify the one that you are working on)

We recommend to have the color panel docked on top right, else get it with menu Window-Color (or SHIFT-F9).

The Flash CS3 Color panel
In the color panel you then can:

Select the color type• 
Select various colors (depending on color type)• 
Change the alpha channel (i.e. transparency)• 
With the little pulldown menu on top right, you also can change the color model from RGB to HSB• 

The swatches panel (not shown here) includes a series of standard colors. These are same ones you get with the Fill controls in the
Tools and Parameters panel

6.3  Solid colors

Solid colors can be defined in various ways (and there is a whole science behind it). Let's just recall a few principles. For more
information, please see the Wikipedia links in the color article.

Let's define a few terms first:

Hue

means "color"• 
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Saturation

means amount of a color you apply, i.e. the intensity.• 

Brightness

How much light you apply. A lot of light makes a the color washed out and very little light makes it very dark.• 

Transparency

How much you can see trough• 
See alpha channel below• 

6.3.1  RGB colors

RGB colors are the most popular ones used in computing applications. A color is defined by the amount of Red - Green - Blue. By
default, the CS3 color panel is in RGB mode.

RGB is the way computer monitors work. E.g. to get a nice yellow you need 100% Red + 100% Green + 0% Blue. RGB is a so-called
additive color mixing model. “Projection of primary color lights on a screen shows secondary colors where two overlap; the
combination of all three of red, green, and blue in appropriate intensities makes white.” (Wikipedia). Now if you project each of these
primary colors with different intensity, overlapping colors will change.

This model is not how colors work when you mix real paint. Then you'd rather work with a red-yellow-blue model. Color printers yet
work with another model, i.e. magenta, cyan and yellow (or more).

RGB colors can be encoded in various ways. For Internet formats such as HTML, CSS or Flash, most often a hex triplet is used, i.e. a
hexadecimal 6 digit number. With 2 hexadecimal digits you can represent numbers in the range of 0 to 255.

With ordinary numbers you would represent a full red like this:

(255,0,0) - meaning full red, no green, no blue

The corresponding hex triplet is FF 00 00:

#FF0000

In terms of percentage of colors you get:

(100%, 0% , 0%)

Let's now have a look at a few colors in a diagram we copied from Wikipedia on sept 8 2007: It represents "Truecolor", i.e. RGB values
in 24 bits per pixel (bpp). In Truecolor, colors can be defined using three integers between 0 and 255, each representing red, green and
blue intensities. For example, the following image shows the three "fully saturated" faces of the RGB cube, unfolded into a plane:

(0, 0, 0) is black• 
(255, 255, 255) is white• 
(255, 0, 0) is red• 
(0, 255, 0) is green• 
(0, 0, 255) is blue• 
(255, 255, 0) is yellow• 
(0, 255, 255) is cyan• 
(255, 0, 255) is magenta• 

yellow
(255,255,0)

green
(0,255,0)

cyan
(0,255,255)
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red
(255,0,0)

blue
(0,0,255)

red
(255,0,0)

magenta
(255,0,255)

For more information about colors see links in the color article. Have a look at Wikipedia's great list of colors if you need to find a
number for your favorite color name. (If you speak french, get this one. You also may read the Wikipedia Web colors article. It also
includes a list of colors and explains what a hex triplet is.

Using the Flash color panel with solid RGB colors

It's probably a good idea to pick a standard color (click on the little pain bucket or choose from the swatches panel)• 
You then can adjust brightness/saturation with the slider or select another more non-standard color from clicking into the
Color Picker.

• 

Below is a standard blue (the brightness/saturation slider remains in the middle)

The Flash - Standard RBG Blue
Below is a blue with augmented brightness (using the slider to the right of the color picker).

The Flash - Washed out Blue
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6.3.2  The HSB/HSV model

The HSV (Hue, Saturation, Value) model also known as HSB (Hue, Saturation, Brightness) defines a color in terms of three
components:

Hue, the color: Represented as a position in the 360 degrees of a color circle.1. 
Saturation, the intensity or "purity" of the color: Ranges from 0-100%. 0 means no color, i.e., a shade of grey between black
and white. 100 means intense color.

2. 

Value or Brightness of the color: Ranges from 0-100%. 0 is always black. Depending on the saturation, 100 may be white or a
more or less saturated color.

3. 

The Hue scale from 0 to 360 degrees is the following:

The hue scale (Wikipedia)
In many graphics tools (not in Flash) you get a HSV color wheel that looks like this:

The hue scale (Wikipedia)
On the outside you can select a color (H), then on the inside you can select V and S.

For more information about HSV, read Wikipedia's HSV color space article.

In Flash, when you change RGB model to HSB (with the little pull down menu on the top right of the color panel) you will see this:

Color panel in HSV/HSB mode
The slider to the right will adjust both Saturation and Brightness.
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6.3.3  Tint and Shade

According to Wikipedia, “In color theory, a tint is the mixture of a color with white, and a shade is the mixture of a color with black.
Mixing with white increases value or lightness, while mixing with black reduces chroma. Mixing with any neutral color, including black
and white, reduces chroma or colorfulness. The intensity does not change.”

In Flash, tint is a color that you can add to a symbol in motion tweening. Alternatively (but not at the same time) you can modify its
brightness. In addition you can change its alpha value (make it more or less transparent)

See the Flash special effects tutorial tutorial.

6.4  Flash Color Gradients

Flash supports there are 2 kinds of color gradients (see the picture below)

Linear: color changing in one direction• 
Radial: color changing from a center to outside• 

Linear and radial gradients and Gradient Transform
Color gradients work with color bands. You can define 2 or more colors and Flash will fill in intermediate colors between them. The
result then depends:

on the choice of colors• 
on the width of the color band (from one color to the next one)• 

You can change these be defining and dragging color pointers in the Color panel. Read on ...

6.4.1  Using color points

There are some built-in gradients (linear and radial) that you may use as is, however you most likely want to change things. To do so,
you need the color panel and then manipulate the controls in the preview window.

If you select either "linear" or "radial" Type you will see the gradient preview window at the bottom of the color panel:
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Color panel - Gradients - Color points
The little "arrow squares" you now can move from left-to-right are called color pointers and they delimit color bands.

Here is a list of common operations:

(a) Adjust color bands

To make a color band smaller or larger, move various color pointers left or right• 

(b) Add new color bands

Click into the area of the color pointers. This will add new color pointer.• 

(b) Change the color of a color pointer

Click on a color pointer, then select a color in the panel above or double-click on the color pointer to select from the swatches
panel.

• 

(c) Remove a color pointer

Drag it down and off (below the gradient preview window)• 

6.4.2  Transforming gradients

With the gradient transform tool (hidden underneath the Free Transform tool) you can do five things:

rotate gradients (both linear and radial).1. 
stretch out the gradient2. 
stretch the radial gradient in only one direction (make an oval)3. 
Move the center of gradient4. 
Make the "rings" asymmetric5. 

Procedure

Select the tool (hold down the mouse over the Free Transform tool in the tools panel) and select the Gradient Transform
Tool.

• 

After selecting an object you will see five handles with which you can: stretch in one direction, resize, turn, make rings ellipsoid
or move the center. See the screen capture below, which shows the handles for a radial gradient transform:

• 
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Radial Gradient Transform - resizing
(note: I forgot to annotate the triangle which you also can move).

Stretching or rotating a linear gradient works in a similar way:

Linear gradient transform - turning

6.5  The alpha channel

In computer graphics, alpha compositing is the process of combining an image with a background to create the appearance of partial
transparency (Wikipedia)

In more simple terms, you can set the alpha to some percentage:

100% can't see through• 
80% bad see trough• 
50% in between• 
30% good see through• 
10% good see through, but very little color• 
0% no color left• 

Alpha color channel
Hint: With the alpha channel you can create other effects than see-through "windows". E.g. you can overlay textures with color or the
other way round.

6.6  Drawing with bitmaps
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Color panel - bitmap colors

Importing a bitmap

There are two solutions:

You can just paste a bitmap graphic into the library from the clipboard. For example, if you see a nice (and copyright free)
texture on the Internet with the Firefox navigator, do the following: (1) View image, (2) Copy Image, (3) CTRL-V into Flash

• 

Save the image on your computer then click on the Import button in the colors panel.• 

Finding textures

See the texture article• 

Using a bitmap

You can use a bitmap graphics either as stroke or as fill color.• 

Adjusting "grain size"

With the free transform tool you can adjust how a bitmap will be applied. You can change:

Size, i.e. whether the bitmap is applied as is, or reduced or magnified in x, y direction or both• 
Rotation• 
Skew (a kind of distortion)• 

Select the Free Transform tool, then

Click on the fill or stroke• 
Play with the handles (if the bitmap is big, you may have to search for these handle way out of the stage !)• 
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Gradient Transform tool on bitmaps
Note: I have the impression that there may be some bugs (i.e. the tool acts strangely when I use it twice with several instances of the
same bitmap).

6.7  Filters for symbol instances

You can apply various color changes to all symbol instances (movie clips, buttons and graphics). To do so, play with the Color and
Blend controls in the properties panel.

You can add filters (e.g. a gradient glow a bevel or a drop shadow) to movie clip and button symbol instances. Use the Filters panel to
do so, (click on the tab in the properties panel), else use menu Windows->Properties->Filters)

To add filters, simply click on the + sign and then play with the parameters. Using different sorts of "Quality" also has an important
effect on the rendering, high quality may slow down certain computers.

Blur X and Blur Y define the size of the affected area• 
Strength the force of the filter (more or less)• 
Shadow and Highlight, the dark/light colors of the filter effect• 
Angle and Distance, direction of the filter effect• 
Knockout and Type, whether it applies to the inside and whether the orginal drawing is knocked away.• 

This is a nice feature that beginners often overlook. So if you need cool looking 3D effects on graphics explore these filters. You also
can apply several filters to the same object. In the screen capture below we show an attempt to create a floating 3D button from a
simple red circle.
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Flash CS3 filters you can apply to movie clip and button instances
Tip: Since filters are applied to instances of movie clips, you may use them in motion tweens. E.g. in the first key frame you could use
no filter and in the second keyframe a filter, or change parameters or apply different filters ....

6.8  Colors in 3D graphics

Just for your information: 3D graphics languages and tools usually offer a much richer palette of color types and much more
sophisticated textures. CS4 may have these too, at the time of writing I didn't upgrade yet.

E.g. in VRML/X3D (a Web standard) you get color types like this:

Diffuse color is a color that reflects light depending on the angle of the surface. The object appears brighter (more lit) when its
surface is directly exposed to light as you would expect. That's your "normal color".

• 

Emissive color defines "glowing objects". E.g. you would use this to build a visible lamp.• 

Specular color defines extra reflection has when the angle from the light is close to the angle you are looking at. It is used
together with shininess. You can experiment this effect in real life by holding a (new apple) or a photograph between you and
a window (or a lamp).

• 

In Flash, you actually can get these effects (but I don't know how to do it in a simple way, the easiest way may be to play with filters as
described just above).

6.9  Links

General color

See the color article. It includes links to good Wikipedia articles• 

Other kinds of assets

Texture• 
Clipart• 
Sound Assets• 
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7 Flash bitmap tracing tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This entry is part of the Flash tutorials.

7.1  Overview

Bitmap tracing means transforming a bitmap graphic (e.g. a photograph) into a vectorized object.

Learning goals
Learn about basic Flash 9 (CS3), Illustrator and Inkscape bitmap tracing.

Prerequisites
Flash CS3 desktop tutorial
Flash drawing tutorial
Flash layers tutorial
Flash shape tweening tutorial

Moving on
The Flash article has a list of other tutorials.

Quality
This text should technical people get going and may not be good enough for self-learning beginners. It can be used as
handout in a "hands-on" class. That is what Daniel K. Schneider made it for...

Level
It aims at beginners. More advanced features and tricks are not explained here.

Materials (*.fla file you can play with)
http://tecfa.unige.ch/guides/flash/ex/tracing-intro/
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

Bitmap tracing will turn a bitmap (e.g. a photograph or a non-vectorized graphic) into vector graphics. This allows you for example to

Shape tween portraits (see also the Flash shape tweening tutorial)• 
To take bitmap graphics found on the Internet and turn them into somewhat usable vector graphics for animation (useful if you
can find any appropriate vectorized clipart).

• 

7.2  Extracting a drawing from a picture

Vienna Lion picture
That's a tough problem, since a picture got many colors and sometimes objects overlap (i.e. you have to remove these and then repair
with painting).

To the right you see the picture of some lion that can be found in Vienna (plus the head of a research assistant). We show how we
extracted just the lion (about 30 minutes of work).

Step 1 - Trace the picture

Menu: Modify->Bitmap->Trace Bitmap• 
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Parameters used were: Color threshold=80, minimum area=5, Curve Fit= tight, Corner threshold = normal• 

This will lead to a set of shapes that are neither too big nor to small

Step 2 - Kill unwanted shapes and erase overlapping ones

There are several kinds of tools and tactics you may use:

Use the Lasso in the tools panel to get rid of most the unwanted background, but don't use it too close to the shape you want
to keep.

• 

Magnify after this to something like 400 percent• 

Use the eraser tool• 

Use the lasso again or Shift-Click on unwanted objects. Then hit the DEL key.• 

Use the eraser to draw fine lines (elect a very small rubber) if you have to cut wanted/unwanted area in the same shape. Then
kill the unwanted one

• 

Use the eyedropper to select a color and then the paint brush to repair some stuff.
Do not use object drawing mode for this.♦ 
You should set the paint controls to "paint behind", i.e. to repair outlines rather paint behind something when you
touch it with the brush.

♦ 

• 

...• 

Vienna vectorized lions scene

Step 3 - Smooth it and make it a drawing object

Select all the shapes (hit CTRL-A). Then

Menu->Modify->Shape->Optimize. Set this to maximum.• 
Menu->Modify->Union• 

Step 4 - Convert to symbol and use it

The result is really dreadful as you can see in the thumbnail to the right:)

Source

See the "lion*" files in http://tecfa.unige.ch/guides/flash/ex/tracing-intro/

7.3  Tracing parameters in Flash CS3

There exist four parameters in the tracing panel:

(1) Color threshold

When two pixels are compared, if the difference in the RGB color values is less than the color threshold, the two pixels are
considered the same color. As you increase the threshold value, you decrease the number of colors. If you want a minimum of
colors, try something like 255 (or even more)

• 
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(2) Minimum area

The number of surrounding pixels to consider when assigning a color to a pixel. I.e. if you want few resulting vector shapes,
set this high

• 

(3) Curve fit

This will determine how smoothly outlines are drawn. E.g. in a portrait you can make disappear things like standing our hair.• 

(4) Corner threshold

Defines whether sharp edges are retained or smoothed out.• 

See this little gallery of my traced portrait.

Typical settings you could use are:

(a) A trace that keeps most of the information (many many graphic shapes in the result

Color threshold=10, minimum area=1, Curve Fit= Pixels, Corner threshold = many corners• 

(b) A sort of "normal" picture that gets most of the important outlines

Color threshold = 30 and minimum area = 30, corner threshold and curve fits = normal• 

(c) A few colors picture result with sharp lines

Color threshold = 200 and minimum area = 2• 

Source of the demo application (it uses a component for navigation)

Directory: http://tecfa.unige.ch/guides/flash/ex/tracing-intro/
Fla: flash-cs3-tracing-parameters.fla

Tuning

Of course, once you have your trace, you then can remove unwanted elements (e.g. backgrounds in a portrait), change colors or apply
all other drawing techniques you know.

7.4  Bitmap shape tweening in Flash

We will trace of portrait picture (jpg bitmap) and then add a shape tween to it.

Step 1 - Import a bitmap

Import the picture to Flash, e.g. by dragging it to the Flash desktop.• 
You may resize the picture first with an external tool• 

Step 2 - Trace it

Menu: Modify->Bitmap->Trace Bitmap• 
You can play around with a few settings• 

Here is an example that shows the original and the traced result side by side
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Live tracing with IllustratorCS3

Step 3 - Make a shape tween

Hit F6 in some distant frame• 
Make changes to the vector image in the new frame. E.g. distort or change colors (use the Select or the Lasso tool to select
areas of the picture)

• 

Add the shape tween.• 

You can admire the result (files flash-cs3-shape-picture-morphing3.*)

Tuning

Adjust the size of the picture to the scene with the• 
You may extend the first frame to remain stable for a while so that users can see the original• 
Then you could add a "stop();" in the Last Frame. Hit F9 and type• 

stop();

This will stop the animation. (See the Flash button tutorial for more about ActionScript.• 

Of course this is really ugly ...

7.5  Tracing a bitmap with Illustrator

Step1 - Trace the bitmap

Illustrator CS3 has more sophisticated bitmaps tracing features. Here is a very short example that includes a shape tween:

Open the picture in Illustrator• 
Select it• 
Now you will have a "Live Trace button" on the control panel on top• 
Next to it is a little pulldown menu from which you can select various options, for a portrait you may choose "Color 16"• 

Live tracing with IllustratorCS3
Once you hit the trace button, the controls on top will change and you can play with all sorts tracing methods and parameters
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Live tracing controls with IllustratorCS3

Step2 - Import to Flash

Copy/paste if from Illustrator with the options: Paste using AI File Importer preferences and untick maintain layers• 
You may adjust the size of the stage to the size of the picture somewhat, I chose to add some big margins for a reason you
will see later.

• 

Convert it to a symbol (so that you have a copy in the library)• 

Step 3 - Break it Apart

Then right-click->Break Apart• 
You have to do this several times, since illustrator produced object groups within object groups (use ctrl-Z if you think you
went too far).

• 

Step 4 - Create a new keyframe

Right-click on frame 20 and hit F6 to create a new keyframe with the same picture.• 

Step 5 - Distort the picture in keyframe 1

Try everything you can

Select parts and change the color with the paint bucket. That's actually the only thing I did• 
You also can move parts, but probably you then should start with a much simple ray trace.• 
Distort parts with the Selection Tool, the Subselection tool and the Free Transform tool• 

Step 6 - Add a shape tween between the two frames

... enjoy

Tune

You also may at the very end (after the last keyframe) insert the original jpg picture. Tracing bitmaps is a very difficult issue,
since there are many kinds of algorithms you can select from.

• 

Basically the machine must be told how to group similar pixels together into a vector objects. For example, an algorithm can group
together pixels with similar brightness, similar color, or try to find lines from similar pixels.

Publish

In the HTML setting you probably want to take off the "loop" option• 

You can admire the result

Files: flash-cs3-shape-picture-morphing.*)
Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

7.6  Tracing a picture with Inkscape

The free Inkscape editor can also trace. If you don't own Illustrator and need more than CS3 can offer, you may give it a try.

File->New ; Select the bitmap file (e.g. a *.jpg)• 
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Select it (!)• 
Path -> Trace Bitmap item (or Shift-Alt B)• 
You then will see a popup with various options, Click on Update to make as many trials you like. Make sure your picture is
selected. Then play with:

Brightness cutoff♦ 
Edge detection♦ 
Color quantisation♦ 

• 

Each of these does different sort of traces.• 
Click on OK once you are happy

The original picture will still be there. Remove it and save the result with File->Save As♦ 
• 

Using two graphics from start

This time I used another strategy:

I made two different traces with Inkscape• 
I used one for keyframe 1 and the other for keyframe 2 and saved them in SVG• 
Since Flash cannot import SVG (why the hell ?) I open these files in Illustrator and then pasted to Flash.• 
I then used the erasor tool to isolate a few graphics shapes (e.g. hair and eyes)• 
I then put "hair" and "eyes" in a different layer• 
I finally inserted some shape hints (see the flash shape tweening tutorial• 

Changing the background color

I added a new layer and painted a rectangle over the stage in Keyframe 1• 
Same for a new keyframe• 
Then I also added a shape animation between the two.• 

You can admire the result. It's also fairly ugly (despite some extra work)

Source
Fla file: flash-cs3-shape-picture-morphing2.fla
Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

Ok that would be the only picture of me in edutech wiki. In addition I made these very quickly which is not what you should do in a "real"
production. The result is really ugly and useless ...

7.7  Links

Convert bitmaps to vector graphics (Adobe Flash C3 Help)• 
Control shape changes with shape hints (Adobe Flash C3 Help)• 
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8 Flash frame-by-frame animation tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This entry is part of the Flash tutorials.

8.1  Introduction

Frame-by-frame animation means to display one image after each other and that creates the illusion of a movie.

Learning goals
Learn basic Flash 9 (CS3) frame-by-frame animation, one kind of Flash animation.
Save a frame-by-frame animation as reusable movie clip.
Learn about symbol edit mode.
Learn about some object transformation features

Prerequisites
Flash CS3 desktop tutorial
Flash layers tutorial
Flash drawing tutorial (for starters some of it, at some point you'll have to dig into it a bit)

Moving on
If you want to do serious frame-by-frame animation, you probably better drawing skills. In particular, you should read the Flash
object transform tutorial and the Flash arranging objects tutorial since you'll have to change graphics from one frame to the
next one.
The Flash article has a list of other tutorials. You probably should continue with the Flash motion tweening tutorial. It will teach
how to make fly things. You also can read the Flash shape tweening tutorial which tells how to do morphing animation.

Quality
This text should technical people get going and may not be good enough for self-learning beginners. It can be used as
handout in a "hands-on" class. That is what Daniel K. Schneider made it for...

Level
It aims at beginners. More advanced features and tricks are not explained here.

Materials (*.fla files you can play with)
http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/

The executive summary

Purpose: Frame-by-frame animation gives you very detailed control over the movie (since it's the technology used to make animation
pictures until recently before different 2D and 3D computer animation techniques came into the existence). Disadvantage is that
frame-by-frame drawing is very time consuming work. Therefore, most often, designers use a combination of frame-by-frame animation
and interpolation techniques (called tweening in Flash lingo). Often, frame-by-frame animation is used to animate single objects that in
turn can be used as part of larger Flash animations. A typical example are buttons that highlight when you move the mouse over them
or when you click on them.

Executive summary of the procedure:

Insert drawings in various keyframes• 
Modify these drawings a little bit over time• 

8.2  The timeline and keyframes

The principle of frame-by-frame animations made with drawings is that you draw various versions of the same objects in different
frames. These are then displayed one after each other in rapid order (most often between 10-25 frames / second).

A frame is a drawing that is displayed at a given time. In the timeline, each stop in each layer of the timeline is a frame and they are
numbered from 1 to whatever length your animation has. Let's start by introducing the meaning of a few symbols in the timeline. We
later will come back to these.
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If you feel that display of timeline elements is too tiny, you can fix this with the time line options (little pull-down menu in the upper right).
This menu also allows displaying a preview of the animation (but that takes up space of course).

Time line options pulldown menu
When you start drawing with Flash, everything is drawn by default into a first frame in layer 1.

The default keyframe is frame # 1
E.g. if you insert a letter, for example, you will see something like in the screen capture just above.

The first frame in the timeline will have a dot inside. So if you see a frame with ".", it means that there is some content inside.• 
The playhead showing the current frame (the red rectangle) sits on top of frame one.• 

There are other symbols that can appear in the timeline and we will introduce them later as we need these.

We now will introduce three frame-by-frame animation examples. We will do this in the main time line of the *.fla file. Alternatively, you
also can first create so-called movie clip symbols and then edit these objects as described in the end of this article.

8.3  A simple letter after letter animation

Have a look at the this simple animation first.

The *.fla, *.swf and *.html files flash-cs3-frame-by-frame-hello.* can be found at
http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/

We will produce an animation that will display the word "HELLO", one letter after each other. The principle is quite simple: We will insert
new letters in new keyframes. One could do this by inserting "H" into keyframe 1, then add "E" to keyframe 2 etc. We will do something
slightly different here, i.e. we insert a keyframe every 5 frames.

Step 1

We insert the letter "H" in frame 1 (alternatively you may start in frame 5, i.e. the user won't see the "H" when the frame loads. Anyhow,
later you always can add extra empty frames.

Steps 2 to 5

Now we repeat this procedure by adding new letters in new frames. So first we will transform frame 5 into a new keyframe. It is
important to understand that there are two kinds of new keyframes:
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Blank ones that will clear the stage, i.e. the objects will be gone. That's not what we want here.1. 
Keyframes that carry "forward" contents of the keyframe before. We will use this one.2. 

The procedure is the following (see the picture below)

Right-click in a frame, then select Insert Keyframe (not insert blank keyframe). Alternatively hit F6, i.e.use the [Flash CS3
keyboard shortcuts|shortcut]].

• 

Editing keyframe #5
Repeat this, until you incrementally spelled out "HELLO".

Step 6

Test if it works:

Firstly you simply can move back and forth the playhead (red rectangle that sits on the top of the timeline)• 
Then you can test the movie though the menu Control->Test Movie or hit CTRL-Return. This will open a up a new window
where you can see more or less what an end-user would see.

• 

Step 7

Now we want to tune a few things:

(1) You may not be happy that the movie starts with letter "H" already displayed. Right-Click on Frame 1 and Insert Frame (not a
keyframe!) or hit F5. Repeat this 4-5 times. Then hold down the mouse and drag the black dot in the new frame 1 to frame 5.

(2) Your Movie may be too slow or too fast. Flash animation made with the CS3 drawing tools is not time-based (as in SVG for
instance) so you have to fix a frame rate. You can change the frame rate (number of pictures shown/second) in two ways:

Click on an empty spot on the stage and change the rate in the properties panel that you should see below• 
Menu Modify->Document (CTRL-J)• 

For this animation, about 15 frames are about right I think.

(3) You also may align the letters. But you have to do this in each keyframe, else they will jump around, which actually may be an effect
you like.

To align all letters in all frames: Click on the Edit multiple frames button.
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Select all frames

Then, you can select the frames you want to edit together by moving the "[" "]" sliders on top of the timeline• 
Then select letter-by-letter groups, then use the align pane (Window->Align), but untick To stage.• 

This tool is quite dangerous, since it's hard to control what happens in each frame. Make sure to save your file before you engage in
this ! Anyhow, next time make sure to place your objects where they should be.

Step 8

Now you can publish this as a web page.

Make sure to save the animation in some place you can remember, because Flash will put the exported Flash, HTML and
JavaScript there.

• 

Then, click on an empty spot in the stage and click the "Publish Settings" button or menu File->Publish Settings.• 
Click the publish button when you are happy with the settings. It will put all the necessary files in the same directory where
your *.fla file sits.

• 

Then click on either the Flash *.swf file or the *.html file and see if it works.• 

As an exercise, you now can add extra keyframes after frame 1,5,10, etc. and move up or down letters. Alternatively, read on ...

8.4  Frame-by-frame shaky animation

Sometimes, e.g. in trailers or in little advertisement boxes you can see some sort of shaky or jittery icons, like in the example we are
going to discuss now.

The *.fla, *.swf and *.html files flash-cs3-shaking-hello.* can be found here: http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/

Step 1 - change stage size

Define size and background color of your stage (I use 400x200 px this time). To do so, click with the selection tool on an
empty spot of the stage and change the properties of the stage in the properties panel (usually shown below the stage).

• 

This time, we will use two layers, so create 2 layers, call one of these "hello".• 

Step 2 - draw a hello word

In the "hello" layer, draw the word "Hello" with the pencil for a change• 
Select the pencil

Put the Pencil tool into "Smooth mode".♦ 
Put Flash into object mode (circle in the options area of the tools panel)♦ 
Select a wide stroke (15px or more)♦ 

• 

Go back to the drawing tutorial if you don't how to use object mode and how to set the smooth control for the pencil.

Step 3 - fix the hello word

You may have to fix the Word "Hello", since despite smooth mode your drawing may not be so hot.• 
Firstly use the Free Transform tool to adjust size, rotation, etc. of each letter.• 
Then use the Subselection tool to fix certain letters, probably your "o" will be ugly.• 
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To do good work, you need to set magnification to something like 400 (Menu View->Magnification).♦ 
Then you can drag around the distortion points' (squares) and kill some of these and/or move the curve control
handles (dots attached to a line).

♦ 

You can read further explanation about envelope transforms♦ 
Finally select all letters with the selection tool and center them. You may also may make the whole drawing bigger or smaller
(just change the "W" property in the properties panel while everything is selected, i.e. see the screen capture below).

• 

So now you should have (very) roughly something like this:

Hello with the pencil

Step 4 - Draw an oval

Draw an oval or something around the "Hello" word if you want. Use another layer for this and lock the "Hello" layer while you
do this. See the Flash layers tutorial if you don't know how to use layers.

• 

Again, use the subselection tool to fine tune if needed. If you need more explanation about object transformation, have a peek
at the Flash object transform tutorial.

• 

Step 5 - Make a new keyframe for both layers

Create a new keyframe in frame 2 (as explained above).

Hit F6 or Right-click; Insert Key Frame for the "hello" layer• 
Hit F6 or Right-click; Insert Key Frame for the "oval" layer• 
Now you should have a copy of both the "hello" word and the Oval in the new frame.• 

Step 6 - Make changes

Now you can make slight changes to your drawings in frame 2 (so make sure that frame 2 is selected !)• 
I changed color a bit for both the oval and the hello word.

Unlock the "hello" layer if it's still locked.♦ 
"Edit->Select All"♦ 
Change the color in the properties window♦ 

• 

Then twist a little bit some letters and maybe the Oval
You can do this for instance with the subselection tool or the Freetransform tool. (I only used the subselection tool
and basically turned a few Curve control handles).

♦ 
• 

Below is a picture of the slightly altered graphics:
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Hello with the pencil - second frame

Step 7 - Add other frames

Just two frames will do, but you can add more of course :)

This example was a bit more professional. We tried to select a good stage size and made some efforts to get the drawings right.

8.5  Rocket science

Frame-by-frame animation is also quite useful if you want to create animated objects that you then can reuse in another animation as a
movie clip. Let's first look at this little rocket we shall discuss.

The *.fla, *.swf and *.html files flash-cs3-rocket.* can be found here: http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/

I imported this rocket from Uncyclomedia Commons:

http://commons.uncyclomedia.org/wiki/Image:Rocket.svg

It's an SVG file that I first opened with Illustrator.• 
I then copy/pasted it to Flash. See the Clipart article (i.e. the section on Importing to Flash).• 

Now we would like to animate the flames of this little rocket.

Step 1 - Break the rocket into components

Break the rocket apart (right-click->Break Apart). You now should see various rectangles drawn around its various shapes.• 
Flames are made with 2 shapes (the two rectangles in the lower right)• 

A broken apart imported SVG rocket
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Step 2 - Put the flames into another layer

The easiest way is to use distribute these to other layers

Select the 2 flames (hold down the SHIFT key and click on the orange and yellow parts• 
Then Right-click->Distribute to layers• 
Rename the two layers you created.• 

Now you should have something like in the screen dump below. I am positioned in the yellow flame layer and show the other two as
outlines.

Rocket with flames in layers

Step 3 - Duplicate frame 1 to frames 2 and 3 in these two layers.

As explained above, in frame 2: Right-click->Insert Keyframe. Do this for each of the three layers• 
Repeat this for frame 3.• 

Step 4 - Change the flames for each frame

I simply used the Free Transform tool and dragged the rectangle towards the lower right.• 
By doing this you also might have moved the rectangle itself, just push it back underneath the rocket... (either with the arrows,
or with the selection tool).

• 

In order to get this right, you should each time put all the other layers (rocket plus one of the flames) in outline mode with the
layers tool.

• 
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Rocket with flames in layers

Step 5- Tuning

The animation is now a bit too fast. We would like to get the kind of effect you see in old and cheap cartoons on TV.• 
If you wish you can drag the keyframes (each dot to the right). I made a keyframe in every 5, but I also adjusted the Framerate
to 30/second. That's good TV quality. (click on workspace and adjust in properties panel)

• 

Rocket frames stretched

Then you also could improve drawing of the flames (see the Flash object transform tutorial and/or add more keyframes.
Finally, you could add motion tweens between the keyframes. I didn't do this since motion tweening is not part of this tutorial.

• 

Step 4 - Test and publish

Test and enjoy :)• 
Publish• 

Step 5 - Export as a video clip only

File->Export Movie will just save a *.swf Flash animation file (no HTML and JS).

There are two ways of exporting an *.swf movie.

"Normal", i.e. compressed. This means that when import this flash file into another flash file, you can't edit the object anymore.• 
"Uncompressed". This means that after you import the rocket you can edit it somewhat. To get this option, untick Compress
Movie in the settings dialog that will pop up.

• 

Step 6 - Turn it into a movie clip symbol (optional)

You also can turn this whole animation into a movie clip symbol. This is best strategy if you want to build a library of fully editable flash
movie clips you can import into other animations. Also, as we shall point out later, you actually could start by creating a movie clip
symbol and then create an animation.

Select all layers and frames (click on the first layer, then SHIFT-click on the last). Make sure that every frame and layer in the• 
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timeline is black
Copy all the frames (everything) Menu Edit->Timeline->Copy Frames• 
Menu Insert->New Symbol. Tick the Movie clip option and give it a good name, e.g. "Rocket".• 
Then you should be in Rocket editing mode and just see "Layer 1" on top• 
Put the cursor in the first frame• 
The paste the whole rocket code: Menu Edit->Timelines->Paste Frames• 

You now should see something like this:

Rocket animation made into a symbol
Next you can copy this symbol to another flash file which you may call my_library.fla. We just killed everything in the file (except the
symbol) and saved it under a different name (flash-cs3-rocket-symbol.fla)

Result

Now we have two versions of rocket *.swf move clipt that we can reuse in another Flash animations

flash-cs3-rocket.swf• 

flash-cs3-rocket-uncompressed.swf. This version also has the improved flames• 

In addition we have file *.fla file with just a rocket symbol inside. You can copy/paste symbols from one flash file to another one.

flash-cs3-rocket-symbol.fla• 

Below is a short how-to re-use *.swf files , but you also can directly go and read the Flash motion tweening tutorial.

8.6  Reuse frame-by-frame animations as movie clips

8.6.1  Reuse of swf files

The swf flash files we just created can be used as components in new Flash animation.

The *.fla, *.swf and *.html files flash-cs3-rocking-hello.* can be found here: http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/

Step 1 - Import *.swf files into the library of a new Flash file

Create a new flash file (File->New)• 
Then import stuff you made: File->Import->Import to library

Select the flash-cs3-rocket.swf file♦ 
Do the same with the flash-cs3-shaking-hello.swf file♦ 

• 

You now have a nice rocket and a flashing hello in your library:
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Hello and rocket movies in your library

Step 2 - Drag the symbols (movies) to the stage

Drag the item in the library onto the stage• 
Now your rocket is too big :(• 
No problem. Use the Free Transform tool to make it smaller and to rotate

Hold down the SHIFT key when you resize it from a corner !♦ 
• 

Here is the result:

Hello and rocket movies used

Step 3 - Learn about motion animation

Of course, now you should do a moving animation with these flashing objects. See the Flash motion tweening tutorial and before this
enjoy the flying rocket:

http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/flash-cs3-rocket-moving.html

8.6.2  Creation and reuse of embedded movie clips

In the Rocket science example and in the others too, we created the animation in the main time line. Alternatively (and better for the
future) you should first start by creating a new symbol:

Menu Insert->New Symbol. Tick the Movie clip option and give it a good name, e.g. "Rocket".• 
Then you land directly in symbol editing mode and you can create an animation for just this object as described in all the
examples above.

• 

Once you are done with symbol editing, double-click on "scene" in the edit bar (on top of the stage) or click on the little "back
arrow". Always make sure that know whether you edit just a symbol or whether you are in the main timeline (the whole
scene) !

• 

Read more in the Flash embedded movie clip tutorial about creating and using embedded movie clips. This tutorial will also introduce
some ActionScript code that is needed to stop/start embedded animations.

Also remember that you can copy/paste anything from one *.fla file to another and this includes movie clips. So it's a good idea to
create somewhere a private library (a fla file) that includes all your major artwork.
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8.7  Links

8.7.1  Example materials

Example files used (including *.fla source) can be found here:

http://tecfa.unige.ch/guides/flash/ex/frame-by-frame-intro/

Click on either an *.html or *.swf file to see.• 
Get just the *.fla file if you want to make modifications. The standard copyright of this wiki applies.• 
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9 Flash motion tweening tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This entry is part of the Flash tutorials.

9.1  Overview

Motion tweening means motion animation with interpolation.

Learning goals
Learn about basic motion animation, i.e. move an object from A to B, to C ...
Add some simple shape transforms to the animated object
Learn how to to frame-by-frame animations with embedded movie clips.

Prerequisites
Flash CS3 desktop tutorial
Flash layers tutorial (first part)
Flash drawing tutorial (at least some of it)
Flash frame-by-frame animation tutorial (not absolutely needed, but probably useful)

Moving on
Flash shape tweening tutorial
Flash animation summary
After that you should be ready for interactivity. E.g. do the Flash button tutorial

Quality and level
This text should technical people get going. It's probably not good enough for beginners, but may be used as handout in
"hands-on" class. That is what Daniel K. Schneider made it for...
It aims at beginners. More advanced features and tricks are not explained here.

Materials (*.fla file you can play with)
http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/

9.2  Introduction

9.2.1  Frame-by-frame vs. tweening

In Flash, you can create several kinds of animations and associated special effects. To create motion animation, there are 2 options:

Frame-by-frame animation (ancient technique used for cartoons). This leads to precise results but is time consuming. Actually,
before doing this tutorial you can do Flash frame-by-frame animation tutorial first.

• 

Tweening. Wikipedia, retrieved 20:45, 7 August 2007 (MEST) defines “Tweening, short for in-betweening, as the process of
generating intermediate frames between two images to give the appearance that the first image evolves smoothly into the
second image. Inbetweens are the drawings between the keyframes which help to create the illusion of motion. Tweening is a
key process in all types of animation, including computer animation. Sophisticated animation software enables one to identify
specific objects in an image and define how they should move and change during the tweening process. Software may be
used to manually render or adjust transitional frames by hand or use to automatically render transitional frames using
interpolation of graphic parameters.”. In other contexts, one uses also "morphing". E.g. PCMag (retrieved 20:45, 7 August
2007 (MEST)) defines tweening as “An animation technique that, based on starting and ending shapes, creates the necessary
"in-between" frames. See morphing”.

• 

9.2.2  What can be animated with motion tweening ?

In Flash 9, you can animate all sorts of compound objects:

Symbols, i.e. any object that is an instance of a library object, e.g.
Graphic symbols♦ 

• 
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Movies (full *.swf Flash animations or embedded movie clips)♦ 
Buttons♦ 

Compound objects (things that you grouped together)• 
Text boxes• 

If you want to work on your own project ...

In this tutorial we will mostly work with graphic symbols. So the first thing you may have to do - if you want to work on your own project -
is to convert one of your graphics to a graphic symbol and to put it in a separate layer.

Right-click on the object (click down the right mouse button) and then select Convert to Symbol .... Alternatively just select the
object and hit F8.

• 

Each object to be animated should be in a separate layer. All the other objects may remain in a single layer.• 

convert a select object to a symbol
So before we start, make sure that you have a least one graphic symbol, i.e. the object that you would like to move around in your
library. E.g. the library of the "cat example" we will build now contains this:

Library items (only graphic symbols)

Use of layers

You must use a different layer for each separate animation. If you plan to animate several of your objects, there is a practical shortcut
to distribute each object to a new layer:

Select objects you want to distribute into layers (e.g. with right-click->select all or shift-click on each object)1. 
Then, Modify->Timeline->Distribute to layers2. 
Finally, rename the layers in order to help you find things...3. 

9.3  Introductory example - moving a cat

In this example, we will use the drawings made for the flash drawing tutorial and move one of the cats around. If you want to reproduce
what we do here, you can start from file flash-cs3-drawing-trees3.fla. Objects you will need are already in the library. I am aware that
these drawings are ugly, but it makes these tutorials so much more human ....

Executive summary

The principle of motion tweening is quite simple:

(1) Firstly position an object in different locations at different times

We call these positions keyframes in the timeline, since objects are frozen in different states.• 
Btw, you also can change other features than just the position of an object (more later)• 

(2) Then, you have to apply some interpolation method (tweening) between the two keyframes, i.e. you tell the computer to generate
some in-between picture for each frame between the 2 keyframes in the timeline.
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Simple motion tweening is a linear path, i.e. the object will move on a line from x1,y1 to x2,y2.• 
You can also apply a motion tween along a random path (but this is bit more complicated and we will introduce this technique
below).

• 

9.3.1  Moving a cat from x to y

You should lock all other layers. This way you are sure not to edit by mistake a frame of another layer.

Step 1 - Create a a new layer and insert an object for animation

Create a new layer and call it "animation cat" for example (see the Flash layers tutorial if you forgot how).• 
Select this layer• 
Put an tween-able object inside, e.g. drag it from your library onto the stage, or cut/paste or copy/paste from an other layer or
*.fla document.

In our case we cut/paste the existing cat that was sitting in the lower left in the "Objects" layer.♦ 

• 

We move the object (cat) outside of the stage, because the cat in our scenario will move into the scene.• 

Remember, that you can not motion tween editable objects, so you need to turn a drawing into a symbol first.

So you should see something like this:

The cat before animation. It sits outside the stage and waits
Now you already have a first keyframe for your animation. I.e. the cat is waiting in keyframe 1 to be moved.

Step 2 - Create a second keyframe

Make sure that you still have the "animation cat" layer selected.• 
Right-click somewhere in the timeline, e.g. at 20 and Insert Keyframe

This will create a new keyframe and copy the contents of the keyframe before, i.e. contents of frame 1 just for this
layer.

♦ 
• 

Drag the object (cat) to its final position, e.g. to the right and which can be outside the stage again.• 

Step 3 - Create the motion tween

Click on a random frame between the two keyframes (still in the same layer)• 
Then right-click and select Create Motion Tween. Alternatively, you also could have used the Tween pull-down menu in the
properties panel at the bottom and select motion.

• 
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Creation a motion tween with the right-click menu
The timeline for the layer including this object should now include a solid line with an arrow (if it is dashed something went wrong).

The result should look like in the screen capture below:

Between the two keyframes you see a solid line with an arrow (look at the "Animation cat" layer).• 
You should see your object moved to a different position somewhere in the middle of the two keyframes.• 

Creating a motion tween for the cat

Step 4 - Replicate contents of the other layers

As you could see in the screen captures above, the stage is empty, except for the cat. This is because all other drawings for
the other layers exist only for frame 1.

• 

For each other layer, right-click on frame 20 (i.e. in the position of your second keyframe) and hit F5 (Insert Frame, not insert
keyframe !)

• 

This will "stretch" your drawings from frame 1 to frame 20. The drawings still sit in frame 1, but they are carried over up-to
frame 20. This is shown in the timeline by a little white rectangle.

• 

You now should have something like this:
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The first result

Step 5 - Test it

You can glide (left-right) the playhead (red rectangle on top of the red line that indicates the current frame in the timeline). It
will manually move the object through all positions within the interpolation path.

• 

Then try: menu Control->Test Movie or hit CTRL-Enter. This will open a popup window with a Flash preview.• 

Step 6 - Tuning

You may find that the cat moves too fast. First thing you could do is lower the frame rate/second. Click on the workarea and change the
document properties. However, this will lead to a "jumpy" animation. It's a better idea to use frame 50 instead of frame 20 as end-point.

Drag the black dot in the animation layer from frame 20 to frame 50. Hold down the mouse on the black dot, wait a bit and
then drag.

• 

For the other layers: hit F5 in frame 50 (same as above).• 

You also can accelerate/decelerate the cat's movement. Play with the "Ease" option in the Properties panel. Click on layer
"animation cat", then select an empty "between frame" somewhere. You now can make changes in the tweening properties.

• 

If your cat moves in front instead of behind objects, then you can fix this by arranging the layers' order: Grab the objects layer
in the timeline panel and move it before or after the animation layer (i.e. pull it up or down).

• 

Results

You can look at my published result: flash-cs3-motion-tweening.html• 
You can grab all the files from this directory:• 

http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/

9.3.2  Adding more motion tweens

We want the cat to move back where it came from.

Turning the cat
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In our case we have an animation from left to right and the cat will leave the stage. Once it's off the stage we will turn it so that it can
walk back.

Next to frame 50 I made a third key frame. Click on frame 51 and hit F6.• 
Then turn the cat: Click on the cat and use menu Modify->Transform->Flip Horizontal)• 

Add a new motion tween

You can add more motion tweens to an object simply by repeating the procedure outlined above.

Add a new fourth keyframe to the right, e.g. in frame 81. Simply hit F6 again.• 
Right-click on an empty frame between keyframe 3 and 4 and add a motion tween as above• 
Of course, you then also adjust the ending frame for the other layers as above (hit F5) in column 80.• 

In the screen capture below you can see that we now have several keyframes. In the "animation cat" layer you can see several dots,
each one represents a keyframe.

Moving a cat
You can look at the published result (the cat will walk back where it came from) here: flash-cs3-motion-tweening2.html

The directory including the *.fla file which you can load into your Flash and play with is here:

http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/

9.3.3  Adding (some) motion shape tweening

In each frame you can change some properties of the moving object. In the next example, we will have the cat move up on top of the
hill. We want to implement 2 effects:

The cat should become smaller (because it's further away)• 
It should change color (because it's an effort to run up a hill).• 

Step 1 - Insert a new keyframe
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I inserted a new keyframe in frame 25 (i.e. between the first two existing key frames)• 
In the (new) 2nd keyframe the cat was moved next to the other little one on top of the hill.• 

Step 2 - Change size of cat in keyframe 2

Go to the frame (click on frame 25 or wherever yours is)• 
Select the object (i.e. the little cat)• 
Select the Free Transform Tool in the tools panel (see flash drawing tutorial), hold down the SHIFT key and drag a corner.• 

Step 3 - Change the color of the cat in keyframe 2

Go to the frame• 
Select the cat• 
In the properties panel you can change the tint (a kind of color) of the cat.• 

Here is a screen capture. The animated cat is pink and sits next to the other cat. It's pink because moving up the hill takes effort ...

Moving a cat and changing its size and color
You can look at the published result here: flash-cs3-motion-shape-tweening.html

The directory including the *.fla file which you can load into your Flash and play with is here:

http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/

9.4  Doing more informed work

9.4.1  Edit bar

If you have to do some frequent zooming you can display the Edit Toolbar (see the screen capture below).

Get the edit toolbar: Window->Toolbars->Edit bar• 

This bar also will allow you to directly edit symbols you got in your library.

9.4.2  Onion skins

You can display the path an object will take by clicking one of the onion skin buttons in the Controller toolbar. This is handy if you have
several objects that move.

Get the controller toolbar: Window->Toolbars->Controller and then click on either the Onion Skin or the Onion Skin Outlines
icon.

• 
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Onion skins for the moving cat

9.4.3  Grids and rules

To achieve what we just did, you don't need these. But for more precise artwork you certainly will...

Right-click somewhere on the workarea and play with Rules, Grids and Guides ...• 

9.5  Rotating animations

Instead of moving an object from point A to point B, you also can rotate it around point A. A good example would be hands in a clock.

Step 1 - create the object to animate

Create a separate layer for the object you want to rotate.• 
Draw the object (and don't make any new keyframes yet)• 
Transform it into a symbol (right-click and select graphic symbol).• 

Step2 - move the center point

Then with the free transform tool move its center point somewhere else if you want. E.g. to rotate an hour hand for clock move
it towards and end (the center of the clock).

• 
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Move the center point of the hour hand - Rotating clock

Step 3 - make a motion tween

Make a new keyframe, i.e.hit F6 in a new frame. You can leave the object where it is (depends on the aim of your animation)• 
Then create the motion tween (right-click anywhere in between the two keyframes)• 
Now in the parameters panel select Rotate = CW (clockwise) as in the example shown in the picture. Btw ""CCW" would
mean "countclock wise"

• 

If you want to rotate it more than once during the animation time, enter "XX times". E.g. we entered 12 for the minute hand in
the clock animation.

• 

Motion tween around a center - Rotating clock

Clock example

If you want, you can:

Look at rotating clock example• 
Or get the flash-cs3-rotating-clock.fla file from http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/ and play with it.• 

9.6  You don't like my cats ? / Embedded movie clips

As we pointed out in the Flash drawing tutorial, you can import professionally made clipart into Flash. Furthermore, you now should
learn how to move animated objects, i.e. use so-called embedded movie clips. See also the Flash embedded movie clip tutorial.
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9.6.1  Use of embedded movie clips

Instead of using the main timeline to create all your animations, you also can animate so-called "movie clips", i.e. instances of movie
clips.

Menu Insert->New Symbol• 
Select Movie Clip (and give a good name)• 
Double-click on this newly created movie clip in the library. You now can edit this object's own timeline.• 

Alternatively transform an object into a movie clip:

Select the object (or use the lasso or another appropriate tool to select several objects)• 
Right-click->Convert to Symbol; Select Movie clip• 
Double-click on this object to edit.• 

There are two ways to edit a movie clip:

(1) In "stand-alone" view, i.e. you only will see the components of the movie clip. Double click on the movie symbol's icon (not it's
name) in the library. You now can edit, e.g. a add a motion animation or change its drawings. Most of time, this editing mode is
preferable.

(2) Edit with the scene as background. If you put an instance of the movie clip on the stage and then double-click on this instance, you
can edit the same movie clip symbol, but you will see the objects of the stage while you edit.

By editing a movie symbol you basically can do the all the stuff you have learnt so far, e.g. in the Flash frame-by-frame animation
tutorial. In other words, movie clips have their own timeline.

A pulsating moving sun

Let's now create a very simple animation, i.e. a pulsating sun that is moving from left to right in the sky. First, we will make a simple
motion tween of a yellow circle moving from left to right:

Create a new Flash fileand change the size to 800x200 pixels• 
Draw a yellow circle and put it to the left of the stage• 
Convert it to a movie clip symbol (Right-click->Convert to Symbol; Select Movie clip)• 
Hit F6 in frame 120 and move the circle that is now an instance of a movie clip to the right of the stage• 
Make a motion tween.• 

Then edit the sun symbol to create a frame-by-frame animation

Editing a movie clip symbol used in a motion tween

As you can see, we are editing the sun "symbol". Look at the Edit bar (that sits between the timeline and the stage). It displays
the editing hierarchy, i.e. "Scene 1" and "Sun".

• 

This frame-by-frame animation changes both the color and the size of the circle. Read the Flash frame-by-frame animation
tutorial if you don't know how to create frame-by-frame animations.

• 
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Do not forget to go back to the main timeline (scene) once you are done, e.g. by double-clicking on the "scene" in the edit bar (on
top of the stage) or by clicking on the little "back arrow". When you edit a movie clip you are in symbol edit mode and you should not
add anything else by mistake. Make sure that you are aware at which level you edit and where to place objects !

Finally you also may add a sky in the main timeline (e.g. with a gradient color, see the flash colors tutorial)

The example code is in the http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/ directory
flash-cs3-motion-tweening-sun.html
flash-cs3-motion-tweening-sun.fla

Note: we use embedded movie clips in many other tutorials. E.g. see ActionScript 3 interactive objects tutorial or Motion tweening of an
animated object chapter in the Flash animation summary or the Shape tweens of motion tween elements chapter in the Flash shape
tweening tutorial

I usually prefer this kind of animation, since I am more interested in creating interactive application (vs. video clip-like animations). If
you plan to learn this, you also should learn how to stop/play embedded movie clips, i.e. trigger with the help of a button or something
else an event that will movie_clip.play() and movie_clip.stop().

9.6.2  Use of swf movie clips in motion tweens

You can import ready made flash animations, e.g. a cat that would have moving legs. In the next chapter we use a simpler animation
that uses a rocket. Rocket making itself is described in the Flash frame-by-frame animation tutorial.

To import a Flash movie as object: Use File->Import->Import to library You then will see the *.swf files as items and you can drag them
on the stage. With the Transform tools you then can adapt a few features (like size and rotation) to your needs.

movie clip (*.swf) library items
If you want, you can:

Look at the flying rocket• 
Or get the file flash-cs3-rocket-moving.fla from here:• 

http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/

Don't worry about details of *.swf movie clip reuse. The motion guide tweens chapter below will show how to do this in some more
detail.

9.7  Motion guide tweens

Instead of having an object move from one point to another in a straight path, we can make it follow an arbitrary path we draw, i.e. a
motion guide.

Step 1 - Create a normal motion tween

Like explained above, create two keyframes, i.e. one for start and one for the end. Each keyframe should contain a copy of the
same symbol (as above). Then insert a motion tween.

• 

This is important, else you will fail ...• 

Step 2 - Insert a motion guide layer
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Select the first keyframe and layer that starts your animation• 
On the layer edit bar in the time line click on the little motion guide icon (looks like a slinky) or Right-click->Add Motion Guide.• 

You should get something like in the capture below:

A Motion Guide layer

Step 3 - Draw the motion guide in the motion guide layer

Make sure that you selected the motion guide layer you just created selected. You may lock the other layers and just display
their outlines.

• 

Then. with the pencil tool. draw the line your rocket has to follow. Use "Object mode" and "Smooth drawing" from the tools
panel controls (see the Flash drawing tutorial if you forgot how to use the pencil).

• 

In the screen capture below, the motion guide would be the red (fatter) line on top of the hill's outline.

A rocket motion guide drawn with the pencil in the Motion Guide layer

Step 4 - Snap the animated object to the start of the motion guide

Unlock all layers• 
Select the animation layer (not the motion guide layer !) and select your start frame.• 
Then drag the object (i.e. our rocket) to the start of the line until the little white circle in the center of the rocket will "snap" to
the line. Just drag, don't click...

• 

A rocket snaps to the motion guide

Step 5 - Snap it to the end
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Select the end frame first• 
Then drag the object (the rocket) to the end of the line until it snaps. It should snap with the little white circle.• 

Step 6 - Orient to path

You can have the object tilt along the path if you want• 
Select the animation layer (not the guide)• 
Select a frame in between start and end• 
In the properties panel (bottom of the desktop), check the box "Orient to path"• 

If you want, you can:

Look at the flying rocket• 
Or get the file flash-cs3-motion-guide-tweening.fla from here and play with it.• 

http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/

9.8  Publishing and stopping an animation

9.8.1  Publish settings

When you publish a Flash animation, you should first choose the correct settings.

Step 1 - Get the settings

Either click on an empty spot on the workarea, then hit the Publish button in the properties panel• 
Or, menu File->Publish Settings• 

Step 2 - Choose the Flash version

If you want to make sure that your animation plays on most every computer, select Flash Player 8 (the previous version). Otherwise
Flash Player 9 is now widely deployed. You must select "9" if you use Action Script 3.

Step 3 - HTML

Then select the HTML tab (also in the Publish settings)

You can untick the loop button (but see below for a more solid solution)• 

Step 4 - Hit the publish button

This will copy three files to the same directory where you *.fla file sits.

A *.swf• 
A *.html• 
A *.js• 

Copy all three to your website. Then you can edit the html file and add some more HTML if you like. (Make sure to save copy of this
HTML file, since when you publish again the html file will be overwritten).

9.8.2  Stopping an animation

We will improve a bit the flying rocket example, i.e. have the animation stop and display some friendly "Hello".

Step 1 -Create a new layer

Create a new layer and call it "action"• 

Add a new keyframe for this layer

Select the layer• 
Right-click after the last frame of your animation and add Insert Blank Keyframe (in our case this is frame 21) or hit F7.• 
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Add some Action Script

Hit the F9 button• 
This will open the Actions-Frame panel in ActionScript 2 (you can dock it to the properties panel) or the Actions panel in
ActionScript 3.

• 

Insert this (in either AS2 or AS3):• 

stop();

As you can see in the screenshot below, the last frame in the action layer has a little "a" in it. This means that there is some
scripting attached to it.

• 

Fine tune

In our case I dragged the Background layer to the right (or hit F5).• 
Then I inserted a "Hello" movie into this last frame. I took the one we made in the Flash frame-by-frame animation tutorial• 

Here is screen dump with the 2 new layers and the bit of ActionScript code.

Adding a short action script stop(); instruction to the action layer

If you want, you can:

Look at the flying rocket plus the flashing hello.• 
Or get the file flash-cs3-motion-guide-tweening2.fla file from http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/ and
play with it.

• 

9.9  Resources and discussion
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9.9.1  Resources

clipart• 
Follow up the links in Flash and AS3 links - general and Flash and AS3 links - tutorials for other tutorials.• 

9.9.2  Daniel K. Schneider's opinion

I do have to say that I find the SMIL/SVG time-based animation model including its interpolation mechanisms more elegant and simpler
to understand. In SVG, you simply decide which property of the object (position, size, shape, whatever) you want to animate and how
interpolation should be done. That kind of animation can be done in Flash through ActionScript programming. E.g. by using a tweening
library like TweenLite and its sister classes.

9.10  Software

Besides Flash from Adobe, certain animation software can export in Flash. I didn't find any software that can export to *.fla, just *.swf.
Therefore using such tools is ok if you just want to produce animations in an easier way.

E-Frontier products (commercial)

E-Frontier home page• 
E.g. Anime Studio Anime Studio (Wikipedia)• 
Motion Artist• 

Toufee (free online software, needs registration)

Toufee Home Page• 
Toufee (Wikipedia)• 
Toufee Wiki• 

KToon (not tested)

Frame-by-frame animation drawing tool for Unix systems (including Linux).• 
Ktoon can export animations in Flash or a series of PNG images.• 
KToon Home Page• 
KToon Wikipedia article• 

9.10.1  Links to Video Tutorials

You also can look at some of the videos you can find on the Adobe web site

Video tutorials
Click in the top left window on "Flash CS3 Professional"♦ 
Then view in particular "Creating animations with motion tweens" and "Understanding the timeline, keyframes and
frame rate.

♦ 

• 

9.10.2  Other Links

Flash animation (Wikipedia)• 

9.10.3  Materials used

(including the *.fla's)

Grab stuff from this directory:

http://tecfa.unige.ch/guides/flash/ex/motion-tweening-intro/
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10 Flash shape tweening tutorial
This article or section is incomplete and its contents need further attention.

Some sections may be missing, some information may be wrong, spelling and grammar may have to be improved etc. Use your
judgement !

Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This entry is part of the Flash tutorials.

10.1  Overview

Shape tweening means transforming an object from one state into an other. This is usually called morphing.

Learning goals
Learn how to create basic Flash 9 (CS3) morphing, i.e. shape tweening.
Learn how to use shape hints
Learn how to use shape tweens within embedded movie clips

Prerequisites
Flash CS3 desktop tutorial
Flash layers tutorial
Flash drawing tutorial
Flash object transform tutorial
Flash frame-by-frame animation tutorial or Flash motion tweening tutorial

Moving on
The Flash article has a list of other tutorials.

Quality
This text should technical people get going and may not be good enough for self-learning beginners. It can be used as
handout in a "hands-on" class. That is what Daniel K. Schneider made it for...

Level
It aims at beginners. More advanced features and tricks are not explained here.

Materials (*.fla file you can play with)
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

10.2  Introductory example

The principle

You can transform any form into any other form.

Shape tweens work on so-called editable objects, e.g. it will not work with symbols or grouped objects. You may shape tween:

Drawing objects (drawings made in object mode)• 
Shapes (drawing made in merge mode)• 

Also, as in motion tweening, the object to be shaped must be in a separate layer.

Step 1 - Draw an object

We draw an oval with a thick border with the Oval tool and also set the background.• 
Then we center the oval in the stage. To do so, use the Align panel (Window->Align, or hit Crtl-K)

Check to stage and click on the Align icons until you get it right :)♦ 
• 

You should have something like this:

85

http://edutechwiki.unige.ch/en/User:Daniel_K._Schneider
http://edutechwiki.unige.ch/mediawiki/index.php?title=Help:List_of_Flash_tutorials&diff=19477
http://edutechwiki.unige.ch/en/User:Daniel_K._Schneider
http://edutechwiki.unige.ch/en/Flash_tutorials
http://edutechwiki.unige.ch/en/Flash_CS3_desktop_tutorial
http://edutechwiki.unige.ch/en/Flash_layers_tutorial
http://edutechwiki.unige.ch/en/Flash_drawing_tutorial
http://edutechwiki.unige.ch/en/Flash_object_transform_tutorial
http://edutechwiki.unige.ch/en/Flash_frame-by-frame_animation_tutorial
http://edutechwiki.unige.ch/en/Flash_motion_tweening_tutorial
http://edutechwiki.unige.ch/en/Flash
http://edutechwiki.unige.ch/en/User:Daniel_K._Schneider
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/


A starting frame with an Oval to be morphed

Step 2 - Insert a new blank keyframe

Right-click on frame 10 and Insert Blank Keyframe or hit F7 (not "Insert Frame" / "Insert Keyframe" (F6))• 

This will insert an empty new Keyframe

Step 3 - Add a new object to the new keyframe

In this frame, draw a new object, i.e. we inserted a Polystar, also in object mode.

Select the Polystar tool (It sits below the rectangle tool and you must hold down the mouse to get at it)• 
Then, in the properties panel, select from the Options pull-down menu: Star and Number of sides = 9• 
Then, draw it• 

Step 4 - Change its shape and align it with the oval and the stage

Then make it a bit "oval" and adjust it more or less to the size of the oval

Either click on the Free Transform Tool or Right-click on the polystar; Select Free Transform• 
Drag out one sides if needed• 
To see the oval you can click on the "Edit multiple frames" icon in the Timeline control bar.• 
Then make again sure that it is centered by using the Align panel• 

You should have something like this:
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A polystar

Step 5 - Change colors of the polystar

Untick the "Edit multiple frames" icon !!• 
Then you can change the colors of the stroke and the fill• 

Step 6 - Morph

Click on an empty frame between the two keyframes• 
In the properties panel below select Tween: Shape• 
Alternatively: Just right-click on an empty frame and select Create Shape Tween• 

Step 7 - Repeat the other way round

Insert a new empty keyframe• 
Copy the picture from frame 1 (select it and hit CTRL-C in frame 1)• 
Paste it to the empty keyframe• 
Center it to the stage (or align it with the other objects)• 
Add the shape tween.• 

Test;

Move around the playhead• 
Menu Control->Test Movie• 
If the animation is too fast, reduce the frame rate in the properties panel or better drag out the keyframes to the right.• 

Done :)

Result and source
You can admire the result
Source: flash-cs3-shape-tweening-intro.fla
Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/
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10.3  Morphing traced bitmaps

To morph images there are two kinds of solutions:

Break images apart (right-click on the picture). This turns it into a shape. You then can make a copy of it and manipulate all
sorts of things (e.g. size, colors, e.g. with the lasso tool and the magic wand).

• 

Trace images, i.e. turn them into vector graphics.• 

See the Flash bitmap tracing tutorial for some ugly examples or portrait morphing.

10.4  Morphing a simple shape into a monster

In this animation I made three keyframes

Something like a tear in the first• 
Tear decomposing at the bottom• 
The bottom will decompose into the beginning of a monster• 

You can admire the result (files flash-cs3-shape-tweening-tear.*)

Anyhow, the idea is that for some shape transformations, you should learn how to to transform shapes. See the Flash object transform
tutorial

Some design tips

You should consider doing a shape transform in several steps, i.e. use several shape tweens in a row (for the same shape)• 
For smooth shape tweening, working with objects without borders (strokes) is usually a better choice. (set the stroke color to
none, e.g. the white rectangle with a red diagonal bar). Also, unbreak graphics until the whole thing becomes a shape. You
always can make it graphic again by "union" it (Modify->Combine Objects->Union).

• 

You can put several shape tweens in different layers. E.g. I added a "background" shape tween to the above animation. It's a
simple rectangle with 2 different color gradients.

• 

Results and source

Admire the result. It's absolutely dreadful (Ok it was done in 5 minutes ....)• 

flash-cs3-shape-tweening-tear2.fla
Source directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

10.5  Shape hints - where should shapes go

In order to create some slightly better shape animations you can give Flash hints where a shape should go. “Shape hints identify points
that should correspond in starting and ending shape. For example, if you are tweening a drawing of a face as it changes expression,
you can use a shape hint to mark each eye. Then, instead of the face becoming an amorphous tangle while the shape change takes
place, each eye remains recognizable and changes separately during the shift.” ([1], retr. nov 2008)

Create one or more shape hints (Modify->Shape->Add shape hint) or hit CTRL-SHIFT-h.• 
You will see some little letters that appear• 
Then, drag these onto shapes into a keyframe• 
Repeat this in the next keyframe• 

Let's look at a not so canonical example (shape hints work best for shapes that do not move a lot). These hints do something to the
animation, but do not ask me what exactly. To do shape hinting right, each morphed shape should be in a different layer if I understand
right.

Below are three screen captures for keyframe 1, keyframe 2 and keyframe 3 of an animation that starts with a tear on top. It then
separates into 2 tears. In the third keyframe one becomes a hill and the other one morphs into a tree. It almost looks good, as you can
see

Shape hints in Flash CS3
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No shape hint in first keyframe Shape hint in middle keyframe Shape hint in last keyframe

To view all shape hints

Shape hints will disappear from view when edit something.

Select the layer(s) within which you have shape hints (or hit CTRL-ALT-h)• 
Select View->Show Shape Hints.• 

Results and source

Admire the result. It's absolutely dreadful (Ok it was done in 5 minutes ....)• 

flash-cs3-shape-tweening-hints.fla
Source directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

Alternative example

In the Flash bitmap tracing tutorial we tried shape hints for a portrait morphing. A 2-color portrait was morphed into another. Some
objects were given shape hints.

Fla file: flash-cs3-shape-picture-morphing2.fla
Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

10.6  Shape tweens of motion tween elements

10.6.1  A simple motion animation with 2 shape changing objects

To use a shape tweened object in a motion tween animation, you simply can save a shape tween as *.swf (Flash) and then import as
movie. But you also can draw everything in the same *.fla file using embedded movie clips.

Step 1 - Draw the object

anything (but preferably without strokes since shape tweens don't render these very well) ...• 

Step 2 - Turn into movie symbol

Select the object• 
Right-click->Convert to Symbol• 
Select Movie clip !• 

Repeat this for the other objects you want to animate, e.g. create a blue circle that represents a planet.
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Convert an object to movie symbol

Step 3 - Edit the movie clip symbols

Double-click on the instance of the symbol in the stage (or the movie clip in the library)• 
Do shape tweens. Make sure that you really are in symbol edit mode. E.g. in the screen capture below you can see in the Edit
bar that we are editing "Planet" (a movie) and not "Scene 1".

• 

Edit a Movie Symbol (the planet)
Click on scene 1 (or whatever your scene is called) to get back to the normal stage (alternatively use the pull-down menus to the right).

The planet was made with a simple gradient transform. In the first keyframe there is some green on the upper left and in the
second keyframe it is on the lower right.

• 

The star simply changes color from yellow to orange and then from orange back to yellow.• 

Step 4 - Create a motion animation for each of the shape tween movie clips

Tip: if you want to move an object around an ellipse, draw a real ellipse then cut of tiny bit with the eraser. It then becomes a
motion guide line.

• 

The picture below shows the kind of time line in you should get in the main scene.
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Edit a Movie Symbol (the planet)

Final Tips

Make sure at which level you are editing (scene or embedded movie clip) !• 
Use a different layer for each motion animation. In each layer just put one symbol. Then add (if you want) a motion guide layer
to each of these layers... otherwise you met get really unexpected results (E.g. if you see a "tween" in your library something
went wrong).

• 

Results

You can admire the result• 
Get files flash-cs3-shape-tweening-in-motion.* from:• 

Source: flash-cs3-shape-tweening-in-motion.fla
Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

10.6.2  A simple doubly embedded motion animation with 2 shape changing objects

Of course a planet should turn around the star. Therefore we should embed the planet motion animation with the star motion animation,
e.g. something like this motion-in-motion animation

Source

Get files flash-cs3-shape-tweening-in-motion2.* from:• 

Source: flash-cs3-shape-tweening-in-motion2.fla
Directory: http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

10.7  Links

10.7.1  Example materials

Example files used (including *.fla source) can be found here:

http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/

Click on either an *.html or *.swf file to see.• 
Get just the *.fla file if you want to make modifications. The standard copyright of this wiki applies.• 

91

http://edutechwiki.unige.ch/en/Image:Flash-cs3-shape-tweens-in-motion.png
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/flash-cs3-shape-tweening-in-motion.html
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/flash-cs3-shape-tweening-in-motion.fla
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/flash-cs3-shape-tweening-in-motion2.html
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/flash-cs3-shape-tweening-in-motion2.fla
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/
http://tecfa.unige.ch/guides/flash/ex/shape-tweening-intro/


10.7.2  Adobe documentation

Control shape changes with shape hints (Adobe Flash C3 Help). There is a nice example morphing "1" into "2".• 
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11 Flash animation summary
Page created by Daniel K. Schneider, 28 September 2007• 
Last modified by Daniel K. Schneider, 9 November 2008• 

This entry is part of the Flash tutorials.

11.1  Introduction

This article in our Flash series is a summary of: Flash frame-by-frame animation tutorial, Flash motion tweening tutorial and Flash
shape tweening tutorial. It also includes some of: Flash CS3 desktop tutorial, Flash drawing tutorial, Flash CS3 keyboard shortcuts,
Flash object transform tutorial, Flash arranging objects tutorial, Flash colors tutorial and Flash bitmap tracing tutorial.

Learning goals

Review some technical design guidelines and procedures regarding frame-by-frame, motion and shape animations.

You can use this as self-reviewing aid: If you don't understand some items, you will have to go over some tutorials again. This entry
also includes a .fla file that we used as task for a mid-term exam...

11.2  General principles

Description of the *.fla file and stage size

Make sure to start with an appropriate stage size. Change it via the properties panel or menu Modify->Document• 
Fill in a description associated with the *.fla source, also available through the menu Modify->Document• 

Configuration of the desktop

The way you want your desktop configured depends on your screen size and the type of animation you build. If your screen is big
enough, put as many tools at your finger tips as you can. In particular:

All toolbars• 
Properties panel at the bottom• 
Colors, Swatches, Align, Info and Transform on top right• 
Libraries middle right• 

E.g. something like this:

Example configuration of a CS3 Flash desktop

Tips

You can hide/show panels with F4 (e.g. if stage size is big)• 
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You can save a configuration and give it a name• 

If you are lost: go back to the Flash CS3 desktop tutorial

11.3  Layers and Frames

Put each object to be animated in a separate layer ! Yes, do not animate two or more different objects in one layer (except in
frame-by-frame animation)

To create a new layer click on the insert layer icon (left underneath the layers)♦ 

• 

Immediately give this layer a meaningful name.
simply double-click on the layer name♦ 

• 

If objects of one layer should be in front/in the back of an other layer you can grab a layer with the mouse and move it up or
down.

• 

When you edit objects in one layer, it's good policy to lock all the other layers !• 

The Flash CS3 Layers tool
If you are lost: go back to the Flash layers tutorial

11.4  Simple drawing

There are two modes: merge mode and object mode:

In merge mode (default) you draw shapes and over or under-paint other shapes.• 
In object mode you draw graphic objects that you later can edit again.• 

Most of your drawings should be in object mode. So make sure that this icon is on when you select a drawing tool: 

Only use merge mode when you paint like you would with real paint.• 
You then can assemble these shapes with menu Modify->Combine Objects->Union. The result is a graphic object.• 

Other commands:

To select several objects: either hold down the SHIFT key, use a selection box or the Lasso tool.• 
To break apart a drawing (well anything actually): right-click; Break Apart. However, to edit the shape inside a graphic objects
you don't need to break it apart. You also can double-click on the graphic shape. You should see something like "Drawing
Object" in the Edit bar". Make sure to return to main timeline editing once you are done.

• 

If you are lost: go back to the Flash drawing tutorial and Flash arranging objects tutorial

11.5  Intermediate drawing

Tips

Always lock other frames when you draw on one frame.• 
For advanced drawing, you should consider learning how to use the pen tool• 

(Flash pen tutorial).
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11.5.1  Object transformation

To transform an object or shape there are several tools, most importantly:

The Select tool: Make sure all objects are de-selected, then move the cursor close to a stroke of an object or a shape. When
the cursor changes shape you can distort it.

• 

The Free Transform Tool has three different modes you can select with the options controls in the tools bar:
Change size, rotate, skew (by default you get this). Move the cursor close to lines or corners and watch the cursor
change form.

♦ 

Distort tool♦ 
Envelope tool♦ 

• 

The Subselection tool lets you fine tune things you did with the above tools• 
Subselection Tool, Distort Tool and Envelope tool let you either drag distortion points (squares), turn or drag curve control
handles (circles).

• 

Additional stuff is in the Modify menu. Also see the Flash CS3 keyboard shortcuts.

Make sure you only selected one single object (unless it's on purpose) before you start transforming.• 
Flash changes the cursor when it switches to a given "transform mode" and it may display additional handles. There are lots
and you should become familiar with these.

• 

If you feel lost, go back to the Flash object transform tutorial.

11.5.2  Arranging objects

To align objects, work with the align panel (menu Window->Align or Ctrl-k). There are also shortcuts.• 

To assemble shapes into a graphic object, use the Modify->Combine Objects->Union or turn the selected shapes into a
symbol

• 

To break apart an object, use right-click->Break Apart. If you want to produce shapes, you may have to repeat this step.• 

Tips

Set snapping preferences right: View->Snapping or right-click on the workspace. Then Edit snapping

If you need this: see the Flash arranging objects tutorial.

11.5.3  Colors and filters

You can achieve a lot just by changing colors, color gradients or by adding filters to movie clip symbols you use in animations.• 

See the Flash colors tutorial if needed.

11.6  Frame-by-frame animation

Is useful for several things, e.g.

To do precision work, e.g. drawing 15 frames for just an arm movement;• 
To make pulsating objects that you can move around;• 
To insert/remove objects into the animation• 

Procedure

Frame by frame animation works with anything. Just draw any kind of shapes or graphic objects or whatever else in each keyframe.
Animation simply works because the frames are shown to the user in rapid succession.

To add new keyframes that are empty:

In the timeline (in the right layer!) click into the new frame to create• 
Hit F7 (or right-click->Insert New Keyframe)• 
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Then draw something new or copy/paste from an other frame.

To add new keyframes and copy over contents from the last keyframe:

In the timeline (in the right layer!) click into the new frame to create• 
Hit F6 (or right-click->Insert Keyframe)• 

Tips

Play with the frame rate• 
To slow down animation you also can space out keyframes (click on a keyframe, then drag it in the timeline).• 
To align objects in several frames, enable Edit multiple frames in the edit bar. Move the "onion skin" handles on top of the
timeline to select the frames you want to work with (don't forget to disable this once you are done!).

• 

If you are lost: go back to the Flash frame-by-frame animation tutorial

11.7  Simple motion tweening

You only should animate non-editable objects (symbols, text boxes, etc.). It's best to turn all your animated objects into movie clips
because you then can use Filters. E.g. add a glow or a bevel to an object.

Procedure

Draw something in a keyframe (e.g. frame 1) and make it a movie symbol (right-click->Convert to Symbol)• 
Create a new keyframe (e.g. in frame 20) by hitting F6 (this will copy the object from the previous frame). F7 will create an
empty keyframe and you will have to copy/paste manually.

• 

Then move the object in the new frame to its new place.• 
If you did things right, you now have an object in a start keyframe and another in the end keyframe. These objects should be
instances of the same symbol in the library or better, the same instance (copy/paste from frame 1).

• 

Then click anywhere in the timeline between these 2 frames and right-click->Create Motion Tween.• 

Iron principles

Every animation object must be in its own layer and it must be a movie clip (or another non-editable object)• 
Unless you are an expert, don't put more than one object into an animation layer and don't use simple graphics or shapes
(results are unpredictable, i.e. you get a tween within a tween).

• 

Tips

You can accelerate/decelerate motion in the properties panel.• 
If see a "tween" object in your library, something went wrong (!) or you are an expert and know what you do. Break the
tween objects a part, save the graphics to a movie clip symbols. Then remove the tweens and start over.

• 

You can have several motion tweens in a row within a layer. Just hit F6/F7 to extend again.• 
If you want to rotate an object (instead of moving it), change the rotate parameters in the parameters panel.• 

If you are lost: go back to the Flash motion tweening tutorial

11.8  Motion tweening with shape modification

(1) You can add a little bit of shape tweening to motion tweening if your animation is based (as we told you) on symbols. To do so,

Click on the symbol instances in start frame or end frame. The you can:• 
Change tint, alpha etc. in the properties panel.• 
Use the Free transform tool to rotate or change the size of an instance.• 
Add filters in the filters panel' (it should sit next to the properties panel, else add it with menu
Window->Properties-Filters.

• 

This is not shape tweening, but consider using this technique before you try to add motion within a shape tween (putting shapes in
different positions in the two keyframes will not just move the shape but also transform it while moving).

(2) Alternatively, add a shape tween inside of the movie clip. Double click on the item in the library and edit it.

If you are lost: go back to the Flash motion tweening tutorial
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Note: Timeline effects will be covered in a later tutorial.

11.9  Motion guide tweening

Procedure

Select the layer for which you want to create a motion guide.• 
Make sure it includes a motion tween, else create it now.• 
Then click on the first (!) keyframe (e.g. frame 1) and insert a motion guide layer.• 
Draw the motion guide line with the pencil in this new motion guide layer• 
In the animation layer snap the object to the line (in frame 1 and the other keyframes).• 
Display onion skins if you want to see the animation path while working on a background for example.• 

Tips:

You can have several motion tweens in a row in the animation layer• 
In order to move an object around a perfect circle, draw the circle with the oval tool in object mode (and without fill). Then
make a tiny somewhere with eraser tool. This will produce a nice curve.

• 

Play with acceleration/deceleration, i.e. create several keyframes and move objects in the intermediate keyframes along the
motion guide.

• 

If you are lost: go back to the Flash motion tweening tutorial

11.10  Shape tweening

You can only animate editable objects, i.e. shapes and simple Drawing objects.

Therefore if you want to morph a graphic symbol, a textbox, a picture, etc. break it apart. You may have to break it apart more than
once.

Then simply follow the same procedure as for the motion animation:

Make a drawing in one frame• 
Hit F6 in a distant frame and modify the shape/ simple drawing in the new frame• 
Click in the middle and add the shape tween.• 

Tip:

To morph simple graphic objects you may want to take the stroke away (change its color to none).• 
Do not try to create a motion animation with shape tweening !• 
Instead, try a motion tween and modify the shape. You can in the properties panel distort symbols and change their tint. Or
better, create a shape tween within a movie clip.

• 

Create several layers if you work with several shapes. Then you also can use shape hints.• 
To morph bitmaps (e.g. *.jpg photographs) you will have to trace them (see the Flash bitmap tracing tutorial).• 

If you are lost: go back to the Flash shape tweening tutorial

11.11  Manipulation of frames

To extend a drawing layer (e.g. a background) so that it displays until the end of an animation defined in an other layer: Click
on the wanted end-frame position and hit F5 (or right-click->Insert Frame).

• 

To move a keyframe, click in it (cursor must now include a white rectangle) and drag it left or right.• 

To kill frames, select all the frames you want (click on one end, then SHIFT-click on the other end). Then, use
right-click->Remove Frames.

• 

If you are lost: go back to the Flash motion tweening tutorial.
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11.12  Motion tweening of an animated object

You can import an *.swf file and move it as a movie clip symbol.

Alternatively, you can create animations within animations:

Hit CTRL-F8 to create a new symbol or convert an existing graphic to a movie clip symbol with F8.• 
Make sure to select Movie Clip !• 
Give this movie clip an appropriate name• 
Then you can drag the symbol from the library to the stage or directly edit it in the library. Double click on the movie clip
symbol or the instance to edit and create any animation you like. Make sure that know whether you are editing a symbol or
your scene...

• 

You also can copy/paste a series of frames (e.g. a frame-by-frame animation or a motion tween to this new embedded movie symbol
from another *.fla file:

Select all the frames and layers you want (SHIFT click) then right-click->Copy Frames• 
Go to frame one of layer 1 of your new movie symbol and right-click->Paste Frames.• 

So it is copy/paste frames, not "normal" copy/paste !

Important: Make sure where you are when you edit, check whether are you editing a scene and the main timeline or whether you are
editing a movie clip i.e. in symbol edit mode ! If you mix up the two (or more) levels of editing you are likely to mess up things ! This is
the same problem as customizing button symbols

If you are interested in working with embedded movie clips, there is more detailed explanation in the Flash embedded movie clip
tutorial

If you are totally lost: go back to the Flash frame-by-frame animation tutorial, Flash motion tweening tutorial and the Flash shape
tweening tutorial (there is some useful information in each of them). Finally you may have a glance at the ActionScript 3 interactive
objects tutorial if you need some more ActionScript tricks.

11.13  Testing and Publishing

Hit Ctrl-ENTER to test• 
Menu File->Export->Movie just to export the *.swf (Flash)• 
Menu File->Publish Settings Verify settings, then hit the PublishButton.• 

11.14  Important principles and tips

As soon as you are happy with a drawing, save it to the library as graphic symbol or movie clip.• 
Name your layers• 
Lock all other layers when you work on one layer.• 
Do motion animation with symbols only. Avoid having any "tween" objects in your library (most likely something went wrong).• 
Only use one symbol per motion animation layer.• 
Shape animation works with either shapes and/or simple editable graphics.

To convert a non-editable object to a shape or simple graphic: Break it apart (right-click on the object and Break
Apart)

♦ 

To convert an editable object or a shape (or several of these) into a non-editable object select these and
right-click->Create symbol.

♦ 

To convert a shape into a graphic object: Modify->Combine Objects->Union♦ 

• 

11.15  Self-revision example

11.15.1  Tasks

Complete a weather animation by using the existing layers and the objects in the library. You only need to add one extra motion guide
layer to complete the tasks described below.

Download the *.fla file from here:
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flash-cs3-cloud-animation-problem.fla• 

Notes:

All drawing objects you need are in the library and instances are on the stage too. All layers are locked. Unlock as needed.• 
This animation has about 50 frames. There is no need to go further, but the animation layers are only defined for frame 1. I.e.
it is up to you to add motion and shape tweens and insert a frame-by-frame animation

• 

Clouds and the sun are not in the right start position when you open the *.fla file• 
This animation is not really professional. We kept it as simple as possible.• 

11.15.1.1  Cloud animation

At start, clouds must be very small and then gradually move forward and become big.• 

Tip: This is a motion tween animation with a shape transform of the cloud instance (not a shape tween !)

11.15.1.2  Rain animation

Insert animated rain underneath a big cloud once it is close, e.g. around frame 40• 

Tip: Use a frame-by-frame animation (e.g. about 10 frames)

11.15.1.3  Sun animation

The Sun must rise from the left and from behind the hills, then move to the top and finally set behind the hills to the right.• 
The sun must follow a more or less smooth path, i.e. an arc and not just two lines.• 

Tip: This is a motion guide tween.

11.15.1.4  Sky animation

Sky should be brighter around the sun• 
Bonus: Also make the sky darker when the clouds arrive• 

Tip: This includes at least 2 shape tweens in a row. Use color gradients: 1-2 color bands should do. Do the gradient transform before
you start duplicating the sky of frame 1. Alternatively you also can add a glow to the sun with a filter ...

11.15.1.5  Extra effect

Add one other animation effect somewhere. Whatever you like.• 

11.15.2  Advice and Cheatsheet

11.15.2.1  Cheatsheet

Frames

F5 will extend a frame• 
F6 will make a new keyframe and copy its contents• 
F7 will make a new empty keyframe• 

Scaling

ALT-CTRL-S will allow to scale a selected object• 

Shape tweening

Right-click->Break Apart will turn a symbol instance into its components. E.g. the sky as symbol instance will become a
Drawing Object.

• 
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Alternatively, double click on a symbol object to edit its graphics.• 

11.15.2.2  Advice

Always lock layers you are not working on.• 
Backtrack (ctrl-Z) as soon as you see a "tween" object in your library. None is needed.• 
Do not kill library objects !• 
If you completely messed up a layer, lock all layers, unlock the bad one, select all frames (use SHIFT-click) and remove them
(right-click menu). Then restart again with a library object.

• 

11.15.3  Solution

You can find the solution here:

http://tecfa.unige.ch/guides/flash/ex/animation-summary/• 
Files: flash-cs3-cloud-animation-solution.*• 

Note: some vector graphics, i.e. the trees and the cloud have been taken from the Open Clip Art Library. You can find the SVG files in
the same directory. Before importing to Flash I made some modifications with Illustrator

11.16  Links

Open Clip Art Library (SVG clipart to play with, but you will need to pass trough Illustrator to input)• 
Example directory referenced in the various tutorials: http://tecfa.unige.ch/guides/flash/ex/• 
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12 Flash CS3 keyboard shortcuts

Authors: Daniel K. Schneider (TECFA) and Marielle Lange (WidgEd)

This page contains the most important Flash CS3 keyboard shortcuts. There may be some mistakes and omissions for now (e.g.
programming/debugging is not covered). Table size optimized for Mozilla/Windows.

12.1  The useful list

Standard windows commands not shown here

F5 - Add simple frame
F6 - Add new Keyframe
F7 - Add blank Keyframe
CTRL+ENTER - Test a Movie

F9 - Action Panel
F4 - Show/Hide All Panels
F10 - Keystroke Menu command mode

12.1.1  Tools Panel

While drawing on the stage you quickly can change tools that way.

V - Selection Tool
A - Sub Selection Tool
Q - Free Transform tool
F - Gradient Transform Tool
L - Lasso Tool

P - Pen Tool
N - Line Tool
T - Text Tool
R - Rectangle Tool
O - Oval Tool
Y - Pencil Tool
B - Paint Brush

S - Ink Bottle
K - Paint Bucket
I - EyeDropper
D - Dropper
E - Eraser

H - Hand Tool
M,Z - Magnifier (Zoom)

12.1.2  Modifying and editing

CTRL+G - Group
CTRL+SHIFT-G - Ungroup
CTRL+B - Break Apart

CTRL+A - Select All
CTRL+SHIFT+A - Deselect All
CTRL+C - Copy
CTRL+V - Paste
CTRL+SHIFT+V - Paste in Place
CTRL+D - Duplicate

CTRL+SHIFT+O - Optimize Curves

CTRL+T - Modify Font
CTRL+SHIFT+T - Modify Paragraph
CTRL+left Arrow - Narrower Letter Spacing
(kerning)
CTRL+right Arrow - wider Letter Spacing (kerning)

CTRL+SHIFT+9 - Rotate 90° Clockwise
CTRL+SHIFT+7 - Rotate 90° Counter clockwise
CTRL+SHIFT+Z - Remove Transform

CTRL+ALT+S - Scale and Rotate
CTRL+SHIFT+Z - Remove Transform

12.1.3  Arranging

CTRL+Up Arrow - Move Ahead
CTRL+Down Arrow - Move Behind
CTRL+SHIFT+Up Arrow - Bring to Front
CTRL+SHIFT+Down Arrow - Send to Back

CTRL+ALT+1 - Left Align
CTRL+ALT+2 - Horizontal Center
CTRL+ALT+3 - Right Align
CTRL+ALT+4 - Top Align
CTRL+ALT+5 - Vertical Center
CTRL+ALT+6 - Bottom Align
CTRL+ALT+7 - Distribute Widths
CTRL+ALT+9 - Distribute Heights
CTRL+ALT+SHIFT+7 - Make Same Width
CTRL+ALT+SHIFT+9 - Make Same Height
CTRL+ALT+8 - Set "Align to stage"
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12.1.4  Windows and Panels

Open/close various Panels

F1 - Help
F4 - Show/Hide Panels
CTRL+K - Align Panel
CTRL+T - Transform
SHIFT+F9 - Color Mixer
CTRL+F9 - Color Swatches
CTRL+L - Show/Hide Library
F9 - Actions

If your screen is big enough you won't need these a lot ...

CTRL+F3 - Properties Inspector
CTRL+F2 - Tools Panel
CTRL+ALT-T - Timeline
CTRL+M - Modify Movie Properties
CTRL+E - Toggle between Edit Movie& Edit Symbol
Mode
CTRL+SHIFT+L - Show/Hide Timeline
CTRL+SHIFT+W - Show/Hide Work Area

12.1.5  Frames and Symbols

(most of the time, position first inside the timeline)

F5 - Add frame (extend the timeline)
SHIFT+F5 - Delete Frame
F6 - Add Key Frame (and copy over old contents)
SHFIT-F6 - Clear Key Frame
F7 - Add Blank Key Frame (and leave the stage empty)

F8 - Turn into Symbol
CTRL+F8 - Make new Symbol

CLICK DRAG - Move keyframe (Select, release - then
drag !)
CTRL-DRAG - Select several Frames

12.1.6  Timeline

Enter - Play Movie
CTRL+0 (zero) - Rewind Movie
< - Previous Frame
> - Next Frame

CTRL+ENTER - Test Movie
CTRL+SHIT+ENTER - Debug Movie

Home - Goto First Scene
End - Goto Last Scene
Page Up - Goto Previous Scene
Page Down - Goto Next Scene

12.1.7  Files

CTRL+N - New File
CTRL+O - Open File
CTRL+S - Save File

CTRL+R - Import Image/Sound/etc...
CTRL+SHIFT+O - Open as Library

SHIFT+F12 - Publish
CTRL+SHIFT+R - Export to .swf/.spl/.gif/etc...

12.1.8  View

CTRL+1 - View movie at 100% size
CTRL+2 - Show Frame
CTRL+3 - Show All

12.1.9  Generate shortcut table

Menu Edit->Keyboard shortcuts• 
Click on the little icon on top right (Export Set as HTML).
This will generate a single HTML file with several tables,
showing all commands that can have a shortcuts plus the
shortcuts currently defined.

• 

12.1.10  Links

What Are the Flash Shortcut Keys? by Adobe, a good short list.• 
Most useful Flash 8 Shortcut Keys by Anders Bergmann.• 
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12.1.11  Conventions

On a Mac replace "Control" by "Command"• 
In this table, "+" means hold down both (usually I just use a "-" for this)• 

12.1.12  Other tricks

(from Adobe, to sort out)

With the arrow cursor: Control + Click and Drag - Duplicates a shape By hitting the control key first (Macintosh & Windows) and THEN
clicking and dragging on a selected shape or group of shapes, you will create a duplicate of those shapes at the spot where you
release the mouse button.

CTRL+Clicking a keyframe to move frame: CTRL+clicking a frame in the timeline switches the cursor to a slider, and allows you to click
and drag that frame to a new place in the timeline within that same layer. Useful if you want to stretch out tweens for example

With the magnifier tool:

Control + Click - Toggles to the opposite magnifier. If the + magnifier (zoom in) is active, and you hit Control while clicking, you will
switch to the - magnifier and actually zoom OUT.

With the dropper tool:

Shift + Click - Select a color for both fill and outline tools Clicking a red fill will do the same, giving you the Bucket tool, and switching fill
colors to red. But the outline tool colors are not changed. Clicking on text switches the text tool to that color, and gives you the text tool.
Shift clicking with the dropper makes the color you click on active for ALL tools, and doesn't automatically switch you to any tool. It
leaves the dropper active.

This is one of the least well known short cuts in Flash, and is the ONLY way to use the dropper on an outline for example, and then be
able to switch to the fill tool and have that color automatically active already.
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